Subject: Re: Comments on Application Mapping I-Ds

From: Eliot Lear <[email-masked]>
Date: Mon, 16 Aug 2004 13:50:18 -0700

Andy:

General comments below, I think we agreed at the meeting that since 
Margaret was not in the room (always a good method to decide things) and 
since it probably didn't matter too much, we'd go with her organization. 
  And so this means the following for BEEP:

> 1) General Comments
> 
>  - Titles should be consistent; every one is a different style.
>    We need to decide which style is best:
>     - BEEP Application Protocol Mapping for NETCONF
>     - NETCONF Over SOAP
>     - Using the NETCONF Configuration Protocol over Secure Shell (SSH)

Title - Using the NETCONF Configuration Protocol over BEEP

I don't personally like the "using" part, but I don't care all that much.

>   
>  - The following normative sections should exist in
>    all documents, and be consistent in content:
>    - NETCONF Session Establishment
>    - NETCONF Capabilities Exchange
>    - NETCONF Session Usage
>    - NETCONF Session Teardown

This is fine.  Expect a draft on short order.

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://ops.ietf.org/lists/netconf/>

---

From: Margaret Wasserman <[email-masked]>
Date: Mon, 16 Aug 2004 22:34:32 -0400

>Margaret was not in the room (always a good method to decide things) 
>and since it probably didn't matter too much, we'd go with her 
>organization.

I guess I'll have to miss more meetings, as I am apparently more 
persuasive when I'm not present... :-)

>Title - Using the NETCONF Configuration Protocol over BEEP

Unfortunately, we have to expand the acronyms, so I think we end up with:

Using NETCONF over the Blocks Extensible Exchange Protocol (BEEP)

Do you think we have to expand NETCONF?  Or that we can get away with 
claiming that NETCONF _is_ the fully-expanded name of the protocol?

Margaret

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 16 Aug 2004 20:45:46 -0700

Hi -

> From: "Margaret Wasserman" <[email-masked]>
> To: "Eliot Lear" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Monday, August 16, 2004 7:34 PM
> Subject: Re: Comments on Application Mapping I-Ds
...
> claiming that NETCONF _is_ the fully-expanded name of the protocol?
...

I think it would be better to expand it.

Randy

---

From: Andy Bierman <[email-masked]>
Date: Mon, 16 Aug 2004 21:04:46 -0700

>I think it would be better to expand it.

Agreed.  The full title should be:

   Network Configuration Protocol (NETCONF)

>Randy

Andy

---

From: Ted Goddard <[email-masked]>
Date: Tue, 17 Aug 2004 09:08:29 -0600

Note that "SOAP" is no longer an acronym, it's now just "SOAP".
However, as of SOAP 1.1, it was "Simple Object Access Protocol".

Does that warrant expansion?

Ted.

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 17 Aug 2004 14:00:39 -0700

Hi -

> From: "Ted Goddard" <[email-masked]>
> To: <[email-masked]>
> Sent: Tuesday, August 17, 2004 8:08 AM

...

I think expansion is warranted.

An explanation of the politics of the name, along with
any additional etymological details could go in a parenthetical
comment in the document's introduction.

Randy