Subject: Re: [Netconf] WG Last Call for draft-ietf-netconf-rfc4742bis-05.txt

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Fri, 7 Jan 2011 15:48:30 +0100

Hi All,

this is just a reminder that the WGLC for 4742bis draft ends 
today.

Please consider to review the document and send your comments 
to NETCONF ML. Please state which proposal on ML you support.
Please also consider to comment on Wes' mail, which proposes
a few new changes.

Following issues could benefit from a discussion, e.g.:

- How should the LineFeed in section 4.2 be handled? Do we 
  need a special character to make it visible?
- Should we keep the example in 4.3. as it was in -04, namely an example
for EOM mechanism?
- Should we stick the capability to "base:1.1" or state ":base:1.1 or
later"?

Thank you.

Mehmet

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of ext Bert (IETF) Wijnen
> Sent: Tuesday, December 21, 2010 1:19 PM
> To: Netconf
> Subject: [Netconf] WG Last Call for draft-ietf-netconf-rfc4742bis-
> 05.txt
> 
> 
> WG participants,
> 
> This is a 2,5 week (holiday season) WG Last Call for this draft.
> The idea is to only check if the agreed upon edits have been made
> properly/correctly and if they do not have any unforeseen side
> effects/impacts.
> 
> The WG LC ends on Jan 7th, 2011. Please carefully check/review and
> send us any comments you may have BEFORE Jan 7th 2011.
> 
> Bert and Mehmet
> (Mehmet is the document shepherd)
> 
> Background:
> 
> We have been discussing (on this WG mailing list) a set of changes
> to the rfc4742bis draft. This to try and get proper/reasonable
framing.
> 
> The WG chairs concluded we do have more or less FULL consensus on
> the proposed edits. And so we asked Margaret to make those edits
> to the Internet Draft. She did so and the I-D (revision 05) has
> been posted.
> 
> -------- Original Message --------
> Subject: 	[Netconf] I-D
Action:draft-ietf-netconf-rfc4742bis-05.txt
> Date: 	Mon, 20 Dec 2010 14:00:01 -0800
> From: 	[email-masked]
> To: 	[email-masked]
> CC: 	[email-masked]
> 
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the Network Configuration Working Group
of
> the IETF.
> 
> 
> 	Title           : Using the NETCONF Configuration Protocol over
> Secure Shell (SSH)
> 	Author(s)       : M. Wasserman, T. Goddard
> 	Filename        : draft-ietf-netconf-rfc4742bis-05.txt
> 	Pages           : 13
> 	Date            : 2010-12-20
> 
> This document describes a method for invoking and running the NETCONF
> protocol within a Secure Shell (SSH) session as an SSH subsystem.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-netconf-rfc4742bis-
> 05.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 07 Jan 2011 16:47:38 +0100

>   need a special character to make it visible?

Yes, it would be better.

> - Should we keep the example in 4.3. as it was in -04, namely an example

I objected against the placement of the example in my review of pre-05,
the example belongs at the end of sec. 4.2. It is NOT an example of EOM
framing, so reading it as a part of 4.3 is confusing.

> - Should we stick the capability to "base:1.1" or state ":base:1.1 or

I'd stick to "base:1.1" and extend it with every new version. It could
be that a later version again makes some changes to the mechanism. The
far end of "later" is very loose.

Lada

-- 
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: "t.petch" <[email-masked]>
Date: Fri, 7 Jan 2011 18:23:12 +0100

Mehmet

Just a reminder, I have proposed a visible LineFeed on 28Dec, and also believe
that
the current text is confusing if not wrong as to what roles the various Line
Feeds are
playing

Tom Petch