Subject: [Netconf] 4741bis, sec. 3, para 2

From: Andy Bierman <[email-masked]>
Date: Thu, 13 Jan 2011 07:29:24 -0800

Hi,

This paragraph is holding up 4741bis, so let's see if it can be improved,
but  I will just remove my objection either way.

Issues:

-          'message' is too generic.  The server never responds to a bad <hello>
with <rpc-reply>

-          MUST is not realistic; what if the server is out of memory, or some severe resource
impairment is occurring?  The server must have the option of dropping the session.

-          The server must do something when it gets a message.  Drop and ignore the message will only
cause the client to timeout.  Better to drop the session and get it over with faster.

OLD:

   All NETCONF messages MUST be well-formed XML, encoded in UTF-8.  If a
   peer receives a message that is not well-formed XML, it MUST reply
   with an 'operation-failed' error.

NEW:

   All NETCONF messages MUST be well-formed XML, encoded in UTF-8.  If a
   peer receives an 'rpc' message that is not well-formed XML, it SHOULD reply
   with an 'operation-failed' error.  If a reply cannot be sent for
   any reason, the server MUST close the session.

Andy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 13 Jan 2011 16:33:38 +0100

>    any reason, the server MUST close the session.

Looks good to me.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>