Subject: [Netconf] a couple 4741bis lingering issues

From: Kent Watsen <[email-masked]>
Date: Mon, 7 Feb 2011 08:27:10 -0800

I'm not sure if it's too late to bring this up, but I was reviewing the mailing list archive and realized that two issues didn't seem to reach closure:

1. <rpc-error> before <rpcResponse>

This issue was first raised by Martin over a year ago  and then again by me (though I messed up and wrote <data> comes *after* when I meant *before*):

   http://www.ietf.org/mail-archive/web/netconf/current/msg03876.html
   http://www.ietf.org/mail-archive/web/netconf/current/msg06072.html

Both times the thread peters out and yet the issue remains in 4741bis-07.  Shouldn't the spec provide guidance on how to handle an error after <data> has started to stream?

2. Namespace passing

This issue is much more recent, but I'm not sure if a consensus to not change the current text was reached.  Andy last posted about a rare corner-case, but does that mean we stick with the status quo though many said that implementations were unlikely to support it?

  http://www.ietf.org/mail-archive/web/netconf/current/msg06709.html

Thanks,
Kent

---

From: Kent Watsen <[email-masked]>
Date: Mon, 7 Feb 2011 09:05:32 -0800

For the first issue, could we define:

  <xs:element name="rpc-error" substitutionGroup="rpcResponse">
      <xs:complexType>
         <xs:complexContent>
            <xs:extension base="rpcResponseType">
                <xs:sequence>
                  <xs:element ref="rpc-error"/>
               </xs:sequence>
            </xs:extension>
         </xs:complexContent>
      </xs:complexType>
   </xs:element>   

This schema validates previous responses while also allowing <rpc-error> to show up after <data>.  Seems that this would not break backwards compatibility, since both peers would need to advertize base:1.1 for it to be used.

Thanks,
Kent

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Kent Watsen
Sent: Monday, February 07, 2011 11:27 AM
To: [email-masked]
Subject: [Netconf] a couple 4741bis lingering issues

2. Namespace passing

Thanks,
Kent

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: "Bert (IETF) Wijnen" <[email-masked]>
Date: Tue, 08 Feb 2011 10:14:51 +0100

Kent, you are indeed quite late. In fact, WG LC (last Call) closed several weeks ago.
IETF LC closed yesterday.

Besides that, I believe we did discuss these issues before, and did not get to
consensus. And thus decided to not make any changes for these items.

We can of course keep reopening old issues over and over again, but that
way we will never get a new document published.

So I am inclined to declare this as "we do not want to reopen this
discussion since I do not see why we would reach consensus this time:.

(can't check with my co-chair right now)
Bert
Document Shepherd and co-chair of NETCONF

On 2/7/11 5:27 PM, Kent Watsen wrote:
> 1.<rpc-error>  before<rpcResponse>
>
> This issue was first raised by Martin over a year ago  and then again by me (though I messed up and wrote<data>  comes *after* when I meant *before*):
>
> Both times the thread peters out and yet the issue remains in 4741bis-07.  Shouldn't the spec provide guidance on how to handle an error after<data>  has started to stream?
>
>
> 2. Namespace passing
>