Subject: [Netconf] Fwd: Last Call: <draft-ietf-netconf-4741bis-07.txt> (Network Configuration Protocol (NETCONF)) to Proposed Standard

From: "Bert (IETF) Wijnen" <[email-masked]>
Date: Mon, 07 Feb 2011 12:36:21 +0100

Dear WG participants,

IETF Last Call for this document has ended.
AS far as I know, we have had 3 review comments,

- one from the IANA crew. Juergen and Andy have I think
   sufficiently) answered that one. But I'll check and make
   sure that IANA is now indeed happy (or at least understands
   the proper actions to be taken).

- One from the gen area by Brian Carpenter
- One from the tsv area by Rolf Winter.

The last two commenters both raised concerns about not-so-consistent
use of RFC2119 language. My understanding is that 3 editors of
the document are working on a revision of the draft that addresses this
(plus any other comments we recieved). Hopefully we will see that soon
and then be able to continue with the IESG process.

Bert Wijnen
Document Shepherd

-------- Original Message --------
Subject: 	Last Call: (Network Configuration Protocol (NETCONF)) to Proposed Standard
Date: 	Mon, 24 Jan 2011 06:57:55 -0800
From: 	The IESG <[email-masked]>
To: 	IETF-Announce <[email-masked]>
CC: 	[email-masked]

The IESG has received a request from the Network Configuration WG
(netconf) to consider the following document:
- 'Network Configuration Protocol (NETCONF)'
   <draft-ietf-netconf-4741bis-07.txt>  as a Proposed Standard

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action. Please send substantive comments to the
[email-masked] mailing lists by 2011-02-07. Exceptionally, comments may be
sent to [email-masked] instead. In either case, please retain the
beginning of the Subject line to allow automated sorting.

The file can be obtained via
http://datatracker.ietf.org/doc/draft-ietf-netconf-4741bis/

IESG discussion can be tracked via
http://datatracker.ietf.org/doc/draft-ietf-netconf-4741bis/

No IPR declarations have been submitted directly on this I-D.
_______________________________________________
IETF-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf-announce

---

From: "Bert (IETF) Wijnen" <[email-masked]>
Date: Wed, 09 Feb 2011 09:01:09 +0100

FYI

-------- Original Message --------
Subject: 	[IANA #426231] Re: Last Call: (Network Configuration Protocol (NETCONF)) to Proposed Standard
Date: 	Wed, 9 Feb 2011 00:50:58 +0000
From: 	Amanda Baber via RT <[email-masked]>
Reply-To: 	[email-masked]
CC: 	[email-masked], [email-masked], [email-masked], [email-masked], [email-masked], 
[email-masked]

They did. Thanks!

Amanda

On Mon Feb 07 11:40:39 2011, [email-masked] wrote:
>  Amanda/IANA,
>
>  Did the below explanations make things clear?
>
>  Thanks,
>  Bert WIjnen
>  Document Shepherd
>
>  On 2/5/11 5:34 PM, Andy Bierman wrote:
>  >  Hi,
>  >
>  >  These are the specific capabilities to update the RFC reference.
>  >  Also the '1.1' capabilities are missing from the assignment.
>  >
>  >  Andy
>  >
>  >
>  >
>  >      IANA is requested to update the allocations of the following
>  >      capabilities to reference this document when it is published as
>  an
>  >      RFC.
>  >
>  >      +--------------------
>  +----------------------------------------------+
>  >      | Index              | Capability Identifier
>  |
>  >      +--------------------
>  +----------------------------------------------+
>  >      | :writable-running  |
>  urn:ietf:params:netconf:capability:writable- |
>  >      |                    | running:1.0
>  |
>  >      |                    |
>  |
>  >      | :candidate         |
>  urn:ietf:params:netconf:capability:candidate |
>  >      |                    | :1.0
>  |
>  >      |                    |
>  |
>  >      | :rollback-on-error |
>  urn:ietf:params:netconf:capability:rollback- |
>  >      |                    | on-error:1.0
>  |
>  >      |                    |
>  |
>  >      | :startup           |
>  urn:ietf:params:netconf:capability:startup:1 |
>  >      |                    | .0
>  |
>  >      |                    |
>  |
>  >      | :url               |
>  urn:ietf:params:netconf:capability:url:1.0   |
>  >      |                    |
>  |
>  >      | :xpath             |
>  urn:ietf:params:netconf:capability:xpath:1.0 |
>  >      +--------------------
>  +----------------------------------------------+
>  >
>  >      IANA is requested to add the following capabilities to the
>  registry:
>  >
>  >      +---------------------
>  +---------------------------------------------+
>  >      | Index               | Capability Identifier
>  |
>  >      +---------------------
>  +---------------------------------------------+
>  >      | :base:1.1           | urn:ietf:params:netconf:base:1.1
>  |
>  >      |                     |
>  |
>  >      | :confirmed-commit:1 |
>  urn:ietf:params:netconf:capability:confirme |
>  >      | .1                  | d-commit:1.1
>  |
>  >      |                     |
>  |
>  >      | :validate:1.1       |
>  urn:ietf:params:netconf:capability:validate |
>  >      |                     | :1.1
>  |
>  >      +---------------------
>  +---------------------------------------------+
>  >
>  >
>  >
>  >
>  >  -----Original Message-----
>  >  From: Amanda Baber via RT [mailto:[email-masked]]
>  >  Sent: Friday, February 04, 2011 7:06 PM
>  >  Cc: [email-masked]; [email-masked]; j.schoenwaelder@jacobs-
>  university.de; Andy Bierman; [email-masked];
>  [email-masked]
>  >  Subject: [IANA #423100] Last Call:<draft-ietf-netconf-4741bis-
>  07.txt>   (Network Configuration Protocol (NETCONF)) to Proposed
>  Standard
>  >
>  >  IESG:
>  >
>  >  IANA has reviewed draft-ietf-netconf-4741bis-07.txt, which is
>  >  currently in Last Call, and has the following comments:
>  >
>  >  IANA understands that, upon approval of this document, there are
>  four
>  >  actions that IANA needs to complete.
>  >
>  >  First, in the IEFT XML namespace registry located at:
>  >
>  >  http://www.iana.org/assignments/xml-registry/ns.html
>  >
>  >  a new namespace is to be registered as follows:
>  >
>  >  ns: netconf:base:1.0
>  >  URI: urn:ietf:params:xml:ns:netconf:base:1.0
>  >  Registration template: NONE
>  >  Reference: [RFC-to-be]
>  >
>  >  Second, in the IANA XML schema registry located at:
>  >
>  >  http://www.iana.org/assignments/xml-registry/schema.html
>  >
>  >  a new schema is to be registered as follows:
>  >
>  >  ID: netconf
>  >  URI: urn:ietf:params:xml:schema:netconf
>  >  Filename: [as provided in Appendix B of the approved document]
>  >  Reference: [RFC-to-be]
>  >
>  >  Third, in the YANG Module Names subregistry of the Yang parameters
>  >  registry located at:
>  >
>  >  http://www.iana.org/assignments/yang-parameters/yang-
>  parameters.xhtml
>  >
>  >  a new module is to be added to the registry as follows:
>  >
>  >  name: ietf-netconf
>  >  namespace: urn:ietf:params:xml:ns:netconf:base:1.0
>  >  prefix: nc
>  >  module: [left blank]
>  >  reference: [RFC-to-be]
>  >
>  >  Fourth, in the Network Configuration Protocol (NETCONF) Capability
>  URNs
>  >  registry located at:
>  >
>  >  http://www.iana.org/assignments/netconf-capability-urns/netconf-
>  capability-urns.xhtml
>  >
>  >  the references for the existing, registered URNs should be updated
>  to
>  >  reference [RFC-to-be]. In addition, the matrix entry for the Network
>  >  Configuration Protocol (NETCONF) Capability URNs registry should be
>  >  updated to reference [RFC-to-be]. IANA understand that this document
>  >  adds no new registration to the the Network Configuration Protocol
>  >  (NETCONF) Capability URNs registry, but simply updates the
>  references of
>  >  the existing registrations.
>  >
>  >  IANA understands that these are the only actions that need to be
>  >  completed upon approval of this document.
>  >
>  >  Thanks,
>  >
>  >  Amanda Baber
>  >  IANA
>  >
>  >  On Mon Jan 24 15:01:13 2011, [email-masked] wrote: