Subject: Re: [Netconf] js comments on draft-ietf-netconf-system-notifications-03

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 4 Apr 2011 12:45:12 -0700

Hi -

> From: "Andy Bierman" <[email-masked]>
> To: "Martin Bjorklund" <[email-masked]>; <[email-masked]>
> Cc: <[email-masked]>
> Sent: Wednesday, March 30, 2011 3:34 AM
> Subject: Re: [Netconf]js comments on draft-ietf-netconf-system-notifications-03
>
> The reason I want these notifications is that people tend to ignore locking
> so knowing other sessions started may avoid collisions manually.

I don't see how this could work.    It's like detecting an oncoming bus
by the rush of wind as it moves past.

First, the notifications don't help a client find out about other
sessions already in place when its own session started.  Secondly,
there's a race condition, in that there is unavoidably a delay
between the start of a session and the processing of the receipt
of the notification of the start of that session by other clients,
during which time those clients may have sent requests of their own.

Randy

---

From: Andy Bierman <[email-masked]>
Date: Mon, 4 Apr 2011 13:28:16 -0700

see inline

Andy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Randy Presuhn
Sent: Monday, April 04, 2011 12:45 PM
To: [email-masked]
Subject: Re: [Netconf] js comments on draft-ietf-netconf-system-notifications-03

Hi -

[ab: it works as well as CLI without locking]

[ab: it isn't supposed to be perfect, but it helps an audit application
correlate what a session did during a login.  I don't see why they should
be removed.]

Randy

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf