Subject: [Netconf] Most used transport protocol for NETCONF

From: Sean Gillings <[email-masked]>
Date: Mon, 18 Jul 2011 16:38:30 +0300

RFC4741 lists BEEP, SSH, SSL & Console as permitted transport protocols for NETCONF format XML messages over a CLI interface.  Has anyone collected statistics concerning which is the most popular protocol in use currently?  If so can you please post results in this thread or reply with thread &/or URL where such data can be found?

Séan [Amdocs OSS Division]
Senior Software Design Architect (Activation)

This message and the information contained herein is proprietary and confidential and subject to the Amdocs policy statement,
you may review at http://www.amdocs.com/email_disclaimer.asp

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 18 Jul 2011 15:55:56 +0200 (CEST)

Hi,

Sean Gillings <[email-masked]> wrote:
> RFC4741 lists BEEP, SSH, SSL & Console as permitted transport protocols for
> NETCONF format XML messages over a CLI interface.  Has anyone collected
> statistics concerning which is the most popular protocol in use currently?  If
> so can you please post results in this thread or reply with thread &/or URL
> where such data can be found?

The short answer: SSH.

Note the listing you refer to in 4741 is just an example.  NETCONF can
run on any transport for which there is a mapping.  Also note that RFC
6241, which obsoletes 4741, has an updated example where 'console' is
removed.  SSH is mandatory, and most (all?) open source and commercial
stacks supports only SSH out of the box.  This said, I think there are
some vendors that also support BEEP or SOAP/HTTP/TLS.

Also note that current devices uses the SSH mapping defined in RFC
4742, but this RFC was obsoleted by 6242, which defines a new SSH
framing protocol.

/martin

---

From: "Bert (IETF) Wijnen" <[email-masked]>
Date: Mon, 18 Jul 2011 15:56:02 +0200

First, Pls note that RFC4741 was recently obsoleted by RFC6241.

I can only guess. But since SSH is the (only) mandatory transport protocol that MUST be supported
my guess would be that it is SSH.

Those who actually do use NETCONF, pls feel free to let us know on the NETCONF WG mailing list
which of the trasports you actually use..

Bert

On 7/18/11 3:38 PM, Sean Gillings wrote:
> RFC4741 lists BEEP, SSH, SSL&  Console as permitted transport protocols for NETCONF format XML messages over a CLI interface.  Has anyone collected statistics concerning which is the most popular protocol in use currently?  If so can you please post results in this thread or reply with thread&/or URL where such data can be found?
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>