Subject: [Netconf] regarding string data-type restrictions while configuring through Netconf

From: Ramu n <[email-masked]>
Date: Tue, 19 Jul 2011 02:19:33 +0000

Hi,

In <edit-config> operation, for string data-type fields can contain some special characters like tab(\t), ?

these type of characters are used for help inforamtion in Command Line, So in Command Line these special characters are not allowed as part of string value.

Example:

<rpc message-id="101"
          xmlns="urn:ietf:params:xml:ns:netconf:base:1.0">
       <edit-config>
         <target>
           <running/>
         </target>
         <config>
           <top xmlns="http://example.com/schema/1.2/config">
             <interface>
               <name>?????????????</name>
               <mtu></mtu>
             </interface>
           </top>
         </config>
       </edit-config>
     </rpc>

Please suggest, Is there any limitaions on string data-type while configuring through Netconf.

Regards,

Ramu N
***************************************************************************************

            This e-mail and attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient's) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 19 Jul 2011 08:07:35 +0200

> In <edit-config> operation, for string data-type fields can contain some special characters like tab(\t), ?

RFC 6020 says:

9.4.  The string Built-In Type

   The string built-in type represents human-readable strings in YANG.
   Legal characters are tab, carriage return, line feed, and the legal
   characters of Unicode and ISO/IEC 10646 [ISO.10646]:

     ;; any Unicode character, excluding the surrogate blocks,
     ;; FFFE, and FFFF.
     string = *char
     char = %x9 / %xA / %xD / %x20-D7FF / %xE000-FFFD /
            %x10000-10FFFF

NETCONF itself (RFC 6241) does not place any restriction on the
content of XML elements.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>