Subject: Re: [Netconf] [netmod] system data model rpcs

From: "Bert (IETF) Wijnen" <[email-masked]>
Date: Tue, 26 Jul 2011 17:05:36 -0400

On 7/26/11 4:11 PM, Yoshifumi Atarashi wrote:
> Many venders and ISPs operators think that Power/Reboot control
> mechanism are  caution of securty hole .
> Be carefully consider the risks.
>      Yoshifumi Atarashi
OK, I remember that way back when, there were safety laws that would forbid to
do a remote reboot (actually that was a remote power on.).

But in any event, these dyas, someone can ssh into a device, got to root mode
and then do a reboot also. SO in that sense, I do not see why it would be
so different if Netcofn could do it (with proper access control of course).

Bert

> (11/07/26 16:02), Juergen Schoenwaelder wrote:
>> Hi,
>>
>> I am wondering whether we should add some additional RPCs to the
>> system data model. I am thinking about very basic things such as a
>> reboot RPC and/or a powerdown RPC.
>>
>> /js
>>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: Yoshifumi Atarashi <[email-masked]>
Date: Tue, 26 Jul 2011 17:31:37 -0400

Thank you, Bert.
We(Venders) sometimes are bullied by operators about security issue......
I don't mind these control.
For netconf/netmod deployment, I'm thinking something is better instead of
power control, more useful for ISPs systems.
    Yoshifumi  Atarashi