Subject: [Netconf] Addition of 'description' or 'label' in commit operation

From: Rohit Pobbathi <[email-masked]>
Date: Mon, 27 Feb 2012 10:35:32 +0530

Hi All,

The addition of a 'description' / 'label' with commit operation is very
useful in certain scenarios. (eg. Rollback).

Neither RFC 4741 nor RFC 6241 has any mention regarding an OPTIONAL
description / label associated with commit operation.

Is there any known issue with this OR is it accepted to be implementation
specific ?

Below is an example of commit operation with an optional label:

<rpc message-id="101" xmlns="urn:ietf:params:xml:ns:netconf:base:1.0">

  <commit>

    <label>USER-LABEL</label>

  </commit>

</rpc>

Regards,

Rohit

---

From: Andy Bierman <[email-masked]>
Date: Mon, 27 Feb 2012 02:39:08 -0800

On 02/26/2012 09:05 PM, Rohit Pobbathi wrote:
> Hi All,
>
> The addition of a ‘description’ / ‘label’ with commit operation is very useful in certain scenarios. (eg. Rollback).
>
> Neither RFC 4741 nor RFC 6241 has any mention regarding an OPTIONAL description / label associated with commit operation.
>
> Is there any known issue with this OR is it accepted to be implementation specific ?
>
> <rpc message-id="101" xm lns=&quo netconf:base:1.0">
>
> <commit>
>
> *<label>USER-LABEL</label>*
>
> </commit>
>
> </rpc>
>

Actually, the <label> element needs to be in a different namespace than the <commit>
element.  The label would presumably show up in a sys-config-change or sys-confirmed-commit
notification, and perhaps in the proprietary server log.  Seems simple enough to add.
Maybe you should have brought it up before the Base Notifications RFC was published.

> Rohit

Andy