Subject: Re: [Netconf] [netmod] Modeling NETCONF Event Notifications

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 3 Jul 2012 16:01:33 +0200

True. Is there any volunteer willing to yangify RFC 5277?

Mehmet 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext
> Juergen Schoenwaelder
> Sent: Tuesday, July 03, 2012 1:59 PM
> To: Jernej Tuljak
> Cc: NETMOD Working Group
> Subject: Re: [netmod] Modeling NETCONF Event Notifications
> 
> On Tue, Jul 03, 2012 at 12:03:31PM +0200, Jernej Tuljak wrote:
> 
> > I have questions regarding NETCONF Notifications and YANG. Which
> > YANG module is the standard module that models RFC5277
> > notifications? I've got nc-notifications@2008-07-14
> > <mailto:nc-notifications@2008-07-14> and notifications@2008-07-14
> > <mailto:notifications@2008-07-14> over here, but it's quite evident
> > that they are part of yuma's netconfd. Are these what I'm looking
> > for?
> 
> RFC 5277 predates the 'yangification' of the NETCONF specification and
> there likely is a need to update/redo RFC 5277 at some point in time.
> 
> /js
> 
> --
> Juergen Schoenwaelder           Jacobs University Bremen gGmbH
> Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
> Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 3 Jul 2012 16:28:25 +0200

Hi,

another option (in theory) would be to merge RFC 5277 into a future
version of NETCONF as a capability. Anyway, this seems to belong to
NETCONF space, so I remove NETMOD from the CC list.

/js

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 3 Jul 2012 16:35:03 +0200

However, aligning RFC 5277 with RFC 6241 can be done pretty fast.
As I understand people don't want to open a new construction ground with
RFC 6241, or?

Mehmet 

> From: ext Juergen Schoenwaelder
[mailto:[email-masked]]
> Sent: Tuesday, July 03, 2012 4:28 PM
> To: Ersue, Mehmet (NSN - DE/Munich)
> Cc: Jernej Tuljak; [email-masked]

---

From: Andy Bierman <[email-masked]>
Date: Thu, 05 Jul 2012 18:53:08 -0700

> True. Is there any volunteer willing to yangify RFC 5277?

Yes -- since I already started with notifications.yang and nc-notifications.yang.

> Mehmet

Andy

> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

---

From: Andy Bierman <[email-masked]>
Date: Thu, 05 Jul 2012 18:59:29 -0700

> NETCONF space, so I remove NETMOD from the CC list.

It already is 2 capabilities (:notification:1.0 and interleave:1.0).
Let's keep that part stable.  I agree the YANG modules for RFC 5277 do not
have to be in RFC5277bis, but we like to do it that way so people have a clear
picture way in advance what is changing.

You know that if we open up RFC 5277, then people like me will suggest new
features that customers have asked for ;-)

E.g. -- source filtering -- the replay buffer is a ring buffer.
There is no way for an operator to squelch a noisy event generator,
especially for events that are minor or redundant.  All these events
go in the replay buffer and flood it, potentially over-writing important events
already in the replay buffer.  Another solution is to have multiple replay queues by priority.

Andy