Subject: [Netconf] Idle timeout handling in NETCONF session with notification subscription

From: Rohit Pobbathi <[email-masked]>
Date: Tue, 16 Oct 2012 17:03:34 +0530

Hi,

What should be the behavior of SSH Idle Timeout for a NETCONF Session with
notification subscription (without interleave) ?

The time interval between the <notification> cannot be predicted.

RFC 5277 is silent on the above issue.

Regards,

Rohit

---

From: Andy Bierman <[email-masked]>
Date: Wed, 17 Oct 2012 06:29:21 -0700

NETCONF is silent on all timeouts, except confirmed commit.
We implement configurable hello-timeout and idle-timeout parameters.
The default idle timeout is an hour, and any session with notifications
active is not subject to an idle-timeout.

NETCONF does not say you are allowed to drop idle sessions
or sessions stuck in 'hello-wait' state.  But the standard leaves out lots
of stuff that real implementations have to deal with.

Andy

On Tue, Oct 16, 2012 at 4:33 AM, Rohit Pobbathi
<[email-masked]>wrote:

> Hi,****
> ** **
> notification subscription (without interleave) ?****
>
> The time interval between the <notification> cannot be predicted.****
>
> ** **
>
> RFC 5277 is silent on the above issue.****
>
> ** **
>
> Regards,****
>
> Rohit****
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>
>