Subject: [Netconf] Query regarding lifetime of a NETCONF session with notification subscription

From: Rohit Pobbathi <[email-masked]>
Date: Tue, 29 Jan 2013 18:35:48 +0530

Hi,

I have a query regarding lifetime of a NETCONF session with notification
(Server does not support interleave capability in this case).

As per RFC 5277, below is the definition of a Notification Subscription:

Subscription:  An agreement and method to receive event notifications

      over a NETCONF session.  A concept related to the delivery of

      notifications (if there are any to send) involving destination and

      selection of notifications.  It is bound to the lifetime of a

      session.

3.5.  Subscriptions Data

   Subscriptions are non-persistent state information, and their

   lifetime is defined by their session or by the <stopTime> parameter.

Consider the case where the server may have a functionality to initiate
session closure based on simple inactivity timeout.

In such a scenario, the period of inactivity between two notifications can
cause a session closure.

To receive subsequent notifications, the NMS must create another session and
enable subscription.

RFC 5277 does not mention about the inactivity timeout in a session with
notification subscription, please clarify.

Regards,

Rohit

---

From: Andy Bierman <[email-masked]>
Date: Wed, 30 Jan 2013 00:27:41 -0800

I don't think RFC 5277 says anything about idle timeouts.
No NETCONF document does, so this is outside the scope
of the standard.  Do whatever you want I guess.
There was no interest in the WG to re-open RFC 5277
when it was discussed last year.

Andy

On Tue, Jan 29, 2013 at 5:05 AM, Rohit Pobbathi
<[email-masked]>wrote:

> Hi,****
> ** **
> (Server does not support interleave capability in this case).****
>
> ** **
>
> As per RFC 5277, below is the definition of a Notification Subscription:**
> **
>
> Subscription:  An agreement and method to receive event notifications****
>
>       over a NETCONF session.  A concept related to the delivery of****
>
>       notifications (if there are any to send) involving destination and**
> **
>
>       selection of notifications.  It is bound to the lifetime of a****
>
>       session.****
>
> ** **
>
> *3.5.  Subscriptions Data*****
>
> ** **
>
>    Subscriptions are non-persistent state information, and their****
>
>    lifetime is defined by their session or by the <stopTime> parameter.***
> *
>
> ** **
>
> *Consider the case where the server may have a functionality to initiate
> session closure based on simple inactivity timeout.*
>
> ** **
>
> cause a session closure.****
>
> To receive subsequent notifications, the NMS must create another session
> and enable subscription.****
>
> ** **
>
> notification subscription, please clarify.****
>
> ** **
>
> Regards,****
>
> Rohit****
>
> ** **
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>
>