Subject: [Netconf] draft-kwatsen-conditional-enablement-00

From: Kent Watsen <[email-masked]>
Date: Tue, 26 Feb 2013 22:00:03 +0000

NETCONF WG,

The following draft has been submitted for your consideration:

    http://tools.ietf.org/html/draft-kwatsen-conditional-enablement-00

Thanks,
Kent

---

From: Andy Bierman <[email-masked]>
Date: Tue, 26 Feb 2013 14:43:09 -0800

Hi Kent,

I'll bite first ;-)

YANG can already do this with when-stmt and XPath.
I know when-stmt for config=true can only point to other config=true,
but I look at the "platform config" an an access control issue, and
it is just more config that is only set by a privileged system user.

     groups {
           my-group-g1 {
               system {
                   hostname xyz;
               }
           when {
               model tx1000;
               routing-engine re0;
               time 2am to 4am;
           }
         }
       }

If the 'model', routine-engine', and range begin/end variables were YANG leafs
then when-stmt can be used to describe the condition.

IMO, inventing a new expression syntax when we already have 1 is not needed.

Andy

On Tue, Feb 26, 2013 at 2:00 PM, Kent Watsen <[email-masked]> wrote:

> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>
>

---

From: Kent Watsen <[email-masked]>
Date: Wed, 27 Feb 2013 00:38:30 +0000

Hi Andy,

Thanks for your comments and biting first  ;)

I think the with YANG's when-statement is that it applies to the schema as a whole, whereas this solution works on distinct data elements.  For instance, envision a list of interfaces, we may want some (but not all)  interfaces to enabled conditionally, and then, perhaps with different policies.

Thanks,
Kent

From: Andy Bierman <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, February 26, 2013 5:43 PM
To: Kent Watsen <[email-masked]<mailto:[email-masked]>>
Cc: NetConf <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Netconf] draft-kwatsen-conditional-enablement-00

Hi Kent,

I'll bite first ;-)

     groups {
           my-group-g1 {
               system {
                   hostname xyz;
               }
           when {
               model tx1000;
               routing-engine re0;
               time 2am to 4am;
           }
         }
       }

Andy

On Tue, Feb 26, 2013 at 2:00 PM, Kent Watsen <[email-masked]<mailto:[email-masked]>> wrote:
NETCONF WG,

Thanks,
Kent

_______________________________________________
Netconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netconf