Subject: [Netconf] NETCONF extensions in 6020

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 6 Jun 2013 20:04:50 +0200

Hi,

today I got a tricky question that I couldn't adequately answer: RFC 6020 introduces extensions to the NETCONF protocol - specifically, several new attributes for edit-config. However, this extension is not explicitly advertised as a capability. Does it mean that advertising *any* YANG module in hello automatically includes support for these YANG-based extensions?

Thanks, Lada

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 06 Jun 2013 22:39:08 +0200 (CEST)

Hi,

Ladislav Lhotka <[email-masked]> wrote:
> Hi,
> 
> today I got a tricky question that I couldn't adequately answer: RFC 6020
> introduces extensions to the NETCONF protocol - specifically, several new
> attributes for edit-config. However, this extension is not explicitly
> advertised as a capability. Does it mean that advertising *any* YANG module in
> hello automatically includes support for these YANG-based extensions?

No.  These attributes are only applicable for ordered-by user
(leaf-)lists.  If a server advertises support for a YANG module with
such nodes, it means it supports these attributes (for these nodes).

If a server does not support any modules with ordered-by user
(leaf-)lists, these attributes don't apply.

/martin

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 7 Jun 2013 10:54:30 +0200

> (leaf-)lists, these attributes don't apply.

OK. The question came from a colleague who implements NETCONF fro OpenWRT's Unified Configuration Interface, and he doesn't want to support the "before" and "after" updates even for ordered-by-user lists - so the entire list would have to be completely replaced instead. I will try to change his mind…

Thanks, Lada