Subject: [Netconf] Rpc-error

From: Tina TSOU <[email-masked]>
Date: Tue, 9 Jul 2013 18:02:38 +0000

Dear all,
Mehmet asked me to move below offline discussion to the mailing list.
My co-author and I who are preparing an Internet Draft about the extension of rpc-error to support multiple language, refer the rfc6243 and several other RFCs, there is no YANG Module definition for rpc-error, it's defined in details in the netconf.xsd.
It seems YANG module for RPC in current RFCs mainly takes care the input, but pays less attention on output, we are wondering if there is any background or reasons.
What do you think about this?

Thank you,
Tina

---

From: Andy Bierman <[email-masked]>
Date: Tue, 9 Jul 2013 11:25:44 -0700

On Tue, Jul 9, 2013 at 11:02 AM, Tina TSOU <[email-masked]> wrote:
> My co-author and I who are preparing an Internet Draft about the extension
> of rpc-error to support multiple language, refer the rfc6243 and several
> other RFCs, there is no YANG Module definition for rpc-error, it's defined
> in details in the netconf.xsd.
>
> It seems YANG module for RPC in current RFCs mainly takes care the input,
> but pays less attention on output, we are wondering if there is any
> background or reasons.
>

I wanted something like this, because it is in yuma-netconf.yang,
and ietf-netconf.yang was derived from that module:

http://www.netconfcentral.org/modulereport/yuma-netconf#RpcDataReplyType.659

There is already a definition of <rpc-error> contents (rpcErrorType grouping)
and I needed a YANG extension to define the xml:lang attribute:

http://www.netconfcentral.org/modulereport/yuma-netconf#LangString.210

> What do you think about this?

NETCONF error-message already supports the xml:lang attribute.
Are you proposing to apply this attribute to other fields?
That is the only one of type 'string'.

  error-message:  Contains a string suitable for human display that
      describes the error condition.  This element will not be present
      if no appropriate message is provided for a particular error
      condition.  This element SHOULD include an "xml:lang" attribute as
      defined in [W3C.REC-xml-20001006] and discussed in [RFC3470].

> Tina

Andy

---

From: Tina TSOU <[email-masked]>
Date: Fri, 12 Jul 2013 20:19:38 +0000

Dear Andy et al,
Here is the draft.

Begin forwarded message:

From: <[email-masked]<mailto:[email-masked]>>
Date: July 11, 2013, 5:59:49 AM PDT
To: Tina Tsou <[email-masked]<mailto:[email-masked]>>, Xiaofeng Ji <[email-masked]<mailto:[email-masked]>>, Shouchuan Yang <[email-masked]<mailto:[email-masked]>>, Ting Zou <[email-masked]<mailto:[email-masked]>>, Gang Yan <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-ysc-netconf-rpc-error-extension-00.txt

A new version of I-D, draft-ysc-netconf-rpc-error-extension-00.txt
has been successfully submitted by Shouchuan Yang and posted to the
IETF repository.

Filename:     draft-ysc-netconf-rpc-error-extension
Revision:     00
Title:         NETCONF rpc-error extension
Creation date:     2013-07-11
Group:         Individual Submission
Number of pages: 9
URL:             http://www.ietf.org/internet-drafts/draft-ysc-netconf-rpc-error-extension-00.txt
Status:          http://datatracker.ietf.org/doc/draft-ysc-netconf-rpc-error-extension
Htmlized:        http://tools.ietf.org/html/draft-ysc-netconf-rpc-error-extension-00

Abstract:
  The NETCONF is a machine-machine interface, it is easy to expand.
  This document will expand the rpc-error message to make multiple
  language support easily.

The IETF Secretariat

Thank you,
Tina

On Jul 9, 2013, at 11:25 AM, "Andy Bierman" <[email-masked]<mailto:[email-masked]>> wrote:

On Tue, Jul 9, 2013 at 11:02 AM, Tina TSOU <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

Thank you,

Tina

Andy