Subject: [Netconf] Updating Operational data nodes using netconf

From: Ambika Tripathy <[email-masked]>
Date: Wed, 5 Feb 2014 18:42:33 +0530

Hi,

I am new to netconf. I have one fundamental question related to operation
attribute update using netconf. (as i know <edit-config> will only update
config data defied in a yang model.)

Lets Say my model is:

rw location-mgmt
+-- rw locations [location-id]
    +-- rw location-id string
    +-- rw location-name string
    +-- rw state string
    +-- rw postal-code uint32
    +-- ro temperature uint16
    +-- ro humidity uint16

How can I update temperature and humidity attribute for the above model
using a netconf client <RPC> message?

-- 
Ambika Prasad Tripathy
Cell @+91 9437547730/8553070866
Alt email: [email-masked]
[email-masked]

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 5 Feb 2014 14:26:57 +0100

> using a netconf client <RPC> message?

There is no standard way of doing this (yet). You have to roll your
own RPC, which YANG luckily enables you to define.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Ambika Tripathy <[email-masked]>
Date: Wed, 5 Feb 2014 19:21:13 +0530

Thanks Juergen,

So, that mean i have to define one RPC in my yang model and implement that
by my application. And pass temperature and humidity as two input parameter
in that RPC to update it in YANG data store? Please conform.

br,
Ambika

skype:ambika_nethawk

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 5 Feb 2014 15:03:40 +0100

On 05 Feb 2014, at 14:51, Ambika Tripathy <[email-masked]> wrote:

> Thanks Juergen,
> 
> So, that mean i have to define one RPC in my yang model and implement that by my application. And pass temperature and humidity as two input parameter in that RPC to update it in YANG data store? Please conform.

Note that the “ro” parameters are operational state, so generally they are supposed to be updated by the device. In your case, the device may have temperature and humidity sensors, so there is no reason for the client to tinker with these values.

Lada 

> 
> br,
> Ambika
> 
> 
> On Wed, Feb 5, 2014 at 6:56 PM, Juergen Schoenwaelder <[email-masked]> wrote:
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 5 Feb 2014 15:05:19 +0100

> in that RPC to update it in YANG data store? Please conform.

That is one way of doing this. You can also create something more
generic but it is all up to you.

/js

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 5 Feb 2014 15:19:19 +0100

On 05 Feb 2014, at 15:05, Ambika Tripathy <[email-masked]> wrote:

> Hi Lada,
> 
> That's true.. But i want to over-write the values of those variable by outside box using netconf client.

OK, then probably the best option is an RPC, as Jürgen suggested. Alternatively, it’s also sometimes possible to define a configuration parameter that is coupled with the operational value somehow - it would be up to the data model designer to specify the semantics.

Lada

> 
> br,
> Ambika
> 
> 
> On Wed, Feb 5, 2014 at 7:33 PM, Ladislav Lhotka <[email-masked]> wrote:
>

---

From: Andy Bierman <[email-masked]>
Date: Wed, 5 Feb 2014 08:59:52 -0800

Hi,

Beyond the protocol mechanics of editing operational state,
one has to wonder about the high-level network management
model here.

What does it actually mean for the client to tell the
server to change the reading on its temperature gauge?

It doesn't mean change the temperature of the device
so the gauge accurately reflects the new desired value.\
That would be configuration.

It doesn't mean just report this value and behave as if the
temperature is the correct value.

It seems to just mean "behave as if the temperature is
the provided value", which seems like configuration to me.

I think there is more to configuration than persistence.
Editing operational state seems to just be configuration with
a limited lifetime.

Andy