Subject: [Netconf] Netconf/YANG Interop test details

From: Balazs Lengyel <[email-masked]>
Date: Mon, 24 Feb 2014 11:59:57 +0100

Hello All,

Around IETF 85 there was a Netconf Interop test organized.

http://www.internetsociety.org/articles/successful-netconf-interoperability-testing-announced-ietf-85

We, Ericsson did not participate at the time, however we are
getting interested in interop testing. Where can I get some details
about the testing? What data models were used? What test cases were
run? Was it automated or fully manual testing? Was the full test
report prepared? Where do I find it? Was any further Interop testing
done since then?

Any details would be interesting?

regards Balazs

--
Balazs Lengyel Ericsson Hungary Ltd.
System Manager
ECN: 831 7320 Tel: +36-1-437-7320
Mobile: +36-70-330-7909 email: [email-masked]

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 24 Feb 2014 14:06:08 +0100

On Mon, Feb 24, 2014 at 11:59:57AM +0100, Balazs Lengyel wrote:
>    [1]http://www.internetsociety.org/articles/successful-netconf-interoperability-testing-announced-ietf-85
>    We, Ericsson did not participate at the time, however we are getting
>    interested in interop testing. Where can I get some details about the
>    testing? What data models were used? What test cases were run? Was it
>    automated or fully manual testing?

People brought to the interop meeting whatever they had. Some had
collections of test cases, some were testing more ad-hoc. Sometimes
test cases were modified to work with whatever data models were
available. As such, the testing was mostly manual.

>    Was the full test report prepared?  Where do I find it?

There is not a full test report and it surely would not be public
since such testing events take place under an NDA. Bert Wijnen
produced a highlevel writeup for the IETF Journal, which you might
know:

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Mon, 24 Feb 2014 14:38:04 +0100

See at bottom

> http://www.internetsociety.org/articles/successful-netconf-interoperability-testing-announced-ietf-85
Thanks for posting that link Juergen.

We also presented the results summary at the NETCONF session at that IETF,
See:
     http://www.ietf.org/proceedings/85/slides/slides-85-netconf-3.pdf

Bert