Subject: [Netconf] Implementing a NETCONF Client

From: Adel Zaalouk <[email-masked]>
Date: Thu, 19 Jun 2014 15:53:28 +0200

Hi,

I am planning on implementing a NETCONF client from scratch. However, I am relatively new to this business. Therefore, I would really appreciate it if someone can give me some pointers on how to bootstrap my implementation, I am not after a fancy client or anything, I just need to implement the basic functionalities assuming that I know the YANG model of the underlying device.

Best regards,
Adel.

---

From: Kent Watsen <[email-masked]>
Date: Thu, 19 Jun 2014 18:11:35 +0000

There are a number of open source NETCONF libraries to handle protocol basics, but "assuming that I know the YANG model of the underlying device" introduces the need for schema-aware logic, for instance, to drive a user-interface.   Can you say more about the kind of client you are trying to write?

Kent

From: Adel Zaalouk <[email-masked]<mailto:[email-masked]>>
Date: Thursday, June 19, 2014 at 9:53 AM
To: NetConf <[email-masked]<mailto:[email-masked]>>
Subject: [Netconf] Implementing a NETCONF Client

Hi,

Best regards,
Adel.

---

From: Adel Zaalouk <[email-masked]>
Date: Thu, 19 Jun 2014 20:58:18 +0200

Hi Kent, 

Thank you for your reply. 

For example, if I have the following yang sub-tree 

      +--rw resources
      |  +--rw port* [resource-id]
      |  |  +--rw resource-id      inet:uri
      |  |  +--ro number?          uint64
      |  |  +--ro name?            string
      |  |  +--ro current-rate?    uint32
      |  |  +--ro max-rate?        uint32
      |  |  +--rw configuration

I would like to be able to use the client to list ports, or to modify the port configuration for instance. I.e., I am given the YANG model, and I would like to translate this to configurable NETCONF parameters. 

Thank you. 
Best regards, 
Adel. 
________________________________________
From: Kent Watsen [[email-masked]]
Sent: Thursday, 19 June 2014 8:11 PM
To: Adel Zaalouk; [email-masked]
Subject: Re: [Netconf] Implementing a NETCONF Client

Kent

Hi,

Best regards,
Adel.

---

From: [email-masked]
Date: Fri, 20 Jun 2014 10:42:38 +0800

I think you should write a YANG parser or get a open source YANG parser( 
e.g pyang(python), yangdump(C), opendaylight yangtools(java)).

/frank

"Netconf" <[email-masked]> 写于 2014-06-20 02:58:18:

> Adel Zaalouk <[email-masked]> 
> 发件人:  "Netconf" <[email-masked]>
> 
> 2014-06-20 02:58
> 
> 收件人
> 
> Kent Watsen <[email-masked]>, "[email-masked]" 
<[email-masked]>, 
> 
> 抄送
> 
> 主题
> 
> Re: [Netconf] Implementing a NETCONF Client
> 
> Hi Kent, 
> 
> I would like to be able to use the client to list ports, or to 
> modify the port configuration for instance. I.e., I am given the 
> YANG model, and I would like to translate this to configurable 
> NETCONF parameters. 
> 
> Thank you. 
> Best regards, 
> Adel. 
> There are a number of open source NETCONF libraries to handle 
> protocol basics, but "assuming that I know the YANG model of the 
> underlying device" introduces the need for schema-aware logic, for 
> instance, to drive a user-interface.   Can you say more about the 
> kind of client you are trying to write?
> 
> Kent
> 
> I am planning on implementing a NETCONF client from scratch. 
> However, I am relatively new to this business. Therefore, I would 
> really appreciate it if someone can give me some pointers on how to 
> bootstrap my implementation, I am not after a fancy client or 
> anything, I just need to implement the basic functionalities 
> assuming that I know the YANG model of the underlying device.
> 
> 
> Best regards,
> Adel.
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail (and any attachment transmitted herewith) is privileged and confidential and is intended for the exclusive use of the addressee(s).  If you are not an intended recipient, any disclosure, reproduction, distribution or other dissemination or use of the information contained is strictly prohibited.  If you have received this mail in error, please delete it and notify us immediately.
--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail (and any attachment transmitted herewith) is privileged and confidential and is intended for the exclusive use of the addressee(s).  If you are not an intended recipient, any disclosure, reproduction, distribution or other dissemination or use of the information contained is strictly prohibited.  If you have received this mail in error, please delete it and notify us immediately.