Subject: [Netconf] Question on filter - is it valid that multiple content match nodes in nested containers

From: Yong Zhu <[email-masked]>
Date: Fri, 29 Jan 2016 15:21:45 +0000

Hi Workgroup,

I just want to verify the "nested multiple content match nodes" filter is valid or not.
"   o  If any containment nodes are present in the sibling set, then they
      are processed further and included if any nested filter criteria
      are also met.
" 
>From the above, I think it is valid filter, right?

For example:
<filter type="subtree">
<top>
<users>
  <users_leaf1>users leaf1 match content</users_leaf1>
  <user>
    <user_leaf1>user leaf1 match content</user_leaf1>
  <user>
</user>
</users>
</top>
</filter>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 29 Jan 2016 21:35:26 +0100

This is invalid XML.

/js

On Fri, Jan 29, 2016 at 03:21:45PM +0000, Yong Zhu wrote:
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>