Subject: Re: [Netconf] [netmod] Question on the output of <get> rpc-reply for operational model?

From: Randy Presuhn <[email-masked]>
Date: Thu, 28 Jan 2016 22:46:56 -0800 (GMT-08:00)

Hi -

>From: Juergen Schoenwaelder <[email-masked]>
>Sent: Jan 28, 2016 10:03 AM
>To: Yong Zhu <[email-masked]>
>Cc: "[email-masked]" <[email-masked]>
>Subject: Re: [netmod] Question on the output of <get> rpc-reply for operational model?
>
>Hi,
>
>your question is mainly a protocol question and not so much a YANG
>question so it probably belongs to NETCONF more than NETMOD. RFC 6241
>in the section describing subtree filtering says:
>
>   o  If any sibling nodes of the selection node are instance identifier
>      components for a conceptual data structure (e.g., list key leaf),
>      then they MAY also be included in the filter output.
>
>I would expect that sensible implementations implement the MAY and
>include sibling key leafs (and that they would do this recursively).

As a practial matter, interoperability dictates that clients 
must *always* be prepared for the possibility that a server might
not be "sensible", and will instead omit such sibling key leafs.

Randy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 29 Jan 2016 09:30:25 +0100

> not be "sensible", and will instead omit such sibling key leafs.

Right. So a client better asks explicitly for key leafs to be returned
than relying on a MAY behavior.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Yong Zhu <[email-masked]>
Date: Fri, 29 Jan 2016 15:08:17 +0000

Hi Juergen and Randy,

Thank for your answer. I am good now.

/Yong

-----Original Message-----
From: Netconf [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
Sent: Friday, January 29, 2016 12:30 AM
To: Randy Presuhn
Cc: [email-masked]
Subject: Re: [Netconf] [netmod] Question on the output of <get> rpc-reply for operational model?

On Thu, Jan 28, 2016 at 10:46:56PM -0800, Randy Presuhn wrote:
> As a practial matter, interoperability dictates that clients must 
> *always* be prepared for the possibility that a server might not be 
> "sensible", and will instead omit such sibling key leafs.
>

Right. So a client better asks explicitly for key leafs to be returned than relying on a MAY behavior.

/js

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf