Subject: [Netconf] RESTCONF fields-expr

From: Andy Bierman <[email-masked]>
Date: Mon, 11 Jan 2016 11:59:24 -0800

Hi,

I think the fields-expr is too complicated and
provides too many ways to do the same thing.

   fields-expr = path '(' fields-expr ')' /
                 path ';' fields-expr /
                 path
   path = api-identifier [ '/' path ]

   fields=foo/bar is exactly the same as fields=foo(bar)

I propose the following syntax change:

OLD:

 path = api-identifier [ '/' path ]

NEW:

  path = api-identifier

Andy

---

From: "fengchong (C)" <[email-masked]>
Date: Tue, 12 Jan 2016 01:52:15 +0000

Hi,

Why not use :

   fields-expr = ‘(‘(field-expr)’)’/
                    ‘(‘*(field-expr’;’)field-expr’)’
     field-expr = path /
                  path’/’fields-expr
     path = api-identifier [ '/' path ]

________________________________
冯冲
华为技术有限公司 Huawei Technologies Co., Ltd.
[Company_logo]

Phone:
Fax:
Mobile: 18519117316
Email: [email-masked]
地址：南京市软件大道101号华为南京基地 邮编：210001
Huawei Technologies Co., Ltd.

http://www.huawei.com
________________________________
本邮件及其附件含有华为公司的保密信息，仅限于发送给上面地址中列出的个人或群组。禁
止任何其他人以任何形式使用（包括但不限于全部或部分地泄露、复制、或散发）本邮件中
的信息。如果您错收了本邮件，请您立即电话或邮件通知发件人并删除本邮件！
This e-mail and its attachments contain confidential information from HUAWEI, which
is intended only for the person or entity whose address is listed above. Any use of the
information contained herein in any way (including, but not limited to, total or partial
disclosure, reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!
发件人: Netconf [mailto:[email-masked]] 代表 Andy Bierman
发送时间: 2016年1月12日 3:59
收件人: Netconf
主题: [Netconf] RESTCONF fields-expr

Hi,

OLD:

NEW:

  path = api-identifier

Andy

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 12 Jan 2016 09:36:51 +0100

> On 11 Jan 2016, at 20:59, Andy Bierman <[email-masked]> wrote:
> 
> Hi,
> 

I sort of agree, see the example in my review. Perhaps it would be possible to use (a subset of) XPath in order to avoid introducing a new query language, at the cost of some extra escaping. It was discussed here:

http://news.oreilly.com/2008/08/can-a-url-contain-an-xpath.html

Lada

> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 12 Jan 2016 09:44:30 +0100 (CET)

Ladislav Lhotka <[email-masked]> wrote:
> I sort of agree, see the example in my review.

The syntax is used in some google REST apis, see e.g.
https://developers.google.com/custom-search/json-api/v1/performance#fields-syntax

/martin