Subject: [Netconf] edit-config to startup configuration datastore

From: "Rastislav Szabo -X (raszabo - PANTHEON TECHNOLOGIES at Cisco)" <[email-masked]>
Date: Fri, 15 Apr 2016 07:37:38 +0000

Hi,

I would like to ask for the clarification on why the contents of startup configuration datastore cannot be modified by <edit-config> operation. Although the text of the RFC 6241 does not explicitly prohibit it, the [email-masked] does not allow startup as the target of the edit-config RPC.

The reason why I'm asking this is that we think that we have found a use-case for this in our project. Details on the project follow.

In sysrepo [1] and Netopeer2 [2] integration project we aim to provide a convenient API for any Linux applications/daemons to become manageable via NETCONF. To do it, (in the most-basic use-case) they would just need to switch (or amend) the part of the code, where they read their configuration e.g. from text config files to the code that would read it from sysrepo datastore. The issue is, that many Linux daemons are designed to read the config only by their startup. We thought that for such applications, the best approach would be to say that they do not support running datastore (their config never appears in running) and the only way to control them is via modification of their startup configuration. Sysrepo datastore of course will provide the API to support changes of the running state of the applications, but it will be more challenging for the integration into legacy Linux daemons. While it is not integrated into some of them, it would be better to have only startup config NETCONF support, than no NETCONF support at all.

[1] https://github.com/sysrepo/sysrepo
[2] https://github.com/CESNET/Netopeer2

Thanks,
Rastislav

---

From: Kent Watsen <[email-masked]>
Date: Mon, 18 Apr 2016 16:44:30 +0000

This is before my time, but I would've thought startup would be editable, given that it is lockable...

Kent

From: Netconf <[email-masked]<mailto:[email-masked]>> on behalf of "Rastislav Szabo -X (raszabo - PANTHEON TECHNOLOGIES at Cisco)" <[email-masked]<mailto:[email-masked]>>
Date: Friday, April 15, 2016 at 3:37 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Netconf] edit-config to startup configuration datastore

Hi,

I would like to ask for the clarification on why the contents of startup configuration datastore cannot be modified by <edit-config> operation. Although the text of the RFC 6241 does not explicitly prohibit it, the [email-masked]<mailto:[email-masked]> does not allow startup as the target of the edit-config RPC.

The reason why I’m asking this is that we think that we have found a use-case for this in our project. Details on the project follow.

Thanks,
Rastislav