Subject: Re: [Netconf] WG Adoption Call for draft-bierman-netconf-rfc6536bis WAS:FW: new NACM draft

From: "Mehmet Ersue" <[email-masked]>
Date: Wed, 4 Jan 2017 17:30:52 +0100

Dear All,

we assume now the WG support for the adoption of
draft-bierman-netconf-rfc6536bis.
Authors please submit as draft-ietf-netconf-rfc6536bis-00. Thanks.

Mehmet & Mahesh

-----Original Message-----
From: Netconf [mailto:[email-masked]] On Behalf Of Mehmet Ersue
Sent: Wednesday, December 14, 2016 10:20 PM
To: 'Netconf' <[email-masked]>
Subject: [Netconf] WG Adoption Call for draft-bierman-netconf-rfc6536bis
WAS:FW: new NACM draft

Dear NETCONF WG,

for the potential topics to add we only got comments from Martin. We assume
now there are no other comments.

This is a 2+ week WG adoption call for draft-bierman-netconf-rfc6536bis to
adopt as NETCONF WG item.

Please state your opinion on the mail list by December 30, 2016 with
"yes/support" or "no support".  

If you support, please let us know what you would like to address
additionally.
If you don't support, please elaborate your reasons.  

Thank you,
Mehmet & Mahesh

-----Original Message-----
From: Martin Bjorklund [mailto:[email-masked]]
Sent: Wednesday, December 7, 2016 9:20 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Netconf] new NACM draft

MehmetErsue <[email-masked] <mailto:[email-masked]> > wrote:
> Hi Andy, Martin,
> 
> thank you for the initial draft.
> 
> We discussed in IETF 97 different issues and the additional sections 
> we could add.

Ok.  But do we have to resolve all issues before adopting this document?  I
think the current document is ready for adoption, and then the WG can work
on fixing any open issues.

> IIRC the list was:
> - schema-mount related text into schema-mount or the NACM draft,

I think schema mount needs to discuss how it works with NACM.  This should
be an open issue in schema mount.

> - assigning priorities to clients,

I don't believe this is a NACM issue.

> - access control on dynamic datastores (e.g. I2RS),

The text in 3.2 probably need to be relaxed a bit to allow NACM to be
applied to other datastores.

> - the issue from RFC 6536 with parent/child relationships which is 
> important for RESTCONF.

Can you elaborate on this?

/martin

> 
> I would like to suggest to have a discussion on these issues and 
> understand whether they should be included.
> 
> Mehmet
> 
> On Wed, Nov 30, 2016 at 2:10 AM, Andy Bierman <[email-masked]
<mailto:[email-masked]> > wrote:
> 
> > Hi,
> >
> > A new version of draft-bierman-netconf-rfc6536bis has been posted:
> > https://www.ietf.org/id/draft-bierman-netconf-rfc6536bis-01.txt
> >
> >
> > We would like this draft to be adopted as the starting point for 
> > item #5 in the current NETCONF charter.
> >
> >
> >
> > Andy and Martin
> >
> >
> > _______________________________________________
> > Netconf mailing list
> > [email-masked] <mailto:[email-masked]> 
> > https://www.ietf.org/mailman/listinfo/netconf
> >
> >
> 
> 
> --
> Cheers,
> Mehmet

_______________________________________________
Netconf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netconf

---

From: Andy Bierman <[email-masked]>
Date: Thu, 5 Jan 2017 10:26:44 -0800

> Authors please submit as draft-ietf-netconf-rfc6536bis-00. Thanks.
done

> Mehmet & Mahesh

Andy