Subject: Re: [Netconf] Fwd: YANG modules dependencies tool: result for the "Client/Server Configuration Model" package

From: Benoit Claise <[email-masked]>
Date: Wed, 22 Mar 2017 18:23:16 +0100

Dear all,

Looking at this package again.
http://www.yangcatalog.org/yang-search/impact_analysis.php?modules[]=ietf-tls-client&modules[]=ietf-tls-server&modules[]=ietf-ssh-client&modules[]=ietf-ssh-server&modules[]=ietf-restconf-client&modules[]=ietf-restconf-server&modules[]=ietf-key-store&modules[]=ietf-netconf-client&modules[]=ietf-netconf-server&orgs[]=ietf&recurse=&rfcs=1

Regards, Benoit
> This should have been sent to NETCONF, not NETMOD.
>
> Regards, Benoit
>
> -------- Forwarded Message --------
> Subject: 	YANG modules dependencies tool: result for the 
> "Client/Server Configuration Model" package
> Date: 	Sun, 13 Nov 2016 16:23:40 +0900
> From: 	Benoit Claise <[email-masked]>
> To: 	NETMOD Working Group <[email-masked]>
> CC: 	Joe Clarke (jclarke) <[email-masked]>
>
>
>
> Dear all,
>
> Let's look at this "Client/Server Configuration Model" package, i.e. 
> those drafts:
>     draft-ietf-netconf-keystore-00 Keystore Model
>     draft-ietf-netconf-ssh-client-server-00 SSH Client and Server Models
>     draft-ietf-netconf-tls-client-server-00 TLS Client and Server Models
>     draft-ietf-netconf-netconf-client-server-00 NETCONF Client and 
> Server Models
>     draft-ietf-netconf-restconf-client-server-00 RESTCONF Client and 
> Server Models
>
> During this week-end hackathon, Joe Clarke created a very useful 
> visual tool.
> For this package, see 
> http://www.yangcatalog.org/yang-search/impact_analysis.php?modules[]=ietf-tls-client&modules[]=ietf-tls-server&modules[]=ietf-ssh-client&modules[]=ietf-ssh-server&modules[]=ietf-restconf-client&modules[]=ietf-restconf-server&modules[]=ietf-key-store&modules[]=ietf-netconf-client&modules[]=ietf-netconf-server&orgs[]=ietf&recurse=&rfcs=1
>
> Some info on the tool. You can add all the YANG modules you want, you 
> can select the level of recursion, you can move the bubbles around, 
> you can move the mouse over a YANG module to display the draft name, 
> etc. From there, you can see the bottleneck, i.e. the YANG module that 
> should get our prioritized attention (the one with black circle). RFCs 
> are in red (and there is a flag to remove them), and drafts are in 
> green. See all options under the "graph options" pull down menu.
>
> After selecting the right option, the conclusions are in the attached 
> picture.
>
> Un-selecting the "include RFCs" button provides even a clearer view: 
> in this "package", ietf-keystore requires our attention.
>
>
>
> Regards, Benoit
>
>
>
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

---

From: Kent Watsen <[email-masked]>
Date: Wed, 22 Mar 2017 17:40:21 +0000

Hi Benoit,

FYI, this dependency-graph will be even more interesting when the ietf-syslog and ietf-pce-pcep modules are updated to also use the keystore & ietf-tls-client modules.  My understanding is that these other drafts may be updated soon after the RFC Submit form is re-enabled on Monday morning.

K.

On 3/22/17, 1:23 PM, "Netconf on behalf of Benoit Claise" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Dear all,

Regards, Benoit

Regards, Benoit

-------- Forwarded Message --------
Subject:

YANG modules dependencies tool: result for the "Client/Server Configuration Model" package

Date:

Sun, 13 Nov 2016 16:23:40 +0900

From:

Benoit Claise <[email-masked]><mailto:[email-masked]>

To:

NETMOD Working Group <[email-masked]><mailto:[email-masked]>

CC:

Joe Clarke (jclarke) <[email-masked]><mailto:[email-masked]>

Dear all,
Let's look at this "Client/Server Configuration Model" package, i.e. those drafts:
    draft-ietf-netconf-keystore-00 Keystore Model
    draft-ietf-netconf-ssh-client-server-00 SSH Client and Server Models
    draft-ietf-netconf-tls-client-server-00 TLS Client and Server Models
    draft-ietf-netconf-netconf-client-server-00 NETCONF Client and Server Models
    draft-ietf-netconf-restconf-client-server-00 RESTCONF Client and Server Models

During this week-end hackathon, Joe Clarke created a very useful visual tool.
For this package, see http://www.yangcatalog.org/yang-search/impact_analysis.php?modules[]=ietf-tls-client&modules[]=ietf-tls-server&modules[]=ietf-ssh-client&modules[]=ietf-ssh-server&modules[]=ietf-restconf-client&modules[]=ietf-restconf-server&modules[]=ietf-key-store&modules[]=ietf-netconf-client&modules[]=ietf-netconf-server&orgs[]=ietf&recurse=&rfcs=1

Some info on the tool. You can add all the YANG modules you want, you can select the level of recursion, you can move the bubbles around, you can move the mouse over a YANG module to display the draft name, etc. From there, you can see the bottleneck, i.e. the YANG module that should get our prioritized attention (the one with black circle). RFCs are in red (and there is a flag to remove them), and drafts are in green. See all options under the "graph options" pull down menu.

After selecting the right option, the conclusions are in the attached picture.
Un-selecting the "include RFCs" button provides even a clearer view: in this "package", ietf-keystore requires our attention.

Regards, Benoit

Netconf mailing list

[email-masked]<mailto:[email-masked]>

---

From: Benoit Claise <[email-masked]>
Date: Tue, 28 Mar 2017 08:14:36 -0500

Kent,

You're right. More interesting.

Let me stress some (more on this later) of the enhancements done during 
this hackathon by Joe Clarke on this tool.
- The color coding change: RED was flagging RFCs, while RED is perceived 
as a bottleneck.
- We now have the distinction per RFC, WG document, and individual draft
- You can see "IETF" in the legend. Hint: There is more than the IETF 
now. Again, more on this later

Regards, Benoit

> Hi Benoit,
>
> FYI, this dependency-graph will be even more interesting when the 
> ietf-syslog and ietf-pce-pcep modules are updated to also use the 
> keystore & ietf-tls-client modules.  My understanding is that these 
> other drafts may be updated soon after the RFC Submit form is 
> re-enabled on Monday morning.
>
> K.
>
> On 3/22/17, 1:23 PM, "Netconf on behalf of Benoit Claise" 
> <[email-masked] <mailto:[email-masked]> on behalf 
> of [email-masked] <mailto:[email-masked]>> wrote:
>
> Dear all,
>
>     *Subject: *
>     *Date: *
>     *From: *
>     Benoit Claise <[email-masked]> <mailto:[email-masked]>
>
>     *To: *
>
>     	
>
>     NETMOD Working Group <[email-masked]> <mailto:[email-masked]>
>
>     *CC: *
>
>     	
>
>     Joe Clarke (jclarke) <[email-masked]> <mailto:[email-masked]>
>
>
>
>     Dear all,
>
>     Some info on the tool. You can add all the YANG modules you want,
>     you can select the level of recursion, you can move the bubbles
>     around, you can move the mouse over a YANG module to display the
>     draft name, etc. From there, you can see the bottleneck, i.e. the
>     YANG module that should get our prioritized attention (the one
>     with black circle). RFCs are in red (and there is a flag to remove
>     them), and drafts are in green. See all options under the "graph
>     options" pull down menu.
>
>     Un-selecting the "include RFCs" button provides even a clearer
>     view: in this "package", ietf-keystore requires our attention.
>
>
>
>     Regards, Benoit
>
>
>
>
>     [email-masked] <mailto:[email-masked]>
>