Subject: [Netconf] hands-on NetConf

From: "El Mimouni, Omar Ilias (IntlAssoc)" <[email-masked]>
Date: Thu, 9 Mar 2017 15:59:34 +0000

Hi,
I am new to NetConf (and YANG), and I was wondering where I can find some examples/tutorials as a starting point.
There are plenty of repositories and projects out there and I am kind of confused:

1 - https://github.com/CESNET/libnetconf
2 - https://github.com/CZ-NIC/libnetconf
3-  https://github.com/CESNET/libnetconf2
4 - https://github.com/CESNET/netopeer

Can someone please point out some getting started tutorial about how to use NetConf Client/Server?

Cheers,
Omar

(Sorry if this was sent twice!)

---

From: "Mehmet Ersue" <[email-masked]>
Date: Thu, 9 Mar 2017 17:42:29 +0100

Dear Omar,

some of the tutorials and open source can be reached via NETCONF Wiki:

https://trac.ietf.org/trac/netconf

Regards,

Mehmet

From: Netconf [mailto:[email-masked]] On Behalf Of El Mimouni,
Omar Ilias (IntlAssoc)
Sent: Thursday, March 9, 2017 5:00 PM
To: [email-masked]
Subject: [Netconf] hands-on NetConf

Hi,

I am new to NetConf (and YANG), and I was wondering where I can find some
examples/tutorials as a starting point.

There are plenty of repositories and projects out there and I am kind of
confused:

Can someone please point out some getting started tutorial about how to use
NetConf Client/Server?

Cheers,

Omar

---

From: "El Mimouni, Omar Ilias (IntlAssoc)" <[email-masked]>
Date: Thu, 9 Mar 2017 16:45:46 +0000

Hi Mehmet,

Thank you for your reply.
Indeed, that's where I started after posting the question. I am looking currently at the YumaPro, as it is the first implementation in the list.
Do you think that's a good choice? Are you familiar with their SDK? Any other suggestions are welcome!

Cheers,
Omar

From: Mehmet Ersue [mailto:[email-masked]]
Sent: Thursday, March 09, 2017 11:42 AM
To: El Mimouni, Omar Ilias (IntlAssoc) <[email-masked]>; [email-masked]
Subject: RE: [Netconf] hands-on NetConf

Dear Omar,

Regards,
Mehmet

From: Netconf [mailto:[email-masked]] On Behalf Of El Mimouni, Omar Ilias (IntlAssoc)
Sent: Thursday, March 9, 2017 5:00 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Netconf] hands-on NetConf

Hi,

Cheers,
Omar

---

From: "Mehmet Ersue" <[email-masked]>
Date: Thu, 9 Mar 2017 17:58:52 +0100

Hi Omar,

Andy Bierman is the inventor of YumaPro.

Please send him a private mail.

Regards,

Mehmet

From: El Mimouni, Omar Ilias (IntlAssoc)
[mailto:[email-masked]] 
Sent: Thursday, March 9, 2017 5:46 PM
To: Mehmet Ersue <[email-masked]>; [email-masked]
Subject: RE: [Netconf] hands-on NetConf

Hi Mehmet,

Indeed, that's where I started after posting the question. I am looking
currently at the YumaPro, as it is the first implementation in the list.

Do you think that's a good choice? Are you familiar with their SDK? Any
other suggestions are welcome!

Cheers,

Omar

From: Mehmet Ersue [mailto:[email-masked]] 
Sent: Thursday, March 09, 2017 11:42 AM
To: El Mimouni, Omar Ilias (IntlAssoc) <[email-masked]
<mailto:[email-masked]> >; [email-masked]
<mailto:[email-masked]> 
Subject: RE: [Netconf] hands-on NetConf

Dear Omar,

Regards,

Mehmet

From: Netconf [mailto:[email-masked]] On Behalf Of El Mimouni,
Omar Ilias (IntlAssoc)
Sent: Thursday, March 9, 2017 5:00 PM
To: [email-masked] <mailto:[email-masked]> 
Subject: [Netconf] hands-on NetConf

Hi,

Cheers,

Omar

---

From: "El Mimouni, Omar Ilias (IntlAssoc)" <[email-masked]>
Date: Thu, 9 Mar 2017 16:59:29 +0000

Ok. Thank you!

From: Mehmet Ersue [mailto:[email-masked]]
Sent: Thursday, March 09, 2017 11:59 AM
To: El Mimouni, Omar Ilias (IntlAssoc) <[email-masked]>; [email-masked]
Subject: RE: [Netconf] hands-on NetConf

Hi Omar,

Regards,
Mehmet

From: El Mimouni, Omar Ilias (IntlAssoc) [mailto:[email-masked]]
Sent: Thursday, March 9, 2017 5:46 PM
To: Mehmet Ersue <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Netconf] hands-on NetConf

Hi Mehmet,

Cheers,
Omar

From: Mehmet Ersue [mailto:[email-masked]]
Sent: Thursday, March 09, 2017 11:42 AM
To: El Mimouni, Omar Ilias (IntlAssoc) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Netconf] hands-on NetConf

Dear Omar,

Regards,
Mehmet

Hi,

Cheers,
Omar