Subject: [Netconf] Revised-datastores > tweaking yang-push to accommodate

From: "Eric Voit (evoit)" <[email-masked]>
Date: Tue, 11 Apr 2017 13:38:18 +0000

It would be great to cover some implications of the revised-datastore work within the subscription drafts.  The goal should be the we only need augment the yang-push draft with some new identities when the revised-datastore work completes.

To accomplish this, I believe that we should tweak the yang-push subscription model by:

(1) Adding a 'filter-type' identity  (previously filter subtyping was accomplished via an explicit subtree choice statement)

*       'Subtree', 'xpath'  would be of filter-type

*       New filter types (metadata?) could be augmented in

(2) Adding a 'datastore-type' identity

*       'running', 'candidate', 'startup'  would be of filter-type

*       revised-datastore identities could be augmented in

With such a change the yang tree would look like:

    +--rw filters
    |  +--rw filter*
    |     +--rw  identifier        filter-id
    |     +--rw  filter-type       filter-type
    |     +--rw  filter                anyxml
    +--rw subscription*
           +--rw (filter)
           |    +--:(by-reference)
           |    |  +--rw filter-ref?         filter-ref
           |    +--:(inline)
           |        +--rw  filter-type       filter-type
           |        +--rw  filter                anyxml
           +--rw (target)
                     +--:(datastore)
                     |     +--rw datastore   datastore-type
                     +--:(event-stream)
                            +--rw stream       stream-type

I believe such a restructuring should allow the growth of new filter types, streams, and datastores purely though the addition of new identifies.

Thoughts?  Concerns?   If no, I will submit a new version of draft-ietf-netconf-yang-push-06 which matches to this later in the week.

Eric

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Tue, 11 Apr 2017 14:38:09 +0000

I should have put in the 'subscription-config' container to make the tree reflect this (added in-line in blue below).   Note: per the other part of revised-datastores, it would be great to merge the separate config and operational data.   But that is a different issue.

Eric

From: Eric Voit, April 11, 2017 9:38 AM

    +--rw filters
    |  +--rw filter*
    +--rw subscription-config

Eric