Subject: [Netconf] I-D Action: draft-ietf-netconf-yang-push-06.txt

From: [email-masked]
Date: Thu, 20 Apr 2017 06:49:51 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network Configuration of the IETF.

        Title           : Subscribing to YANG datastore push updates
        Authors         : Alexander Clemm
                          Eric Voit
                          Alberto Gonzalez Prieto
                          Ambika Prasad Tripathy
                          Einar Nilsen-Nygaard
                          Andy Bierman
                          Balazs Lengyel
	Filename        : draft-ietf-netconf-yang-push-06.txt
	Pages           : 49
	Date            : 2017-04-20

Abstract:
   Providing rapid visibility into changes made on YANG configuration
   and operational objects enables new capabilities such as remote
   mirroring of configuration and operational state.  Via the mechanism
   described in this document, subscriber applications may request a
   continuous, customized stream of updates from a YANG datastore.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netconf-yang-push/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-netconf-yang-push-06
https://datatracker.ietf.org/doc/html/draft-ietf-netconf-yang-push-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-netconf-yang-push-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Thu, 20 Apr 2017 14:12:11 +0000

Changes in the new version include:

- Intro simplified, and appendix added talking about relationship to other subscription drafts.

- Datastore replaces stream as the target for a filter.

- Definitions of filters improved.  Filters are also now identities, so new ones can be more easily added (looking towards OpState work for new options here).

- Security sections improved to better describe per receiver filtering options.

-  The YANG model which is augmented from draft-ietf-netconf-subscribed-notifications moved to identities for filters and ,  YANG augmentations in this doc matched up.

-  Terms refined and text redundancies cleaned-up throughout

The open questions/issues list is getting smaller.  Top of mind are those below. Please feel to ask questions on these (or anything else).

* do we want a new RPC to allow a subscriber to force on-change resynchronization?
* should we require support for all YANG patch operations?
* do the OpState draft authors feel the filter format meet their needs
* validation needed that new bundled notification message can be extended/augmented later.
* GRPC support still desired.  Not how to accomplish within IETF
* pyang crashes on deviation which adds notifiable on change extension

Eric

> From: [email-masked], April 20, 2017 9:50 AM
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf