Subject: [Netconf] I-D Action: draft-ietf-netconf-subscribed-notifications-01.txt

From: [email-masked]
Date: Fri, 14 Apr 2017 14:36:06 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network Configuration of the IETF.

        Title           : Custom Subscription to Event Notifications
        Authors         : Eric Voit
                          Alexander Clemm
                          Alberto Gonzalez Prieto
                          Einar Nilsen-Nygaard
                          Ambika Prasad Tripathy
	Filename        : draft-ietf-netconf-subscribed-notifications-01.txt
	Pages           : 49
	Date            : 2017-04-14

Abstract:
   This document defines capabilities and operations for the customized
   establishment of subscriptions upon a publisher's event streams.
   Also defined are delivery mechanisms for instances of the resulting
   events.  Effectively this allows a subscriber to request and receive
   a continuous, custom influx of publisher generated information.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netconf-subscribed-notifications/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-netconf-subscribed-notifications-01
https://datatracker.ietf.org/doc/html/draft-ietf-netconf-subscribed-notifications-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-netconf-subscribed-notifications-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Fri, 14 Apr 2017 22:08:10 +0000

Changes in this version:

1.   Security considerations updated

2.   Intro rewrite, as well as scattered text changes

3.   Added Appendix A, to help match this to related drafts in progress

4.   Updated filtering definitions, and filter types in yang file, and  moved to identities for filter types

5.   Added Syslog as a stream

6.   HTTP2 transport option

7.  Replay made an optional feature 

8.  Enabled notification timestamp to have different formats.

9.  Two error codes added.

To me the most interesting one is #5.  Do people have opinions on whether unstructured syslog entries should be exposed as a stream?  (In RFC-5277, such a definition was eventually skipped, even though looking in its history draft-ietf-netconf-notification-02 section B.2 laid out a more structured method of accomplishing this.  I don't have history on why it was dropped.)

If there is not interest, or is confusion, it can easily be removed just like it was for RFC-5277.

Eric

> -----Original Message-----
> From: Netconf [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Friday, April 14, 2017 5:36 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Netconf] I-D Action: draft-ietf-netconf-subscribed-notifications-01.txt
> 
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf