Subject: [Netconf] NETCONF Notification - Yang support

From: "[email-masked]" <[email-masked]>
Date: Thu, 20 Apr 2017 20:59:14 +0000

Hi Authors,

I 'm looking at the notifications.yang and nc-notifications.yang. Is this standardized?

RFC5277 (which predates Yang RFC6020) doesn't mention of the any yang for notifications. So can you please guide me on the status of this yang. Is a NETCONF server/client compliant with RFC5277 expected to support this yang for schema discovery or is it an inherent capability as part of "urn:ietf:params:netconf:capability:notification:1.0" capability?

Thanks a lot in advance for the response.

Thanks,
Vasudevan Sridharan.

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Thu, 20 Apr 2017 21:07:50 +0000

Hi Vasudevan,

Have you looked yet at:
https://datatracker.ietf.org/doc/draft-ietf-netconf-subscribed-notifications/
This is on a path to obsolete RFC-5277.

Also there is work discussed at the last IETF:
https://tools.ietf.org/html/draft-voit-netmod-yang-notifications2-00
is this hitting the areas in which you are asking?

Eric

From: Netconf [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, April 20, 2017 4:59 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Netconf] NETCONF Notification - Yang support

Hi Authors,

Thanks,
Vasudevan Sridharan.

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 20 Apr 2017 21:38:59 +0000

Eric,

Thanks for the quick response. My question is more of a basic one - If a NETCONF server advertises a capability in hello exchange, is it necessary to have a yang implementation to support the advertised capability?

I don't see this in RFC5277 (may be because it was standardized before yang RFC came into picture).

I see this as a requirement in https://tools.ietf.org/html/rfc6243#section-4.1

Thanks,
Vasu.

From: Eric Voit (evoit) [mailto:[email-masked]]
Sent: Thursday, April 20, 2017 4:08 PM
To: Sridharan, Vasudevan <[email-masked]>
Cc: Gera, Sanjay <[email-masked]>; Xu, Jing <[email-masked]>; Terwilliger, David <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: NETCONF Notification - Yang support

Hi Vasudevan,

Have you looked yet at:

Eric

From: Netconf [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Thursday, April 20, 2017 4:59 PM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [Netconf] NETCONF Notification - Yang support

Hi Authors,

Thanks,
Vasudevan Sridharan.

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Thu, 20 Apr 2017 22:18:51 +0000

If I am reading your thread right, you are looking at models like:
http://www.netconfcentral.org/modules/nc-notifications/2008-07-14
and seeing if they have been standardized.   They have not.

As RFC 5277 predated yang, there is no yang-model.  But
"urn:ietf:params:netconf:capability:notification:1.0"
Is still advertised.  This is not an issue.

https://datatracker.ietf.org/doc/draft-ietf-netconf-subscribed-notifications/
will eventually advertise:
"urn:ietf:params:netconf:capability:notification:2.0"
with a yang model behind it.

Eric

From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, April 20, 2017 5:39 PM
To: Eric Voit (evoit) <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: NETCONF Notification - Yang support

Eric,

Thanks,
Vasu.

From: Eric Voit (evoit) [mailto:[email-masked]]
Sent: Thursday, April 20, 2017 4:08 PM
To: Sridharan, Vasudevan <[email-masked]<mailto:[email-masked]>>
Cc: Gera, Sanjay <[email-masked]<mailto:[email-masked]>>; Xu, Jing <[email-masked]<mailto:[email-masked]>>; Terwilliger, David <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: NETCONF Notification - Yang support

Hi Vasudevan,

Have you looked yet at:

Eric

Hi Authors,

Thanks,
Vasudevan Sridharan.

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 20 Apr 2017 22:20:51 +0000

Thanks again Eric for the quick response!

Sent: Thursday, April 20, 2017 5:19 PM

Eric

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Thursday, April 20, 2017 5:39 PM
To: Eric Voit (evoit) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: NETCONF Notification - Yang support

Eric,

Thanks,
Vasu.

Hi Vasudevan,

Have you looked yet at:

Eric

Hi Authors,

Thanks,
Vasudevan Sridharan.