Subject: [Netconf] notification-complete in draft-ietf-netconf-subscribed-notifications-02

From: "Tim Jenkins (timjenki)" <[email-masked]>
Date: Wed, 3 May 2017 22:21:39 +0000

Hi,

I have a question about two of the state notifications in Section 7 of https://tools.ietf.org/html/draft-ietf-netconf-subscribed-notifications-02. What is the difference between <notification-complete> and <subscription-terminated>?  And why isn't <notification-complete> called <subscription-complete>?

If the need for for <notification-complete> is due to stop time, why not just use that as a reason to <subscription-terminated>?

But then perhaps subscription-terminated shouldn't use error-identifier; perhaps it should use something that can mean things that aren't exclusively errors. There could be other non-error reasons a subscription is terminated and this notification should still be sent.

I'd prefer there be fewer notification types when the same basic thing is happening that is already described by another notification, particularly when that other notification has the ability to specify a reason.

Thanks,

Tim

--
Cisco Systems Canada Co.
2000 Innovation Drive
Kanata, ON, Canada, K2K 3E8
Preferences <http://www.cisco.com/offer/subscribe/?sid=000478326>
Unsubscribe <http://www.cisco.com/offer/unsubscribe/?sid=000478327>
Privacy <http://www.cisco.com/web/siteassets/legal/privacy.html>

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Wed, 3 May 2017 22:42:35 +0000

This makes sense.

Especially as we are not mirroring RFC5277 at this point, I think we can eliminate “notification-complete”, and make “stop-time-reached” an error-code of the “subscription-terminated” notification.

Eric

From: Tim Jenkins, May 3, 2017 6:22 PM

Hi,

Thanks,

Tim