Subject: Re: [Netconf] New Version Notification for draft-nmdsdt-netconf-rfc7895bis-00.txt

From: Kent Watsen <[email-masked]>
Date: Wed, 31 May 2017 18:39:50 +0000

A proposed rfc7895bis has been posted, to update YANG Library to
support the revised-datastores draft.

Would the chairs kindly consider initiating a poll to adopt this
draft as a WG item?

Thanks,
Kent

-----ORIGINAL MESSAGE-----

A new version of I-D, draft-nmdsdt-netconf-rfc7895bis-00.txt
has been successfully submitted by Kent Watsen and posted to the
IETF repository.

Name:		draft-nmdsdt-netconf-rfc7895bis
Revision:	00
Title:		YANG Module Library
Document date:	2017-05-30
Group:		Individual Submission
Pages:		15
URL:            https://www.ietf.org/internet-drafts/draft-nmdsdt-netconf-rfc7895bis-00.txt
Status:         https://datatracker.ietf.org/doc/draft-nmdsdt-netconf-rfc7895bis/
Htmlized:       https://tools.ietf.org/html/draft-nmdsdt-netconf-rfc7895bis-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-nmdsdt-netconf-rfc7895bis-00

Abstract:
   This document describes a YANG library that provides information
   about all the YANG modules used by a network management server (e.g.,
   a Network Configuration Protocol (NETCONF) server).  Simple caching
   mechanisms are provided to allow clients to minimize retrieval of
   this information.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Andy Bierman <[email-masked]>
Date: Wed, 31 May 2017 11:53:12 -0700

Hi,

This appears to add 1 top-level container to the YANG Module Library
This new container can be in its own module, in another RFC.

    container datastores {
       config false;
       description
         "Identifies which datastores are supported by this server.";
       leaf-list datastore {
         type identityref {
           base ds:datastore;
         }
         description
           "A datastore supported by this server.";
       }
     }

I do not see why this top-level YANG subtree is related to the YANG module
library.
It is not linked in any way to the /modules-state subtree.

IMO this will confuse people since it is not obvious that something
called the YANG module library would contain a list of datastores.

One might expect to find the datastore list in /netconf-state/datastores
since that's where its been for 7 years.

Also the text says "supported by this server".  What protocol is "this
server"?
What if there are multiple protocols and not all datastores are accessible
in all protocols?

Andy

On Wed, May 31, 2017 at 11:39 AM, Kent Watsen <[email-masked]> wrote:

> Htmlized:       https://datatracker.ietf.org/
> doc/html/draft-nmdsdt-netconf-rfc7895bis-00
>
>
> Abstract:
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>

---

From: Kent Watsen <[email-masked]>
Date: Wed, 31 May 2017 21:28:31 +0000

Hi Andy,

> This appears to add 1 top-level container to the YANG Module Library

In addition to the top-level 'datastores' container, the update also adds a 'datastore' leaf-list under the 'module' node...

> This new container can be in its own module, in another RFC.

But already ietf-yang-library MUST be implemented, and we have to make the other change mentioned above.   How about we change the draft title from "YANG Module Library" to "YANG Library" (which betters matches the module name "ietf-yang-library") and declare this module is being where meta-information goes.  It's not the best name, but I can live with it.

> I do not see why this top-level YANG subtree is related to the YANG module library.

See above.

> since that's where its been for 7 years.

Seriously?  Perhaps if "netconf" weren't in its name, but even then, we'd have
to rework the draft some more.   We could start new draft to define something
like /restconf-state, but repurposing yang-library seems easier and (hopefully)
could be done in a protocol-independent manner.

> Also the text says "supported by this server".  What protocol is "this server"?

It was meant to be the protocol-agnostic so, for instance, NC and RC servers
running on the same device could have different responses.

> What if there are multiple protocols and not all datastores are accessible

Exactly.

Kent

On Wed, May 31, 2017 at 11:39 AM, Kent Watsen <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,
Kent

-----ORIGINAL MESSAGE-----

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

_______________________________________________
Netconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netconf

---

From: Andy Bierman <[email-masked]>
Date: Wed, 31 May 2017 14:38:00 -0700

Hi,

IMO the datastores info should be in the ietf-datastores module in the RD
draft.

Andy

On Wed, May 31, 2017 at 2:28 PM, Kent Watsen <[email-masked]> wrote:

> In addition to the top-level 'datastores' container, the update also adds
> a 'datastore' leaf-list under the 'module' node...
>
>
>
>
>
> But already ietf-yang-library MUST be implemented, and we have to make the
> other change mentioned above.   How about we change the draft title from
> "YANG Module Library" to "YANG Library" (which betters matches the module
> name "ietf-yang-library") and declare this module is being where
> meta-information goes.  It's not the best name, but I can live with it.
>
>
>
>
>

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 01 Jun 2017 08:56:06 +0200 (CEST)

Hi,

> This new container can be in its own module, in another RFC.

The main addition, which requires a new revision of YANG library, is
the leaf-list datastore which is specified on a per-module basis.
This allows the server to inform the client which modules are
implemented in the different datastores.  This addition has been
discussed in the previous versions of revised-datastores (most recent
is section D.2 in draft-ietf-netmod-revised-datastores-01).

/martin