Subject: [Netconf] WGLC call on draft-bierman-netconf-rfc6536bis

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 10 Jul 2017 16:06:51 -0700

The work group issued a last call on the above draft back in April. Since then there have been at least two revisions of the draft. Before we forward the draft for IESG consideration, we want to make sure no one has no objection to the changes since the last call. This starts a one week call ending Monday for any changes since the last call. At that time, if there are no objections, the document will be prepared for publication.

Thanks.

Mahesh (for co-chairs).

---

From: Andy Bierman <[email-masked]>
Date: Mon, 10 Jul 2017 16:18:06 -0700

Hi,

The latest version is an IETF draft.

https://www.ietf.org/id/draft-ietf-netconf-rfc6536bis-04.txt

Andy

On Mon, Jul 10, 2017 at 4:06 PM, Mahesh Jethanandani <
[email-masked]> wrote:

> The work group issued a last call on the above draft back in April. Since
> then there have been at least two revisions of the draft. Before we forward
> the draft for IESG consideration, we want to make sure no one has no
> objection to the changes since the last call. This starts a one week call
> ending Monday for any changes since the last call. At that time, if there
> are no objections, the document will be prepared for publication.
>
> Thanks.
>
> Mahesh (for co-chairs).
>
>
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>

---

From: Kent Watsen <[email-masked]>
Date: Tue, 11 Jul 2017 00:07:22 +0000

Looking at the diff since the Last Call [1], I see effort has been made to disentangle NACM from the NETCONF protocol, which is a good thing, but I still see remnants of NETCONF protocol, both in the title and also throughout the body of the draft.   Please review each use of "NETCONF" to ensure that it has been neutralized (no longer NETCONF protocol-specific).

[1] https://tools.ietf.org/rfcdiff?difftype=--hwdiff&url2=draft-ietf-netconf-rfc6536bis-04.txt&url1=draft-ietf-netconf-rfc6536bis-01.txt

K.

On 7/10/17, 7:18 PM, "Netconf on behalf of Andy Bierman" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi,

Andy

On Mon, Jul 10, 2017 at 4:06 PM, Mahesh Jethanandani <[email-masked]<mailto:[email-masked]>> wrote:
The work group issued a last call on the above draft back in April. Since then there have been at least two revisions of the draft. Before we forward the draft for IESG consideration, we want to make sure no one has no objection to the changes since the last call. This starts a one week call ending Monday for any changes since the last call. At that time, if there are no objections, the document will be prepared for publication.

Thanks.

Mahesh (for co-chairs).

_______________________________________________
Netconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netconf

---

From: Andy Bierman <[email-masked]>
Date: Mon, 10 Jul 2017 17:17:59 -0700

Hi,

I do not think any more edits are needed to remove the word NETCONF.
We added text that says how RESTCONF is also supported.
We added text that says the NACM extension statements can be applied to
non-NACM servers.
There is no intention in the document to support generic access control for
any generic protocol.
This was not part of the charter.  We supported RESTCONF and YANG 1.1 as
required by the charter.

Andy

On Mon, Jul 10, 2017 at 5:07 PM, Kent Watsen <[email-masked]> wrote:

>
>
> Looking at the diff since the Last Call [1], I see effort has been made to
> disentangle NACM from the NETCONF protocol, which is a good thing, but I
> still see remnants of NETCONF protocol, both in the title and also
> throughout the body of the draft.   Please review each use of "NETCONF" to
> ensure that it has been neutralized (no longer NETCONF protocol-specific).
>
>
>
> [1] https://tools.ietf.org/rfcdiff?difftype=--hwdiff&
> url2=draft-ietf-netconf-rfc6536bis-04.txt&url1=draft-
> ietf-netconf-rfc6536bis-01.txt
>
>
>
> K.
>
>
>
>
>
> On 7/10/17, 7:18 PM, "Netconf on behalf of Andy Bierman" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>
>
> Hi,
>
>
>

---

From: Andy Bierman <[email-masked]>
Date: Mon, 10 Jul 2017 18:42:25 -0700

Hi,

I was hoping the RESTCONF text would be enough for developers to figure out
how to support RESTCONF, but maybe they will get confused by NETCONF-only
text in other sections.  We can look at instances of the word NETCONF to
determin
if it should be (1) unchanged), (2) removed or (3) changed tp "NETCONF or
RESTCONF".

Andy

---

From: Kent Watsen <[email-masked]>
Date: Tue, 11 Jul 2017 21:12:12 +0000

Hi Andy,

The two things that caught my eye initially were:

1) The title is: Network Configuration Protocol (NETCONF) Access Control Model
Would it be too crazy to change it to, for instance: Network Access Control Model (NACM)?

2) the description statement for the 'default-deny-write' extension says:

        If present, the NETCONF server will only allow the designated
        'recovery session' to have write access to the node.  An
        explicit access control rule is required for all other users.

Actually, there's nothing about RESTCONF anywhere in the YANG module (AFAICT).

Kent

On 7/10/17, 8:17 PM, "Andy Bierman" <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

I do not think any more edits are needed to remove the word NETCONF.
We added text that says how RESTCONF is also supported.
We added text that says the NACM extension statements can be applied to non-NACM servers.
There is no intention in the document to support generic access control for any generic protocol.
This was not part of the charter.  We supported RESTCONF and YANG 1.1 as required by the charter.

Andy

On Mon, Jul 10, 2017 at 5:07 PM, Kent Watsen <[email-masked]<mailto:[email-masked]>> wrote:

K.

Hi,

Andy

Thanks.

Mahesh (for co-chairs).