Subject: [Netconf] Yangdoctors last call review of draft-ietf-netconf-netconf-client-server-04

From: Andy Bierman <[email-masked]>
Date: Fri, 28 Jul 2017 15:15:46 -0700

Reviewer: Andy Bierman
Review result: Ready with Nits

Review: draft-ietf-netconf-netconf-client-server-04

Modules:
 (M1) [email-masked]
 (M2) [email-masked]

YANG Usage:

 I did not find anything wrong in either module.
 pyang and yangdump-pro do not report any errors or warnings.

Comments:

C1:

 (M1) feature ssh-initiate
 (M1) feature ssh-listen
 (M2) feature ssh-listen
 (M2) feature ssh-call-home

 Are these features really needed since a NETCONF server MUST support
 the SSH transport?

C2:

Sec 1.2 Tree Diagrams

Old text should be replaced with reference to
draft-ietf-netmod-yang-tree-diagrams-01

C3: Sec 2.1:

Should use the new version of pyang that expands leafref nodes
in tree diagrams.

C4:

 (M1) IETF copyright says 2014; change to 2017
 (M2) IETF copyright says 2014; change to 2017

---

From: Kent Watsen <[email-masked]>
Date: Mon, 31 Jul 2017 23:06:26 +0000

Hi Andy,

Thanks for your review.  Below are my responses to your comments.

Thanks,
Kent

--

Reviewer: Andy Bierman

Modules:

YANG Usage:

Comments:

C1:

<KENT> the features themselves are needed.  For instance, a server
might only support call-home, despite but the RFC says.

C2:

Sec 1.2 Tree Diagrams

<KENT> same comment as before

C3: Sec 2.1:

<KENT> done!  (actually, I upgraded pyang last week)

C4:

<KENT> done.