Subject: [Netconf] RESTCONF Fields on a container

From: "Johan Vikman (jvikman)" <[email-masked]>
Date: Tue, 4 Jul 2017 16:24:52 +0000

Hi,

Should it be possible to retrieve a container and its children using the fields operator. I.e.

restconf/list?fields=mycontainer

Or do you have to retrieve as a resource, on a specific list instance, like

restconf/list=key/mycontainer

BR,
Johan Vikman

---

From: Andy Bierman <[email-masked]>
Date: Wed, 5 Jul 2017 12:14:56 -0700

> restconf/list=key/mycontainer

You are supposed to provide list keys:

 /restconf/data/example-mod:list=key1,key2?fields=mycontainer

This issue is discussed in the RFC.
If the response encoding is XML, then multiple list entries would produce
an invalid XML instance document.
Our server returns an error if this request is made and the Accept header
indicates the response will be XML.
It accepts the request if the response will be JSON, since a JSON array can
represent multiple list entries.
I think the RFC says to always return an error even for JSON.

BR,
> Johan Vikman

Andy

>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>
>