Subject: Re: [Netconf] WG LC for draft-ietf-netconf-rfc6536bis

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 13 Jul 2017 19:12:16 -0700

Andy,

> On May 28, 2017, at 10:16 AM, Andy Bierman <[email-masked]> wrote:
> 
> Hi,
> 
> Just be clear -- we will add explicit support for revised datastores, not just a
> normative reference for terminology.  The NACM CRUDX mappings for the
> intended, applied, and operational datastores will be in this draft.
> 
> Are there any objections to adding revised datastore support to NACM?
> This might be an expansion of scope for the charter item.

This is covered by item #6 in the charter:

6. Based on the revised datastore concept work in NETMOD, provide a
revision for the NETCONF and RESTCONF protocols and the used datastore
framework. 

> 
> 
> Andy
> 
> 
> On Sat, May 27, 2017 at 4:19 AM, t.petch <[email-masked] <mailto:[email-masked]>> wrote:
> ----- Original Message -----
> From: "Andy Bierman" <[email-masked] <mailto:[email-masked]>>
> Sent: Saturday, May 27, 2017 3:20 AM
> 
> On Wed, May 24, 2017 at 12:16 AM, Martin Bjorklund <[email-masked] <mailto:[email-masked]>>
> wrote:
> 
> > Andy Bierman <[email-masked] <mailto:[email-masked]>> wrote:
> > > On Tue, May 23, 2017 at 12:41 PM, Mahesh Jethanandani <
> > > [email-masked] <mailto:[email-masked]>> wrote:
> > >
> > > >
> > > > > On May 23, 2017, at 12:15 AM, Martin Bjorklund <[email-masked] <mailto:[email-masked]>>
> > wrote:
> > > > >
> > > > > Andy Bierman <[email-masked] <mailto:[email-masked]>> wrote:
> > > > >> Hi,
> > > > >>
> > > > >> The update is on github.
> > > > >> http://github.com/netconf-wg/rfc6536bis <http://github.com/netconf-wg/rfc6536bis>
> > > > >>
> > > > >> I would like Martin to look it over before it is posted.
> > > > >
> > > > > Done, and the new text looks good.  I moved the new subsection
> to be
> > > > > the first in 3.2, and I also fixed some minor terminology
> issues.
> > > > >
> > > > > But, I wonder if we shouldn't make the document even less
> NETCONF
> > > > > specific, and align the terminology to revised-datastores.  For
> > > > > example, currently the document talks about access to "NETCONF
> > > > > datastores".   With the new less protocol-specific terminology
> this
> > > > > would simply be "datastore”.
> > > >
> > > > I would prefer this.
> > > >
> > >
> > > OK, but the operations are somewhat NETCONF specific.
> > > We will try to make sure we do not create more inconsistencies than
> we
> > > remove ;-)
> >
> > Yes.  But I think what we should do is not any technical changes, just
> > align terminology.
> >
> >
> 
> OK -- the term NETCONF datastore was used twice, now just datastore.
> (pushed to github)
> 
> The term datastore appears a lot.  There are 3 variants:
> 
>     - datastore
>     - configuration datastore
>     - target datastore
> 
> With revised datastores these are not all the same anymore.
> We probably need to go through the entire document and check if the
> correct variant is used in each instance.
> 
> Are there other terms that are needed for alignment?
> 
> Does NACM need to reference the revised-datastores draft to import
> terminology?
> 
> <tp>
> 
> Yes, Normative Reference please.
> 
> Tom Petch
> 
> > /martin
> 
> Andy
> > >
> > > Andy
> 
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

Mahesh Jethanandani
[email-masked]

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 18 Jul 2017 08:44:49 +0200

Looking at the draft, it is clear that the draft makes normative reference to the datastore draft for the datastore terms its uses in the document itself. After talking to Andy, it appears there is no strong use-case defined for adding datastore specific access control at this time. 

This therefore concludes the WG LC on the document. I will prepare the document for publication at this time.

> On Jul 14, 2017, at 4:12 AM, Mahesh Jethanandani <[email-masked]> wrote:
> 
> Andy,
> 
>> On May 28, 2017, at 10:16 AM, Andy Bierman <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi,
>> 
>> [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>
> 
> 
> 

Mahesh Jethanandani
[email-masked]