Subject: [Netconf] WG Last Call for SSH/TLS and NETCONF/RESTCONF Client Server Models

From: "Mehmet Ersue" <[email-masked]>
Date: Mon, 10 Jul 2017 15:13:38 +0200

Dear NETCONF WG,

we hereby issue WG Last Call for 3 weeks for the drafts below: 

SSH/TLS Client Server Models:

       https://tools.ietf.org/html/draft-ietf-netconf-ssh-client-server-03 

       https://tools.ietf.org/html/draft-ietf-netconf-tls-client-server-03  

NETCONF/RESTCONF Client Server Models:

https://tools.ietf.org/html/draft-ietf-netconf-netconf-client-server-04  

https://tools.ietf.org/html/draft-ietf-netconf-restconf-client-server-04

Please review and send your comments to NETCONF WG mailing list by July 31,
2017 EOB PT (extended duration because of IETF #99 in between).

Please be aware that these drafts are planned to publish as standard track
documents.

We would like to ask WG members to state explicitly that you have
read/reviewed and whether you support the publication of the drafts.

Please indicate also if you plan to implement or have already implementation
experience with these drafts.

Authors: 

Please indicate with an email on the maillist explicitly whether you are
aware or you are not aware of any IPRs related to the drafts.

PS: Next in the row are the YANG-Push draft set going to WGLC after IETF #99
meeting.

Thank you,

Mehmet and Mahesh

---

From: Kent Watsen <[email-masked]>
Date: Wed, 12 Jul 2017 00:28:31 +0000

I just noticed an inconsistency in the ssh/tls client/server models.  What we have now is:

  /ssh-client-grouping/server-auth/...
  /ssh-client-grouping/client-auth/...
  /tls-client-grouping/server-auth/...
  /tls-client-grouping/client-auth/...
  /tls-server-grouping/certificates/...             <-- put under a container called "server-auth"?
  /tls-server-grouping/client-auth/...
  /ssh-server-grouping/host-keys/...              <-- put under a container called "server-auth"?
  /ssh-server-grouping/client-cert-auth/...   <-- put under a container called "client-auth"?

You see the pattern and the odd balls, right?  Should we try to normalize these, or just let be?

The last suggestion, about changing "client-cert-auth" to "client-auth" may be problematic,
as standard client password/public-key based authentication mechanisms are configured in
the ietf-system module from RFC 7317.  I don't like this inconsistency either...

Kent

On 7/10/17, 9:13 AM, "Netconf on behalf of Mehmet Ersue" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Dear NETCONF WG,

Please review and send your comments to NETCONF WG mailing list by July 31, 2017 EOB PT (extended duration because of IETF #99 in between).
Please be aware that these drafts are planned to publish as standard track documents.

We would like to ask WG members to state explicitly that you have read/reviewed and whether you support the publication of the drafts.
Please indicate also if you plan to implement or have already implementation experience with these drafts.

Authors:
Please indicate with an email on the maillist explicitly whether you are aware or you are not aware of any IPRs related to the drafts.

PS: Next in the row are the YANG-Push draft set going to WGLC after IETF #99 meeting.

Thank you,
Mehmet and Mahesh

---

From: "Mehmet Ersue" <[email-masked]>
Date: Wed, 12 Jul 2017 19:47:01 +0200

See ME:

Cheers,

Mehmet

From: Kent Watsen [mailto:[email-masked]] 
Sent: Wednesday, July 12, 2017 2:29 AM
To: Mehmet Ersue <[email-masked]>; 'Netconf' <[email-masked]>
Subject: Re: [Netconf] WG Last Call for SSH/TLS and NETCONF/RESTCONF Client Server Models

ME: Normalize

ME: It would be good if we adopt/use what’s in 7317 somehow.

Kent

On 7/10/17, 9:13 AM, "Netconf on behalf of Mehmet Ersue" <[email-masked] <mailto:[email-masked]>  on behalf of [email-masked] <mailto:[email-masked]> > wrote:

Dear NETCONF WG,

 

Authors: 

Thank you,

Mehmet and Mahesh

---

From: "t.petch" <[email-masked]>
Date: Wed, 19 Jul 2017 10:42:14 +0100

"4.  Design Considerations

   Editorial: this section is a hold over from before, previously called
   "Objectives".  It was only written two support the "server" (not the
   "client").  The question is if it's better to add the missing
   "client" parts, or remove this section altogether. "

I would have expected this question to be resolved before rather than
during Last Call.

IMO this I-D is rather weak on text, as opposed to YANG, so I would
support adding text.

Tom Petch

----- Original Message -----
From: "Mehmet Ersue" <[email-masked]>
To: "'Netconf'" <[email-masked]>
Sent: Monday, July 10, 2017 2:13 PM
Subject: [Netconf] WG Last Call for SSH/TLS and NETCONF/RESTCONF Client
Server Models

> PS: Next in the row are the YANG-Push draft set going to WGLC after
IETF #99

------------------------------------------------------------------------
--------

> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>

---

From: Kent Watsen <[email-masked]>
Date: Wed, 19 Jul 2017 22:39:20 +0000

Hi Tom,

Thanks for your review.
Please find my responses below.

Kent

4.  Design Considerations

<KENT> this section hasn't been read by me in ages, primarily because
it hasn't changed in all that time. :shrug:

<KENT> The question really is if it's helpful.  If we like it, should
we copy/paste it into the restconf-client-server draft also?

Tom Petch

----- Original Message -----
From: "Mehmet Ersue" <[email-masked]>
To: "'Netconf'" <[email-masked]>
Sent: Monday, July 10, 2017 2:13 PM
Subject: [Netconf] WG Last Call for SSH/TLS and NETCONF/RESTCONF Client
Server Models

---

From: "t.petch" <[email-masked]>
Date: Fri, 21 Jul 2017 17:12:48 +0100

Kent

You may not have read Section 4 for ages but it is still part of the I-D
that is being Last Called.  As I said before, I cannot see how something
that speculates over whether or not it is worth including can be fit for
Last Call.

Tom Petch

----- Original Message -----
From: "Kent Watsen" <[email-masked]>
To: "t.petch" <[email-masked]>; "Mehmet Ersue" <[email-masked]>;
"'Netconf'" <[email-masked]>
Sent: Wednesday, July 19, 2017 11:39 PM
Subject: Re: [Netconf] WG Last Call for NETCONF Client Server Models

---

From: Kent Watsen <[email-masked]>
Date: Fri, 21 Jul 2017 20:22:58 +0000

Tom,

You already made that point and I didn't dispute it.

Back to the main point, I raised this issue during yesterday's presentation, but no one spoke to it at the time, and so I said that we'd continue here.

I dislike the idea of having essentially identical text in both the netconf-client-server and restconf-client-server drafts.   We could factor the text out into a separate Informational RFC, but that doesn't seem right either.   I now think that we should remove the section, as it has served its primary purpose already, and the module is pretty self-explanatory now, and I'm not offended by module-focused drafts being weak on surrounding text, especially since the YANG module needs to stand on its own.

I know you support adding text missing "client" text, but are there any objections from anyone to removing the section?

Kent

--

Kent

Tom Petch

---

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 26 Jul 2017 12:01:30 -0400

WG,

During the meeting at IETF 99, there were several hands that went up indicating that they had read these documents. But as Kent noted in his presentation, he had not received any comments - good or bad.

We would like to ask those hands that went up and others in the WG to please indicate if they believe the documents are ready. Silence unfortunately, does not tell us much. Please indicate that you have concerns/no concerns/support the document. Even a +1 for adoption is helpful. If you have concerns, please indicate what specific concerns you have.

The LC runs till Monday.

Thanks.

p.s. Kent has already agreed to issue an update to correct a discrepancy in the drafts.
p.p.s. Authors please indicate if you are aware of any IPRs. We need that for each draft and from each author.

> On Jul 10, 2017, at 9:13 AM, Mehmet Ersue <[email-masked]> wrote:
> 
> Dear NETCONF WG,
>  
>        https://tools.ietf.org/html/draft-ietf-netconf-ssh-client-server-03 <https://tools.ietf.org/html/draft-ietf-netconf-ssh-client-server-03>
>        https://tools.ietf.org/html/draft-ietf-netconf-tls-client-server-03 <https://tools.ietf.org/html/draft-ietf-netconf-tls-client-server-03>  
>        https://tools.ietf.org/html/draft-ietf-netconf-netconf-client-server-04 <https://tools.ietf.org/html/draft-ietf-netconf-netconf-client-server-04>  
>        https://tools.ietf.org/html/draft-ietf-netconf-restconf-client-server-04 <https://tools.ietf.org/html/draft-ietf-netconf-restconf-client-server-04>
>  
>  
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netconf <https://www.ietf.org/mailman/listinfo/netconf>
Mahesh Jethanandani
[email-masked]