Subject: Re: [Netconf] Summary of NETCONF WG from IETF 99

From: Kent Watsen <[email-masked]>
Date: Sat, 5 Aug 2017 00:15:14 +0000

Thanks to all that took the time to review the minutes.
The minutes have now been posted:

  https://datatracker.ietf.org/meeting/99/materials/minutes-99-netconf

Cheers,
Kent  // co-chair

On 7/24/17, 1:51 PM, "Netconf on behalf of Kent Watsen" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Could folks please review/update the raw minutes?
  http://etherpad.tools.ietf.org:9000/p/notes-ietf-99-netconf?useMonospaceFont=true.

Presenters in particular should review the minutes for their presentations.  FWIW, I
did this for the YANG Library presentation yesterday and found a need for a number
clarifications there.

Cheers,
Kent  // as co-chair

On 7/24/17, 12:18 AM, "Netconf on behalf of Mahesh Jethanandani" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Below is the NETCONF WG session summary and AIs that were taken from the IETF 99 meeting.

This e-mail verifies the discussion that took place in the room. Barring any strong objection, the AIs identified in this summary will be acted upon.

The NETCONF session took place on Thursday, July 20, 2017, between 15:50-17:50 CET.

- We had approx. 55+ participants in the 2 hour NETCONF session,
- We reviewed the status of the WG,
- We had a discussion on chartered and non-chartered documents.

The raw notes from the meeting are available at:
http://etherpad.tools.ietf.org:9000/p/notes-ietf-99-netconf?useMonospaceFont=true

  *   Zerotouch draft is going through a LC. Minor issues will be addressed with an update. The WG thinks it can go forward to the next step. (note in the meeting notes there is a note about ‘choice’ statement containing ‘container’ statements which is flagged as an error by both yumapro and pyang. Kent believes that it should not be an error per RFC 7950. Need it resolved).
  *   Keystore draft needs to be updated for issues raised in WGLC. A new WGLC might become necessary if there are substantial changes i.e. because of a necessary separate module for identifiers.
  *   SSH/TLS NETCONF/RESTCONF Client Server Models are in WGLC. Drafts had received zero comments. That concerns AD and co-chairs, who have asked the WG to review and comment on them on the mailing list.
  *   YANG push and Subscribed notifications drafts needs to be updated for the discussed issues. Other issues need discussion on the mailing list. Co-chairs will lead to WGLC based on the discussion result.
  *   Netconf-event notifications and Restconf notifications. These two drafts had support in the WG to go for WGLC. It will need YANG Doctors review to be started.
  *   The WG thinks Notification Message Headers and Bundles should be adopted as a WG item.
  *   YANG Library, Netconf NMDA  and Restconf NMDA are part of current charter.
  *   YANG Library - Co-chairs will ask for adoption on the mailing list.
  *   Netconf NMDA needs to be updated with additional content before adopting. The discussion will continue on the mailing list. Whether get-operation gets deprecated will be decided on mailing list. Adoption call will be issued on the mailing list once an update to the draft is posted.
  *   Restconf NMDA is ready for adoption. Co-Chairs will call for adoption on the mailing list.
  *   There was not much support for the accounting draft at this time. But it was agreed that more discussion was needed.
  *   The room was in favor to work on Netconf proxy with a few hands. A call will be initiated on the mailing list.
  *   Several hands were in favor of working on UDP based Publication Channel, which is in the focus of the charter and can be done together with the YANG Push draft set. Co-Chairs will check when a call for adoption can be initiated.

Mahesh Jethanandani (for co-chairs).

---

From: "t.petch" <[email-masked]>
Date: Wed, 9 Aug 2017 09:18:21 +0100

---- Original Message -----
From: "Kent Watsen" <[email-masked]>
Sent: Saturday, August 05, 2017 1:15 AM

>   https://datatracker.ietf.org/meeting/99/materials/minutes-99-netconf

Mmmm the spelling and grammar look a little quirky, such as

I support thois work. Junod does this.
 WHoi has rread the drtaft?
it iwll be done sonn somewhre.
You are saying that it should be doen in a so called design team to get
a new yang push draft?
 netconf to IPFIX, it is a lot to be learnet there.

Perhaps voice recognition is not with us yet.

Tom Petch

>
> Cheers,
> Kent  // co-chair
>
>
> On 7/24/17, 1:51 PM, "Netconf on behalf of Kent Watsen"
<[email-masked]<mailto:[email-masked]> on behalf of
> Could folks please review/update the raw minutes?
http://etherpad.tools.ietf.org:9000/p/notes-ietf-99-netconf?useMonospace
Font=true.
> On 7/24/17, 12:18 AM, "Netconf on behalf of Mahesh Jethanandani"
<[email-masked]<mailto:[email-masked]> on behalf of
[email-masked]<mailto:[email-masked]>> wrote:
> This e-mail verifies the discussion that took place in the room.
Barring any strong objection, the AIs identified in this summary will be
acted upon.
> The raw notes from the meeting are available at:
http://etherpad.tools.ietf.org:9000/p/notes-ietf-99-netconf?useMonospace
Font=true
>
>
>   *   Zerotouch draft is going through a LC. Minor issues will be
addressed with an update. The WG thinks it can go forward to the next
step. (note in the meeting notes there is a note about ‘choice’
statement containing ‘container’ statements which is flagged as an error
by both yumapro and pyang. Kent believes that it should not be an error
per RFC 7950. Need it resolved).
>   *   Keystore draft needs to be updated for issues raised in WGLC. A
new WGLC might become necessary if there are substantial changes i.e.
because of a necessary separate module for identifiers.
>   *   SSH/TLS NETCONF/RESTCONF Client Server Models are in WGLC.
Drafts had received zero comments. That concerns AD and co-chairs, who
have asked the WG to review and comment on them on the mailing list.
>   *   YANG push and Subscribed notifications drafts needs to be
updated for the discussed issues. Other issues need discussion on the
mailing list. Co-chairs will lead to WGLC based on the discussion
result.
>   *   Netconf-event notifications and Restconf notifications. These
two drafts had support in the WG to go for WGLC. It will need YANG
Doctors review to be started.
>   *   Netconf NMDA needs to be updated with additional content before
adopting. The discussion will continue on the mailing list. Whether
get-operation gets deprecated will be decided on mailing list. Adoption
call will be issued on the mailing list once an update to the draft is
posted.
>   *   There was not much support for the accounting draft at this
time. But it was agreed that more discussion was needed.
>   *   The room was in favor to work on Netconf proxy with a few hands.
A call will be initiated on the mailing list.
>   *   Several hands were in favor of working on UDP based Publication
Channel, which is in the focus of the charter and can be done together
with the YANG Push draft set. Co-Chairs will check when a call for
adoption can be initiated.
> Mahesh Jethanandani (for co-chairs).

------------------------------------------------------------------------
--------

> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>