Subject: [Netconf] Netconf NMDA: Default datastore for rpc get-data?

From: "Eric Voit (evoit)" <[email-masked]>
Date: Tue, 26 Sep 2017 15:11:13 +0000

Hi Martin,

I see you have mandatory instead of default for your source datastore of the rpc get-data.  What do you think about having the default of "operational" in place so that all queries need not specify this?

Eric

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 27 Sep 2017 12:19:09 +0200 (CEST)

"Eric Voit (evoit)" <[email-masked]> wrote:
> Hi Martin,
> 
> I see you have mandatory instead of default for your source datastore
> of the rpc get-data.  What do you think about having the default of
> "operational" in place so that all queries need not specify this?

The operation get-data is generic, and accepts any datastore as input
parameter.  It is not clear why "operational" should be the default if
no datastore is specified.  Maybe we think it will be the most common
datastore to ask for, but that's not a good reason for a default
value.  I think it is better to be explicit.  

/martin

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Wed, 27 Sep 2017 12:52:19 +0000

> From: Martin Bjorklund, September 27, 2017 6:19 AM
> 
> parameter.  It is not clear why "operational" should be the default if no
> datastore is specified.  Maybe we think it will be the most common datastore
> to ask for, but that's not a good reason for a default value.

The reason I was thinking it might be a good default is to simplify the interface for less expert users.  

Having new users internalize the NMDA partitioning before being able to ask what is running on the box will add some complexity.

Eric

>  I think it is better to be explicit.
> 
> 
> /martin