Subject: Re: [Netconf] WG adoption of NETCONF NDMA draft

From: wangzitao <[email-masked]>
Date: Tue, 26 Sep 2017 02:27:42 +0000

Hi WG,
I support adoption of this work. And I have some comments:

………………………………………………………………………………………………………………………………………………………………………..
         container where {
           description
             "Filter content with the specified criteria.  All given
              criteria are logically AND:ed.";

           leaf config {
             type boolean;
             description
               "Filter for nodes with the given value for their
                'config' property.";
           }
<Michael>: Here defined config truth/false as a filter’s criteria. According to NMDA revised datastore, there are four type (ct = config true; cf = config false

       rw = read-write; ro = read-only). Why not define the “rw” and “ro” as other criteria?
           leaf origin {
<Michael>: why not define some “when” statement like:  when 'derived-from-or-self(../source, "or:operational")';?
                       The ‘origin‘’ seems only exist when retrieving the data in operational datastore.
             if-feature origin;
             type identityref {
               base or:origin;
             }
             description
               "Filter based on 'origin' annotation.  A node matches the
                filter if its 'origin' annotation is derived from or
                equal to the given filter value.";
           }
         }

         leaf with-origin {
           when 'derived-from-or-self(../source, "or:operational")';
           if-feature origin;
           type boolean;
           default false;
           description
             "If this parameter is 'true', the server will return
              the 'origin' annotation for the nodes that has one.";
         }

Best Regards!
-Michael

发件人: Netconf [mailto:[email-masked]] 代表 Mahesh Jethanandani
发送时间: 2017年9月24日 13:18
收件人: netconf <[email-masked]>
主题: [Netconf] WG adoption of NETCONF NDMA draft

The NETCONF NDMA draft was presented an discussed in IETF 99 in Prague. The authors agreed to provide an update, which they did with -01 version of the draft. The authors believe the document is ready for WG adoption.

This starts a two week call to adopt NETCONF NDMA draft as a WG document. Since the focus of the draft is NDMA compliance, it falls within the charter of the WG.

https://tools.ietf.org/html/draft-dsdt-nmda-netconf-01

Please indicate whether you think this draft should be adopted as a WG item. If you have objections to it being adopted, please state your reasons by responding on this thread.

Thanks.

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>

---

From: Robert Wilton <[email-masked]>
Date: Fri, 29 Sep 2017 11:45:56 +0100

[Cross posting to Netmod WG]

Hi Michael,

On 26/09/2017 03:27, wangzitao wrote:
> <Michael>: Here defined config truth/false as a filter’s criteria. 
> According to NMDA revised datastore, there are four type (ct = config 
> true; cf = config false
>
The ct/cf and rw/ro are reporting two different things are 2 different 
things:

A YANG schema node can be labelled as config true, or config false.
Some YANG datastores can only be read by a client (e.g. <intended> and 
<operational>).
Other YANG datastores can be both read and also written by the client 
(e.g. <running>, <startup>, <candidate>).

Do you think that the NMDA draft is sufficiently clear on this point, or 
does this need to be clarified in some way?

Thanks,
Rob