Subject: [Netconf] I-D Action: draft-ietf-netconf-keystore-03.txt

From: [email-masked]
Date: Tue, 17 Oct 2017 21:46:22 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network Configuration WG of the IETF.

        Title           : YANG Data Model for a "Keystore" Mechanism
        Author          : Kent Watsen
	Filename        : draft-ietf-netconf-keystore-03.txt
	Pages           : 28
	Date            : 2017-10-17

Abstract:
   This document defines a YANG module for a system-level mechanism,
   called a "keystore", containing security-sensitive data including
   private keys, pinned certificates, and pinned SSH host-keys.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netconf-keystore/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-netconf-keystore-03
https://datatracker.ietf.org/doc/html/draft-ietf-netconf-keystore-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-netconf-keystore-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Kent Watsen <[email-masked]>
Date: Wed, 18 Oct 2017 04:57:06 +0000

Please ignore.  This draft was posted primarily to resolve a YANG validation error from the zerotouch draft submission.  This draft is still being updated to reflect the last call comments from before.

Kent // contributor

--

Abstract:

The IETF datatracker status page for this draft is:
https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dnetconf-2Dkeystore_&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=tfp6AyxoWTemrxU6f-cwJY9lOBMFs-K_WDwG0oJuTgc&s=spWgrT7jrb11weoPy-ObarYaogzUpo6U0BtCL34Bl4g&e=

There are also htmlized versions available at:
https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dnetconf-2Dkeystore-2D03&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=tfp6AyxoWTemrxU6f-cwJY9lOBMFs-K_WDwG0oJuTgc&s=zIbPZU5DVPtp6dDHdHqH2iOpjzohS3W6GW-Ps71U40Y&e=
https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Dietf-2Dnetconf-2Dkeystore-2D03&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=tfp6AyxoWTemrxU6f-cwJY9lOBMFs-K_WDwG0oJuTgc&s=FmuuoRqQm__WCTMN1FNg1hSek3Z2sVwti92itTE2Vz4&e=

A diff from the previous version is available at:
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dietf-2Dnetconf-2Dkeystore-2D03&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=tfp6AyxoWTemrxU6f-cwJY9lOBMFs-K_WDwG0oJuTgc&s=Vvpfx-IwdxxOWKc_kjWhDdyTzPTHeAo-3ew0BDuSjcE&e=

Internet-Drafts are also available by anonymous FTP at:
https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-2Ddrafts_&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=tfp6AyxoWTemrxU6f-cwJY9lOBMFs-K_WDwG0oJuTgc&s=9hDHJDd64Wqime4O5ycbrGrV82J9FtPzb5H7GVkTCo8&e=

_______________________________________________
Netconf mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_netconf&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=tfp6AyxoWTemrxU6f-cwJY9lOBMFs-K_WDwG0oJuTgc&s=HTWozXyPUmVmUwveU1iPqlYczuDCeLBXA8MW5g_FUy8&e=

---

From: Benoit Claise <[email-masked]>
Date: Thu, 19 Oct 2017 11:09:00 +0200

Dear all,

The ietf-keystore YANG module is imported by many YANG modules at the IETF.
This new version implies that most YANG modules must be updated.
Look at all the dependent YANG modules with a red circle (= COMPILATION 
FAILED)
https://www.yangcatalog.org/yang-search/impact_analysis.php?modules[]=ietf-keystore&recurse=10&rfcs=1&show_subm=1&show_dir=dependents

You're in the cc list because your dependent YANG modules fail 
COMPILATION and must now be updated.

Regards, Benoit
> https://www.ietf.org/mailman/listinfo/netconf
> .
>

---

From: Kent Watsen <[email-masked]>
Date: Thu, 19 Oct 2017 13:30:19 +0000

Most of these drafts depend on the ietf-tls-client and ietf-tls-server YANG modules, either directly or through a dependency on ietf-pcep or ietf-actn-vn.  I'll post an update to draft-ietf-netconf-tls-client-server to update those two YANG modules to resolve most of your compiling issues ASAP.

Thanks,
Kent

--

Dear all,

Regards, Benoit
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_netconf&d=DwICaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=ek0wNqq87ubNoX0pyrQmwcy0UqKXEgNs5dSiYeEKsdM&s=oDEp-AcPQOpgfQXzelCUwAI8bYVZ7kNk9mAp9sl5OHs&e=
> .
>