Subject: Re: [Netconf] two-week review of drafts related to notifications and subscriptions

From: Kent Watsen <[email-masked]>
Date: Mon, 23 Oct 2017 23:00:48 +0000

Thank you to all those who participated in the review of
the drafts related to event notifications.  Recall that
our interest was to get a heartbeat from the working group
regarding the readiness of these drafts to progress to Last
Call.  As we see it, most of the discussion centered on the
subscribed-notifications draft, and we're optimistic that
the next update of that draft could be in shooting distance
to a Last Call.  Assuming that is true, would it make sense
to do that, or should we look at including other drafts in
a combo Last Call.  We understand that there is an interest
to take a vertical slice (yang-push, subscribed-notifications,
and netconf-notif) to Last Call together, but maybe it would
make more sense to do subscribed-notifications, netconf-notif,
and restconf-notif together, as the latter two drafts provide
the instance examples for the first draft.

What are your thoughts?

Thanks,
Kent and Mahesh

--

We’d like to direct the WG attention to the set of drafts related
to notifications and subscriptions, with the goal of getting a 
pulse on if the WG thinks they are ready to progress now.

To enable you get an overview and to see how the documents relate
to each other, this draft is a good place to start:  https://tools.ietf.org/html/draft-voit-netconf-subscription-and-notif-overview-00.

The drafts related to this review are:

   -  draft-ietf-netconf-subscribed-notifications
   -  draft-ietf-netconf-yang-push
   -  draft-ietf-netconf-netconf-event-notifications
   -  draft-ietf-netconf-restconf-notif
   -  draft-ietf-netconf-notification-messages
 
While this is not an official WGLC, we will issue one if the 
response is positive. Please provide comments within two weeks.

Thanks,
Mahesh and Kent

_______________________________________________
Netconf mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_netconf&d=DwIGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=6EmQf9DJN6gYrH_xCp3oiMMsgNpXCh7lN3VAHxwuG-4&s=vrMmzT7gkE3A2xzCWX5U8WjjxlRtLR137nXwhyPqO3Q&e=

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Tue, 24 Oct 2017 16:43:47 +0000

Hi Kent,
Hi Mahesh,

> From: Netconf, October 23, 2017 7:01 PM
> 
> Thank you to all those who participated in the review of the drafts related to
> event notifications.  Recall that our interest was to get a heartbeat from the
> working group regarding the readiness of these drafts to progress to Last Call.
> As we see it, most of the discussion centered on the subscribed-notifications
> draft, and we're optimistic that the next update of that draft could be in
> shooting distance to a Last Call.  Assuming that is true, would it make sense to
> do that, or should we look at including other drafts in a combo Last Call.  We
> understand that there is an interest to take a vertical slice (yang-push,
> subscribed-notifications, and netconf-notif) to Last Call together, but maybe it
> would make more sense to do subscribed-notifications, netconf-notif, and
> restconf-notif together, as the latter two drafts provide the instance examples
> for the first draft.

From my perspective, the vertical slice makes more sense:
- YANG subscriptions has more industry activity, and early implementations needing interoperability guidance
- YANG-Push defines a notification which places the subscription-id within the notification message (something you don't get right away with subscribed-notifications).  This makes is more useful.
- the instance examples in the transport drafts also include examples of yang-push subscriptions (i.e., the horizontal slice also has vertical elements).
- restconf-notif's HTTP2 configured subscriptions are less complex if they use only the new notification message format

Eric 

> What are your thoughts?
> 
> Thanks,
> Kent and Mahesh
> 
> 
> --
> 
> We’d like to direct the WG attention to the set of drafts related to notifications
> and subscriptions, with the goal of getting a pulse on if the WG thinks they are
> ready to progress now.
> 
> To enable you get an overview and to see how the documents relate to each
> other, this draft is a good place to start:  https://tools.ietf.org/html/draft-voit-
> netconf-subscription-and-notif-overview-00.
> 
> While this is not an official WGLC, we will issue one if the response is positive.
> Please provide comments within two weeks.
> 
> Thanks,
> Mahesh and Kent
> 
> 
> 
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_netconf&d=DwIGaQ&c=HAkYuh63rsuhr6
> Scbfh0UjBXeMK-
> ndb3voDTXcWzoCI&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=6
> EmQf9DJN6gYrH_xCp3oiMMsgNpXCh7lN3VAHxwuG-
> 4&s=vrMmzT7gkE3A2xzCWX5U8WjjxlRtLR137nXwhyPqO3Q&e=
> 
> 
> https://www.ietf.org/mailman/listinfo/netconf

---

From: Alexander Clemm <[email-masked]>
Date: Wed, 25 Oct 2017 00:11:52 +0000

+1 on Eric's comments.

I believe going to WGLC with the "vertical slice" that includes YANG-Push as well as subscribed notifications is the preferable option.  Several reasons:

- You mention that subscribed-notifications with its new revision will be in range for WGLC, and YANG-Push has had less areas of contention and is deemed in good overall shape, as also commented on this list.  I believe that this is clearly ready.  
- Industry activity has been asking for YANG-Push for some time.  I do not think anything would be gained from incurring further delay; IMHO it will not make the solution substantially better, only erode momentum of IETF solution.  
- and historically they have been a bundle anyway - subscribed-notifications was "broken out" from YANG-Push at some point to generalize the solution

Thanks
--- Alex

> -----Original Message-----
> From: Netconf [mailto:[email-masked]] On Behalf Of Eric Voit
> (evoit)
> Sent: Tuesday, October 24, 2017 9:44 AM
> To: Kent Watsen <[email-masked]>; [email-masked]
> Cc: Mahesh Jethanandani (mahesh) <[email-masked]>
> Subject: Re: [Netconf] two-week review of drafts related to notifications and
> subscriptions
> 
> Hi Kent,
> Hi Mahesh,
> 
> > Thank you to all those who participated in the review of the drafts
> > related to event notifications.  Recall that our interest was to get a
> > heartbeat from the working group regarding the readiness of these drafts
> to progress to Last Call.
> > As we see it, most of the discussion centered on the
> > subscribed-notifications draft, and we're optimistic that the next
> > update of that draft could be in shooting distance to a Last Call.
> > Assuming that is true, would it make sense to do that, or should we
> > look at including other drafts in a combo Last Call.  We understand
> > that there is an interest to take a vertical slice (yang-push,
> > subscribed-notifications, and netconf-notif) to Last Call together,
> > but maybe it would make more sense to do subscribed-notifications,
> > netconf-notif, and restconf-notif together, as the latter two drafts provide
> - YANG-Push defines a notification which places the subscription-id within
> the notification message (something you don't get right away with
> subscribed-notifications).  This makes is more useful.
> - the instance examples in the transport drafts also include examples of
> yang-push subscriptions (i.e., the horizontal slice also has vertical elements).
> > We’d like to direct the WG attention to the set of drafts related to
> > notifications and subscriptions, with the goal of getting a pulse on
> > if the WG thinks they are ready to progress now.
> >
> > To enable you get an overview and to see how the documents relate to
> > each other, this draft is a good place to start:
> > https://tools.ietf.org/html/draft-voit-

---

From: "t.petch" <[email-masked]>
Date: Wed, 25 Oct 2017 12:07:23 +0100

----- Original Message -----
From: "Kent Watsen" <[email-masked]>
Sent: Tuesday, October 24, 2017 12:00 AM

> the instance examples for the first draft.

Kent

Your start to this thread called out five related I-D for consideration;
I think that you were spot on to link the five together.

Early comments said that three were nearly ready so we will ignore the
other two; a mistake, IMHO.  I do not think it makes sense to proceed
without at least
  -  draft-ietf-netconf-notification-messages
so the priority should be to fix that first;

e.g. I cannot see the status of RFC5277 being determinate without all
five being in play.

Tom Petch

p.s. I think that proceeding with the easier parts and then wishing we
had done it differently as the other parts progress is a common
pattern - for NETCONF, netmod, the IETF - but that does not make it a
good way of working.

> to each other, this draft is a good place to start:
https://tools.ietf.org/html/draft-voit-netconf-subscription-and-notif-ov
erview-00.
> response is positive. Please provide comments within two weeks.
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailma
n_listinfo_netconf&d=DwIGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoC
I&r=9zkP0xnJUvZGJ9EPoOH7Yhqn2gsBYaGTvjISlaJdcZo&m=6EmQf9DJN6gYrH_xCp3oiM
MsgNpXCh7lN3VAHxwuG-4&s=vrMmzT7gkE3A2xzCWX5U8WjjxlRtLR137nXwhyPqO3Q&e=