Subject: [Netconf] I-D Action: draft-ietf-netconf-subscribed-notifications-06.txt

From: [email-masked]
Date: Fri, 27 Oct 2017 15:21:03 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network Configuration WG of the IETF.

        Title           : Custom Subscription to Event Streams
        Authors         : Eric Voit
                          Alexander Clemm
                          Alberto Gonzalez Prieto
                          Einar Nilsen-Nygaard
                          Ambika Prasad Tripathy
	Filename        : draft-ietf-netconf-subscribed-notifications-06.txt
	Pages           : 52
	Date            : 2017-10-27

Abstract:
   This document defines capabilities and operations for the customized
   establishment of subscriptions upon a publisher's event streams.
   Also defined are delivery mechanisms for instances of the resulting
   notification messages.  Effectively this allows a subscriber to
   request and receive a continuous, custom feed of publisher generated
   information.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netconf-subscribed-notifications/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-netconf-subscribed-notifications-06
https://datatracker.ietf.org/doc/html/draft-ietf-netconf-subscribed-notifications-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-netconf-subscribed-notifications-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Fri, 27 Oct 2017 22:27:41 +0000

Thanks all for the comments during the last few weeks.   The agreed comments are now posted.

The open issues are at:
https://github.com/netconf-wg/rfc5277bis/issues

This version includes best guess answers for the two emails I sent a few hours ago:
(1) a simplification so that "encoding" is not mandatory for dynamic subscriptions (it is inherited from the transport session)
(2) A "connecting" status for configured subscription receivers.

If people prefer alternatives, these can be backed out.

Thanks,
Eric

> -----Original Message-----
> From: Netconf [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Friday, October 27, 2017 6:21 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Netconf] I-D Action: draft-ietf-netconf-subscribed-notifications-06.txt
> 
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf