Subject: Re: [Netconf] two-week review of drafts related to notifications and subscriptions

From: "Ambika Prasad Tripathy Tripathy (ambtripa)" <[email-masked]>
Date: Wed, 11 Oct 2017 19:32:01 +0000

Hi,

I too supporting following docs to go LC.
    -  draft-ietf-netconf-subscribed-notifications
    -  draft-ietf-netconf-yang-push
    -  draft-ietf-netconf-netconf-event-notifications

We have implemented the solution for OpenDaylight Beryllium release project through YANG-PUSH client. The server implantation done using cisco devices.  

— 
Br,
Ambika Prasad Tripathy

On 10/11/17, 8:10 AM, "Netconf on behalf of Tianran Zhou" <[email-masked] on behalf of [email-masked]> wrote:

    I agree with Eric, and support the following three documents to go to LC.
    -  draft-ietf-netconf-subscribed-notifications
    -  draft-ietf-netconf-yang-push
    -  draft-ietf-netconf-netconf-event-notifications
    
    We also have implementations on these.
    We had a successful Hackathon during the 99 meeting. A collector can subscribe data from network which consists of Cisco and Huawei devices in remote labs.
    
    Regards,
    Tianran
    
    > -----Original Message-----
    > From: Netconf [mailto:[email-masked]] On Behalf Of Eric Voit
    > (evoit)
    > Sent: Thursday, October 05, 2017 6:55 AM
    > To: Kent Watsen
    > Cc: [email-masked]
    > Subject: Re: [Netconf] two-week review of drafts related to notifications
    > and subscriptions
    > 
    > Thanks Kent for kicking off this review!   Some thoughts in-line...
    > 
    > > From: Kent Watsen, Wednesday, October 4, 2017 5:25 PM
    > >
    > > We’d like to direct the WG attention to the set of drafts related to
    > > notifications and subscriptions, with the goal of getting a pulse on
    > > if the WG thinks they are ready to progress now.
    > >
    > > To enable you get an overview and to see how the documents relate to
    > > each other, this draft is a good place to start:
    > > https://tools.ietf.org/html/draft-voit-
    > > netconf-subscription-and-notif-overview-00.
    > >
    > > The drafts related to this review are:
    > >    -  draft-ietf-netconf-subscribed-notifications
    > >    -  draft-ietf-netconf-yang-push
    > >    -  draft-ietf-netconf-netconf-event-notifications
    > 
    > The three drafts above should be in fairly good shape.  It would be great
    > to get comments on any and all aspect of these documents.
    > 
    > >    -  draft-ietf-netconf-notification-messages
    > 
    > 'notification-messages' is just recently adopted, and there are multiple
    > open questions listed in the appendix.  I don't think this should be read
    > with an eye toward WGLC.  But it can safely be read for solution elements,
    > approaches, and gaps.
    > 
    > >    -  draft-ietf-netconf-restconf-notif
    > 
    > Even though restconf-notif has been around for a while, I don't think it
    > is ready for a fine-toothed comb at this point.  There are several reasons
    > for this:
    > a) There is not an easily accessible Notification element for encoding in
    > JSON until notification-messages draft solidifies.  (And RESTCONF has
    > market affinity with JSON.)
    > b) Capability discovery is much easier for configured subscriptions over
    > HTTP2 once notification-messages is available.
    > c) There are no implementations which have validated the approach.
    > 
    > As an author, I have *not* cleaned up examples in restconf-notif yet because
    > these examples will change based on the result of work on the
    > notification-messages draft.  That said this document is also readable for
    > solution elements and approaches.
    > 
    > Thanks,
    > Eric
    > 
    > >
    > > While this is not an official WGLC, we will issue one if the response
    > is positive.
    > > Please provide comments within two weeks.
    > >
    > > Thanks,
    > > Mahesh and Kent
    > >
    > >
    > > _______________________________________________
    > > Netconf mailing list
    > > [email-masked]
    > > https://www.ietf.org/mailman/listinfo/netconf
    > _______________________________________________
    > Netconf mailing list
    > [email-masked]
    > https://www.ietf.org/mailman/listinfo/netconf
    _______________________________________________
    Netconf mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/netconf

---

From: "Einar Nilsen-Nygaard (einarnn)" <[email-masked]>
Date: Thu, 12 Oct 2017 14:12:22 +0000

+1 support for WGLC.

We have successfully implemented earlier versions of these drafts on IOS-XE, as noted by Ambika below, and are tracking implementing the updated specs. We have released this code for customers to use as of IOS-XE 16.6.1 on a limited subset of platforms (Cat3K/Cat9K).

We also have a fork of the Python ncclient library that provides RPC extensions to use a subset of the features available (see https://github.com/CiscoDevNet/ncclient if interested). When the specification transitions to RFC and we have a compliant device implementation, we will complete that implementation and push upstream.

Cheers,

Einar

On 11 Oct 2017, at 20:32, Ambika Prasad Tripathy Tripathy (ambtripa) <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

—
Br,
Ambika Prasad Tripathy

On 10/11/17, 8:10 AM, "Netconf on behalf of Tianran Zhou" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

   Regards,
   Tianran

-----Original Message-----
From: Netconf [mailto:[email-masked]] On Behalf Of Eric Voit
(evoit)
Sent: Thursday, October 05, 2017 6:55 AM
To: Kent Watsen
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Netconf] two-week review of drafts related to notifications
and subscriptions

Thanks,
Eric

Thanks,
Mahesh and Kent

_______________________________________________
Netconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netconf
_______________________________________________
Netconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netconf
   _______________________________________________
   Netconf mailing list
   [email-masked]<mailto:[email-masked]>
   https://www.ietf.org/mailman/listinfo/netconf

_______________________________________________
Netconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netconf