Subject: Re: [Netconf] YANG Patch 'remove' operation

From: Phil Shafer <[email-masked]>
Date: Wed, 11 Oct 2017 20:00:06 -0400

Robert Wilton writes:
>When I looked at this again, it looks like "replace" also shouldn't fail 
>on non existence.

"replace" was meant to allow non-existance.  It means "replace the
item completely", but should effectively ignored if the item does
not already exist.  This is the model we've used in JUNOS.

Thanks,
 Phil

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 12 Oct 2017 08:41:38 +0200 (CEST)

Phil Shafer <[email-masked]> wrote:
> not already exist.

No, this is not how it is specified.  Both RFC 6020 and 7950 have this:

      If the operation is "merge" or "replace", the node is created if
      it does not exist.

/martin

---

From: Phil Shafer <[email-masked]>
Date: Thu, 26 Oct 2017 12:05:09 -0400

>      If the operation is "merge" or "replace", the node is created if

This is what I meant: the "replace" opeation is ignored and normal
behavior proceeds.

Thanks,
 Phil