Subject: Re: [Netconf] Review of subscribed notifications draft (was Re: Netconf Digest, Vol 117, Issue 18)

From: "Tim Jenkins (timjenki)" <[email-masked]>
Date: Thu, 9 Nov 2017 14:42:38 +0000

Comments embedded with <Tim>.

From: Netconf <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Reply-To: "[email-masked]" <[email-masked]>
Date: Thursday, November 9, 2017 at 1:04 AM
To: "[email-masked]" <[email-masked]>
Subject: Netconf Digest, Vol 117, Issue 18

Send Netconf mailing list submissions to
                [email-masked]<mailto:[email-masked]>

To subscribe or unsubscribe via the World Wide Web, visit
                https://www.ietf.org/mailman/listinfo/netconf
or, via email, send a message with subject or body 'help' to
                [email-masked]<mailto:[email-masked]>

You can reach the person managing the list at
                [email-masked]<mailto:[email-masked]>

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Netconf digest..."

Today's Topics:

   1. Re: Review of subscribed notifications draft (Eric Voit (evoit))

----------------------------------------------------------------------

Message: 1
Date: Thu, 9 Nov 2017 06:04:18 +0000
From: "Eric Voit (evoit)" <[email-masked]<mailto:[email-masked]>>
To: Mahesh Jethanandani <[email-masked]<mailto:[email-masked]>>
Cc: netconf <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Netconf] Review of subscribed notifications draft
Message-ID: <[email-masked]<mailto:[email-masked]>>
Content-Type: text/plain; charset="utf-8"

...

  *   Also if configured subscriptions cannot be modified, which BTW is not obvious why,
If you allow configuration operations to modify behavior of a dynamic subscription, you get several consequences such as:
(a) the subscriber is no longer agreeing to what the subscription contract includes
(b) complexity: how will the receiver know the subscription has changes without also implementing the subscription-modified state change notification.   If seems simpler just to kill the subscription, and let the subscriber renegotiate the parameters new.

<Tim>
I was under the impression that configured subscriptions *can* be modified, but only by management operations. And when that happens, if the modifications result in a subscription that is valid, the receivers are notified of the change by the use of the "subscription-modified" notification.
</Tim>

  *   then it would help to say that the configured subscription needs to be terminated by <delete-subscription> (??), and a new subscription be created.
I will add that.

<Tim>
If they cannot, then that should say that the deletion must be done by a management operation, not by delete-subscription. Delete-subscription is usable only on dynamic subscriptions.

What perhaps could be made clearer is that dynamic subscriptions have no configuration data at all and cannot be affected by normal management operations, which is why the RPC "kill-subscription" was created.
</Tim>

Thanks again!
Eric

More later. Thanks.

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]><mailto:[email-masked]>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailarchive.ietf.org/arch/browse/netconf/attachments/20171109/37cd4aab/attachment.html>

------------------------------

Subject: Digest Footer

_______________________________________________
Netconf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netconf

------------------------------

End of Netconf Digest, Vol 117, Issue 18
****************************************

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Thu, 9 Nov 2017 16:28:10 +0000

From: Tim Jenkins (timjenki)
Sent: Thursday, November 9, 2017 9:43 AM
To: [email-masked]; Eric Voit (evoit) <[email-masked]>; [email-masked]
Subject: Re: Review of subscribed notifications draft (was Re: Netconf Digest, Vol 117, Issue 18)

From: Netconf <[email-masked]<mailto:[email-masked]>> on behalf of "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Reply-To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, November 9, 2017 at 1:04 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Netconf Digest, Vol 117, Issue 18

Today's Topics:

Message: 1

...

<Tim>

<Eric> Yes this is absolutely the case.   Note my comment was about using configuration operations to modify a dynamic subscription.

</Tim>

<Tim>

<Eric> Exactly.   What I meant by “I will add that” is: “I will add clarification that deleting a configured subscription can only be done by deleting that subscription’s configuration.

<Eric>  This is exactly why kill-RPC was added.  And some text on this is in Section 4.4.

Eric
</Tim>

Thanks again!
Eric

More later. Thanks.

Mahesh Jethanandani

-------------- next part --------------

Subject: Digest Footer