Subject: [Netconf] draft-ietf-netconf-rfc6536bis Edit proposal

From: Rohit R Ranade <[email-masked]>
Date: Fri, 17 Nov 2017 11:17:54 +0000

Hi Andy,

If we want to use the NACM  module for RESTCONF also , then I propose the below changes.

OLD:
leaf denied-operations {
         type yang:zero-based-counter32;
         config false;
         mandatory true;
         description
           "Number of times since the server last restarted that a
            protocol operation request was denied.";
       }

NEW:
leaf denied-operations {
         type yang:zero-based-counter32;
         config false;
         mandatory true;
         description
           "Number of times since the NETCONF server last restarted that a
            protocol operation request was denied by the NETCONF server.";
       }

? To keep the meaning similar to RFC 6536

NEW:
ADD "leaf restconf-denied-operations" to provide the values for state-data corresponding to the RESTCONF server.

Another way was to mention that "denied-operations" is the total number of times the request was denied across all servers after they were started. But since RESTCONF/NETCONF Servers MAY be started / stopped at different time a combined total did not seem right.

With Regards,
Rohit R

From: Rohit R Ranade
Sent: 15 November 2017 10:42
To: [email-masked]
Subject: [Netconf] draft-ietf-netconf-rfc6536bis Query

Hi All,

For the state-data in NACM like the below :

leaf denied-operations {
         type yang:zero-based-counter32;
         config false;
         mandatory true;
         description
           "Number of times since the server last restarted that a
            protocol operation request was denied.";
       }

"Number of times since the server" ==> Here the server is being referenced to NETCONF server or RESTCONF server ?
Please note that the both the NETCONF server and RESTCONF server maybe using the same NACM configurations but the state-data maintained by each protocol maybe different.

With Regards,
Rohit R

---

From: Andy Bierman <[email-masked]>
Date: Fri, 17 Nov 2017 11:03:16 -0800

Hi,

I don't think any changes are needed.
If the NETCONF and RESTCONF protocols are not supported
by the same server, then there should be separate server instances.

Andy

On Fri, Nov 17, 2017 at 3:17 AM, Rohit R Ranade <[email-masked]>
wrote:

>            "Number of times since the *NETCONF *server last restarted
> that a
>
>             protocol operation request was denied by the *NETCONF *
> server.";
>
>        }
>
> è To keep the meaning similar to RFC 6536
>
>
>
> NEW:
>
> ADD “leaf restconf-denied-operations” to provide the values for state-data
> corresponding to the RESTCONF server.
>
>
>
> Another way was to mention that “denied-operations” is the total number of
> times the request was denied across all servers after they were started.
> But since RESTCONF/NETCONF Servers MAY be started / stopped at different
> time a combined total did not seem right.
>
>
>
> With Regards,
>
> Rohit R
>
>
>
> *From:* Rohit R Ranade
> *Sent:* 15 November 2017 10:42
> *To:* [email-masked]
> *Subject:* [Netconf] draft-ietf-netconf-rfc6536bis Query
>
>
>
> Hi All,
>
>
>
> “Number of times since the server” è Here the server is being referenced
> to NETCONF server or RESTCONF server ?
>
> Please note that the both the NETCONF server and RESTCONF server maybe
> using the same NACM configurations but the state-data maintained by each
> protocol maybe different.
>
>
>
> With Regards,
>
> Rohit R
>