Subject: Re: [netext] [netlmm] [MEXT] NEXTEXT2: first draft of the bof description

From: Hesham Soliman <[email-masked]>
Date: Thu, 02 Jul 2009 02:20:19 +1000

> => That's 180 diversion from the above statement. Are L3 protocols allowed
> or not? I don't call them extensions because it's not clear which protocol
> is being extended.
> 
> 
> RKo> I suggested "no host protocol changes" for stating the it precisely. It
> was not meant to say we should endorse the statement.

=> Ok but I'm asking for your opinion on what the requirement should be. Is
your opinion that the requirement should be "no protocol support in the
host"?

Hesham

---

From: "Koodli, Rajeev" <[email-masked]>
Date: Wed, 1 Jul 2009 18:47:21 -0400

> > RKo> I suggested "no host protocol changes" for stating the it 
> > RKo> precisely. It
> => Ok but I'm asking for your opinion on what the requirement 
> should be. Is your opinion that the requirement should be "no 
> protocol support in the host"?
> 

No, we should not rule out protocol extensions which may be needed for a
feature to work (just as an example, informing a mobile node that a flow
is moving to another interface - I would like to have such indications
at L2 whenever possible)

The requirement should be "no L3 mobility protocol changes in the host".

-Rajeev

---

From: Hesham Soliman <[email-masked]>
Date: Thu, 02 Jul 2009 12:11:57 +1000

> The requirement should be "no L3 mobility protocol changes in the host".

=> In that case your requirement contradicts your own words above it, not to
mention, it's a silly requirement to make because you seem to have a strange
idea about what mobility protocol means (almost something like mobility
protocol = binding update) and none of the reasons for eliminating the host
from the conversation apply here. Actually, what you say above doesn't
amount to a requirement, it's how you think things should be done. It's
going to be very hard to answer the "why" part given the above.

It's disappointing that this work has not progressed even to the point of
producing decent requirements given the amount of attention it's getting on
the mailing list. 

Hesham

> 
> -Rajeev
> 
> 
>> Hesham
>> 
>> 
>> 
>> 
> _______________________________________________
> netext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netext

---

From: "Koodli, Rajeev" <[email-masked]>
Date: Thu, 2 Jul 2009 01:54:22 -0400

I guess it was not clear.. I did not suggest that "no host protocol
changes" should be a requirement, but a better use than saying "no host
changes". 

I think we are making progress. We (at least many folks) are receptive
to 1) relying on L2 capabilities as much as possible, 2) using host
configurations to address some of the issues, and 3) not ruling out L3
extensions without changing the PMIP mobility model (i.e., the MN is not
involved in mobility management of persistence and reachbility). Please
see Marcelo's e-mail below; it seems like a good formulation to me.

-Rajeev

> -----Original Message-----
> From: marcelo bagnulo braun [mailto:[email-masked]] 
> Sent: Wednesday, July 01, 2009 5:31 AM
> To: Koodli, Rajeev
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [netext] [netlmm] [MEXT] NEXTEXT2: first draft 
> of the bofdescription
> 
[snip]
> >   
> right, this is what i was asking
> 
> So, i think this can be defined in terms of what is in 
> control of the network, correct?
> So, would it make sense to define this as a requirement that 
> it must be network that decides through wich interface the 
> node sends traffic In particular, it is the network side that decides:
> - when the node performs a handoff to the other interface
> - how the traffic is distributed among interfaces
> - which flow flows through each interface
> 
> Is that what you have in mind?
> 
> Regards, marcelo
> 
 
> -----Original Message-----
> From: Hesham Soliman [mailto:[email-masked]] 
> Sent: Wednesday, July 01, 2009 7:12 PM
> To: Koodli, Rajeev; [email-masked]
> Subject: Re: [netext] [netlmm] [MEXT] NEXTEXT2: first draft 
> of the bof description
> 
> 
> 
> 
> >> => Ok but I'm asking for your opinion on what the 
> requirement should 
> >> be. Is your opinion that the requirement should be "no protocol 
> >> support in the host"?
> >> 
> > 
> > No, we should not rule out protocol extensions which may be 
> needed for 
> > a feature to work (just as an example, informing a mobile 
> node that a 
> > flow is moving to another interface - I would like to have such 
> > indications at L2 whenever possible)
> > 
> => In that case your requirement contradicts your own words 
> above it, not to mention, it's a silly requirement to make 
> because you seem to have a strange idea about what mobility 
> protocol means (almost something like mobility protocol = 
> binding update) and none of the reasons for eliminating the 
> host from the conversation apply here. Actually, what you say 
> above doesn't amount to a requirement, it's how you think 
> things should be done. It's going to be very hard to answer 
> the "why" part given the above.
> 
> It's disappointing that this work has not progressed even to 
> the point of producing decent requirements given the amount 
> of attention it's getting on the mailing list. 
> 
> Hesham
> 
> 
> > 
> > -Rajeev
> > 
> > 
> >> Hesham
> >> 
> >> 
> >> 
> >>

---

From: "Mohana Jeyatharan" <[email-masked]>
Date: Thu, 2 Jul 2009 14:07:29 +0800

Hi all,

The below classification on requirements looks really good. 
1) relying on L2 capabilities as much as possible, 2) using host
> extensions without changing the PMIP mobility model

One more point, the mobile node should be able to indicate flow
prefernce, handoff indication etc to the network and the final decision
can be made by the network. At least we should cater for mobile node
indicating its prefernce to the network. As some of us have described in
the ML, this should be supported. However, I am fine with the fact that
the final decsion can be made by the network. 

Thanks.

BR,
Mohana

> From: [email-masked] [mailto:[email-masked]] On
Behalf
> Of Koodli, Rajeev
> Sent: Thursday, July 02, 2009 1:54 PM
> To: [email-masked]
> Subject: Re: [netext] [netlmm] [MEXT] NEXTEXT2: first draft of the
> bofdescription
> 
>

---

From: Hesham Soliman <[email-masked]>
Date: Thu, 02 Jul 2009 16:15:44 +1000

On 2/07/09 4:07 PM, "Mohana Jeyatharan" <[email-masked]>
wrote:

> indicating its prefernce to the network.

=> Agree, but you're contradicting the paragraph you're quoting above, which
you said "looks really good".....

Hesham

As some of us have described in

---

From: "Mohana Jeyatharan" <[email-masked]>
Date: Thu, 2 Jul 2009 14:45:26 +0800

Hi Hesham,

I meant, network can decide MN interface for flow mobility, handoff
based on its own policies or MN provided information. So, just wanted to
highlight that MN should be able to indicate its prefernce via signaling
and as Marcelo pointed network must decide.

Even if the network initiates flow mobility, we still need some host
changes. So, I was refering to the host changes tied to the host
initiating the flow mobility process by indicating its prefernce. Just
wanted to highlight that this too needs to be supported.
BR,
Mohana

> Sent: Thursday, July 02, 2009 2:16 PM
> To: Mohana Jeyatharan; Koodli, Rajeev; [email-masked]
> >> extensions without changing the PMIP mobility model (i.e., the MN
is
> > not

---

From: marcelo bagnulo braun <[email-masked]>
Date: Thu, 02 Jul 2009 09:36:24 +0200

> is moving to another interface - I would like to have such indications
I think it is imporntant to distinguish between the changes that are 
required for the protocol to work (i.e. the changes that are needed in 
order to be able to do an inter tech HO) and the changes that are needed 
to provide optimizations.

I think we should simply forget about the ones for optimizations at this 
point and focus on the ones that are required for the protocol to work.

> The requirement should be "no L3 mobility protocol changes in the host".

So, do you think that other L3 protocol changes that are not mobility 
protocols are acceptable?
Or do you think that L2 mobility protocol changes are acceptable?
Please note that requiring L2 protocol changes would colide with the 
potential requirement of supporting all L2...

Regards, marcelo

---

From: marcelo bagnulo braun <[email-masked]>
Date: Thu, 02 Jul 2009 09:43:27 +0200

Koodli, Rajeev escribió:
> to 1) relying on L2 capabilities as much as possible,
mmm, but if you want to support all L2, this is basically only an 
optimization, right?

>  2) using host
> configurations to address some of the issues,

sure, but this is not a requiremnet but a preference, (with which i 
agree with)
>  and 3) not ruling out L3
> extensions 

so, basically we are not imposing the requirement of no L3 protocol 
changes in the host, correct?

> without changing the PMIP mobility model 

> (i.e., the MN is not
>>> The requirement should be "no L3 mobility protocol changes 
>>>       
>> in the host".
>>

---

From: Hesham Soliman <[email-masked]>
Date: Thu, 02 Jul 2009 23:35:08 +1000

> and as Marcelo pointed network must decide.

=> Understood, but that's in direct contradiction with the text you quoted.

> wanted to highlight that this too needs to be supported.

=> That's fine but you can't want that and still agree with that requirement
you quoted.

Hesham