Subject: Re: [netext] Fwd: New Version Notification fordraft-hui-netext-service-flow-identifier-00

From: Frank Xia <[email-masked]>
Date: Wed, 01 Jul 2009 11:00:33 -0500

Hi Hui

Please check my inline comments..

BR
Frank
----- Original Message ----- 
From: "Min Hui" <[email-masked]>
To: "Frank Xia" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, July 01, 2009 1:08 AM
Subject: Re: [netext] Fwd: New Version Notification 
fordraft-hui-netext-service-flow-identifier-00

Hi, Frank Xia

Thanks for your comments, please see my reply in line.

- Hui Min

2009/7/1 Frank Xia <[email-masked]>:
> Hi Min
>
> I had a quick look at the document which
> looks clear. Some comments are below.
>
> 1)"multiple service flows of the mobile node can
>  be separately controlled based on the service
>  flow identifier in the Proxy Binding Update
>  and Acknowledge messages"
>  I could not find the motivation of separate
>  controlling of a service.  It is for traffic
>  engineering, QoS enforcement or something else?
>

It is used for content charging, QoS enforcement, etc. It is important
for operators to treat services  separately.
Frank=>Agree.   is possible for LMA
send a service flow identifier to MAG?

> 2)it is also not clear to me how the mobile
>  node notifies the MAG the service type.
>  It seems that the MAG identifies the service
>  through data packets from the mobile node.
>  Deep Packet Inspection technology is required
>  for MAG?

Yes, MAG is required to know the transport layer information. But I
guess the service type you mentioned refer to the "TOS" in the service
flow description. TOS is a field in the IP header, so DPI is not
necessary in this respect.

Frank=>I did not mean "TOS"， but appliactions (or flows).

>
> 3)What is the relationship between this draft
> and flow mobility being discussed in Netext BoF 2?
> They both have key words "flow" :-).
>

We considered this question as well. This draft is about the
granularity of PMIPv6, it is an important part of PMIPv6, although it
is independent of flow mobility. So we are wondering whether the
NETEXT BOF can add the granularity issue into the scope.

>
> BR
> Frank
>
>
> ----- Original Message ----- From: "Min Hui" <[email-masked]>
> To: <[email-masked]>
> Sent: Monday, June 29, 2009 10:27 PM
> Subject: [netext] Fwd: New Version Notification
> fordraft-hui-netext-service-flow-identifier-00
>
>
>> Hi, all
>>
>> I have just submitted a new draft:
>>
>> http://www.ietf.org/internet-drafts/draft-hui-netext-service-flow-identifier-00.txt
>>
>> This draft defines a new Service Flow Identifier option carrying the
>> service flow identifier and service flow attributes in the Proxy
>> Binding Update and Acknowledgement message, so that the granularity of
>> PMIPv6 becomes per service flow basis.
>>
>> Any comment is welcomed.
>> Thanks a lot.
>>
>> -Hui Min
>>
>>
>>
>> ---------- Forwarded message ----------
>> From: IETF I-D Submission Tool <[email-masked]>
>> Date: 2009/6/30
>> Subject: New Version Notification for
>> draft-hui-netext-service-flow-identifier-00
>> To: [email-masked]
>> 抄送： [email-masked], [email-masked]
>>
>>
>>
>> A new version of I-D, draft-hui-netext-service-flow-identifier-00.txt
>> has been successfuly submitted by Min Hui and posted to the IETF
>> repository.
>>
>> Filename:        draft-hui-netext-service-flow-identifier
>> Revision:        00
>> Title:           Service Flow Identifier in Proxy Mobile IPv6
>> Creation_date:   2009-06-29
>> WG ID:           Independent Submission
>> Number_of_pages: 18
>>
>> Abstract:
>> Proxy Mobile IPv6 enables network-based mobility for a regular IPv6
>> mobile node without requiring its participation in any mobility-
>> related signaling. This document introduces extensions to Proxy
>> Mobile IPv6 that allows network dynamically binding each service flow
>> to the mobile node, respectively. Therefore, multiple service flows
>> of the mobile node can be separately controlled based on the service
>> flow identifier in the Proxy Binding Update and Acknowledge messages.
>>
>>
>>
>> The IETF Secretariat.
>> _______________________________________________
>> netext mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/netext
>>
>
>

---

From: Min Hui <[email-masked]>
Date: Thu, 2 Jul 2009 15:17:05 +0800

Hi Frank,

Pls see my answer below.

-hui min

> send a service flow identifier to MAG?

service flow identifier is generated by MAG,  LMA uses the SFID which
is sent by MAG. It seems not necessary for LMA to send SFID to MAG.

> Frank=>I did not mean "TOS"， but appliactions (or flows).

MN isn't modified to carry the service type notification. It's MAG
itself to check the data packet and generate service flow option. So
the service type (or applications as you mentioned) is learned by MAG
but not MN.