Subject: [netext] Comments on I-D: draft-xia-netext-tunnel-negotiation-01.txt

From: "[email-masked]" <[email-masked]>
Date: Wed, 22 Jul 2009 23:39:47 +0200

After reviewing this I-D I have the following comments:

1. Why do we need a tunnel negotiation mechanism? Is the protocol
   broken without such capability? No.
   Does this negotiation make the protocol operation somehow more
   optimal? I dont believe that is the case either.

2. The I-D states that the LMA and MAG may have different capabilities
   and preferences. However a MAG is part of the PMIP6 domain. The
   MAG/LMA have a security association between them. Hence it is
   unlikely that the LMA or MAG will be unaware of the tunnelling
   capabilities or preferences. The document does not provide a strong
   reason why such negotiation is needed.

3. Deployments will choose to use either GRE or IP-in-IP
   tunnelling between the MAG/LMA depending on the
   requirements. Negotiating the type of tunnelling in the signaling
   is not required.

It might be useful to provide a better explanation of the problems in
choosing a tunnelling method between the MAG/LMA which would warrant
such negotiation. But in the absence of such I dont think we really
need to go down this route.

-Raj

---

From: Frank Xia <[email-masked]>
Date: Wed, 22 Jul 2009 17:19:01 -0500

Hi Raj

Thank for your review.
Please check my response...

BR
Frank

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, July 22, 2009 4:39 PM
Subject: [netext] Comments on I-D: 
draft-xia-netext-tunnel-negotiation-01.txt

>   optimal? I dont believe that is the case either.
Frank=>Yes.  Here is a use case.  LMA is related to muliple MAGs.
MAG 1 may choose IPv6/IPv4 in IPv6, MAG 2 may select GRE,
MAG 3 prefers IPsec ESP, while MAG 4 picks IPv6/IPv4 in IPv4-UDP.
Without negotiation mechanism,  LMA must implement all the tunnel!

>   reason why such negotiation is needed.
Frank=> LMA and MAG are very possible located in
different domains.  For example,  non-3GPP accesses
(such as WiMAX ASN-GW)  belong to  domains which are
different from 3GPP core network domains.

>   requirements. Negotiating the type of tunnelling in the signaling
Frank=> Just we list in the documents, there are
a bunch of tunnels.  I could not find requirements in SDO's
specification on the criteria of selecting a tunnel.

            0x01: IPv6/IPv4 in IPv6
            0x02: IPv6/IPv4 in IPv4
            0x03: GRE
            0x04: IPsec ESP
            0x05: IPv6/IPv4 in IPv4-UDP
            0x06: IPv6/IPv4 in IPv4-UDP-TLV
            0x07: IPv6/IPv4 in IPv4-UDP-ESP

> need to go down this route.
Frank=> We will try to explain this in the presentation.

>
> -Raj
>
> _______________________________________________
> netext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netext

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 23 Jul 2009 00:32:37 +0200

Hi Frank,

> Without negotiation mechanism,  LMA must implement all the tunnel!

The MAGs and LMA are all part of the same PMIP6 domain. The MAG/LMA pairs
are aware of what tunnelling capability is supported or preferred. The LMA
will need to support whatever set of tunnelling mechanisms are used in that
PMIP6 domain. And since they are all part of a single domain, there can be
simply a policy which requires all tunnelling to be over GRE in which case
the MAG/LMA entities in that domain will support only GRE tunnelling.

> different from 3GPP core network domains.

When you say different domains, I suppose you mean administrative domains.
But from the PMIP6 protocol perspective the MAG and LMA are part of a single
PMIP6 domain. A MAG in a WiMAX network and the LMA in a 3GPP core still
logically belong to the same PMIP6 domain.

>             0x07: IPv6/IPv4 in IPv4-UDP-ESP

I think you exaggerate the list here :)
Basically you have IP-in-IP or GRE. The rest are variants.
And given the requirement to secure the signaling via IPsec, the MAG/LMA
already support IPsec.

> Frank=> We will try to explain this in the presentation.

That's fine. But I am just saying that the extension itself does not seem to
be solving any critical problem or need.

-Raj

---

From: Frank Xia <[email-masked]>
Date: Wed, 22 Jul 2009 19:47:33 -0500

Hi Raj

Please check my response.

BR
Frank
----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Wednesday, July 22, 2009 5:32 PM
Subject: Re: [netext] Comments on I-D: 

Hi Frank,

Frank=>Probably we see "domain" from different respectives .
Let me reword the use case.  LMA is located in MN's home networks,
while the MN moves to  visited networks adminsterd by different entities.
The MAG/LMA pairs are not neccessarily aware of tunnelling preference
of each other.

When you say different domains, I suppose you mean administrative domains.
But from the PMIP6 protocol perspective the MAG and LMA are part of a single
PMIP6 domain. A MAG in a WiMAX network and the LMA in a 3GPP core still
logically belong to the same PMIP6 domain.
Frank=>Just my aformentioned explanation, WiMAX networks and 3GPP core
are probably adminstered by different entities.

I think you exaggerate the list here :)
Basically you have IP-in-IP or GRE. The rest are variants.
And given the requirement to secure the signaling via IPsec, the MAG/LMA
already support IPsec.
Frank=>Each variant is unique that special considerations are needed
when implementing them. You can categorize them into two:  IP-in-IP or GRE
for better understanding, while you still need treat variants differently.

-Raj