Subject: [netext] Consensus call to adopt ID: draft-premec-netlmm-bulk-re-registration-03.txt as WG doc

From: "Koodli, Rajeev" <[email-masked]>
Date: Thu, 15 Oct 2009 02:02:05 -0400

Hello,
 
One of the Netext WG items is:
 
Dec 2009	  	Submit Bulk Refresh to IESG for publication as a
Proposed Standard RFC 
 
At the last IETF meeting, there was agreement to use
draft-premec-netlmm-bulk-re-registration-02.txt as the baseline document
for the above item.
 
This document has been revised to version 03 in which the Group ID
proposal outlined in
http://tools.ietf.org/html/draft-gundavelli-netext-mn-groupid-option-01
has been merged based on author's agreement. 
 
This is a consensus call for adoption of
http://tools.ietf.org/html/draft-premec-netlmm-bulk-re-registration-03
as the WG document. 
 
Please respond by October 21.
 
Thanks,
 
-Rajeev

---

From: Qin Wu <[email-masked]>
Date: Thu, 15 Oct 2009 15:30:22 +0800

Hi, 
I think this I-D provide one efficient way for PMIP re-Registration and have already been well designed. 
I would like to support to adopt this I-D.

Regards!
-Qin 
  ----- Original Message ----- 
  From: Koodli, Rajeev 
  To: [email-masked] 
  Sent: Thursday, October 15, 2009 2:02 PM
  Subject: [netext] Consensus call to adopt ID:draft-premec-netlmm-bulk-re-registration-03.txt as WG doc

  Hello,

  Dec 2009  Submit Bulk Refresh to IESG for publication as a Proposed Standard RFC 

  At the last IETF meeting, there was agreement to use draft-premec-netlmm-bulk-re-registration-02.txt as the baseline document for the above item.

  This document has been revised to version 03 in which the Group ID proposal outlined in http://tools.ietf.org/html/draft-gundavelli-netext-mn-groupid-option-01 has been merged based on author's agreement. 

  This is a consensus call for adoption of http://tools.ietf.org/html/draft-premec-netlmm-bulk-re-registration-03 as the WG document. 

  Thanks,

  -Rajeev

------------------------------------------------------------------------------

  _______________________________________________
  netext mailing list
  [email-masked]
  https://www.ietf.org/mailman/listinfo/netext

---

From: Xiangsong Cui <[email-masked]>
Date: Mon, 19 Oct 2009 09:35:06 +0800

Hi,

I support the adoption of this draft as a WG document.

Regards
Xiangsong

----- Original Message ----- 
From: "Koodli, Rajeev" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, October 15, 2009 2:02 PM
Subject: [netext] Consensus call to adopt 
ID:draft-premec-netlmm-bulk-re-registration-03.txt as WG doc

Hello,

Thanks,

-Rajeev

--------------------------------------------------------------------------------

---

From: <[email-masked]>
Date: Wed, 21 Oct 2009 14:49:16 +0200

Hi,

As do I,

Best regards,

	Teemu 

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] 
>On Behalf Of ext Xiangsong Cui
>Sent: 19 October, 2009 04:35
>To: Koodli, Rajeev; [email-masked]
>Subject: Re: [netext] Consensus call to adopt 
>draft-premec-netlmm-bulk-re-registration-02.txt as the 
>baseline document for the above item.
>
>This document has been revised to version 03 in which the 
>Group ID proposal outlined in

---

From: jouni korhonen <[email-masked]>
Date: Wed, 21 Oct 2009 15:57:06 +0300

+1

Cheers,
	Jouni

On Oct 21, 2009, at 3:49 PM, <[email-masked]> <[email-masked] 
 > wrote:

---

From: <[email-masked]>
Date: Wed, 21 Oct 2009 17:03:31 +0200

Dear all,
I also support WG adoption of this document.
;-) 
BTW I detected some minor nits on
page 4: remove double 'sending a'
            remeinder -> remainder 
page 5: identifed -> identified
page 6: identifiy -> identify

Best regards, 
Dirk 

________________________________

Von: [email-masked] [mailto:[email-masked]] Im Auftrag
von Koodli, Rajeev
Gesendet: Donnerstag, 15. Oktober 2009 08:02
An: [email-masked]
Betreff: [netext] Consensus call to adopt
ID:draft-premec-netlmm-bulk-re-registration-03.txt as WG doc

Hello,

 

 
 
Thanks,
 
-Rajeev

---

From: "Mohana Jeyatharan" <[email-masked]>
Date: Thu, 22 Oct 2009 08:29:42 +0800

Hi all,

I support the adoption of this document as a WG document.

BR,
Mohana

________________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Koodli, Rajeev
Sent: Thursday, October 15, 2009 2:02 PM
To: [email-masked]
Subject: [netext] Consensus call to adopt ID:draft-premec-netlmm-bulk-re-registration-03.txt as WG doc

Hello,

 

 
 
Thanks,
 
-Rajeev

---

From: Qin Wu <[email-masked]>
Date: Mon, 26 Oct 2009 20:56:03 +0800

Hi,
May I have some comments on the draft-premec-netlmm-bulk-re-registration-03?
It seems to me the Bulk registration Flag (B) are applied in two different cases:
Case 1: The 'B' bit is used for requesting to extend lifetime for all MN that are part of bulk re-registration set.
Case 2: The 'B' bit is used for requesting the MN to be added/removed to the bulk re-registration set.

Suppose MAG requests to extend lifetime for a group of MNs and at the same time requests to
remove another individual MN1 to one bulk registration set, How does the MAG set the 'B' bit in the PBU?

Suppose MAG requests to bulk de-registration to LMA for a group of MNs by set 'B' to zero and at the same time requests to
add another individual MN to one bulk registration set, How does the MAG set the 'B' bit in the PBU?

Suppose MAG request to extend lifetime for one group of MNs and end lifetime for another group of MNs, how does
the MAG set the 'B' bit in the PBU?

Suppose MAG requests to extend lifetime for a group of MNs and at the same time requests to
add another individual MN to one bulk registration set by sending PBU to LMA, how does LMA distinguish 'B' bit used for two 
different cases?

If  one PBU is sent to LMA with 'B' bit set to zero and group ID set to zero, non-zero MN HNP option included, how does LMA distinguish this 
PBU as one message used for removing MN from one bulk re-registration set or one message used for normal PBU?

Therefore I am a little confused with the real purpose of 'B' bit in the PBU. Is it enough for defining only 'B' bit in the PBU?
Is it necessary to define one more bit to indicate whether bulk re-registration is supported if 'B' is only used for adding or removing MN from one
bulk re-registration set? or we constrain the solution scope into only some of scenarios?

What am I missing? Who would like to clarify this to me? 
Thanks a lot!

Regards!
-Qin

---

From: "Koodli, Rajeev" <[email-masked]>
Date: Thu, 29 Oct 2009 11:33:02 -0400

Hello,
 
based on the input received on the ML, the adoption of the ID as WG document is confirmed.
 
Authors: please submit a 00 version once the ID gate opens.
 
Regards,
 
-Rajeev

From: [email-masked] on behalf of Koodli, Rajeev
Sent: Wed 10/14/2009 11:02 PM
To: [email-masked]
Subject: [netext] Consensus call to adopt ID:draft-premec-netlmm-bulk-re-registration-03.txt as WG doc

Hello,

 

 
 
Thanks,
 
-Rajeev