Subject: [netext] FW: I-D Action:draft-jeyatharan-netext-pmip-bulkpbu-bitmap-00.txt

From: "Mohana Jeyatharan" <[email-masked]>
Date: Fri, 16 Oct 2009 09:13:19 +0800

Hi all,

This ID is highlighting a bulk PBU optimization approach using bit maps.

This approach can be used to send multiple PBU signals of any type in a
combined manner using bitmaps.  This approach can work along with the MN
group ID approach as well as highlighted in this draft.

Please see.

Comments are appreciated.
Thanks.

BR,
Mohana
-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Friday, October 16, 2009 9:00 AM
To: [email-masked]
Subject: I-D Action:draft-jeyatharan-netext-pmip-bulkpbu-bitmap-00.txt 

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title           : Bulk PBU using Bitmaps
	Author(s)       : M. Jeyatharan, C. Ng
	Filename        :
draft-jeyatharan-netext-pmip-bulkpbu-bitmap-00.txt
	Pages           : 8
	Date            : 2009-10-15

In Proxy Mobile Internet Protocol version 6 (PMIPv6), each mobile
node attached to a mobile access gateway (MAG) requires separate
signaling.  This might result in excessive network signaling if there
a large number of mobile nodes attached to a MAG.  In this draft we
outline a bulk PBU optimization approach based on bitmap, in order to
reduce the signaling load tied to numerous PBUs originating at the
same time.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-jeyatharan-netext-pmip-bulkpbu
-bitmap-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Qin Wu <[email-masked]>
Date: Mon, 26 Oct 2009 20:56:23 +0800

Hi, Mohana:
I read your I-D about bitmap based PBU and would like to have some comments as follows:
It seems to me the Bulk PBU using Bitmap is one robust header/packet compression mechanism.
in other words, Bulk PBU can be further compressed or optimized using Bitmap which saves 
not only signaling but also packet size comparing with Bulk re-registration mechanism described 
in draft-premec-netlmm-bulk-re-registration-03. 

But what I am still difficult to understand is in which situation or scenario the Bitmap based 
Bulk PBU will be utitlized instead of Bulk re-registration ? 

As you said in the I-D, The PBU originating from the MAG can be of different types 
such as initial registration PBU, handoff PBU, re-registration PBU and de-registration PBU.
 If the PBU originating from the MAG is initial registraion PBU, how can you guarantee that 
MAG initializing Bulk PBU can be attached by several Mobile nodes at the same time 
during initial registration for all these mobile nodes? Without attachment by several mobile 
nodes simutanesouly, how does the MAG construct bitmap base Bulk PBU packet? I think 
the same applies to handoff  PBU.

If the PUB originating from the MAG is re-registraion PBU, I am afraid that the most efficient 
or optimized way is to only carry Bulk Set ID or grouped ID in the re-registration PBU, the 
other mobility options is not necessary to be included, because LMA has already maintained 
binding for all these mobile nodes pertained to Bulk Set ID or grouped ID. In this scenario, 
if we still choose to use bitmap based PBU, more packet size will be costed for bitmap option included.
The same applies to de-registration PBU.

Therefore the only two pratical scenarios occuring to me instead of using Bulk re-registration are
a. Bitmap based Bulk PBU can be used when several MNs ask to be added into Bulk re-registration set.
b. MAG sending a Bitmap based bulk PBU containing several Bulk Set IDs created during the Bulk 
re-registration and several other Individual mobile nodes who would like to be added to one specific 
bulk re-registration set.
In these two scenarios, bitmap based PBU can be used to compress packet size of PBU that includes 
several MNs who ask to join several bulk re-registration sets by avoiding duplicate mobility options for different 
MNs.

Am I right?

Regards!
-Qin
----- Original Message ----- 
From: "Mohana Jeyatharan" <[email-masked]>
To: <[email-masked]>
Sent: Friday, October 16, 2009 9:13 AM
Subject: [netext] FW: I-DAction:draft-jeyatharan-netext-pmip-bulkpbu-bitmap-00.txt

Hi all,

Please see.

BR,
Mohana
-----Original Message-----

--------------------------------------------------------------------------------

> _______________________________________________
> netext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netext
>

---

From: "Mohana Jeyatharan" <[email-masked]>
Date: Tue, 27 Oct 2009 08:38:57 +0800

Hi Qin,

Thanks for your comments on this bitmap ID.

Please see replies below.

BR,
Mohana

> From: Qin Wu [mailto:[email-masked]]
> Sent: Monday, October 26, 2009 8:56 PM
> To: Mohana Jeyatharan; [email-masked]
> Subject: Comments on
> in draft-premec-netlmm-bulk-re-registration-03.

[Mohana] Yes, as you have mentioned the bitmap based approach is not
only reducing number of signals but also a mechanism to reduce packet
size.  The mechanism in draft premec-netlmm-bulk-re-registration is for
re-registration and de-registration of a group of MN's that belong to a
certain group identified by a group identifier.  However the bit map
approach is a general approach that can be used with or without the
group ID approach. Furthermore the bitmap approach is not restricted to
bulk re-registration or bulk de-registration scenarios.  It is more of
bulk PBU...  However I agree that for bulk re-registration of a group,
the ideal way is to use a group ID to refresh the bindings.

> Bulk PBU will be utilized instead of Bulk re-registration ?
> 
> such as initial registration PBU, handoff PBU, re-registration PBU and
de-
> registration PBU.
>  If the PBU originating from the MAG is initial registraion PBU, how
can
> you guarantee that
> MAG initializing Bulk PBU can be attached by several Mobile nodes at
the
> same time
> during initial registration for all these mobile nodes? 

[Mohana] Bulk attachments to a MAG can take place in many practical
scenarios.  For example many users performing initial attachment at the
same time.  A densely populated urban area or train station etc, we may
experience a bulk arrival of initial attachment messages.

Without attachment
> by several mobile
> nodes simutanesouly, how does the MAG construct bitmap base Bulk PBU
> packet? 

[Mohana] Yes, the MAG needs to check its state and identify such
multiple simultaneous registrations from numerous MNs and plan the PBU.
The MAG should construct the bulk PBU using bitmaps to compress the bulk
PBU.

I think
> the same applies to handoff  PBU.

[Mohana] The same for handoff. There can be cases where multiple MNs
attach to certain MAG due to handoff. This can happen in real cases.

 I agree to some extent that the 
> other mobility options is not necessary to be included, because LMA
has
> already maintained
> binding for all these mobile nodes pertained to Bulk Set ID or grouped
ID.
> In this scenario,

[Mohana] Well, I agree that for re-registration PBU, once all nodes have
joined a group, the group ID is ideal way.  Infact, in such cases we
have mentioned that in section 3, that if multiple group IDs are used
then probably the bit map option can be used in case there are multiple
re-registration taking place for these group IDs at the same time.  Here
the bitmap approach is highlighted as interworking with group ID
approach, which is ideal for re-registration PBus.

> The same applies to de-registration PBU.

[Mohana] For the de-registration case, if we are sure that all
deregistration can be tied to one group, then group ID based approach is
more of a neater way of doing it.  What if random movement from the
service area of MAG.  Then the MN deregistration pattern cannot be
grouped into a single group ID.  In such a case, the bitmap approach can
be used.
However I agree that as mentioned in draft-premec-bulk-registration, if
LMA uses blade architecture and all MNs are tied to groups, then
deregistration only needs the MN group identifier.  This is
deterministic grouping.  I think for random grouping bitmap way can be
used.

> Therefore the only two pratical scenarios occuring to me instead of
using
> Bulk re-registration are
> a. Bitmap based Bulk PBU can be used when several MNs ask to be added
into
> Bulk re-registration set.
> re-registration and several other Individual mobile nodes who would
like
> to be added to one specific
> In these two scenarios, bitmap based PBU can be used to compress
packet
> size of PBU that includes
> several MNs who ask to join several bulk re-registration sets by
avoiding
> duplicate mobility options for different
> MNs.
> 
> Am I right?

[Mohana] Yes, you are absolutely right.  Thanks for pointing out these
two scenarios. Another scenario is where there is a LMA failure and the
MAGs choose another LMA.  Another scenario is bulk deregistration of MNs
that do not belong to an MN group identifier as mentioned previously.
> implementation to automatically retrieve the ASCII version of the
------------------------------------------------------------------------
--
> ------