Subject: [netext] #7: Logical interface: UL/DL packet processing

From: "netext issue tracker" <[email-masked]>
Date: Thu, 03 Mar 2011 23:03:18 -0000

#7: Logical interface: UL/DL packet processing

 Uplink/downlink packet matching: Draft says the Logical interface should
 transmit uplink packets on the same physical interface on which the
 downlink packet was received for the particular prefix/flow. How does the
 logical interface associates an uplink packet to a downlink packet?

-- 
---------------------------------------+------------------------------------
 Reporter:  basavaraj.patil@…          |       Owner:  telemaco.melia@…                 
     Type:  defect                     |      Status:  new                              
 Priority:  major                      |   Milestone:                                   
Component:  Localized routing          |     Version:                                   
 Severity:  Active WG Document         |    Keywords:                                   
---------------------------------------+------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/netext/trac/ticket/7>
netext <http://tools.ietf.org/netext/>

---

From: "MELIA, TELEMACO (TELEMACO)" <[email-masked]>
Date: Tue, 15 Mar 2011 16:57:02 +0100

Folks, reflecting the discussions in the team here is the proposed text to solve this issue. Let us know any problem you see with the proposed text.

=====
6.6. Logical Interface Forwarding Conceptual Data Structures

   The LIF should maintain the LIF and FLOW table data structures
   depicted in Figure 4

     LIF TABLE                           FLOW table
   +===============================+   +===============================+
   | PIF_ID | FLOW RoutingPolicies |   | FLOW ID |  PIF_ID             |
   |        | Home Network Prefix  |   +-------------------------------+
   |        | Link Layer Address   |   | FLOW_ID |  PIF_ID             |
   |        | Status               |   +===============================+
   +-------------------------------|
   | PIF_ID | FLOW RoutingPolicies |
   |        | Home Network Prefix  |
   |        | Link Layer Address   |
   |        | Status               |
   +-------------------------------+
   | ....   | ....                 |
   +===============================+

                                 Figure 4

   The LIF table maintains the mapping between the LIF and each PIF
   associated to the LIF (see P3).  For each PIF entry the table should
   store the associated Routing Policies, the Home Network Prefix
   received during the SLAAC procedure, the configured Link Layer
   Address (as described above) and the Status of the PIF (e.g. active,
   not active).

   The method by which the Routing Policies are configured in the UE is
   out of scope of this document.  It is however assumed that this
   method is in place and that these policies are configured in the LIF
   TABLE.

   The FLOW table allows a LIF to properly route each IP flow to the
   right interface (see P7).  The LIF can identify flows arriving on its
   PIFs and can map them accordingly for transmitting the corresponding
   packets.  For locally generated traffic (e.g. unidirectional outgoing
   flows, mobile initiated traffic, etc.), the LIF should perform
   interface selection based on the Flow Routing Policies.  In case
   traffic of an existing flow is suddenly received from the network on
   a different PIF than the one locally stored, the LIF should interpret
   the event as an explicit flow mobility trigger from the network and
   it should update the PIF_ID parameter in the FLOW table.  Similarly,
   locally generated events from the PIFs or configuration updates to
   the local policy rules can cause updates to the table and hence
   trigger flow mobility.

-----Message d'origine-----
De : netext issue tracker [mailto:[email-masked]] 
Envoyé : vendredi 4 mars 2011 00:03
À : MELIA, TELEMACO (TELEMACO); [email-masked]
Cc : [email-masked]
Objet : [netext] #7: Logical interface: UL/DL packet processing

 Uplink/downlink packet matching: Draft says the Logical interface should  transmit uplink packets on the same physical interface on which the  downlink packet was received for the particular prefix/flow. How does the  logical interface associates an uplink packet to a downlink packet?

-- 
---------------------------------------+--------------------------------
---------------------------------------+----
 Reporter:  basavaraj.patil@.          |       Owner:  telemaco.melia@.                 
     Type:  defect                     |      Status:  new                              
 Priority:  major                      |   Milestone:                                   
Component:  Localized routing          |     Version:                                   
 Severity:  Active WG Document         |    Keywords:                                   
---------------------------------------+--------------------------------
---------------------------------------+----

---

From: <[email-masked]>
Date: Wed, 16 Mar 2011 08:34:18 +0100

Hi Tele,

What is the reason for the flow routing policies entry in the LIF table? IMHO, this entry is useless. I mean, routing policies should be node-scoped and only allow to select the interface, i.e configure the flow table; that's it. 

BTW, when a flow handover is performed, policies should also be updated (In order to select the correct interface for new flow). 

BR,
Pierrick

> De : [email-masked] [mailto:[email-masked]] De la part
> de MELIA, TELEMACO (TELEMACO)
> Envoyé : mardi 15 mars 2011 16:57
> À : netext issue tracker; [email-masked]
> Cc : [email-masked]
> Objet : Re: [netext] #7: Logical interface: UL/DL packet processing
> 
> Folks, reflecting the discussions in the team here is the proposed text to
> solve this issue. Let us know any problem you see with the proposed text.
> 
> =====
> _______________________________________________
> netext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netext

---

From: "MELIA, TELEMACO (TELEMACO)" <[email-masked]>
Date: Thu, 17 Mar 2011 14:20:09 +0100

Hell Pierrick, 

Agreed, the policies are node-scoped.
Would folks believe that a sending/updating algorithm would better clarify UL/DL packet handling?

telemaco 

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] 
Envoyé : mercredi 16 mars 2011 08:34
À : MELIA, TELEMACO (TELEMACO); [email-masked]; [email-masked]
Cc : [email-masked]
Objet : RE: [netext] #7: Logical interface: UL/DL packet processing

Hi Tele,

BR,
Pierrick

> De : [email-masked] [mailto:[email-masked]] De la 
> part de MELIA, TELEMACO (TELEMACO) Envoyé : mardi 15 mars 2011 16:57 À 
> : netext issue tracker; [email-masked] Cc : [email-masked] 
> Folks, reflecting the discussions in the team here is the proposed 
> text to solve this issue. Let us know any problem you see with the proposed text.
> 
> =====
> De : netext issue tracker 
> [mailto:[email-masked]]
> À : MELIA, TELEMACO (TELEMACO); [email-masked] Cc : 
> [email-masked] Objet : [netext] #7: Logical interface: UL/DL packet 
> processing
> 
>  Uplink/downlink packet matching: Draft says the Logical interface 
> should transmit uplink packets on the same physical interface on which 
> the downlink packet was received for the particular prefix/flow. How 
> does the logical interface associates an uplink packet to a downlink packet?
> 
> --
> ---------------------------------------+------------------------------
> ---------------------------------------+--
> ---------------------------------------+------------------------------
> ---------------------------------------+--

---

From: "MELIA, TELEMACO (TELEMACO)" <[email-masked]>
Date: Thu, 17 Mar 2011 14:20:09 +0100

Hell Pierrick, 

telemaco 

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] 
Envoyé : mercredi 16 mars 2011 08:34
À : MELIA, TELEMACO (TELEMACO); [email-masked]; [email-masked]
Cc : [email-masked]
Objet : RE: [netext] #7: Logical interface: UL/DL packet processing

Hi Tele,

BR,
Pierrick