Subject: [netext] I-D Action:draft-ietf-netext-logical-interface-support-02.txt

From: [email-masked]
Date: Mon, 14 Mar 2011 14:45:09 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network-Based Mobility Extensions Working Group of the IETF.

	Title           : Logical Interface Support for multi-mode IP Hosts
	Author(s)       : T. Melia, S. Gundavelli
	Filename        : draft-ietf-netext-logical-interface-support-02.txt
	Pages           : 26
	Date            : 2011-03-14

A Logical Interface is a software semantic internal to the host
operating system.  This semantic is available in all popular
operating systems and is used in various protocol implementations.
The Logical Interface support is required on the mobile node
operating in a Proxy Mobile IPv6 domain, for leveraging various
network-based mobility management features such as inter-technology
handoffs, multihoming and flow mobility support.  This document
explains the operational details of Logical Interface construct and
the specifics on how the link-layer implementations hide the physical
interfaces from the IP stack and from the network nodes on the
attached access networks.  Furthermore, this document identifies the
applicability of this approach to various link-layer technologies and
analyzes the issues around it when used in context with various
mobility management features.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-netext-logical-interface-support-02.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Julien Laganier <[email-masked]>
Date: Mon, 14 Mar 2011 15:58:55 -0700

I am surprised that this document was revised without any mailing
discussions of the changes that were carried on...

--julien

On Mon, Mar 14, 2011 at 2:45 PM,  <[email-masked]> wrote:
> _______________________________________________
> netext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netext
>
>

---

From: Sri Gundavelli <[email-masked]>
Date: Mon, 14 Mar 2011 16:08:35 -0800

Hi Julien:

We were hoping to post the text before, but we could not as we did not have
the text till late. Any ways, we can use it as a starting point text for the
discussions. We can update the text as needed. If you can please review and
comment that will be great.

Regards
Sri

---

From: Julien Laganier <[email-masked]>
Date: Mon, 14 Mar 2011 16:10:54 -0700

Hi Sri,

I think the new text fragments should be posted on this mailing list
and discussed first. If and when agreement is reached, then the text
fragments can be included in a revision of the draft. Otherwise I do
not see how the draft can reflect the WG consensus...

--julien

---

From: Sri Gundavelli <[email-masked]>
Date: Mon, 14 Mar 2011 17:19:02 -0800

Hi Julien,

We are not at a last call, still getting the draft to a shape to enable
serious reviews, you can challenge any sections of the draft. As we move
forward, I agree, we should be careful to post the text before. We have
posted the text for each of the issues separately, lets start with them.

Regards
Sri

On 3/14/11 3:10 PM, "Julien Laganier" <[email-masked]> wrote:

>>>> http://www.ietf.org/internet-drafts/draft-ietf-netext-logical-interface-sup
>>>> po
>>>> rt-02.txt
>>>>

---

From: "MELIA, TELEMACO (TELEMACO)" <[email-masked]>
Date: Tue, 15 Mar 2011 10:54:48 +0100

Julien, 

As Sri commented below this is the basis we would like to use for discussions. We submitted a revised version to keep track of the changes.

telemaco 

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Sri Gundavelli
Envoyé : mardi 15 mars 2011 01:09
À : Julien Laganier; [email-masked]
Objet : Re: [netext] I-D Action:draft-ietf-netext-logical-interface-support-02.txt

Hi Julien:

We were hoping to post the text before, but we could not as we did not have the text till late. Any ways, we can use it as a starting point text for the discussions. We can update the text as needed. If you can please review and comment that will be great.

Regards
Sri

On 3/14/11 2:58 PM, "Julien Laganier" <[email-masked]> wrote:

>>        Filename        : 
>> draft-ietf-netext-logical-interface-support-02.txt
>>        Pages           : 26
>>        Date            : 2011-03-14
>> 
>> http://www.ietf.org/internet-drafts/draft-ietf-netext-logical-interfa
>> ce-suppo
>> rt-02.txt
>>

---

From: Julien Laganier <[email-masked]>
Date: Tue, 15 Mar 2011 09:11:55 -0700

And as I commented, we should discuss first and put it in the draft
next. Otherwise when I look at the draft I have no idea what we have
an agreement upon and what we have not. Do you disagree with this?

--julien

---

From: "MELIA, TELEMACO (TELEMACO)" <[email-masked]>
Date: Wed, 16 Mar 2011 15:24:16 +0100

No disagreement Julien. Can we assume -02 version is the starting point?
>From now on only agreed text will be added to the ID.
This is fine?

telemaco

-----Message d'origine-----
De : Julien Laganier [mailto:[email-masked]] 
Envoyé : mardi 15 mars 2011 17:12
À : MELIA, TELEMACO (TELEMACO)
Cc : Sri Gundavelli; [email-masked]
Objet : Re: [netext] I-D Action:draft-ietf-netext-logical-interface-support-02.txt

And as I commented, we should discuss first and put it in the draft next. Otherwise when I look at the draft I have no idea what we have an agreement upon and what we have not. Do you disagree with this?

--julien

On Tue, Mar 15, 2011 at 2:54 AM, MELIA, TELEMACO (TELEMACO) <[email-masked]> wrote:
> De : [email-masked] [mailto:[email-masked]] De la 
> part de Sri Gundavelli Envoyé : mardi 15 mars 2011 01:09 À : Julien 
> Laganier; [email-masked] Objet : Re: [netext] I-D 
> Action:draft-ietf-netext-logical-interface-support-02.txt
>
> Hi Julien:
>
>>> the specifics on how the link-layer implementations hide the 
>>> physical interfaces from the IP stack and from the network nodes on 
>>> the attached access networks.  Furthermore, this document identifies 
>>> the applicability of this approach to various link-layer 
>>> technologies and analyzes the issues around it when used in context 
>>> with various mobility management features.
>>>