Subject: Re: [netext] how to do ptp links on wifi without modifying the MN?

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Fri, 01 Apr 2011 10:13:12 +0200

Hi Alex,

On Thu, 2011-03-31 at 21:20 +0200, Alexandru Petrescu wrote:
> Hi Carlos,
> 
> In a sense yes.
> 
> If MAG wants to send a unicast RA to a MN, it must first learn the 
> link-local address of that MN somehow, in order to send that RA to that 
> ll address.
> 
> Is this what you mean?

Yes, either send the RA unicast to the IPv6 ll addr (the MAG can get
that info from an RS, if sent by the MN) or multicast the RA at IPv6,
but sent it unicast to the L2 addr of the MN (the MAG can get the L2
address from multiple ways, e.g., L2 triggers).

Carlos

> 
> Alex
> 
> Le 31/03/2011 18:29, Carlos Jesús Bernardos Cano a écrit :
> > Hi Alex,
> >
> > Isn't it enough to ensure that the RAs sent by the MAG are just unicast
> > to the MN (at L2 or L3) to "emulate" a ptp link, with regard of 5213
> > operation?
> >
> > I use this and works perfectly well.
> >
> > Carlos
> >
> > On Thu, 2011-03-31 at 16:41 +0200, Alexandru Petrescu wrote:
> >> Thanks... can I make a ptp link on MN without running pppoeconf on MN?
> >> (e.g. run pppoeconf only on some MAG or some switch, but not on MN)
> >>
> >> I am asking because I believe it is not possible to not use pppoeconf on
> >> MN if one wants ptp links on it.  I.e. pppoeconf MAY be the only
> >> solution to make pmipv6 work with wifi MN.
> >>
> >> Do you think different?
> >>
> >> Alex
> >>
> >>
> >> Le 31/03/2011 16:07, Kaibo Zhou a écrit :
> >>> I use pppoeconf in Ubuntu, so I guess it should be able to run on
> >>> some kind of MN.
> >>>
> >>> BR/Zhou
> >>>
> >>> On 03/31/2011 08:43 PM, Alexandru Petrescu wrote:
> >>>> thanks... does pppoeconf run on the mn?
> >>>>
> >>>> Alex
> >>>>
> >>>> Le 31/03/2011 14:27, Kaibo Zhou a écrit :
> >>>>> I once tried to set up a PPP connection on the WLAN using
> >>>>> pppoeconf, and it works well.
> >>>>>
> >>>>>
> >>>>> On 03/31/2011 08:11 PM, Alexandru Petrescu wrote:
> >>>>>> Hi netext,
> >>>>>>
> >>>>>> How to do ptp links on a wifi access?
> >>>>>>
> >>>>>> I am asking because I think there is no method. Or otherwise
> >>>>>> they require modifs on the MN - right?
> >>>>>>
> >>>>>>
> >>>>>> Alex _______________________________________________ netext
> >>>>>> mailing list [email-masked]
> >>>>>> https://www.ietf.org/mailman/listinfo/netext
> >>>>>>
> >>>>>>
> >>>>>
> >>>>
> >>>>
> >>>>
> >>>
> >>
> >> _______________________________________________
> >> netext mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/netext
> >
> 

-- 
Carlos Jesús Bernardos Cano     http://www.netcoms.net
GPG FP: D29B 0A6A 639A A561 93CA  4D55 35DC BA4D D170 4F67

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 01 Apr 2011 11:38:05 +0200

Le 01/04/2011 10:13, Carlos Jesús Bernardos Cano a écrit :
>>  link-local address of that MN somehow, in order to send that RA
>> to that ll address.
>>
>> Is this what you mean?
>
>  that info from an RS, if sent by the MN)

Sounds feasible.  I think we should say so if we do so.  If not, there
may be issues.

1 - first packets sent by MN are not RS, but NA and maybe MLD.  If my
MAG takes these instead of RS then there's no interop.

2 - how does MAG know the RS comes from a Host and not a neighbouring
router, I am not sure.

Is this modifications to rfc4861 ND?

> or multicast the RA at IPv6, but sent it unicast to the L2 addr of
> the MN (the MAG can get the L2 address from multiple ways, e.g., L2
> triggers).

Yes, also Sri just pointed me to a certain rfc60xx which seems to do a
mapping:

   IPmulticast address - link-layer unicast address.

The effect of this would be that the RA is actually received by that
single Host (even though the IP dst address says "all" hosts).

This may indeed work in practice because some if not most IPv6 stacks
wouldn't check the correlation IPmcast-llmcast upon reception.  Unless
some do.

I also wonder whether this new rfc60xx mapping breaks anything
specification-wise, i.e. the IPv6 addressing architecture rfc.  I have
to check.

Also, these RA-based mechanisms would be ok with SLAAC, but nothing is
said about dhcp, which should be made to work as well.

Alex
ps: yes, the 2 main problems to be solved by netext now is flow mobility
and logical interface discussion; this pmip/wifi discussion is annex.

>>> Isn't it enough to ensure that the RAs sent by the MAG are just
>>> unicast to the MN (at L2 or L3) to "emulate" a ptp link, with
>>> regard of 5213 operation?
>>>
>>>> Thanks... can I make a ptp link on MN without running
>>>> pppoeconf on MN? (e.g. run pppoeconf only on some MAG or some
>>>> switch, but not on MN)
>>>>
>>>> I am asking because I believe it is not possible to not use
>>>> pppoeconf on MN if one wants ptp links on it.  I.e. pppoeconf
>>>> MAY be the only solution to make pmipv6 work with wifi MN.
>>>>
>>>> Do you think different?
>>>>
>>>> Alex
>>>>
>>>>
>>>>> I use pppoeconf in Ubuntu, so I guess it should be able to
>>>>> run on some kind of MN.
>>>>>
>>>>> BR/Zhou
>>>>>
>>>>>>>> I am asking because I think there is no method. Or
>>>>>>>> otherwise they require modifs on the MN - right?
>>>>>>>>
>>>>>>>>
>>>>>>>> Alex _______________________________________________
>>>>>>>> netext mailing list [email-masked]
>>>> _______________________________________________ netext mailing
>>>> list [email-masked]

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 1 Apr 2011 04:41:23 -0700 (PDT)

> specification-wise, i.e. the IPv6 addressing architecture rfc.   I have

6085 Address Mapping of IPv6 Multicast Packets on Ethernet.

It is a pity that you missed this.  I think it was done in 6man but I don't see 
it on 6man tools page.

Sri?

---

From: Julien Laganier <[email-masked]>
Date: Mon, 4 Apr 2011 04:20:01 -0700

Carlos, all,

Can everybody please stop to say that they "emulate" point-to-point
links with unicast RAs...

I know what it is to emulate but I do not know what it is to
"emulate". What is for sure is that a point-to-point link is defined
in RFC 4861 as:

   point-to-point - a link that connects exactly two interfaces.  A
                    point-to-point link is assumed to have multicast
                    capability and a link-local address.

Thus unless someone can show me how sending unicast RAs constrains a
link to connect exactly two interfaces, please refrain from equating
the two.

--julien

---

From: Julien Laganier <[email-masked]>
Date: Mon, 4 Apr 2011 04:23:04 -0700

Alex:

As I explained to you during the MEXT session, an 802.11 AP can decide
to have every MN on a different point to point link without any MN
impact, that is internal to the layer 2 on the AP and out-of-scope of
the netext work. I have done it in a lab and I can explain to you
offlist if you want more details.

Thank you.

--julien

On Thu, Mar 31, 2011 at 5:11 AM, Alexandru Petrescu
<[email-masked]> wrote:
> I am asking because I think there is no method.  Or otherwise they
> require modifs on the MN - right?
>
>
> Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 04 Apr 2011 14:31:08 +0200

Le 04/04/2011 13:23, Julien Laganier a écrit :
> Alex:
>
> As I explained to you during the MEXT session, an 802.11 AP can
> decide to have every MN on a different point to point link without
> any MN impact, that is internal to the layer 2 on the AP and
> out-of-scope of the netext work. I have done it in a lab and I can
> explain to you offlist if you want more details.

YEs please explain that to me offlist because I would like to learn
which commands, software, etc. and I have doubts about its scalability,
and about how AP talks to MAG to set that thing up (a new protocol?)

Also, it could be possible to have a different solution about how MAG
sends an IP-unicasted RA to the MN, without using special 802.11
AP support.

Alex

>> Alex _______________________________________________ netext mailing
>> list [email-masked] https://www.ietf.org/mailman/listinfo/netext
>>
>

---

From: <[email-masked]>
Date: Mon, 4 Apr 2011 16:08:41 +0000

Thanks for taking this discussion offline. This discussion is not helping
the WG move forward on its deliverables.

With chair hat on: Raj

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 19 Apr 2011 11:20:30 -0700 (PDT)

Hi Raj,

  Can you please tell us what the chair thinks on PMIPv6 operation on Wi-Fi? We 
can take that as the authoritative answer and move on. 

Otherwise there are statements that have been made on the list saying that 
PMIPv6 would not work on Wi-Fi that would stand.

  OTOH, deployment of MIPv6 on Wi-Fi links has been explored and we have 
documents like RFC 4260.

Regards,

Behcet