Subject: Re: [netext] My comments on draft-ietf-netext-pmip-lr-01

From: Suresh Krishnan <[email-masked]>
Date: Thu, 12 May 2011 17:14:22 -0400

Hi Xiangsong,
   Thanks for your comments. Please find responses inline.

Xiangsong Cui wrote:
 > Hi,
 >
 > I have reviewed this draft, and I have two comments.
 >
 > First, in the case of A11 scenario,
 >
 > It reads "It is also possible that
 >    one of the mobility entities (LMA or MAG) could decide to initiate
 >    localized routing based on configured policy."
 >
 > But based on the statement of section 2, ONLY LMA can initiate the LR
 > function in this case,

Right. But, the base PMIPv6 spec [RFC5213] allows the MAG to be 
configured to initiate localized routing using the EnableMAGLocalRouting 
(static) configuration variable. I have added the following text to 
clarify this

"Please note that a MAG implementing the protocol specified in this 
specification will not dynamically initiate LR in the same LMA case 
(i.e. by sending an LRI), but can statically initiate LR based on the 
EnableMAGLocalRouting configuration variable specified in [RFC5213]."

Does that work for you?

 > So I'm not sure, does this mean MAG may transmit a U-LRA to trigger 
the LMA
 > to initiate the LR function?
 >
 >
 >
 > My Second comment is about the statement of section 4,
 >
 >    "The MAG may refresh the lifetime of an existing local forwarding
 >    service.  For this, it sends an unsolicited LRA (U-LRA) message that
 >    contains the new lifetime value.  The MAG MUST wait for the following
 >    LRI message from the LMA before it can conclude that the refresh
 >    request is granted."
 >
 > I think this is not very clear, what would happen in the LMA if the MAG
 > doesn't transmit the U-LRA message?
 > Does this mean the LMA MUST respond a LRI message to the MAG and the MAG
 > further transmits an acknowledge LRA?
 > If the MAG doesn't receive the following LRI, what would happen? Is there
 > any retransmission?
 > And, does the MAG transmit refreshment PBU to the LMA after it 
transmits the
 > U-LRA?

I think the U-LRA is causing too much confusion and it not very useful. 
It probably makes sense to remove this from the spec.

Thanks
Suresh

---

From: Xiangsong Cui <[email-masked]>
Date: Fri, 13 May 2011 09:18:53 +0800

Hi Suresh,

> -----Original Message-----
> From: Suresh Krishnan [mailto:[email-masked]]
> Sent: Friday, May 13, 2011 5:14 AM
> To: Xiangsong Cui
> Cc: [email-masked]
> Subject: Re: [netext] My comments on draft-ietf-netext-pmip-lr-01
> 
> Hi Xiangsong,

Yes, I think this description is very good.

> It probably makes sense to remove this from the spec.

Yes, if the MAG would send PBU for the MNs, I think we don't need a separate
U-LRA signaling to refresh the LR lifetime.

Thanks,
Xiangsong