Subject: Re: [netext] Seeking consensus on way forward with WG I-D: draft-ietf-netext-redirect

From: Sri Gundavelli <[email-masked]>
Date: Thu, 02 Jun 2011 09:47:39 -0700

Hi Raj,

Thanks for the options.
I¹d prefer option #3, i.e.rRetain the approach, but make it non-normative by
moving it to Appendix Section. I¹m fine with section #2 as well.

Regards
Sri

On 5/31/11 7:06 AM, "[email-masked]" <[email-masked]>
wrote:

> Hello,
>  
> The WG has been notified about the following IPR claim on the I-D:
> draft-ietf-netext-redirect-07.txt
> Please see: 
> http://www.ietf.org/mail-archive/web/netext/current/msg01982.html
>  
> The I-D which had been forwarded to the IESG for approval has now been
> sent back to the WG. We would like to solicit feedback from the WG
> members (and authors) about the way forward.
> There are several possibilities as listed below (but not limited to):
>  
> 1. The concern with the IPR is noted but no change to the current I-D
>    is made (e.g., if the license is free and available for everyone
>    
> 2. Since the IPR basically covers the solution documented in Section
>    5.4 removing the whole section could be an option
>  
> 3. Move Section 5.4 to an appendix and make it non-normative
>  
> 4. Others?
>  
> Please provide your input to this discussion by June 15th, 2011. We
> will move forward based on the consensus opinion.
>  
> -Chairs
> 
> 
> _______________________________________________
> netext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netext

---

From: jouni korhonen <[email-masked]>
Date: Tue, 14 Jun 2011 08:24:05 +0300

Hi,

In my opinion (as the editor of the I-D) #3 involves at least the same amount of document writing/editing effort as #2, but still having two solutions approaches documented in the I-D. Therefore, considering the work that still has to be put into the I-D, #2 makes most sense (it would actually make the I-D shorter, cleaner, remove some IESG concerns and simplify the protocol).

Considering we have dragged solution described in Section 5.4 along so far, #1 or #3 could be the most favorable ways forward. However, #3 in practice has the same effect as #2 from the implementation point of view (have you ever seen optional stuff being implemented without a really good business reason.. even MUSTs that are not mission critical tend to be left unimplemented..). Thus, as said earlier, #2 would make most sense if we go other options than #1.

- Jouni

---

From: Rajeev Koodli <[email-masked]>
Date: Thu, 23 Jun 2011 17:20:49 -0700

Hello,

We have got some input. Based on that, we think we have consensus to go with
Option 2 below.
Authors, please revise the ID and submit.
Thanks.

-Rajeev (for chairs)