Subject: [netext] Consensus call: Work on specifying prefix delegation for Proxy Mobile IPv6?

From: <[email-masked]>
Date: Wed, 10 Aug 2011 21:34:29 +0000

At IETF81, Carl Williams presented the I-D: "Prefix Delegation for
Proxy Mobile IPv6" <draft-zhou-netext-pd-pmip-01.txt>

General consensus at the Netext WG meeting was that prefix delegation
is a required feature for PMIP6. We gauged the interest in the room to
adopt this I-D as the starting point of a WG I-D for the PD feature
and observed the following:

"
Chairs: how many people think the problem is relevant: 19
How many have read it: 7
How many think that the proposed solution in the draft can be starting
point to work on the problem?
In favor: 7 ;  Opposed: 1
"

We are now following up with the questions on the ML.

Question to WG: 

1. Should the WG specify prefix-delegation support for PMIP6?

Yes   [ ]
No    [ ]

2. Can we adopt as WG document the solution proposed in I-D:
draft-zhou-netext-pd-pmip-01.txt as the starting point of this
feature?

Yes   [ ]
No    [ ]

Please respond by August 18th on the ML.

-Chairs

Please see the discussion at the IETF81 WG meeting on this topic at:
http://www.ietf.org/proceedings/81/minutes/netext.txt

---

From: Jouni <[email-masked]>
Date: Thu, 11 Aug 2011 01:10:02 +0300

On Aug 11, 2011, at 12:34 AM, <[email-masked]> <[email-masked]> wrote:
> Yes   [x]
> Yes   [x]

- Jouni

---

From: Sri Gundavelli <[email-masked]>
Date: Wed, 10 Aug 2011 15:46:54 -0700

1. YES
2. YES

On 8/10/11 2:34 PM, "[email-masked]" <[email-masked]>
wrote:

> Yes   [X]
> Yes   [X]
> _______________________________________________
> netext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netext

---

From: [email-masked]
Date: Thu, 11 Aug 2011 10:33:54 +0800

Question to WG: 

Yes   [X ]
No    [ ]

Yes   [X ]
No    [ ]

<[email-masked]> 
发件人:  [email-masked]
2011-08-11 上午 05:34

收件人
<[email-masked]>
抄送

主题
[netext] Consensus call: Work on specifying prefix delegation for Proxy 
Mobile IPv6?

"

Question to WG: 

Yes   [ ]
No    [ ]

Yes   [ ]
No    [ ]

-Chairs

---

From: [email-masked]
Date: Thu, 11 Aug 2011 16:32:52 +0800

Q1. Yes
Q2. Yes

Best Regards,
Chunhui

2011-08-11 05:34

收件人
<[email-masked]>
抄送

主题

"

Question to WG: 

Yes   [ ]
No    [ ]

Yes   [ ]
No    [ ]

-Chairs

---

From: <[email-masked]>
Date: Thu, 11 Aug 2011 14:08:06 +0200

Q1: Yes
Q2: Yes
Comment: please provide more details on the use case in WG I-D, e.g. the phrase
'It assumes that a MR [i.e. Mobile Router] is a regular IPv6 router without extension for mobility managements.' sounds a bit strange to me ...

Thanks!

Regards
Dirk

[netext] Consensus call: Work on specifying prefix delegation for Proxy Mobile IPv6?

"

Question to WG:

Yes   [ ]
No    [ ]

Yes   [ ]
No    [ ]

-Chairs

---

From: Jong-Hyouk Lee <[email-masked]>
Date: Thu, 11 Aug 2011 15:50:19 +0200

Q1: Yes.
Q2: Yes.

Comments: As pointed, the use cases should be provided and personally I
would like to introduce the following articles recently published:

1. Lightweight NEtwork MObility within PMIPv6 for Transportation Systems",
IEEE Systems Journal: http://dx.doi.org/10.1109/JSYST.2011.2158681
2. Performance Analysis of PMIPv6 based NEtwork MObility for Intelligent
Transportation Systems", IEEE Transactions on Vehicular Technology:
http://dx.doi.org/10.1109/TVT.2011.2157949

Cheers.

On Thu, Aug 11, 2011 at 2:08 PM, <[email-masked]> wrote:

> 'It assumes that a MR [i.e. Mobile Router] is a regular IPv6 router without
> extension for mobility managements.' sounds a bit strange to me ...
>
> Thanks!
>
> Regards
> Dirk
>
>

-- 
IMARA Team, INRIA, France.
Jong-Hyouk Lee, living somewhere between /dev/null and /dev/random.

#email: hurryon (at) gmail (dot) com || jong-hyouk.lee (at) inria (dot) fr
#webpage: https://sites.google.com/site/hurryon/

---

From: Hidetoshi Yokota <[email-masked]>
Date: Fri, 12 Aug 2011 07:56:51 +0900

Hi Raj,

> draft-zhou-netext-pd-pmip-01.txt as the starting point of this

Regards,
-- 
Hidetoshi

(2011/08/11 6:34), [email-masked] wrote:
> Proxy Mobile IPv6"<draft-zhou-netext-pd-pmip-01.txt>
>

---

From: [email-masked]
Date: Tue, 16 Aug 2011 20:22:04 +0800

Hello Lee,
Many thanks for your support. I will read the reference materials you 
provide. Regarding the comment, I will details the use case in the future 
version.

Best Regards,
Joy

Jong-Hyouk Lee <[email-masked]> 
2011-08-11 下午 09:50

收件人
[email-masked]
抄送
[email-masked], [email-masked], [email-masked]
主题
Re: [netext] Consensus call: Work on specifying prefix delegation for 
Proxy Mobile IPv6?

Q1: Yes.
Q2: Yes.

Cheers.

On Thu, Aug 11, 2011 at 2:08 PM, <[email-masked]> wrote:
Q1: Yes
Q2: Yes
Comment: please provide more details on the use case in WG I-D, e.g. the 
phrase
'It assumes that a MR [i.e. Mobile Router] is a regular IPv6 router 
without extension for mobility managements.' sounds a bit strange to me 
...

Thanks!

Regards
Dirk

"

Question to WG:

Yes   [ ]
No    [ ]

Yes   [ ]
No    [ ]

-Chairs

---

From: Jong-Hyouk Lee <[email-masked]>
Date: Wed, 17 Aug 2011 13:32:42 +0200

Good; Since a prefix delegation for PMIPv6 is an item I'm also considering
to work, let me know if you need any support.

Cheers.

2011/8/16 <[email-masked]>

>  *Jong-Hyouk Lee <[email-masked]>*
>
> 2011-08-11 下午 09:50
>   收件人
> [email-masked]
> 抄送
> Re: [netext] Consensus call: Work on specifying prefix delegation for Proxy
> Mobile IPv6?
>
>
>
>
> Q1: Yes.
> Q2: Yes.
>
> IEEE Systems Journal: *http://dx.doi.org/10.1109/JSYST.2011.2158681*<http://dx.doi.org/10.1109/JSYST.2011.2158681>
> Transportation Systems", IEEE Transactions on Vehicular Technology: *
> http://dx.doi.org/10.1109/TVT.2011.2157949*<http://dx.doi.org/10.1109/TVT.2011.2157949>
>
> Cheers.
>
> On Thu, Aug 11, 2011 at 2:08 PM, <[email-masked]*<[email-masked]>>
> wrote:
> Q1: Yes
> Q2: Yes
> Please see the discussion at the IETF81 WG meeting on this topic at:*
> **http://www.ietf.org/proceedings/81/minutes/netext.txt*<http://www.ietf.org/proceedings/81/minutes/netext.txt>
>
>
> netext mailing list*
> [email-masked]* <[email-masked]>*
> **https://www.ietf.org/mailman/listinfo/netext*<https://www.ietf.org/mailman/listinfo/netext>
> netext mailing list*
> [email-masked]* <[email-masked]>*
> **https://www.ietf.org/mailman/listinfo/netext*<https://www.ietf.org/mailman/listinfo/netext>
>
>
>
> --
> #webpage: *https://sites.google.com/site/hurryon/*<https://sites.google.com/site/hurryon/>
>

---

From: liu dapeng <[email-masked]>
Date: Thu, 18 Aug 2011 16:07:28 +0800

1. YES
2. YES

Best Regards,
Dapeng Liu

-- 

------
Best Regards,
Dapeng Liu

---

From: Hui Deng <[email-masked]>
Date: Thu, 18 Aug 2011 22:59:03 +0800

Yes  Yes

-Hui

2011/8/18 liu dapeng <[email-masked]>

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 18 Aug 2011 17:50:33 +0200

Hello Raj,

Le 10/08/2011 23:34, [email-masked] a écrit :
> is a required feature for PMIP6.

Please specify whether this prefix delegation feature is for the goal of 
supporting Network Mobility with PMIP?

Or is it to assign the HNP to the Mobile Host (not necessarily to assign 
MNP for NEMO Mobile Router)?  The two goals are distinctive IMHO.

This to help formulate a problem for prefix delegation for PMIP.

[...]
> 1. Should the WG specify prefix-delegation support for PMIP6?

Yes, if it is for MNP for Mobile Router.

> draft-zhou-netext-pd-pmip-01.txt as the starting point of this

No, unless the problem is clearer.

I hope this helps.

Alex

---

From: Sri Gundavelli <[email-masked]>
Date: Thu, 18 Aug 2011 09:14:41 -0700

Alex:

If I may comment.

#1 Implies, mobility for the delegated prefixes

Assigning HNP to mobile = mobility + delegated prefix (Same as #1)

#2 Assigning MNP to NEMO Mobile Router = RFC3963. NEMO MR per definition is
CMIP enabled.

So, the draft is supporting #1.

Sri

---

From: Sri Gundavelli <[email-masked]>
Date: Thu, 18 Aug 2011 09:56:11 -0700

> #2 Assigning MNP to NEMO Mobile Router = RFC3963. NEMO MR per definition is

To ensure the terminology is right:

Delegated Prefix - Prefixes hosted by the mobile node, or the network
elements behind the mobile node

Hosted Prefixes - prefixes hosted by the PMIPv6 mobility elements on the
MN-AR access link. These are not delegated prefixes. An IP host behind the
mobile node cannot use this prefix to generate an address, it wont receive
RA's with these PIO's.

HNP typically implied prefixes delivered on PMIPv6 signaling plane. If DHCP
PD is used by MN or a node behind for obtaining prefixes, those are simple
IP prefixes. However, if mobility is provided to those prefixes, in the form
of this draft, we can group them as HNP's, as mobility is provided and those
prefixes are anchored on the LMA, from routing perspective.

MN/MR Distinction is clear I assume. But, NEMO MR, I may have implied, as
mobile router with CMIP functionality in my prev mail. But, probably NEMO is
a generic term. Any case, the distinction is understood, with or without
CMIP ...

Sri

---

From: Jong-Hyouk Lee <[email-masked]>
Date: Thu, 18 Aug 2011 23:00:12 +0200

Hi, Sri.

Thanks for sharing your opinions. I would like to also hear a reply from
Joy. Joy, could you clearly state your views on the question from Alex?

Cheers.

---

From: <[email-masked]>
Date: Thu, 18 Aug 2011 21:03:03 +0000

Alex,

Does Sri's comment address your question?

-Raj

---

From: Jouni <[email-masked]>
Date: Fri, 19 Aug 2011 00:52:36 +0300

It is about providing mobility for delegated prefixes.

- Jouni (as a co-author)

On Aug 19, 2011, at 12:00 AM, Jong-Hyouk Lee wrote:

> Hi, Sri.
> 
> Thanks for sharing your opinions. I would like to also hear a reply from Joy. Joy, could you clearly state your views on the question from Alex?
> 
> Cheers.
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 19 Aug 2011 15:35:49 +0200

> #1 Implies, mobility for the delegated prefixes

Hm.  I thought it was only for initial assignment of prefixes (DHCP),
not for mobility (PBU). I.e. assign prefix(es) upon initial attachment,
with DHCP, and then do PBU to support mobility.

> Assigning HNP to mobile = mobility + delegated prefix (Same as #1)

I am not sure.  Initial assignment is different than PBU upon each
movement.  And the PMIP spec has a need (IIRC) to assign that HNP somehow.

> #2 Assigning MNP to NEMO Mobile Router = RFC3963. NEMO MR per
> definition is CMIP enabled.

Yes, NEMO MR by definition is CMIP enabled (and CMIP/NEMO does not
assign MNP to MR).

I meant to say that PMIP may need, in some cases only, to assign an HNP
for MR (HoA) _and_ an MNP for the LFNs behind MR.  In some cases these
two prefixes are different.

> So, the draft is supporting #1.

Does the draft imply that the same delegated prefix is used to form
addresses for LFNs _and_ to form the HoA of MR?

Alex

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 19 Aug 2011 15:43:49 +0200

Le 18/08/2011 18:56, Sri Gundavelli a écrit :
> elements behind the mobile node.

Ok.  Sounds as the MNP to me ("Mobile Network Prefix"), sent by MR in RA
on its ingress interface, and used by LFN to form address.  Or maybe
stored by MR in its dhcpd.conf, runs as DHCP Server, and LFN as Client.

> Hosted Prefixes - prefixes hosted by the PMIPv6 mobility elements on
> the MN-AR access link. These are not delegated prefixes. An IP host
> behind the mobile node cannot use this prefix to generate an
> address, it wont receive RA's with these PIO's.

Hosted Prefix sounds as the HNP to me ("Home Network Prefix", or so,
typical of PMIP).

> HNP typically implied prefixes delivered on PMIPv6 signaling plane.

Yes, except that PMIP does not specify how that HNP is assigned, and it
could be done with DHCP.  For example, LMA could do DHCP-PD to obtain
that HNP, and put that HNP in the PBU/PBA; but still use that DHCP-PD to
obtain the prefix.  I believe currently the PMIP may need something like
this.

> If DHCP PD is used by MN or a node behind for obtaining prefixes,
> those are simple IP prefixes. However, if mobility is provided to
> those prefixes, in the form of this draft, we can group them as
> HNP's, as mobility is provided and those prefixes are anchored on
> the LMA, from routing perspective.

YEs, it could be so.  But I am not sure the best way is to anchor all
prefixes at LMA.  We could give freedom to have some prefixes "anchored"
at another entity than the LMA, maybe the DHCP Server, or maybe not even
the DHCP Server but some Gateway.

> MN/MR Distinction is clear I assume. But, NEMO MR, I may have
> implied, as mobile router with CMIP functionality in my prev mail.
> But, probably NEMO is a generic term. Any case, the distinction is
> understood, with or without CMIP ...

Yes, NEMO is a too generic term, I confuse it some times too.  But sure
CMIP/NEMO does not assign prefixes.  (there is recently a different RFC
doing DHCP-PD for NEMO, but this PD is not in the base spec NEMO RFC).

Alex

>
> Sri
>
>
>
>
>
>
>
> On 8/18/11 9:14 AM, "Sri Gundavelli"<[email-masked]>  wrote:
>
>> Alex:
>>
>> If I may comment.
>>
>>
>> On 8/18/11 8:50 AM, "Alexandru
>> Petrescu"<[email-masked]> wrote:
>>
>>> Hello Raj,
>>>
>>>> At IETF81, Carl Williams presented the I-D: "Prefix Delegation
>>>> for Proxy Mobile IPv6"<draft-zhou-netext-pd-pmip-01.txt>
>>>>
>>>> General consensus at the Netext WG meeting was that prefix
>>>> delegation is a required feature for PMIP6.
>>>
>>> Please specify whether this prefix delegation feature is for the
>>> goal of supporting Network Mobility with PMIP?
>>>
>>> Or is it to assign the HNP to the Mobile Host (not necessarily
>>> to assign MNP for NEMO Mobile Router)?  The two goals are
>>> distinctive IMHO.
>>>
>>>> Yes   [ ] No    [ ]
>>>> Yes   [ ] No    [ ]
>>>> _______________________________________________ netext mailing
>>>> list [email-masked]
>>> _______________________________________________ netext mailing
>>> list [email-masked]
>> _______________________________________________ netext mailing list
>> [email-masked] https://www.ietf.org/mailman/listinfo/netext
>
>

---

From: Daniel Migault <[email-masked]>
Date: Fri, 19 Aug 2011 15:47:24 +0200

Q1:YES
Q2:YES
I agree the use case should be more detailed.
Regards,
Daniel

-- 
Daniel Migault
Orange Labs -- Security
+33 6 70 72 69 58

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 19 Aug 2011 15:48:52 +0200

> Does Sri's comment address your question?

It discusses about what the problem is.  Towards that end I thank him.

But it is still not clear to me the goal of this draft.  What problem
does it address?

- is it to support Mobile Routers (LFNs behind MR) in a PMIP domain?
- is it to assign the typical HNP to a PMIP Mobile Host? (PMIP spec
   does not tell how LMA obtains these prefixes, and DHCP-PD is a good
   tool).
- is it to do both above?

Depending on these two goals there are various mechanisms which can be
useful, not only DHCP-PD.  For example, there was a bitwise split
solution presented by Suresh at a plenary some IETFs ago.

Alex

>
> -Raj
>
> On 8/18/11 11:14 AM, "ext Sri Gundavelli"<[email-masked]> wrote:
>
>> Alex:
>>
>> If I may comment.
>>
>>
>>> to assign

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 19 Aug 2011 15:50:21 +0200

> It is about providing mobility for delegated prefixes.

Thanks Jouni.  Is it for an MR?  If yes, then there may exist other 
solutions possible as well.  Have you considered them?

Alex

>> On Thu, Aug 18, 2011 at 6:56 PM, Sri Gundavelli<[email-masked]>  wrote:
>>> On 8/18/11 8:50 AM, "Alexandru Petrescu"<[email-masked]>
>>> wrote:
>>>
>>>> Hello Raj,
>>>>

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 19 Aug 2011 15:51:34 +0200

> solution presented by Suresh at a plenary some IETFs ago.
                                     ^^^^^^^ I meant intarea not plenary.

Alex

---

From: jouni korhonen <[email-masked]>
Date: Sat, 20 Aug 2011 00:11:04 +0300

Alex,

FWIW is to make sure prefix delegation works when the MN in a RR role uses DHCPv6-PD to get its prefixes. It looks straight forward but there are few things to clarify in general operation and PBU/PBA signaling: what happens after a handover as the new MAG needs to learn delegated prefixes to setup a proper forwarding state, and how DHCPv6 (relay in a MAG) and LMA coordinate delegated prefixes to get the delegation work ok & establish proper forwarding state... etc.

There might be other cases and solutions but the above stuff is actually needed..

- Jouni

On Aug 19, 2011, at 4:50 PM, Alexandru Petrescu wrote:

> Thanks Jouni.  Is it for an MR?  If yes, then there may exist other solutions possible as well.  Have you considered them?
> 
> Alex
> 
>> 
>> - Jouni (as a co-author)
>> 
>>

---

From: Alexandru Petrescu <[email-masked]>
Date: Sat, 20 Aug 2011 15:53:31 +0200

Le 19/08/2011 23:11, jouni korhonen a écrit :
>
> Alex,
>
> FWIW is to make sure prefix delegation works when the MN in a RR
> role uses DHCPv6-PD to get its prefixes.

MN in a RR role?  Is the MN going to use the delegated prefix as an HNP?

Alex

> It looks straight forward but there are few things to clarify in
> general operation and PBU/PBA signaling: what happens after a
> handover as the new MAG needs to learn delegated prefixes to setup a
> proper forwarding state, and how DHCPv6 (relay in a MAG) and LMA
> coordinate delegated prefixes to get the delegation work ok&
> establish proper forwarding state... etc.
>
>> Thanks Jouni.  Is it for an MR?  If yes, then there may exist
>> other solutions possible as well.  Have you considered them?
>>
>> Alex
>>
>>>
>>> - Jouni (as a co-author)
>>>
>>>
>>>> Thanks for sharing your opinions. I would like to also hear a
>>>> reply from Joy. Joy, could you clearly state your views on the
>>>> question from Alex?
>>>>
>>>> Cheers.
>>>>
>>>>> #2 Assigning MNP to NEMO Mobile Router = RFC3963. NEMO MR
>>>>> per definition is CMIP enabled.
>>>>
>>>> Delegated Prefix - Prefixes hosted by the mobile node, or the
>>>> network elements behind the mobile node
>>>>
>>>> Hosted Prefixes - prefixes hosted by the PMIPv6 mobility
>>>> elements on the MN-AR access link. These are not delegated
>>>> prefixes. An IP host behind the mobile node cannot use this
>>>> prefix to generate an address, it wont receive RA's with these
>>>> PIO's.
>>>>
>>>> HNP typically implied prefixes delivered on PMIPv6 signaling
>>>> plane. If DHCP PD is used by MN or a node behind for obtaining
>>>> prefixes, those are simple IP prefixes. However, if mobility
>>>> is provided to those prefixes, in the form of this draft, we
>>>> can group them as HNP's, as mobility is provided and those
>>>> implied, as mobile router with CMIP functionality in my prev
>>>> mail. But, probably NEMO is a generic term. Any case, the
>>>> distinction is understood, with or without CMIP ...
>>>>
>>>> Sri
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>> #2 Assigning MNP to NEMO Mobile Router = RFC3963. NEMO MR
>>>>> per definition is CMIP enabled.
>>>>>
>>>>>
>>>>>>> At IETF81, Carl Williams presented the I-D: "Prefix
>>>>>>> Delegation for Proxy Mobile
>>>>>>> IPv6"<draft-zhou-netext-pd-pmip-01.txt>
>>>>>>>
>>>>>>> General consensus at the Netext WG meeting was that
>>>>>>> prefix delegation is a required feature for PMIP6.
>>>>>>
>>>>>> Please specify whether this prefix delegation feature is
>>>>>> for the goal of supporting Network Mobility with PMIP?
>>>>>>
>>>>>> Or is it to assign the HNP to the Mobile Host (not
>>>>>> necessarily to assign MNP for NEMO Mobile Router)?  The
>>>>>> two goals are distinctive IMHO.
>>>>>>
>>>>>>> 2. Can we adopt as WG document the solution proposed in
>>>>>>> I-D: draft-zhou-netext-pd-pmip-01.txt as the starting
>>>>>>> point of this feature?
>>>>>>>
>>>>>>> Yes   [ ] No    [ ]
>>>>>>
>>>>>>> _______________________________________________ netext
>>>>>>> mailing list [email-masked]
>>>>>> _______________________________________________ netext
>>>>>> mailing list [email-masked]
>>>>> _______________________________________________ netext
>>>>> mailing list [email-masked]
>>>> -- IMARA Team, INRIA, France. Jong-Hyouk Lee, living somewhere
>>>> between /dev/null and /dev/random.
>>>>
>>>> #email: hurryon (at) gmail (dot) com || jong-hyouk.lee (at)
>>>> inria (dot) fr #webpage: https://sites.google.com/site/hurryon/
>>>>  _______________________________________________ netext
>>>> mailing list [email-masked]