Subject: Re: [netext] Review of draft-ietf-netext-access-network-option-00

From: jouni korhonen <[email-masked]>
Date: Tue, 1 Nov 2011 15:29:47 +0200

Carlos,

Thanks for the review. See some responses inline.

On Oct 30, 2011, at 9:51 PM, Carlos Jesús Bernardos Cano wrote:

> Hi all,
> 
> I've read draft-ietf-netext-access-network-option-00 and I have some
> comments:
> 
> - I think the document is OK in general.
> - The normative text of Section 3 needs to be revised. For example,
> there are lots of normative words in lowercase.

Ok.

> - Can a PBU carry more than one ANI option? It is not clearly mentioned,
> though Figure 1 may indicate it is possible (as there is both BSSID and
> Geo-Loc shown as part of the identification of the access network.

There can be one ANI option.. as you can access only one operator network at once.

The option structure is still in flux so it is likely to change a bit in the future. For example there might be cases where multiple network identifiers are useful (e.g. SSID accompanied with geo-location etc).

> - Figure 3 is not referred in the document.
> - I think there should be text dealing with the case in which an LMA not
> supporting/understanding the ANI option receives a PBU carrying one.

Ok. You mean a simple capability confirmation like echoing the ANI option back in the PBA? Or something else?

> - It seems that included Nw-ID types are 802.11 related. Is there no
> other case (e.g., 3GPP related) worth including?

This is the initial set. If you have additional Nw-IDs to propose with a good use case, go ahead :)

> - Does the ANI option introduce privacy issues? In case an attacker was
> able to overhear PBUs, it could be able to know where a particular MN is
> geographically located. Not sure this is a realistic concern in a real
> deployment, but authors might want to mention that IPsec encryption
> could be used to mitigate this problem.

I think we do not need to go beyond existing RFC5213 security.. Even MN-ID option introduces a privacy issue more or less.

- Jouni

> 
> Thanks,
> 
> Carlos
> 
> -- 
> Carlos Jesús Bernardos Cano  http://www.netcom.it.uc3m.es/
> GPG FP: D29B 0A6A 639A A561 93CA  4D55 35DC BA4D D170 4F67
> _______________________________________________
> netext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netext

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Wed, 02 Nov 2011 00:45:40 +0100

Hi Jouni,

Thanks for your comments. Some additional ones from my side below.

> The option structure is still in flux so it is likely to change a bit in the future. For example there might be cases where multiple network identifiers are useful (e.g. SSID accompanied with geo-l…

This is exactly what I was referring to. In the current draft, it seems
that multiple network identifiers can be conveyed, but this seems not
possible to be done with a single ANI option (as currently defined).

> Ok. You mean a simple capability confirmation like echoing the ANI option back in the PBA? Or something else?

Well, just some text explaining what an LMA will do in that case. Maybe
just ignore the ANI option, but this needs to be mentioned in the draft,
IMHO.

> This is the initial set. If you have additional Nw-IDs to propose with a good use case, go ahead :)

OK, I'll try that exercise :)

> I think we do not need to go beyond existing RFC5213 security.. Even MN-ID option introduces a privacy issue more or less.

Well, I'm not an expert but I think this deserves at least a second
look. Jong-Hyouk also expressed some concerns about this. At least, I
think this should be mentioned on the Security Considerations section,
IMHO.

Thanks,

Carlos

---

From: jouni korhonen <[email-masked]>
Date: Wed, 2 Nov 2011 11:46:16 +0200

Hi,

On Nov 2, 2011, at 10:54 AM, Jong-Hyouk Lee wrote:

> Dear all.
> 
> Regarding location privacy, I agree with Carlos. As I mentioned it before and Carlos also noticed, it should be mentioned at least at the security consideration section at the document.

Ok. Thou shalt be done.

- JOuni

> 
> Thanks.
> 
> On Wed 02 Nov 2011 12:45:40 AM CET, Carlos Jesús Bernardos Cano wrote:
>> 
>> Hi Jouni,
>> 
>> IMARA Team, INRIA, France
>> Jong-Hyouk Lee, living somewhere between /dev/null and /dev/random
>> 
>> #email: hurryon (at) gmail.com || jong-hyouk.lee (at) inria.fr
>> #webpage: http://sites.google.com/site/hurryon/

---

From: Jong-Hyouk Lee <[email-masked]>
Date: Wed, 02 Nov 2011 09:54:33 +0100

Dear all.

Regarding location privacy, I agree with Carlos. As I mentioned it 
before and Carlos also noticed, it should be mentioned at least at the 
security consideration section at the document.

Thanks.

On Wed 02 Nov 2011 12:45:40 AM CET, Carlos Jesús Bernardos Cano wrote:
>> The option structure is still in flux so it is likely to change a bit 
>> in the future. For example there might be cases where multiple 
>> network identifiers are useful (e.g. SSID accompanied with 
>> geo-location etc).
>
>
>> Ok. You mean a simple capability confirmation like echoing the ANI 
>> option back in the PBA? Or something else?
>
>
>> I think we do not need to go beyond existing RFC5213 security.. Even 
>> MN-ID option introduces a privacy issue more or less.
>
>