Subject: Re: [netext] #12: missing considerations on how to maintain consistent forwarding policies

From: "netext issue tracker" <[email-masked]>
Date: Wed, 13 Feb 2013 18:24:52 -0000

#12: missing considerations on how to maintain consistent forwarding policies

Comment (by [email-masked]):

 (apologies for not addressing this until now)

 I agree policy consistency is critical, and this is actually reflected in
 the draft. However, since the charter does not allows any type of IP
 signaling between the MAG and LMA, specifying any type of policy alignment
 signaling as part of the document seems to be clearly out of the scope.
 The consensus I got from the WG (based on current charter boundaries) was
 to leave that unspecified, so it can be done using L2 signaling for
 example (and be specified by other SDOs).

 Do you have any suggestion on how to give clues without specifying a
 solution in the document? Would it be enough to provide informative
 examples (e.g., conveying that info as part of L2 signaling)?

-- 
-------------------------------------+-------------------------------------
 Reporter:                           |       Owner:  draft-ietf-netext-
  [email-masked]          |  [email-masked]
     Type:  defect                   |      Status:  new
 Priority:  major                    |   Milestone:
Component:  pmipv6-flowmob           |     Version:
 Severity:  Active WG Document       |  Resolution:
 Keywords:                           |
-------------------------------------+-------------------------------------

Ticket URL: <https://trac.tools.ietf.org/wg/netext/trac/ticket/12#comment:1>
netext <http://tools.ietf.org/netext/>

---

From: <[email-masked]>
Date: Thu, 14 Feb 2013 10:49:09 +0000

Hi,

Clearly, I'm not suggesting to describe mechanism for policy alignment, let alone specifying MN-MAG signaling.

Annex giving example on what can be done with L2 signaling may help. However, I think, the draft should state simple and clear assumptions on mobility control to avoid ambiguity on policy alignment. Basically, I suggest to add the following assumption (at least for prefix sharing scenario):

The MN makes the final IP flow mobility decision, then the LMA follows that decision and update its forwarding state accordingly. Note that, It does not prevent network initiated mobility, the network still could trigger mobility on the MN side via out-of-band mechanisms (e.g. 3GPP/ANDSF sends updated routing policies to the MN)... Actually, I'm suggesting the following statement "the MN always makes the final decision"

Pierrick

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la
> part de netext issue tracker
> Envoyé : mercredi 13 février 2013 19:25
> À : [email-masked]; [email-masked]
> Cc : [email-masked]
> Objet : Re: [netext] #12: missing considerations on how to maintain
> consistent forwarding policies
> 
>  I agree policy consistency is critical, and this is actually reflected
> in  the draft. However, since the charter does not allows any type of
> IP  signaling between the MAG and LMA, specifying any type of policy
> alignment  signaling as part of the document seems to be clearly out of
> the scope.
>  The consensus I got from the WG (based on current charter boundaries)
> was  to leave that unspecified, so it can be done using L2 signaling
> for  example (and be specified by other SDOs).
> 
> -------------------------------------+---------------------------------
> -
> -------------------------------------+---
> -------------------------------------+---------------------------------
> -
> -------------------------------------+---
> 
> Ticket URL:
> <https://trac.tools.ietf.org/wg/netext/trac/ticket/12#comment:1>
> _______________________________________________
> netext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netext

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Thu, 14 Feb 2013 22:20:33 +0100

Hi Pierrick,

Please see inline below.

On Thu, 2013-02-14 at 10:49 +0000, [email-masked] wrote:
> Hi,
> 
> Clearly, I'm not suggesting to describe mechanism for policy
> alignment, let alone specifying MN-MAG signaling.

OK, glad we are on the same page :D

> 
> Annex giving example on what can be done with L2 signaling may help.
> However, I think, the draft should state simple and clear assumptions
> on mobility control to avoid ambiguity on policy alignment. Basically,
> I suggest to add the following assumption (at least for prefix sharing
> scenario):
> 
> The MN makes the final IP flow mobility decision, then the LMA follows
> that decision and update its forwarding state accordingly. Note that,
> It does not prevent network initiated mobility, the network still
> could trigger mobility on the MN side via out-of-band mechanisms (e.g.
> 3GPP/ANDSF sends updated routing policies to the MN)... Actually, I'm
> suggesting the following statement "the MN always makes the final
> decision"

OK, let me add some text along those lines in the next version of the
draft.

Thanks!