Subject: Re: [netext] #16: requirement for single interface

From: "netext issue tracker" <[email-masked]>
Date: Wed, 13 Feb 2013 18:35:58 -0000

#16: requirement for single interface

Comment (by [email-masked]):

 This was introduced to address the review performed by Marco Liebsch, and
 also the suggestions from the chairs, to remove a strong dependency on the
 logical interface.

 If two different IP addresses are configured, IP session continuity is
 still possible (for each of the configured IP addresses). What is needed
 is the network to deliver packets for IP X to the right MN's physical
 interface, and the MN to select the right outgoing interface when sending
 traffic back (of course using IP X as source address).

-- 
-------------------------------------+-------------------------------------
 Reporter:                           |       Owner:  draft-ietf-netext-
  [email-masked]          |  [email-masked]
     Type:  defect                   |      Status:  new
 Priority:  major                    |   Milestone:
Component:  pmipv6-flowmob           |     Version:
 Severity:  Active WG Document       |  Resolution:
 Keywords:                           |
-------------------------------------+-------------------------------------

Ticket URL: <https://trac.tools.ietf.org/wg/netext/trac/ticket/16#comment:1>
netext <http://tools.ietf.org/netext/>

---

From: <[email-masked]>
Date: Thu, 14 Feb 2013 11:41:21 +0000

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la
> part de netext issue tracker
> Envoyé : mercredi 13 février 2013 19:36
> À : [email-masked]; [email-masked]
> Cc : [email-masked]
> Objet : Re: [netext] #16: requirement for single interface
> 
>  This was introduced to address the review performed by Marco Liebsch,
> and  also the suggestions from the chairs, to remove a strong
> dependency on the  logical interface.
> 
> still possible (for each of the configured IP addresses). What is
> needed  is the network to deliver packets for IP X to the right MN's
> physical  interface, and the MN to select the right outgoing interface
> when sending  traffic back (of course using IP X as source address).
> 

Ok. I guess that, in this case, mobility of an IP flow requests the MN to support the weak host model, right? 

May I suggest to reword the following sentence (section 3.2.1)

[if the IP layer at the mobile node shows one single interface, then the mobile node has one single IPv6 address configured at the IP layer: pref1::mn1. Otherwise, two different IPv6 addresses (pref1::if1 and pref1::if2) would be configured.]

As

[if the IP layer at the mobile node shows one single logical interface [ref to logical interface I-D], then the mobile node has one single IPv6 address configured at the IP layer: pref1::mn1. Otherwise, per interface IPv6 addresses (e.g. pref1::if1 and pref1::if2) would be configured; each address must be valid on every interfaces.]

> --
> -------------------------------------+---------------------------------
> -
> -------------------------------------+---
> -------------------------------------+---------------------------------
> -
> -------------------------------------+---
> 
> Ticket URL:
> <https://trac.tools.ietf.org/wg/netext/trac/ticket/16#comment:1>
> _______________________________________________
> netext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netext

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Carlos Jesús Bernardos Cano <[email-masked]>
Date: Thu, 14 Feb 2013 22:22:40 +0100

Hi Pierrick,

Please see inline below.

> to support the weak host model, right? 

Yes, that's one possibility.

> [if the IP layer at the mobile node shows one single logical interface [ref to logical interface I-D], then the mobile node has one single IPv6 address configured at the IP layer: pref1::mn1. Other…

I'm fine with your proposal. I'll use that text in the next revision of
the draft, unless people disagree.

Carlos