Subject: [netext] Comments on I-D: draft-wakikawa-netext-pmip-cp-up-separation

From: Basavaraj Patil <[email-masked]>
Date: Tue, 16 Jul 2013 17:23:35 -0500

Hi Ryuji,

The idea of splitting the CP and UP for PMIP6 has been around for quite a
while.
In fact if I were to recollect, Vijay D. had proposed this during the
development of the PMIP6 protocol in Netlmm.

Its a good idea to allow the protocol to optionally have a separate CP/UP
between the MAG and LMA. It would essentially be equivalent to 3GPPs GTP-C
and GTP-U.

The draft itself is preliminary and hopefully will be improved if the WG
decides to adopt it.
Looking forward to the presentation/discussion in Berlin.

-Raj

-- 
Basavaraj Patil

---

From: Ryuji Wakikawa <[email-masked]>
Date: Wed, 17 Jul 2013 07:56:27 +0900

Hi Raj,

Thanks for the comments. 
I remember Vijay's proposal and found his slide;-)
http://www.ietf.org/proceedings/73/slides/netlmm-4.pdf
I should probably reuse his slide in Berlin;-)

The idea is around for a while. We should standardise an extension now so that PMIP can be deployed more.

thanks,
ryuji

On Jul 17, 2013, at 7:23 AM, Basavaraj Patil <[email-masked]> wrote:

> 
> Hi Ryuji,
> 
> The idea of splitting the CP and UP for PMIP6 has been around for quite a while.
> In fact if I were to recollect, Vijay D. had proposed this during the development of the PMIP6 protocol in Netlmm.
> 
> Its a good idea to allow the protocol to optionally have a separate CP/UP between the MAG and LMA. It would essentially be equivalent to 3GPPs GTP-C and GTP-U. 
> 
> The draft itself is preliminary and hopefully will be improved if the WG decides to adopt it. 
> _______________________________________________
> netext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netext

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Tue, 16 Jul 2013 23:16:16 +0000

I agree as well. 

This is a known issue/gap. Many people including Vijay, Charlie and others in the past have suggested that we fix this gap. This data point is important, it makes a case that this is a valid issue and the authors are not on research track. 

This is a minor extension, needed for enabling PMIP-based mobility solutions on platforms with modular architectures and in certain types of WLAN systems.

Sri

---

From: Suresh Krishnan <[email-masked]>
Date: Wed, 17 Jul 2013 14:55:28 -0400

Hi Ryuji,

> I should probably reuse his slide in Berlin;-)

Yep. I also think that there is quite a bit of earlier work we can
reuse. There was also an accompanying draft to Vijay's proposal

http://tools.ietf.org/html/draft-devarapalli-netlmm-pmipv6-data-plane-00

Cheers
Suresh

---

From: Ryuji Wakikawa <[email-masked]>
Date: Thu, 18 Jul 2013 10:17:56 +0900

Hi Suresh and all,

Thanks for the draft published in 2008! 5 years ago!
Indeed, many proposals has been submitted in the past. 

Isn't it good timing to standardise this small extension to PMIP!?

thanks,
ryuji

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 18 Jul 2013 16:35:11 +0300

In past I also had some strong opinions about PMIPv6 UP/CP split
but maybe those can be left now behind ;-)

Regarding the draft it is unclear to me how the LMA knows the
MAG supports the new functionality. Is PMIPv6 Domain wide support
assumed? Second, I think the interactions and co-existence with 
RFC6463 need to be detailed. Last, how is IPv4 address encoded
within the LMA User Plane Address field? Would it make sense to
encode the address using as 4 octets IPv4 address or is the draft
assuming IPv4-mapped IPv6 address?

- Jouni

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 29 Jul 2013 01:55:13 -0700

Hello folks,

The problem isn't just for PMIP, but also for MIP.  Here's a draft
from a couple of years ago with some different details.
http://tools.ietf.org/id/draft-perkins-mext-hatunaddr-01.txt

Regards,
Charlie P.

-- 
Regards,
Charlie P.