Subject: [netext] I-D Action: draft-ietf-netext-pmip6-qos-06.txt

From: [email-masked]
Date: Wed, 13 Nov 2013 11:20:30 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Network-Based Mobility Extensions Working Group of the IETF.

	Title           : Quality of Service Option for Proxy Mobile IPv6
	Author(s)       : Marco Liebsch
                          Pierrick Seite
                          Hidetoshi Yokota
                          Jouni Korhonen
                          Sri Gundavelli
	Filename        : draft-ietf-netext-pmip6-qos-06.txt
	Pages           : 56
	Date            : 2013-11-13

Abstract:
   This specification defines a new mobility option, the Quality of
   Service (QoS) option, for Proxy Mobile IPv6.  This option can be used
   by the local mobility anchor and the mobile access gateway for
   negotiating Quality of Service parameters for a mobile node's IP
   flows.  The negotiated QoS parameters can be used for QoS policing
   and marking of packets to enforce QoS differentiation on the path
   between the local mobility anchor and the mobile access gateway.
   Furthermore, making QoS parameters available on the mobile access
   gateway enables mapping of these parameters to QoS rules that are
   specific to the access technology and allow those rules to be
   enforced on the access network using access technology specific
   approaches.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netext-pmip6-qos

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-netext-pmip6-qos-06

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-netext-pmip6-qos-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: John Kaippallimalil <[email-masked]>
Date: Thu, 14 Nov 2013 17:39:28 +0000

Hi,
I have reviewed this work in detail (v 06 and 05) and think that this is in very good condition to move forward.

My focus was to apply the PMIP QoS attributes to configure parameters in WiFi network (related to my netext draft on WiFi QoS). The mechanisms in this draft are sufficient to work on the flow level, mobility session level and on the different attribute groupings that are needed for admission control/non-admission control scenarios. In all, I think it is technically sound.

Best Regards,
John 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of [email-masked]
> Sent: Wednesday, November 13, 2013 1:21 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [netext] I-D Action: draft-ietf-netext-pmip6-qos-06.txt
> 
> 
> _______________________________________________
> netext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netext

---

From: John Kaippallimalil <[email-masked]>
Date: Thu, 14 Nov 2013 17:44:44 +0000

Hi,

Best Regards,
John

---

From: Ryuji Wakikawa <[email-masked]>
Date: Fri, 15 Nov 2013 12:00:41 +0900

Hi

I’ve reviewed this document. 
The draft is well explained with a lot of examples (a bit redundant but  i am ok with the current version) . 
It is ready for publication. I don’t see any technical problems. 

In section 4.1,  you may explain the default behaviour of  Quality of Service Option (i.e. no D/M flags).
If none of flags are set, QoS resources is added. something like this.

regards,
ryuji

On Nov 14, 2013, at 4:20 AM, [email-masked] wrote:

> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: <[email-masked]>
Date: Fri, 15 Nov 2013 15:53:20 +0100

Dear all,
I have reviewed the draft which seems to be an important step towards operator activities in better integration of cellular (3GPP) and IEEE802- based access systems. I agree to proceed with the draft towards RFC ... although it is not clear to me whether it might first head towards Experimental before entering Standards track? 

Personally I think it might be necessary to put some more text in 
6.3 Protocol operation 
and 
8. Security Considerations
as well as clean up the nits before submission to IESG.
I'll provide my list of detected nits to the authors ;-)
Thanks!
Best regards
Dirk

On Nov 14, 2013, at 4:20 AM, [email-masked] wrote:

> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Draft directories: http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Basavaraj Patil <[email-masked]>
Date: Fri, 15 Nov 2013 12:53:57 -0600

Thanks John, Ryuji and Dirk for your reviews.

-Chairs

On Thu, Nov 14, 2013 at 11:39 AM, John Kaippallimalil <
[email-masked]> wrote:

> My focus was to apply the PMIP QoS attributes to configure parameters in
> WiFi network (related to my netext draft on WiFi QoS). The mechanisms in
> this draft are sufficient to work on the flow level, mobility session level
> and on the different attribute groupings that are needed for admission
> control/non-admission control scenarios. In all, I think it is technically
> sound.
>
> Best Regards,
> John
>
>
>
> > submission

-- 
Basavaraj Patil

---

From: "Seil Jeon" <[email-masked]>
Date: Mon, 18 Nov 2013 11:35:03 -0000

Hi all,

I've reviewed this draft. I also support current shape of this version.
It looks good to go publication process since it has been reviewed for a
long time by many experts.
I hope the rest of the process for the publication would quickly be done.

In addition, dash arrows representing message flows in figs 1 and 2 need to
be fixed for better visual as well as right meaning.

Regards,
Seil

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Wednesday, November 13, 2013 7:21 PM
To: [email-masked]
Cc: [email-masked]
Subject: [netext] I-D Action: draft-ietf-netext-pmip6-qos-06.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
 This draft is a work item of the Network-Based Mobility Extensions Working
Group of the IETF.

Abstract:

---

From: Michał Hoeft <[email-masked]>
Date: Tue, 19 Nov 2013 07:57:08 +0100

Hi all

I’ve reviewed the draft. In my opinion it is really good. Presented idea,
in almost all sections, is well described and easily readable. However, Use
Case C of appendix A is unclear for me. In this case, CSCF servers notify
LMA about new flow, thus LMA initiated QoS request should be used (Use Case
1 from Section 3). However the second paragraph of this section, states
that PBU/PBA signalling should be used. Moreover, in my opinion in sentence
"The PCF notifies the LMA for withdrawing the QoS resources establishes for
that voice flow" (page 50), "voice flow" phrase should be replaced with
more general statement "multimedia flow" or even only "flow". The last two
sentences are very similar to the first ones and seem to be wrong (MAGs
receive UPN nor UPA).

Moreover, please consider following comments and suggestion of minor
changes:
1) Taking in mind future use of the RFC, in my opinion, reference to ETSI
TR 37.834 Study on WLAN/3GPP Radio Interworking will be useful, despite the
fact that work on this document is still in progress.
2) In Fig. 1,  UPN and UPA abbreviations are used but they are not expanded
in text. In my opinion it can be done in 2.2 Section (Terminology) or in
the last paragraph on 9 page.
3) PDP abbreviation used in Fig. 10 and Fig. 12 is not expanded in text.
4) Style of following sentences could be verified to avoid double "whereas"
(p.35).

 QoS differentiation is typically enabled in the mobile operator's
   network using Differentiated Services techniques in the IP transport
   network, whereas radio access specific QoS differentiation depends on
   the radio technology in use.  Whereas accurate and fine granular
   traffic classes are specified for the cellular radio access

6) Fig 5 and Fig 8 should be unified:

           Non-cellular access       |  Cellular Core Network   Cellular
              (e.g. WLAN)            |           +--------+     Access
                                     |           |Policy  |
                                     |           |Control +-----+
                                     |           |Function|     |
             +----+                  |           +---+----+     |
             |WiFi|           (I)    |               |          |
             | AP |---+    +---+---+ |               |          |   ((O))
             +----+   |    |WiFi AR| |  PMIPv6    +-----+    +-----+  |
                      +----+ (MAG) +=|============| PGW |====| SGW |  |
                      |    |  WLC  | |   tunnel   |(LMA)|    |(MAG)|  |
             +----+   |    +-------+ |            +-----+    +-----+--|
             |WiFi|---+              |            //
             | AP |                  |           //
             +----+           (II)   |          //
                           +-------+ |         //
   +----+    +------+      |WiFi AR| |        //
   |WiFi+----+  WLC +------+ (MAG) |=|=======//
   | AP |    |      |      |       | |
   +----+    +------+      +------ + |
                 ^            ^      |
                 |            |      |
                 +------------+
                QoS inter-working

   Figure 5: Architecture for QoS inter-working between cellular access
                          and non-cellular access

                                              +--------+
                                              |Policy  |
                                              |Control |
                                              |Function|
                                              +---+----+
                                                  |
          +----+       +-------+              +---+----+
    +--+  |LTE |_______|  SGW  |              |  PGW   |
    |MN|~~|eNB |       | (MAG) |==============| (LMA)  |
    +--+  +----+       +-------+            //+--------+
     :                                     //
     :                                    //
     V    +----+       +-------+ PMIPv6  //
    +--+  |WiFi|_______|  WLC  |=========
    |MN|~~| AP |       | (MAG) | tunnel
    +--+  +----+       +-------+

                        Figure 8: Handover Scenario

Regards
Michal

2013/11/18 Seil Jeon <[email-masked]>