Subject: [netext] WGLC: draft-ietf-netext-ani-location-04.txt

From: Basavaraj Patil <[email-masked]>
Date: Mon, 17 Nov 2014 14:21:30 -0600

Hello,

The working group I-D: Extensions to the PMIPv6 Access Network Identifier
Option
<draft-ietf-netext-ani-location-04.txt> is ready for working group last
call.

Please consider this email as the start of the WG last call for this I-D.
Your review comments can be sent to the WG mailing list, the authors or to
the chairs.

The WG last call will expire on Dec 2nd, 2014. Please make an effort to
review
this I-D and provide feedback.

-Chairs

-- 
Basavaraj Patil

---

From: <[email-masked]>
Date: Tue, 18 Nov 2014 15:12:45 +0100

Dear WG, authors, and chairs,
I have reviewed the draft and think it is in good shape. I recommend to go forward with the document … after update where you might consider some nits I found:

Generally I propose to use consistent writing of Update-Timer (instead of all variations as update timer, update Timer, Update timer etc.) and of sub-option  (as in rfc6757, instead of Sub option, sub option etc.)

additionally:
Abstract and intro:
a ANI -> an ANI (twice, in the rest of doc it already says ‘an ANI’)
etc). ->  etc.).

p.3
known as Wireless LAN Controller -> known as Wireless LAN Controller (WLC)
sub-options.The -> sub-options. The

ch. 3.1
Note that the length shall not exceed 253 bytes -> Note that the length SHALL NOT exceed 253 bytes (?? I am not really sure about this! There are other may and must which might be capital ones ref. to 2.1, please check!)

ch.3.3
Figure 3: Network-Identifier Sub-option -> Figure 3: ANI Update-Timer Sub-option
ANI length fields -> ANI Length fields (3 times, for reasons of consistency)
A non zero value -> A non-zero value

Ch. 4.1
based on a exchange -> based on an exchange
Information mobility options included the Proxy Binding Update -> Information mobility options included _in_ the Proxy Binding Update

Ch. 6
exposes the civic location of the network to which the mobile node is attached -> may expose the civic location of the access point to which the mobile node is attached (I think ‘network location’ may be quite blurry and thus not so critical)
IPSec Encapsulating Security Payload (ESP) -> should we add reference [RFC4303<http://tools.ietf.org/html/rfc4303>] here?

Thanks and best regards
Dirk

From: netext [mailto:[email-masked]] On Behalf Of Basavaraj Patil
Sent: Montag, 17. November 2014 21:22
To: [email-masked]; [email-masked]
Subject: [netext] WGLC: draft-ietf-netext-ani-location-04.txt

Hello,

The working group I-D: Extensions to the PMIPv6 Access Network Identifier Option
<draft-ietf-netext-ani-location-04.txt> is ready for working group last call.

The WG last call will expire on Dec 2nd, 2014. Please make an effort to review
this I-D and provide feedback.

-Chairs

--
Basavaraj Patil

---

From: "Kent Leung (kleung)" <[email-masked]>
Date: Mon, 24 Nov 2014 08:29:01 +0000

Hi. My comments on this draft. Overall, looks good. Probably need some cleaning up and clarifications.

1.      Global change for consistency:

a.      “group-identifier” or “group identifier”

b.      “sub option(s)” or “sub-option(s)”

c.      “ANI Update Timer” (lower vs update case letters)

d.      “Proxy Binding Update” vs “PBU”

e.      “Proxy Binding Acknowledgement” vs “PBA”

f.       “mobile access gateway” vs “MAG”

g.      “local mobility anchor” vs “LMA”

2.      Sect 1 Intro section

a.      “intra WLC” -> “intra-WLC”

b.      Reword: “In such deployments, the ANI sub-options (for example location) get stale and get only refreshed at the time of lifetime expiry.” -> “In such deployments, the information conveyed in the ANI sub-options (e.g. location) becomes stale and is only refreshed at the time of lifetime expiry.”?

3.      Sect 3.1

a.      “Civic Location Sub-Option” title?

b.       Format should have “IANA-1” instead of “IANA”

4.      Sect 3.2

a.      “MAG Group Identifier Sub-Option” title?

b.      Format should have “IANA-2” instead of “IANA”

5.      Sect 3.3

a.      “Format should have “IANA-3” instead of “IANA”

b.      “non zero” -> “non-zero” or “nonzero”?

c.      Reword to clarify that nonzero does not mean send ANI when update timer expires since that is not an event for triggering the update: “… but rather send ANI updates only when the update timer expires” -> “… but rather send ANI updates when the update timer has expired”?

6.      Sect 4.1

a.      Maybe clarify the meaning of “parameters have changed” to trigger sending PBU with ANI option. For example, parameter value is A, then changed to B, and then back to A. When timer expires, does MAG send the PBU for ANI update? In a sense, the value has changed over time. But good to clarify the determination is based on a changed parameter event or the reported parameter value. I assume it’s the latter. Or just word it as “parameters have changed from the last reported values”?

7.      Sect 5.

a.      Specify what values are defined or reserved by draft

b.      Approval of new XXX type values are to be made through IANA Expert Review?

Kent

From: netext [mailto:[email-masked]] On Behalf Of Basavaraj Patil
Sent: Monday, November 17, 2014 12:22 PM
To: [email-masked]; [email-masked]
Subject: [netext] WGLC: draft-ietf-netext-ani-location-04.txt

Hello,

-Chairs

--
Basavaraj Patil