Subject: [netmod] YANG-based validation?

From: Kent Watsen <[email-masked]>
Date: Fri, 7 Jan 2011 14:34:31 -0800

I'm looking for a utility to validate XML configuration and RPC messages defined by a YANG module.

For XSD and RelaxNG schema, I would normally use `xmllint --schema` or `xmlint --relaxng`...

Is the best option currently to use either `yumadump` or `pyang` to generate the XSD and then use xmllint?

Thanks,
Kent

---

From: Martin Bjorklund <[email-masked]>
Date: Sat, 08 Jan 2011 14:41:22 +0100 (CET)

> the XSD and then use xmllint?

As for pyang, the XSD output is out of date, but there is the DSDL
output that works well for validation of config, rpcs, state data,
etc.

There are currently no plans to update the XSD plugin, but if anyone
would like to contribute that would be very welcome.

/martin