Subject: [netmod] smi2yang-06: notification containers

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 5 Apr 2011 12:01:52 +0200

* smi2yang-06: notification containers

  For every object listed in the OBJECTS clause, a notification
  container is generated. This is necessary since multiple leafs may
  be needed to repesent an object since we have to capture any index
  information. Right now, the name of this container is:

    <notification-name>-<object-name>[-<number>]

   --n linkDown    
    +--ro linkDown-ifIndex
    |  +--ro ifIndex?   leafref
    +--ro linkDown-ifAdminStatus
    |  +--ro ifIndex?         leafref
    |  +--ro ifAdminStatus?   leafref
    +--ro linkDown-ifOperStatus
       +--ro ifIndex?        leafref
       +--ro ifOperStatus?   leafref

  The choice of <notification-name>-<object-name> seems arbitrary
  and the optional disambiguating number may be a surprise.

** Solution #06-01:

   Always produce a number and call the container object-<number>,
   that is:

   --n linkDown    
    +--ro object-1
    |  +--ro ifIndex?   leafref
    +--ro object-2
    |  +--ro ifIndex?         leafref
    |  +--ro ifAdminStatus?   leafref
    +--ro object-3
       +--ro ifIndex?        leafref
       +--ro ifOperStatus?   leafref

   This seems to be closer to SMIv2 and is easier to implement as
   well.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Martin Bjorklund <[email-masked]>
Date: Sat, 09 Apr 2011 13:23:00 +0200 (CEST)

Hi,

>    This seems to be closer to SMIv2 and is easier to implement as

This solution seems ok.

/martin

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 11 Apr 2011 16:45:07 +0200

> >    This seems to be closer to SMIv2 and is easier to implement as

I guess I will put this in place now.

/js