Subject: [netmod] smi2yang-05: accessible-for-notify OBJECT-TYPES

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 5 Apr 2011 12:01:47 +0200

* smi2yang-05: accessible-for-notify OBJECT-TYPES

  SMIv2 objects can have a MAX-ACCESS of accessible-for-notify and
  thus can't be accessed via get operations.

** Solution #05-01

   Accessible-for-notify objects should be treated specially:

   - Do not generate schema tree leafs for accessible-for-notify
     objects.

   - If such objects are lised in the OBJECTS clause of a
     NOTIFICATION-TYPE, generate a proper leaf in the notification
     sub-statements instead of the typical leafref leaf.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Martin Bjorklund <[email-masked]>
Date: Sat, 09 Apr 2011 13:22:28 +0200 (CEST)

Hi,

>      sub-statements instead of the typical leafref leaf.

This solution seems ok.  Some information is actually lost with this
solution - there is no way to formally declare that this special leaf
is related to a specific row.  For example:

  notification foo {
    object-1 {
      leaf barIndex {
        type leafref {
          path "/fooMIB/barTable/barEntry/barIndex";
        }
      }
      leaf barAccessibleForNotify {
        type int32;  // a normal object would be a leafref
      }
    }
  }

I think this solution is good anyway.

/martin

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 11 Apr 2011 22:12:01 +0200

> I think this solution is good anyway.

Implemented and documented. ;-)

/js