Subject: [netmod] system data model rpcs

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 26 Jul 2011 22:02:08 +0200

Hi,

I am wondering whether we should add some additional RPCs to the
system data model. I am thinking about very basic things such as a
reboot RPC and/or a powerdown RPC.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 26 Jul 2011 16:09:28 -0400

> reboot RPC and/or a powerdown RPC.

+1

Lada

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

--
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: Yoshifumi Atarashi <[email-masked]>
Date: Tue, 26 Jul 2011 16:11:57 -0400

Many venders and ISPs operators think that Power/Reboot control
mechanism are  caution of securty hole .
Be carefully consider the risks.
    Yoshifumi Atarashi

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 26 Jul 2011 16:35:27 -0400

> Be carefully consider the risks.

Both Cisco and Juniper have such a CLI command, and previously we had to implement it in NETCONF for the devices we are developing. In some situations, it is actually a security hole NOT to be able to reboot a box.

Lada

--
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: Yoshifumi Atarashi <[email-masked]>
Date: Tue, 26 Jul 2011 17:31:37 -0400

Thank you, Bert.
We(Venders) sometimes are bullied by operators about security issue......
I don't mind these control.
For netconf/netmod deployment, I'm thinking something is better instead of
power control, more useful for ISPs systems.
    Yoshifumi  Atarashi

(11/07/26 17:05), Bert (IETF) Wijnen wrote:
> On 7/26/11 4:11 PM, Yoshifumi Atarashi wrote:
> OK, I remember that way back when, there were safety laws that would
> forbid to
> do a remote reboot (actually that was a remote power on.).
>
> But in any event, these dyas, someone can ssh into a device, got to
> root mode
> and then do a reboot also. SO in that sense, I do not see why it would be
> so different if Netcofn could do it (with proper access control of
> course).
>
> Bert
>