Subject: Re: [netmod] common yang data types - 6021bis

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 2 Apr 2012 16:56:55 +0200

On Fri, Mar 30, 2012 at 09:45:49AM -0400, Lange, Jeffrey K (GE Energy) wrote:

> This isn't directly related to 6021 data types, more of an addition
> to the ietf-inet-types , however one datatype that I found myself
> implementing that would be nice to have as a standard type would be
> a ip/prefix type that isn't limited to just specifying the prefix,
> There is currently the ipv4-prefix and ipv6-prefix which has the
> exact syntax that I'm looking for however the stipulation that all
> lower bits past the prefix length means that I have to define my own
> data type to allow someone to apply an IP address using the notation
> "dead:beef::1/64"

Just to be sure I understand you correctly: You propose to have two
additional typedefs defined that take and ip address plus a prefix,
say ipv4-address-with-prefix / ipv6-address-with-prefix. Correct?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Lange, Jeffrey K (GE Energy)" <[email-masked]>
Date: Mon, 2 Apr 2012 13:14:17 -0400

Yes, that is correct.. and just to be clear,  the string pattern would be exactly the same as ipv4-prefix and ipv6-prefix, it becomes more of a semantic difference.

Ipv6-prefix:
  dead:beef::0/64    //OK
  dead:beef::1/64    //BAD

ipv6-address-with-prefix:
  dead:beef::0/64  //OK
  dead:beef::1/64  //OK

I guess another way to look at it is to loosen up the wording on the ipv6-prefix/ipv4-prefix types to remove the requirement that the bits past the prefix length must be zero so that the same type can be used in different scenarios.

Jeff Lange
Lead Software Engineer
GE Digital Energy - MDS
 
T: +1 585 242 8375
F: +1 585 241 5590
E: [email-masked] 
www.GEDigitalEnergy.com
 
175 Science Parkway
Rochester, NY, 14620, USA

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Monday, April 02, 2012 10:57 AM
To: Lange, Jeffrey K (GE Energy)
Cc: [email-masked]
Subject: Re: [netmod] common yang data types - 6021bis

On Fri, Mar 30, 2012 at 09:45:49AM -0400, Lange, Jeffrey K (GE Energy) wrote:

> This isn't directly related to 6021 data types, more of an addition to 
> the ietf-inet-types , however one datatype that I found myself 
> implementing that would be nice to have as a standard type would be a 
> ip/prefix type that isn't limited to just specifying the prefix, There 
> is currently the ipv4-prefix and ipv6-prefix which has the exact 
> syntax that I'm looking for however the stipulation that all lower 
> bits past the prefix length means that I have to define my own data 
> type to allow someone to apply an IP address using the notation 
> "dead:beef::1/64"

Just to be sure I understand you correctly: You propose to have two additional typedefs defined that take and ip address plus a prefix, say ipv4-address-with-prefix / ipv6-address-with-prefix. Correct?

/js

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 2 Apr 2012 19:22:34 +0200

> I guess another way to look at it is to loosen up the wording on the ipv6-prefix/ipv4-prefix types to remove the requirement that the bits past the prefix length must be zero so that the same type…

Well, changing a published definition usually is not such a good idea.
If ipv*-prefix is used to denote a prefix, then the lower bits do not
matter and we tend to pay attention to normalized representations.

/js