Subject: [netmod] Fwd: New Version Notification for draft-lhotka-yang-json-01.txt

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 5 Jun 2012 13:12:08 +0200

Hi,

this is a new revision of the JSON mapping draft. The main change is a more liberal approach to namespaces - an explicit namespace identifier must be used in JSON only where the local name is ambiguous, which should hopefully be almost nowhere.

Comments are welcome.

Lada

Begin forwarded message:

> From: [email-masked]
> Subject: New Version Notification for draft-lhotka-yang-json-01.txt
> Date: June 5, 2012 1:06:06 PM GMT+02:00
> To: [email-masked]
> 
> A new version of I-D, draft-lhotka-yang-json-01.txt has been successfully submitted by Ladislav Lhotka and posted to the IETF repository.
> 
> Filename:	 draft-lhotka-yang-json
> Revision:	 01
> Title:		 Modeling JSON Text with YANG
> Creation date:	 2012-06-05
> WG ID:		 Individual Submission
> Number of pages: 12
> 
> Abstract:
>   This document defines rules for mapping data models expressed in YANG
>   to configuration and operational state data encoded as JSON text.  It
>   does so by specifying a procedure for translating the subset of YANG-
>   compatible XML documents to JSON text, and vice versa.
> 
> 
> 
> 
> The IETF Secretariat

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: "Ersue, Mehmet (NSN - DE/Munich)" <[email-masked]>
Date: Fri, 15 Jun 2012 21:08:08 +0200

Hi Lada,

this is a very valuable draft to enable JSON fans to use YANG. 
If not done already I would suggest to forward the draft announcement to
APP-Discuss and Core maillists.

Do you have an experimental implementation already?

Martin, Andy: How about pyang or yuma integration?

Cheers, 
Mehmet 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext
> Ladislav Lhotka
> Sent: Tuesday, June 05, 2012 1:12 PM
> To: [email-masked]
> Subject: [netmod] Fwd: New Version Notification
fordraft-lhotka-yang-json-01.txt
> 
> Hi,
> 
> this is a new revision of the JSON mapping draft. The main change is a
more liberal
> approach to namespaces - an explicit namespace identifier must be used
in JSON only
> where the local name is ambiguous, which should hopefully be almost
nowhere.
> > A new version of I-D, draft-lhotka-yang-json-01.txt has been
successfully submitted
> by Ladislav Lhotka and posted to the IETF repository.
> >
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 15 Jun 2012 22:53:23 +0200

Hi Mehmet,

On Jun 15, 2012, at 9:08 PM, Ersue, Mehmet (NSN - DE/Munich) wrote:

> APP-Discuss and Core mail lists.

I sent an announcement of -00 revision to app-discuss but didn't get any reaction.

> Do you have an experimental implementation already?

Not yet, but I plan to write at least the JSON->XML part.

> Martin, Andy: How about pyang or yuma integration?

Andy mentioned he'd been using it already.

Lada

---

From: Andy Bierman <[email-masked]>
Date: Fri, 15 Jun 2012 14:21:04 -0700

> Andy mentioned he'd been using it already.
I said I plan to use it, but it may be awhile before I have time to work on
it.
It is planned for a commercial version of yuma, not the open-source version.

> > Mehmet

Andy