Subject: [netmod] iana-timezones.yang proposal

From: "Lange, Jeffrey K (GE Energy)" <[email-masked]>
Date: Wed, 27 Jun 2012 13:21:17 +0000

As I mentioned earlier, the current free-form timezone-location string in the ietf-system module is not very user friendly, and those timezone location strings are actually an IANA controlled entity.  I have created an iana-timezones module using the timezones and any textual descriptions found in the zone.tab file found in the Time Zone Data v. 2012c downloaded from the iana website. This has resulted in an enumeration with 415 values.  I have also modified the ietf-system module to use this new data type.

The data was extracted from the zone.tab file using the following cryptic combination of grep, cat, sort, and awk :-)

grep -h -v "^#" zone.tab |awk '{ printf ("%s ", $3); sep=""; for (i=4; i<=NF; i++) {printf("%s%s",sep,$i); sep=OFS}; printf("\n");}' |sort -g |cat -n |awk '{ printf("      enum \"%s\" {\n        value %s;\n        description\n          \"", $2, $1); sep=""; for (i=3; i<=NF; i++) {printf("%s%s",sep,$i); sep=OFS};  print "\";\n      }" }'

I pretty much took the header info from the iana-if-type module verbatim, with minor changes to reflect the fact that it is for timezones, so odds are this would need to be adjusted to be in the correct format.

Not every entry in the enumeration has a description, because not every entry in the zone.tab file has a description.  I'm not sure if this would be kosher in an official release or not.

Below is the changes needed for ietf-system:

diff --git a/[email-masked] b/[email-masked]
index dd26ea1..4e7952c 100644
--- a/[email-masked]
+++ b/[email-masked]
@@ -11,6 +11,9 @@ module ietf-system {
   import ietf-netconf-acm {
     prefix nacm;
   }
+  import iana-timezones {
+    prefix ianatz;
+  }
 
   organization "IETF NETMOD (NETCONF Data Modeling Language) Working Group";
   contact
@@ -882,9 +885,9 @@ module ietf-system {
           "Configure the system timezone information.";
         leaf timezone-location {
           if-feature timezone-location;
-          type string;
+          type ianatz:iana-timezone;
           description
-            "The TZ database location identifier string
+            "The TZ database location enumeration
              to use for the system, such as 'Europe/Stockholm'.";
         }
         leaf timezone-name {

And below is the full text of the iana-timezones.yang file I have created

module iana-timezones {
  namespace "urn:ietf:params:xml:ns:yang:iana-timezones";
  prefix ianatz;

  organization "IANA";
  contact
    "        Internet Assigned Numbers Authority
     
     Postal: ICANN
             4676 Admiralty Way, Suite 330
             Marina del Rey, CA 90292
     
     Tel:    +1 310 823 9358
     E-Mail: iana&iana.org";
  description
    "This YANG module defines the iana-timezone typedef, which
     contains YANG definitions for IANA-registered timezones.
     
     This YANG module is maintained by IANA, and reflects the
     IANA Time Zone Database.
     (http://www.iana.org/time-zones)
     
     The latest revision of this YANG module can be obtained from
     the IANA web site.
     
     Copyright (c) 2011 IETF Trust and the persons identified as
     authors of the code.  All rights reserved.
     
     Redistribution and use in source and binary forms, with or
     without modification, is permitted pursuant to, and subject
     to the license terms contained in, the Simplified BSD License
     set forth in Section 4.c of the IETF Trust's Legal Provisions
     Relating to IETF Documents
     (http://trustee.ietf.org/license-info).
     
     This version of this YANG module is part of RFC XXXX; see
     the RFC itself for full legal notices.";

  revision 2012-06-27 {
    description
      "Initial revision. Using IANA Time Zone Data v. 2012c
       (Released 2012-03-27)";
    reference "RFC XXXX: TITLE";
  }
  typedef iana-timezone {
    type enumeration {
      enum "Africa/Abidjan" {
        value 1;
        description
          "";
      }
      enum "Africa/Accra" {
        value 2;
        description
          "";
      }
      enum "Africa/Addis_Ababa" {
        value 3;
        description
          "";
      }
      enum "Africa/Algiers" {
        value 4;
        description
          "";
      }
      enum "Africa/Asmara" {
        value 5;
        description
          "";
      }
      enum "Africa/Bamako" {
        value 6;
        description
          "";
      }
      enum "Africa/Bangui" {
        value 7;
        description
          "";
      }
      enum "Africa/Banjul" {
        value 8;
        description
          "";
      }
      enum "Africa/Bissau" {
        value 9;
        description
          "";
      }
      enum "Africa/Blantyre" {
        value 10;
        description
          "";
      }
      enum "Africa/Brazzaville" {
        value 11;
        description
          "";
      }
      enum "Africa/Bujumbura" {
        value 12;
        description
          "";
      }
      enum "Africa/Cairo" {
        value 13;
        description
          "";
      }
      enum "Africa/Casablanca" {
        value 14;
        description
          "";
      }
      enum "Africa/Ceuta" {
        value 15;
        description
          "Ceuta & Melilla";
      }
      enum "Africa/Conakry" {
        value 16;
        description
          "";
      }
      enum "Africa/Dakar" {
        value 17;
        description
          "";
      }
      enum "Africa/Dar_es_Salaam" {
        value 18;
        description
          "";
      }
      enum "Africa/Djibouti" {
        value 19;
        description
          "";
      }
      enum "Africa/Douala" {
        value 20;
        description
          "";
      }
      enum "Africa/El_Aaiun" {
        value 21;
        description
          "";
      }
      enum "Africa/Freetown" {
        value 22;
        description
          "";
      }
      enum "Africa/Gaborone" {
        value 23;
        description
          "";
      }
      enum "Africa/Harare" {
        value 24;
        description
          "";
      }
      enum "Africa/Johannesburg" {
        value 25;
        description
          "";
      }
      enum "Africa/Juba" {
        value 26;
        description
          "";
      }
      enum "Africa/Kampala" {
        value 27;
        description
          "";
      }
      enum "Africa/Khartoum" {
        value 28;
        description
          "";
      }
      enum "Africa/Kigali" {
        value 29;
        description
          "";
      }
      enum "Africa/Kinshasa" {
        value 30;
        description
          "west Dem. Rep. of Congo";
      }
      enum "Africa/Lagos" {
        value 31;
        description
          "";
      }
      enum "Africa/Libreville" {
        value 32;
        description
          "";
      }
      enum "Africa/Lome" {
        value 33;
        description
          "";
      }
      enum "Africa/Luanda" {
        value 34;
        description
          "";
      }
      enum "Africa/Lubumbashi" {
        value 35;
        description
          "east Dem. Rep. of Congo";
      }
      enum "Africa/Lusaka" {
        value 36;
        description
          "";
      }
      enum "Africa/Malabo" {
        value 37;
        description
          "";
      }
      enum "Africa/Maputo" {
        value 38;
        description
          "";
      }
      enum "Africa/Maseru" {
        value 39;
        description
          "";
      }
      enum "Africa/Mbabane" {
        value 40;
        description
          "";
      }
      enum "Africa/Mogadishu" {
        value 41;
        description
          "";
      }
      enum "Africa/Monrovia" {
        value 42;
        description
          "";
      }
      enum "Africa/Nairobi" {
        value 43;
        description
          "";
      }
      enum "Africa/Ndjamena" {
        value 44;
        description
          "";
      }
      enum "Africa/Niamey" {
        value 45;
        description
          "";
      }
      enum "Africa/Nouakchott" {
        value 46;
        description
          "";
      }
      enum "Africa/Ouagadougou" {
        value 47;
        description
          "";
      }
      enum "Africa/Porto-Novo" {
        value 48;
        description
          "";
      }
      enum "Africa/Sao_Tome" {
        value 49;
        description
          "";
      }
      enum "Africa/Tripoli" {
        value 50;
        description
          "";
      }
      enum "Africa/Tunis" {
        value 51;
        description
          "";
      }
      enum "Africa/Windhoek" {
        value 52;
        description
          "";
      }
      enum "America/Adak" {
        value 53;
        description
          "Aleutian Islands";
      }
      enum "America/Anchorage" {
        value 54;
        description
          "Alaska Time";
      }
      enum "America/Anguilla" {
        value 55;
        description
          "";
      }
      enum "America/Antigua" {
        value 56;
        description
          "";
      }
      enum "America/Araguaina" {
        value 57;
        description
          "Tocantins";
      }
      enum "America/Argentina/Buenos_Aires" {
        value 58;
        description
          "Buenos Aires (BA, CF)";
      }
      enum "America/Argentina/Catamarca" {
        value 59;
        description
          "Catamarca (CT), Chubut (CH)";
      }
      enum "America/Argentina/Cordoba" {
        value 60;
        description
          "most locations (CB, CC, CN, ER, FM, MN, SE, SF)";
      }
      enum "America/Argentina/Jujuy" {
        value 61;
        description
          "Jujuy (JY)";
      }
      enum "America/Argentina/La_Rioja" {
        value 62;
        description
          "La Rioja (LR)";
      }
      enum "America/Argentina/Mendoza" {
        value 63;
        description
          "Mendoza (MZ)";
      }
      enum "America/Argentina/Rio_Gallegos" {
        value 64;
        description
          "Santa Cruz (SC)";
      }
      enum "America/Argentina/Salta" {
        value 65;
        description
          "(SA, LP, NQ, RN)";
      }
      enum "America/Argentina/San_Juan" {
        value 66;
        description
          "San Juan (SJ)";
      }
      enum "America/Argentina/San_Luis" {
        value 67;
        description
          "San Luis (SL)";
      }
      enum "America/Argentina/Tucuman" {
        value 68;
        description
          "Tucuman (TM)";
      }
      enum "America/Argentina/Ushuaia" {
        value 69;
        description
          "Tierra del Fuego (TF)";
      }
      enum "America/Aruba" {
        value 70;
        description
          "";
      }
      enum "America/Asuncion" {
        value 71;
        description
          "";
      }
      enum "America/Atikokan" {
        value 72;
        description
          "Eastern Standard Time - Atikokan, Ontario and Southampton I, Nunavut";
      }
      enum "America/Bahia" {
        value 73;
        description
          "Bahia";
      }
      enum "America/Bahia_Banderas" {
        value 74;
        description
          "Mexican Central Time - Bahia de Banderas";
      }
      enum "America/Barbados" {
        value 75;
        description
          "";
      }
      enum "America/Belem" {
        value 76;
        description
          "Amapa, E Para";
      }
      enum "America/Belize" {
        value 77;
        description
          "";
      }
      enum "America/Blanc-Sablon" {
        value 78;
        description
          "Atlantic Standard Time - Quebec - Lower North Shore";
      }
      enum "America/Boa_Vista" {
        value 79;
        description
          "Roraima";
      }
      enum "America/Bogota" {
        value 80;
        description
          "";
      }
      enum "America/Boise" {
        value 81;
        description
          "Mountain Time - south Idaho & east Oregon";
      }
      enum "America/Cambridge_Bay" {
        value 82;
        description
          "Mountain Time - west Nunavut";
      }
      enum "America/Campo_Grande" {
        value 83;
        description
          "Mato Grosso do Sul";
      }
      enum "America/Cancun" {
        value 84;
        description
          "Central Time - Quintana Roo";
      }
      enum "America/Caracas" {
        value 85;
        description
          "";
      }
      enum "America/Cayenne" {
        value 86;
        description
          "";
      }
      enum "America/Cayman" {
        value 87;
        description
          "";
      }
      enum "America/Chicago" {
        value 88;
        description
          "Central Time";
      }
      enum "America/Chihuahua" {
        value 89;
        description
          "Mexican Mountain Time - Chihuahua away from US border";
      }
      enum "America/Costa_Rica" {
        value 90;
        description
          "";
      }
      enum "America/Creston" {
        value 91;
        description
          "Mountain Standard Time - Creston, British Columbia";
      }
      enum "America/Cuiaba" {
        value 92;
        description
          "Mato Grosso";
      }
      enum "America/Curacao" {
        value 93;
        description
          "";
      }
      enum "America/Danmarkshavn" {
        value 94;
        description
          "east coast, north of Scoresbysund";
      }
      enum "America/Dawson_Creek" {
        value 95;
        description
          "Mountain Standard Time - Dawson Creek & Fort Saint John, British Columbia";
      }
      enum "America/Dawson" {
        value 96;
        description
          "Pacific Time - north Yukon";
      }
      enum "America/Denver" {
        value 97;
        description
          "Mountain Time";
      }
      enum "America/Detroit" {
        value 98;
        description
          "Eastern Time - Michigan - most locations";
      }
      enum "America/Dominica" {
        value 99;
        description
          "";
      }
      enum "America/Edmonton" {
        value 100;
        description
          "Mountain Time - Alberta, east British Columbia & west Saskatchewan";
      }
      enum "America/Eirunepe" {
        value 101;
        description
          "W Amazonas";
      }
      enum "America/El_Salvador" {
        value 102;
        description
          "";
      }
      enum "America/Fortaleza" {
        value 103;
        description
          "NE Brazil (MA, PI, CE, RN, PB)";
      }
      enum "America/Glace_Bay" {
        value 104;
        description
          "Atlantic Time - Nova Scotia - places that did not observe DST 1966-1971";
      }
      enum "America/Godthab" {
        value 105;
        description
          "most locations";
      }
      enum "America/Goose_Bay" {
        value 106;
        description
          "Atlantic Time - Labrador - most locations";
      }
      enum "America/Grand_Turk" {
        value 107;
        description
          "";
      }
      enum "America/Grenada" {
        value 108;
        description
          "";
      }
      enum "America/Guadeloupe" {
        value 109;
        description
          "";
      }
      enum "America/Guatemala" {
        value 110;
        description
          "";
      }
      enum "America/Guayaquil" {
        value 111;
        description
          "mainland";
      }
      enum "America/Guyana" {
        value 112;
        description
          "";
      }
      enum "America/Halifax" {
        value 113;
        description
          "Atlantic Time - Nova Scotia (most places), PEI";
      }
      enum "America/Havana" {
        value 114;
        description
          "";
      }
      enum "America/Hermosillo" {
        value 115;
        description
          "Mountain Standard Time - Sonora";
      }
      enum "America/Indiana/Indianapolis" {
        value 116;
        description
          "Eastern Time - Indiana - most locations";
      }
      enum "America/Indiana/Knox" {
        value 117;
        description
          "Central Time - Indiana - Starke County";
      }
      enum "America/Indiana/Marengo" {
        value 118;
        description
          "Eastern Time - Indiana - Crawford County";
      }
      enum "America/Indiana/Petersburg" {
        value 119;
        description
          "Eastern Time - Indiana - Pike County";
      }
      enum "America/Indiana/Tell_City" {
        value 120;
        description
          "Central Time - Indiana - Perry County";
      }
      enum "America/Indiana/Vevay" {
        value 121;
        description
          "Eastern Time - Indiana - Switzerland County";
      }
      enum "America/Indiana/Vincennes" {
        value 122;
        description
          "Eastern Time - Indiana - Daviess, Dubois, Knox & Martin Counties";
      }
      enum "America/Indiana/Winamac" {
        value 123;
        description
          "Eastern Time - Indiana - Pulaski County";
      }
      enum "America/Inuvik" {
        value 124;
        description
          "Mountain Time - west Northwest Territories";
      }
      enum "America/Iqaluit" {
        value 125;
        description
          "Eastern Time - east Nunavut - most locations";
      }
      enum "America/Jamaica" {
        value 126;
        description
          "";
      }
      enum "America/Juneau" {
        value 127;
        description
          "Alaska Time - Alaska panhandle";
      }
      enum "America/Kentucky/Louisville" {
        value 128;
        description
          "Eastern Time - Kentucky - Louisville area";
      }
      enum "America/Kentucky/Monticello" {
        value 129;
        description
          "Eastern Time - Kentucky - Wayne County";
      }
      enum "America/Kralendijk" {
        value 130;
        description
          "";
      }
      enum "America/La_Paz" {
        value 131;
        description
          "";
      }
      enum "America/Lima" {
        value 132;
        description
          "";
      }
      enum "America/Los_Angeles" {
        value 133;
        description
          "Pacific Time";
      }
      enum "America/Lower_Princes" {
        value 134;
        description
          "";
      }
      enum "America/Maceio" {
        value 135;
        description
          "Alagoas, Sergipe";
      }
      enum "America/Managua" {
        value 136;
        description
          "";
      }
      enum "America/Manaus" {
        value 137;
        description
          "E Amazonas";
      }
      enum "America/Marigot" {
        value 138;
        description
          "";
      }
      enum "America/Martinique" {
        value 139;
        description
          "";
      }
      enum "America/Matamoros" {
        value 140;
        description
          "US Central Time - Coahuila, Durango, Nuevo Leon, Tamaulipas near US border";
      }
      enum "America/Mazatlan" {
        value 141;
        description
          "Mountain Time - S Baja, Nayarit, Sinaloa";
      }
      enum "America/Menominee" {
        value 142;
        description
          "Central Time - Michigan - Dickinson, Gogebic, Iron & Menominee Counties";
      }
      enum "America/Merida" {
        value 143;
        description
          "Central Time - Campeche, Yucatan";
      }
      enum "America/Metlakatla" {
        value 144;
        description
          "Metlakatla Time - Annette Island";
      }
      enum "America/Mexico_City" {
        value 145;
        description
          "Central Time - most locations";
      }
      enum "America/Miquelon" {
        value 146;
        description
          "";
      }
      enum "America/Moncton" {
        value 147;
        description
          "Atlantic Time - New Brunswick";
      }
      enum "America/Monterrey" {
        value 148;
        description
          "Mexican Central Time - Coahuila, Durango, Nuevo Leon, Tamaulipas away from US border";
      }
      enum "America/Montevideo" {
        value 149;
        description
          "";
      }
      enum "America/Montreal" {
        value 150;
        description
          "Eastern Time - Quebec - most locations";
      }
      enum "America/Montserrat" {
        value 151;
        description
          "";
      }
      enum "America/Nassau" {
        value 152;
        description
          "";
      }
      enum "America/New_York" {
        value 153;
        description
          "Eastern Time";
      }
      enum "America/Nipigon" {
        value 154;
        description
          "Eastern Time - Ontario & Quebec - places that did not observe DST 1967-1973";
      }
      enum "America/Nome" {
        value 155;
        description
          "Alaska Time - west Alaska";
      }
      enum "America/Noronha" {
        value 156;
        description
          "Atlantic islands";
      }
      enum "America/North_Dakota/Beulah" {
        value 157;
        description
          "Central Time - North Dakota - Mercer County";
      }
      enum "America/North_Dakota/Center" {
        value 158;
        description
          "Central Time - North Dakota - Oliver County";
      }
      enum "America/North_Dakota/New_Salem" {
        value 159;
        description
          "Central Time - North Dakota - Morton County (except Mandan area)";
      }
      enum "America/Ojinaga" {
        value 160;
        description
          "US Mountain Time - Chihuahua near US border";
      }
      enum "America/Panama" {
        value 161;
        description
          "";
      }
      enum "America/Pangnirtung" {
        value 162;
        description
          "Eastern Time - Pangnirtung, Nunavut";
      }
      enum "America/Paramaribo" {
        value 163;
        description
          "";
      }
      enum "America/Phoenix" {
        value 164;
        description
          "Mountain Standard Time - Arizona";
      }
      enum "America/Port-au-Prince" {
        value 165;
        description
          "";
      }
      enum "America/Port_of_Spain" {
        value 166;
        description
          "";
      }
      enum "America/Porto_Velho" {
        value 167;
        description
          "Rondonia";
      }
      enum "America/Puerto_Rico" {
        value 168;
        description
          "";
      }
      enum "America/Rainy_River" {
        value 169;
        description
          "Central Time - Rainy River & Fort Frances, Ontario";
      }
      enum "America/Rankin_Inlet" {
        value 170;
        description
          "Central Time - central Nunavut";
      }
      enum "America/Recife" {
        value 171;
        description
          "Pernambuco";
      }
      enum "America/Regina" {
        value 172;
        description
          "Central Standard Time - Saskatchewan - most locations";
      }
      enum "America/Resolute" {
        value 173;
        description
          "Central Standard Time - Resolute, Nunavut";
      }
      enum "America/Rio_Branco" {
        value 174;
        description
          "Acre";
      }
      enum "America/Santa_Isabel" {
        value 175;
        description
          "Mexican Pacific Time - Baja California away from US border";
      }
      enum "America/Santarem" {
        value 176;
        description
          "W Para";
      }
      enum "America/Santiago" {
        value 177;
        description
          "most locations";
      }
      enum "America/Santo_Domingo" {
        value 178;
        description
          "";
      }
      enum "America/Sao_Paulo" {
        value 179;
        description
          "S & SE Brazil (GO, DF, MG, ES, RJ, SP, PR, SC, RS)";
      }
      enum "America/Scoresbysund" {
        value 180;
        description
          "Scoresbysund / Ittoqqortoormiit";
      }
      enum "America/Shiprock" {
        value 181;
        description
          "Mountain Time - Navajo";
      }
      enum "America/Sitka" {
        value 182;
        description
          "Alaska Time - southeast Alaska panhandle";
      }
      enum "America/St_Barthelemy" {
        value 183;
        description
          "";
      }
      enum "America/St_Johns" {
        value 184;
        description
          "Newfoundland Time, including SE Labrador";
      }
      enum "America/St_Kitts" {
        value 185;
        description
          "";
      }
      enum "America/St_Lucia" {
        value 186;
        description
          "";
      }
      enum "America/St_Thomas" {
        value 187;
        description
          "";
      }
      enum "America/St_Vincent" {
        value 188;
        description
          "";
      }
      enum "America/Swift_Current" {
        value 189;
        description
          "Central Standard Time - Saskatchewan - midwest";
      }
      enum "America/Tegucigalpa" {
        value 190;
        description
          "";
      }
      enum "America/Thule" {
        value 191;
        description
          "Thule / Pituffik";
      }
      enum "America/Thunder_Bay" {
        value 192;
        description
          "Eastern Time - Thunder Bay, Ontario";
      }
      enum "America/Tijuana" {
        value 193;
        description
          "US Pacific Time - Baja California near US border";
      }
      enum "America/Toronto" {
        value 194;
        description
          "Eastern Time - Ontario - most locations";
      }
      enum "America/Tortola" {
        value 195;
        description
          "";
      }
      enum "America/Vancouver" {
        value 196;
        description
          "Pacific Time - west British Columbia";
      }
      enum "America/Whitehorse" {
        value 197;
        description
          "Pacific Time - south Yukon";
      }
      enum "America/Winnipeg" {
        value 198;
        description
          "Central Time - Manitoba & west Ontario";
      }
      enum "America/Yakutat" {
        value 199;
        description
          "Alaska Time - Alaska panhandle neck";
      }
      enum "America/Yellowknife" {
        value 200;
        description
          "Mountain Time - central Northwest Territories";
      }
      enum "Antarctica/Casey" {
        value 201;
        description
          "Casey Station, Bailey Peninsula";
      }
      enum "Antarctica/Davis" {
        value 202;
        description
          "Davis Station, Vestfold Hills";
      }
      enum "Antarctica/DumontDUrville" {
        value 203;
        description
          "Dumont-d'Urville Station, Terre Adelie";
      }
      enum "Antarctica/Macquarie" {
        value 204;
        description
          "Macquarie Island Station, Macquarie Island";
      }
      enum "Antarctica/Mawson" {
        value 205;
        description
          "Mawson Station, Holme Bay";
      }
      enum "Antarctica/McMurdo" {
        value 206;
        description
          "McMurdo Station, Ross Island";
      }
      enum "Antarctica/Palmer" {
        value 207;
        description
          "Palmer Station, Anvers Island";
      }
      enum "Antarctica/Rothera" {
        value 208;
        description
          "Rothera Station, Adelaide Island";
      }
      enum "Antarctica/South_Pole" {
        value 209;
        description
          "Amundsen-Scott Station, South Pole";
      }
      enum "Antarctica/Syowa" {
        value 210;
        description
          "Syowa Station, E Ongul I";
      }
      enum "Antarctica/Vostok" {
        value 211;
        description
          "Vostok Station, Lake Vostok";
      }
      enum "Arctic/Longyearbyen" {
        value 212;
        description
          "";
      }
      enum "Asia/Aden" {
        value 213;
        description
          "";
      }
      enum "Asia/Almaty" {
        value 214;
        description
          "most locations";
      }
      enum "Asia/Amman" {
        value 215;
        description
          "";
      }
      enum "Asia/Anadyr" {
        value 216;
        description
          "Moscow+08 - Bering Sea";
      }
      enum "Asia/Aqtau" {
        value 217;
        description
          "Atyrau (Atirau, Gur'yev), Mangghystau (Mankistau)";
      }
      enum "Asia/Aqtobe" {
        value 218;
        description
          "Aqtobe (Aktobe)";
      }
      enum "Asia/Ashgabat" {
        value 219;
        description
          "";
      }
      enum "Asia/Baghdad" {
        value 220;
        description
          "";
      }
      enum "Asia/Bahrain" {
        value 221;
        description
          "";
      }
      enum "Asia/Baku" {
        value 222;
        description
          "";
      }
      enum "Asia/Bangkok" {
        value 223;
        description
          "";
      }
      enum "Asia/Beirut" {
        value 224;
        description
          "";
      }
      enum "Asia/Bishkek" {
        value 225;
        description
          "";
      }
      enum "Asia/Brunei" {
        value 226;
        description
          "";
      }
      enum "Asia/Choibalsan" {
        value 227;
        description
          "Dornod, Sukhbaatar";
      }
      enum "Asia/Chongqing" {
        value 228;
        description
          "central China - Sichuan, Yunnan, Guangxi, Shaanxi, Guizhou, etc.";
      }
      enum "Asia/Colombo" {
        value 229;
        description
          "";
      }
      enum "Asia/Damascus" {
        value 230;
        description
          "";
      }
      enum "Asia/Dhaka" {
        value 231;
        description
          "";
      }
      enum "Asia/Dili" {
        value 232;
        description
          "";
      }
      enum "Asia/Dubai" {
        value 233;
        description
          "";
      }
      enum "Asia/Dushanbe" {
        value 234;
        description
          "";
      }
      enum "Asia/Gaza" {
        value 235;
        description
          "Gaza Strip";
      }
      enum "Asia/Harbin" {
        value 236;
        description
          "Heilongjiang (except Mohe), Jilin";
      }
      enum "Asia/Hebron" {
        value 237;
        description
          "West Bank";
      }
      enum "Asia/Ho_Chi_Minh" {
        value 238;
        description
          "";
      }
      enum "Asia/Hong_Kong" {
        value 239;
        description
          "";
      }
      enum "Asia/Hovd" {
        value 240;
        description
          "Bayan-Olgiy, Govi-Altai, Hovd, Uvs, Zavkhan";
      }
      enum "Asia/Irkutsk" {
        value 241;
        description
          "Moscow+05 - Lake Baikal";
      }
      enum "Asia/Jakarta" {
        value 242;
        description
          "Java & Sumatra";
      }
      enum "Asia/Jayapura" {
        value 243;
        description
          "west New Guinea (Irian Jaya) & Malukus (Moluccas)";
      }
      enum "Asia/Jerusalem" {
        value 244;
        description
          "";
      }
      enum "Asia/Kabul" {
        value 245;
        description
          "";
      }
      enum "Asia/Kamchatka" {
        value 246;
        description
          "Moscow+08 - Kamchatka";
      }
      enum "Asia/Karachi" {
        value 247;
        description
          "";
      }
      enum "Asia/Kashgar" {
        value 248;
        description
          "west Tibet & Xinjiang";
      }
      enum "Asia/Kathmandu" {
        value 249;
        description
          "";
      }
      enum "Asia/Kolkata" {
        value 250;
        description
          "";
      }
      enum "Asia/Krasnoyarsk" {
        value 251;
        description
          "Moscow+04 - Yenisei River";
      }
      enum "Asia/Kuala_Lumpur" {
        value 252;
        description
          "peninsular Malaysia";
      }
      enum "Asia/Kuching" {
        value 253;
        description
          "Sabah & Sarawak";
      }
      enum "Asia/Kuwait" {
        value 254;
        description
          "";
      }
      enum "Asia/Macau" {
        value 255;
        description
          "";
      }
      enum "Asia/Magadan" {
        value 256;
        description
          "Moscow+08 - Magadan";
      }
      enum "Asia/Makassar" {
        value 257;
        description
          "east & south Borneo, Sulawesi (Celebes), Bali, Nusa Tengarra, west Timor";
      }
      enum "Asia/Manila" {
        value 258;
        description
          "";
      }
      enum "Asia/Muscat" {
        value 259;
        description
          "";
      }
      enum "Asia/Nicosia" {
        value 260;
        description
          "";
      }
      enum "Asia/Novokuznetsk" {
        value 261;
        description
          "Moscow+03 - Novokuznetsk";
      }
      enum "Asia/Novosibirsk" {
        value 262;
        description
          "Moscow+03 - Novosibirsk";
      }
      enum "Asia/Omsk" {
        value 263;
        description
          "Moscow+03 - west Siberia";
      }
      enum "Asia/Oral" {
        value 264;
        description
          "West Kazakhstan";
      }
      enum "Asia/Phnom_Penh" {
        value 265;
        description
          "";
      }
      enum "Asia/Pontianak" {
        value 266;
        description
          "west & central Borneo";
      }
      enum "Asia/Pyongyang" {
        value 267;
        description
          "";
      }
      enum "Asia/Qatar" {
        value 268;
        description
          "";
      }
      enum "Asia/Qyzylorda" {
        value 269;
        description
          "Qyzylorda (Kyzylorda, Kzyl-Orda)";
      }
      enum "Asia/Rangoon" {
        value 270;
        description
          "";
      }
      enum "Asia/Riyadh" {
        value 271;
        description
          "";
      }
      enum "Asia/Sakhalin" {
        value 272;
        description
          "Moscow+07 - Sakhalin Island";
      }
      enum "Asia/Samarkand" {
        value 273;
        description
          "west Uzbekistan";
      }
      enum "Asia/Seoul" {
        value 274;
        description
          "";
      }
      enum "Asia/Shanghai" {
        value 275;
        description
          "east China - Beijing, Guangdong, Shanghai, etc.";
      }
      enum "Asia/Singapore" {
        value 276;
        description
          "";
      }
      enum "Asia/Taipei" {
        value 277;
        description
          "";
      }
      enum "Asia/Tashkent" {
        value 278;
        description
          "east Uzbekistan";
      }
      enum "Asia/Tbilisi" {
        value 279;
        description
          "";
      }
      enum "Asia/Tehran" {
        value 280;
        description
          "";
      }
      enum "Asia/Thimphu" {
        value 281;
        description
          "";
      }
      enum "Asia/Tokyo" {
        value 282;
        description
          "";
      }
      enum "Asia/Ulaanbaatar" {
        value 283;
        description
          "most locations";
      }
      enum "Asia/Urumqi" {
        value 284;
        description
          "most of Tibet & Xinjiang";
      }
      enum "Asia/Vientiane" {
        value 285;
        description
          "";
      }
      enum "Asia/Vladivostok" {
        value 286;
        description
          "Moscow+07 - Amur River";
      }
      enum "Asia/Yakutsk" {
        value 287;
        description
          "Moscow+06 - Lena River";
      }
      enum "Asia/Yekaterinburg" {
        value 288;
        description
          "Moscow+02 - Urals";
      }
      enum "Asia/Yerevan" {
        value 289;
        description
          "";
      }
      enum "Atlantic/Azores" {
        value 290;
        description
          "Azores";
      }
      enum "Atlantic/Bermuda" {
        value 291;
        description
          "";
      }
      enum "Atlantic/Canary" {
        value 292;
        description
          "Canary Islands";
      }
      enum "Atlantic/Cape_Verde" {
        value 293;
        description
          "";
      }
      enum "Atlantic/Faroe" {
        value 294;
        description
          "";
      }
      enum "Atlantic/Madeira" {
        value 295;
        description
          "Madeira Islands";
      }
      enum "Atlantic/Reykjavik" {
        value 296;
        description
          "";
      }
      enum "Atlantic/South_Georgia" {
        value 297;
        description
          "";
      }
      enum "Atlantic/Stanley" {
        value 298;
        description
          "";
      }
      enum "Atlantic/St_Helena" {
        value 299;
        description
          "";
      }
      enum "Australia/Adelaide" {
        value 300;
        description
          "South Australia";
      }
      enum "Australia/Brisbane" {
        value 301;
        description
          "Queensland - most locations";
      }
      enum "Australia/Broken_Hill" {
        value 302;
        description
          "New South Wales - Yancowinna";
      }
      enum "Australia/Currie" {
        value 303;
        description
          "Tasmania - King Island";
      }
      enum "Australia/Darwin" {
        value 304;
        description
          "Northern Territory";
      }
      enum "Australia/Eucla" {
        value 305;
        description
          "Western Australia - Eucla area";
      }
      enum "Australia/Hobart" {
        value 306;
        description
          "Tasmania - most locations";
      }
      enum "Australia/Lindeman" {
        value 307;
        description
          "Queensland - Holiday Islands";
      }
      enum "Australia/Lord_Howe" {
        value 308;
        description
          "Lord Howe Island";
      }
      enum "Australia/Melbourne" {
        value 309;
        description
          "Victoria";
      }
      enum "Australia/Perth" {
        value 310;
        description
          "Western Australia - most locations";
      }
      enum "Australia/Sydney" {
        value 311;
        description
          "New South Wales - most locations";
      }
      enum "Europe/Amsterdam" {
        value 312;
        description
          "";
      }
      enum "Europe/Andorra" {
        value 313;
        description
          "";
      }
      enum "Europe/Athens" {
        value 314;
        description
          "";
      }
      enum "Europe/Belgrade" {
        value 315;
        description
          "";
      }
      enum "Europe/Berlin" {
        value 316;
        description
          "";
      }
      enum "Europe/Bratislava" {
        value 317;
        description
          "";
      }
      enum "Europe/Brussels" {
        value 318;
        description
          "";
      }
      enum "Europe/Bucharest" {
        value 319;
        description
          "";
      }
      enum "Europe/Budapest" {
        value 320;
        description
          "";
      }
      enum "Europe/Chisinau" {
        value 321;
        description
          "";
      }
      enum "Europe/Copenhagen" {
        value 322;
        description
          "";
      }
      enum "Europe/Dublin" {
        value 323;
        description
          "";
      }
      enum "Europe/Gibraltar" {
        value 324;
        description
          "";
      }
      enum "Europe/Guernsey" {
        value 325;
        description
          "";
      }
      enum "Europe/Helsinki" {
        value 326;
        description
          "";
      }
      enum "Europe/Isle_of_Man" {
        value 327;
        description
          "";
      }
      enum "Europe/Istanbul" {
        value 328;
        description
          "";
      }
      enum "Europe/Jersey" {
        value 329;
        description
          "";
      }
      enum "Europe/Kaliningrad" {
        value 330;
        description
          "Moscow-01 - Kaliningrad";
      }
      enum "Europe/Kiev" {
        value 331;
        description
          "most locations";
      }
      enum "Europe/Lisbon" {
        value 332;
        description
          "mainland";
      }
      enum "Europe/Ljubljana" {
        value 333;
        description
          "";
      }
      enum "Europe/London" {
        value 334;
        description
          "";
      }
      enum "Europe/Luxembourg" {
        value 335;
        description
          "";
      }
      enum "Europe/Madrid" {
        value 336;
        description
          "mainland";
      }
      enum "Europe/Malta" {
        value 337;
        description
          "";
      }
      enum "Europe/Mariehamn" {
        value 338;
        description
          "";
      }
      enum "Europe/Minsk" {
        value 339;
        description
          "";
      }
      enum "Europe/Monaco" {
        value 340;
        description
          "";
      }
      enum "Europe/Moscow" {
        value 341;
        description
          "Moscow+00 - west Russia";
      }
      enum "Europe/Oslo" {
        value 342;
        description
          "";
      }
      enum "Europe/Paris" {
        value 343;
        description
          "";
      }
      enum "Europe/Podgorica" {
        value 344;
        description
          "";
      }
      enum "Europe/Prague" {
        value 345;
        description
          "";
      }
      enum "Europe/Riga" {
        value 346;
        description
          "";
      }
      enum "Europe/Rome" {
        value 347;
        description
          "";
      }
      enum "Europe/Samara" {
        value 348;
        description
          "Moscow+00 - Samara, Udmurtia";
      }
      enum "Europe/San_Marino" {
        value 349;
        description
          "";
      }
      enum "Europe/Sarajevo" {
        value 350;
        description
          "";
      }
      enum "Europe/Simferopol" {
        value 351;
        description
          "central Crimea";
      }
      enum "Europe/Skopje" {
        value 352;
        description
          "";
      }
      enum "Europe/Sofia" {
        value 353;
        description
          "";
      }
      enum "Europe/Stockholm" {
        value 354;
        description
          "";
      }
      enum "Europe/Tallinn" {
        value 355;
        description
          "";
      }
      enum "Europe/Tirane" {
        value 356;
        description
          "";
      }
      enum "Europe/Uzhgorod" {
        value 357;
        description
          "Ruthenia";
      }
      enum "Europe/Vaduz" {
        value 358;
        description
          "";
      }
      enum "Europe/Vatican" {
        value 359;
        description
          "";
      }
      enum "Europe/Vienna" {
        value 360;
        description
          "";
      }
      enum "Europe/Vilnius" {
        value 361;
        description
          "";
      }
      enum "Europe/Volgograd" {
        value 362;
        description
          "Moscow+00 - Caspian Sea";
      }
      enum "Europe/Warsaw" {
        value 363;
        description
          "";
      }
      enum "Europe/Zagreb" {
        value 364;
        description
          "";
      }
      enum "Europe/Zaporozhye" {
        value 365;
        description
          "Zaporozh'ye, E Lugansk / Zaporizhia, E Luhansk";
      }
      enum "Europe/Zurich" {
        value 366;
        description
          "";
      }
      enum "Indian/Antananarivo" {
        value 367;
        description
          "";
      }
      enum "Indian/Chagos" {
        value 368;
        description
          "";
      }
      enum "Indian/Christmas" {
        value 369;
        description
          "";
      }
      enum "Indian/Cocos" {
        value 370;
        description
          "";
      }
      enum "Indian/Comoro" {
        value 371;
        description
          "";
      }
      enum "Indian/Kerguelen" {
        value 372;
        description
          "";
      }
      enum "Indian/Mahe" {
        value 373;
        description
          "";
      }
      enum "Indian/Maldives" {
        value 374;
        description
          "";
      }
      enum "Indian/Mauritius" {
        value 375;
        description
          "";
      }
      enum "Indian/Mayotte" {
        value 376;
        description
          "";
      }
      enum "Indian/Reunion" {
        value 377;
        description
          "";
      }
      enum "Pacific/Apia" {
        value 378;
        description
          "";
      }
      enum "Pacific/Auckland" {
        value 379;
        description
          "most locations";
      }
      enum "Pacific/Chatham" {
        value 380;
        description
          "Chatham Islands";
      }
      enum "Pacific/Chuuk" {
        value 381;
        description
          "Chuuk (Truk) and Yap";
      }
      enum "Pacific/Easter" {
        value 382;
        description
          "Easter Island & Sala y Gomez";
      }
      enum "Pacific/Efate" {
        value 383;
        description
          "";
      }
      enum "Pacific/Enderbury" {
        value 384;
        description
          "Phoenix Islands";
      }
      enum "Pacific/Fakaofo" {
        value 385;
        description
          "";
      }
      enum "Pacific/Fiji" {
        value 386;
        description
          "";
      }
      enum "Pacific/Funafuti" {
        value 387;
        description
          "";
      }
      enum "Pacific/Galapagos" {
        value 388;
        description
          "Galapagos Islands";
      }
      enum "Pacific/Gambier" {
        value 389;
        description
          "Gambier Islands";
      }
      enum "Pacific/Guadalcanal" {
        value 390;
        description
          "";
      }
      enum "Pacific/Guam" {
        value 391;
        description
          "";
      }
      enum "Pacific/Honolulu" {
        value 392;
        description
          "Hawaii";
      }
      enum "Pacific/Johnston" {
        value 393;
        description
          "Johnston Atoll";
      }
      enum "Pacific/Kiritimati" {
        value 394;
        description
          "Line Islands";
      }
      enum "Pacific/Kosrae" {
        value 395;
        description
          "Kosrae";
      }
      enum "Pacific/Kwajalein" {
        value 396;
        description
          "Kwajalein";
      }
      enum "Pacific/Majuro" {
        value 397;
        description
          "most locations";
      }
      enum "Pacific/Marquesas" {
        value 398;
        description
          "Marquesas Islands";
      }
      enum "Pacific/Midway" {
        value 399;
        description
          "Midway Islands";
      }
      enum "Pacific/Nauru" {
        value 400;
        description
          "";
      }
      enum "Pacific/Niue" {
        value 401;
        description
          "";
      }
      enum "Pacific/Norfolk" {
        value 402;
        description
          "";
      }
      enum "Pacific/Noumea" {
        value 403;
        description
          "";
      }
      enum "Pacific/Pago_Pago" {
        value 404;
        description
          "";
      }
      enum "Pacific/Palau" {
        value 405;
        description
          "";
      }
      enum "Pacific/Pitcairn" {
        value 406;
        description
          "";
      }
      enum "Pacific/Pohnpei" {
        value 407;
        description
          "Pohnpei (Ponape)";
      }
      enum "Pacific/Port_Moresby" {
        value 408;
        description
          "";
      }
      enum "Pacific/Rarotonga" {
        value 409;
        description
          "";
      }
      enum "Pacific/Saipan" {
        value 410;
        description
          "";
      }
      enum "Pacific/Tahiti" {
        value 411;
        description
          "Society Islands";
      }
      enum "Pacific/Tarawa" {
        value 412;
        description
          "Gilbert Islands";
      }
      enum "Pacific/Tongatapu" {
        value 413;
        description
          "";
      }
      enum "Pacific/Wake" {
        value 414;
        description
          "Wake Island";
      }
      enum "Pacific/Wallis" {
        value 415;
        description
          "";
      }
    }
  }
}

Jeff Lange
Lead Software Engineer
GE Energy Services
Digital Energy

T +1 585 242 8375
F +1 585 241 5590
[email-masked]
www.GEDigitalEnergy.com

175 Science Parkway
Rochester, NY 14620 United States

GE imagination at work

---

From: Andy Bierman <[email-masked]>
Date: Wed, 27 Jun 2012 06:39:25 -0700

I'll read it when you publish it as an I-D.
I can change the ietf-system module after you publish
and the WG agrees to publish your module.

Andy

On Wed, Jun 27, 2012 at 6:21 AM, Lange, Jeffrey K (GE Energy) <
[email-masked]> wrote:

> As I mentioned earlier, the current free-form timezone-location string in
> the ietf-system module is not very user friendly, and those timezone
> location strings are actually an IANA controlled entity.  I have created an
> iana-timezones module using the timezones and any textual descriptions
> found in the zone.tab file found in the Time Zone Data v. 2012c downloaded
> from the iana website. This has resulted in an enumeration with 415 values.
>  I have also modified the ietf-system module to use this new data type.
>
> The data was extracted from the zone.tab file using the following cryptic
> combination of grep, cat, sort, and awk :-)
>
> grep -h -v "^#" zone.tab |awk '{ printf ("%s ", $3); sep=""; for (i=4;
> i<=NF; i++) {printf("%s%s",sep,$i); sep=OFS}; printf("\n");}' |sort -g |cat
> -n |awk '{ printf("      enum \"%s\" {\n        value %s;\n
>  description\n          \"", $2, $1); sep=""; for (i=3; i<=NF; i++)
> {printf("%s%s",sep,$i); sep=OFS};  print "\";\n      }" }'
>
> I pretty much took the header info from the iana-if-type module verbatim,
> with minor changes to reflect the fact that it is for timezones, so odds
> are this would need to be adjusted to be in the correct format.
>
> Not every entry in the enumeration has a description, because not every
> entry in the zone.tab file has a description.  I'm not sure if this would
> be kosher in an official release or not.
>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: "Lange, Jeffrey K (GE Energy)" <[email-masked]>
Date: Wed, 27 Jun 2012 13:54:56 +0000

> and the WG agrees to publish your module.

Pardon my ignorance on this one, but how does one go about creating an I-D for this?  as I'm not a member of the working group would I even be able to do this?
-Jeff

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 27 Jun 2012 16:00:41 +0200

> Pardon my ignorance on this one, but how does one go about creating an I-D for this?  as I'm not a member of the working group would I even be able to do this?

The procedure is rather simple. You post an individual I-D, say
draft-lange-netmod-iana-timezone-00.txt, and if the WG supports it,
the I-D might become a WG document (and then the name changes to
draft-ietf-netmod-iana-timezone-00.txt or something like that).  One
critical part in this case will be the IANA Considerations section
since IANA would be in charge to keep the YANG module updated whenever
they change the timezone database and that needs to be clearly
explained such that IANA can do the job.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Andy Bierman <[email-masked]>
Date: Wed, 27 Jun 2012 07:57:58 -0700

On Wed, Jun 27, 2012 at 7:00 AM, Juergen Schoenwaelder <
[email-masked]> wrote:

> > Pardon my ignorance on this one, but how does one go about creating an
> I-D for this?  as I'm not a member of the working group would I even be
> able to do this?
>

My concerns are with the IANA duplication.

I prefer to keep the ietf-system YANG module decoupled from
changes in timezones throughout the world.   Using an enumeration
means that vendors have to ship a specific version of the
timezones YANG module with each server.

When the IANA registry is updated, the iana-*.yang file has to be updated,
and a new RFC published.  After that, vendors hopefully will update their
YANG modules to the latest version, and new products will have the updated
version as they are released.  The vendor has to know exactly what version
of the YANG module to advertise, based on the tzdata library that is
installed.
This seems difficult to maintain.

The code is likely to be updated faster than the YANG modules can be
re-deployed.
If the YANG module does not match what the code actually supports, then
it is not helping, it just making things worse.

Andy

---

From: "Lange, Jeffrey K (GE Energy)" <[email-masked]>
Date: Wed, 27 Jun 2012 15:09:46 +0000

>of the YANG module to advertise, based on the tzdata library that is installed.
>The code is likely to be updated faster than the YANG modules can be re-deployed.

I think that the impact is actually not that great because the YANG module only lists the timezone names, not the rules associated with each timezone in the world.  I don't have any hard references to back me up on this, but I would assume that adding a new timezone location is far less common than changing the rules for a particular timezone.

-Jeff

---

From: Andy Bierman <[email-masked]>
Date: Wed, 27 Jun 2012 08:19:22 -0700

On Wed, Jun 27, 2012 at 8:09 AM, Lange, Jeffrey K (GE Energy) <
[email-masked]> wrote:

> I think that the impact is actually not that great because the YANG module
> only lists the timezone names, not the rules associated with each timezone
> in the world.  I don't have any hard references to back me up on this, but
> I would assume that adding a new timezone location is far less common than
> changing the rules for a particular timezone.
>
>

Good point -- adding new timezones is probably rare, so the module will
not need to change very often.  Probably less often than interface types.
You might want to use that draft as a template for your draft:

http://www.ietf.org/id/draft-ietf-netmod-iana-if-type-04.txt

Andy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 27 Jun 2012 17:21:54 +0200

> it is not helping, it just making things worse.

Minor correction: IANA maintained modules are not published as RFCs.
The rest of your argument may apply. I have no clue how much the
_names_ have changed over the last few years but it should likely be
possible to find out somehow.

/js

---

From: Andy Bierman <[email-masked]>
Date: Wed, 27 Jun 2012 08:30:03 -0700

> possible to find out somehow.
I'm confused.
So what will happen with  draft-ietf-netmod-iana-if-type-04?
Isn't it going to be published as an RFC?
How can tools like yuma extract a YANG module, so when
the statement "import iana-if-type" is parsed, a module
exists to import?

I think the NETMOD WG is signing up to make sure these RFCs
get re-published as needed.

Andy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 27 Jun 2012 17:51:07 +0200

On Wed, Jun 27, 2012 at 08:30:03AM -0700, Andy Bierman wrote:

[...]

> get re-published as needed.

Please check the IANA considerations of these documents whether they
are clear enough and if not lets us know.

/js

PS: Changes to the IANAifType-MIB do not cause a new RFC to appear.

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 27 Jun 2012 17:51:47 +0200 (CEST)

> Isn't it going to be published as an RFC?

Yes.  This is the process to hand over an initial module to IANA.
>From there, IANA maintains the YANG module, and publishes new
revisions on their web site.  Just like they do with IF-MIB.  No new
RFCs are published.

/martin

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 27 Jun 2012 17:53:10 +0200 (CEST)

Sorry, s/IF-MIB/IANAifType-MIB/

/martin

---

From: Andy Bierman <[email-masked]>
Date: Thu, 28 Jun 2012 07:38:18 -0700

....

> revisions on their web site.  Just like they do with IF-MIB.  No new

This is fine I guess, as long as the IANA update announcement
goes to the same mailing list as an RFC announcement.

In general this approach has a conformance flaw -- normative references.
In the referencing document really intends that a specific version (or
later)
be used of the registry, there is no way to do that.  The normative RFC
reference is the same for all versions of the registry.

Andy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 28 Jun 2012 16:50:54 +0200

> reference is the same for all versions of the registry.

If there is a flaw, then it likely applies to many things maintained
by IANA including several MIB modules. I do not think we are going to
address that as part of the NETMOD WG.

/js

---

From: t.petch <[email-masked]>
Date: Thu, 28 Jun 2012 16:49:46 +0100

----- Original Message -----
From: "Andy Bierman" <[email-masked]>
To: "Martin Bjorklund" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, June 28, 2012 3:38 PM

Andy

Some IANA registries are updated only by Standards track RFC, in which
case you see the RFC.

Others are updated by, eg, Expert Review, in which case there is no RFC
and, AFAIK, no IANA announcement.  But the RFC that initiates the
registry should state what is involved in the expert review, who does
what, what discussion or notification should take place on what lists
before a registry is updated.  This happens in the nexus of URI schemes,
e-mail, Content-types and such like.

But once there is a IANA registry, then that is the Normative definition
of it, references to it by URL as for any other website; and yes you can
associate a date with it, to ensure that a previous version of the web
page is used, not something that is often done in the IETF but is there
to be used.

So you can make any rule you want about updating it - eg insist that the
registry contains a version number updated by one every time the
contents change - provided you get it into that initial RFC in a form
that IANA can understand and action; and if IANA have any problems, they
flag them early, as at IETF Last Call.

Tom Petch