Subject: [netmod] NetMod routing cfg

From: Joel Halpern <[email-masked]>
Date: Fri, 20 Jul 2012 12:53:37 -0400

In looking at the spec, and comparing with MIBs in the space, one thing 
appeared to be missing.  I could not see an equivalent of the route-info 
field used to represent tagging that is carried between routing 
protocols by the RIB.

Yours,
Joel

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 25 Jul 2012 13:29:05 +0200

> appeared to be missing.  I could not see an equivalent of the route-info

Do you mean this (from RFC 1213)?

  ipRouteInfo OBJECT-TYPE
      SYNTAX  OBJECT IDENTIFIER
      ACCESS  read-only
      STATUS  mandatory
      DESCRIPTION
              "A reference to MIB definitions specific to the
              particular routing protocol which is responsible
              for this route, as determined by the value
              specified in the route's ipRouteProto value.  If
              this information is not present, its value should
              be set to the OBJECT IDENTIFIER { 0 0 }, which is
              a syntatically valid object identifier, and any
              conformant implementation of ASN.1 and BER must be
              able to generate and recognize this value."
      ::= { ipRouteEntry 13 }

I thought it wasn't relevant to a YANG data model. How could it be used in our context?
 
> field used to represent tagging that is carried between routing 

As I understand it, route tags are specific to protocols, e.g., OSPF has the 32-bit "External Route Tag" while RIP uses a 16-bit "Route Tag".

Thanks, Lada

>
> Yours,
> Joel
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C