Subject: Re: [netmod] I-D Action: draft-ietf-netmod-system-mgmt-01.txt

From: "Lange, Jeffrey K (GE Energy)" <[email-masked]>
Date: Tue, 3 Jul 2012 14:09:24 +0000

Looking over the most recent version of the system-mgmt model I was wondering if it would make sense to pull the configuration-source identity definition out into a more generic model?  I could see this same functionality being needed for other things.  I guess if you wanted to use the configuration-source type from a separate module you could import the system module, and use it that way, but then you bring along all the rpcs and everything else that you might not want to use.. 

-Jeff

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Saturday, June 30, 2012 6:36 PM
To: [email-masked]
Cc: [email-masked]
Subject: [netmod] I-D Action: draft-ietf-netmod-system-mgmt-01.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the NETCONF Data Modeling Language Working Group of the IETF.

	Title           : YANG Data Model for System Management
	Author(s)       : Andy Bierman
                          Martin Bjorklund
	Filename        : draft-ietf-netmod-system-mgmt-01.txt
	Pages           : 31
	Date            : 2012-06-30

Abstract:
   This document defines a YANG data model for the configuration and
   identification of the management system of a device.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netmod-system-mgmt

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-netmod-system-mgmt-01

A diff from previous version is available at:
http://tools.ietf.org/rfcdiff?url2=draft-ietf-netmod-system-mgmt-01

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Andy Bierman <[email-masked]>
Date: Tue, 3 Jul 2012 09:02:34 -0700

> Looking over the most recent version of the system-mgmt model I was wondering if it would make sense to pull the configuration-source identity definition out into a more generic model?  I could see…

Yes -- but we could end up with a separate module for every definition if we
followed this logic to its conclusion.

Thanks for bringing up one of the more annoying YANG conformance
issues again. ;-)
Any vendor who wants to use these identities has to import ietf-system.yang, and
therefore has to advertise ietf-system in the <hello>.   The client
will think the
server implements all the mandatory parts of ietf-system.  If it is
not advertised,
then the client has only a string 'ietf-system' which is not even
intended to be unique.

IMO we either have to split all data and meta-data into separate YANG modules,
of fix the NETCONF/YANG conformance model so "module set I use" and
"objects I implement"
are separated.

> -Jeff

Andy

---

From: "Lange, Jeffrey K (GE Energy)" <[email-masked]>
Date: Tue, 3 Jul 2012 17:52:31 +0000

I would like to suggest changing the newly added iburst and prefer ntp boolean leafs to have a default value of 'false'  Currently they do not have a default value, and I would assume that most implementations would take a lack of value to mean false, but for something as simple as a Boolean, it would make things a lot clearer if it was just stated up front that the default is false.

-Jeff

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Saturday, June 30, 2012 6:36 PM
To: [email-masked]
Cc: [email-masked]
Subject: [netmod] I-D Action: draft-ietf-netmod-system-mgmt-01.txt

Abstract: