Subject: [netmod] LL review of {interfaces,ip}-cfg-05

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 26 Jul 2012 14:52:35 +0200

Hi,

I read both drafts and I think overall they are in a good shape. My issues are mostly common to both drafts so I will deal with them together.

*** Technical
My main concern is the lack of operational state data. For an effective management, it is necessary to have operational info at least in the extent provided by the "ip" command in Linux. I am not sure whether the intention is (i) to develop other module(s) with this stuff later, or (ii) to rely on SNMP for this purpose.

*** Formal
1. The sections containing YANG code start with a sentence like
   "This YANG module imports a typedef from ...". Strictly speaking,
   this is not correct because the 'import' statement imports entire
   modules and not only selected items. On the other hand, this
   sentence is redundant because 'import' statements have a prominent
   place at the beginning of each module. I propose to remove these
   sentences and start each section right away with <CODE BEGINS>.
2. Section 6. ("Security Considerations") of ip-cfg-05, in the
   paragraph about "ipv4/ip-forwarding" and "ipv6/ip-forwarding": I
   propose to change both occurrences of "routing functions" to
   "forwarding functions", because other routing functions such as
   routing protocol exchange may be performed even on interfaces with
   disabled forwarding.

Lada

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 26 Jul 2012 21:13:58 +0200

> My main concern is the lack of operational state data. For an effective management, it is necessary to have operational info at least in the extent provided by the "ip" command in Linux. I am not s…

Since there is no general plan, the decision was to focus this work on
configuration at this point in time.
 
>    sentences and start each section right away with <CODE BEGINS>.

These sentence are there so that we have citations of the normative
references in the text (otherwise IETF tools yell at you). While it is
true that a YANG import imports a module, I think the current text is
not wrong - it actually adds additional clarity by stating what is
used from the module(s).

>    routing protocol exchange may be performed even on interfaces with

I agree. It seems also the text starting with "=ipv6/autoconf" should
have been a separate paragraph.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 26 Jul 2012 22:27:47 +0200

> configuration at this point in time.

I think the WG should come up with a general plan.

> not wrong - it actually adds additional clarity by stating what is

Then it may be changed to: "This YANG module uses typedef XY from the imported module …".

Lada

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 27 Jul 2012 16:49:15 +0200

> references in the text (otherwise IETF tools yell at you). While it is

In the routing draft, I (unintentionally) implemented another workaround: a table in sec. 2.2 showing the correspondence between prefixes and module names, with references to the normative documents. This seems more useful than the introductory sequences, especially if some of the prefixes are used in the main text.

Lada

---

From: Martin Bjorklund <[email-masked]>
Date: Sun, 29 Jul 2012 16:38:16 +0200 (CEST)

Ladislav Lhotka <[email-masked]> wrote:
> In the routing draft, I (unintentionally) implemented another workaround: a
> table in sec. 2.2 showing the correspondence between prefixes and module
> names, with references to the normative documents. This seems more useful than
> the introductory sequences, especially if some of the prefixes are used in the
> main text.

But this doesn't really work if the main text doesn't use these
prefixes.

The current technique is not new - it is used for MIBs in several
RFCs.

/martin

---

From: Martin Bjorklund <[email-masked]>
Date: Sun, 29 Jul 2012 16:36:24 +0200 (CEST)

Juergen Schoenwaelder <[email-masked]> wrote:
> I agree.

Fixed.

> It seems also the text starting with "=ipv6/autoconf" should

Yes.  Typo in the source.  Also fixed.

/martin

---

From: Ladislav Lhotka <[email-masked]>
Date: Sun, 29 Jul 2012 15:19:07 -0700

> But this doesn't really work if the main text doesn't use these

Well, it does work in that it pulls the normative references into the text body.

> The current technique is not new - it is used for MIBs in several

Yes, but MIBs - unlike YANG - really specify the individual object definitions that are imported from other MIBs, so that's why I think the formulation for YANG modules should be at least slightly adjusted.

Lada