Subject: [netmod] FW: draft-lange-netmod-iana-timezones

From: "Lange, Jeffrey K (GE Energy)" <[email-masked]>
Date: Mon, 30 Jul 2012 12:40:14 +0000

I received this comment this morning on the timezones data model.  As this document is now in the hands of the working group I thought I would pass along this comment to the group.

Should enum value 0 be a “unknown” state?  There is no such value in the iana timezone database, and in netconf, if the node is not configured, it just wouldn’t be present correct?

Thanks
-Jeff

From: Jeffrey Sarnoff [mailto:[email-masked]]
Sent: Saturday, July 28, 2012 3:17 PM
To: [email-masked]
Subject: draft-lange-netmod-iana-timezones

Re: http://tools.ietf.org/id/draft-lange-netmod-iana-timezones-01.txt

In the document, the enumeration value of zero is assigned (Andorra had been valued 1).
I would prefer that the zero valued enumeration remain unassigned to a specific timezone location.
It has been a convenient and sensible way to indicate 'the local timezone' in situations where the specific localization is as yet unknown or otherwise unresolved.

Respectfully,

Jeffrey Sarnoff
<jeffrey dot sarnoff, gmail>

---

From: Andy Bierman <[email-masked]>
Date: Mon, 30 Jul 2012 07:15:03 -0700

NETCONF enums use the label on the wire.
The enum value is a meaningless field that
never appears on the wire.  (This is not SNMP).

But no, this typedef needs to match the official version.
It is not a clone to be reinvented by this WG.

Andy

On Mon, Jul 30, 2012 at 5:40 AM, Lange, Jeffrey K (GE Energy)
<[email-masked]> wrote:
> I received this comment this morning on the timezones data model.  As this
> document is now in the hands of the working group I thought I would pass
> along this comment to the group.
>
>
>
> Should enum value 0 be a “unknown” state?  There is no such value in the
> iana timezone database, and in netconf, if the node is not configured, it
> just wouldn’t be present correct?
>

As with all leafs, there is no value returned for a missing leaf
(without a default).

> It has been a convenient and sensible way to indicate 'the local timezone'
> in situations where the specific localization is as yet unknown or otherwise
> unresolved.
>
> Respectfully,
>
> Jeffrey Sarnoff
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 30 Jul 2012 16:31:16 +0200

> Should enum value 0 be a “unknown” state?  There is no such value in the iana timezone database, and in netconf, if the node is not configured, it just wouldn’t be present correct?

For NETCONF, the enum's value does not matter much since the enum's
label is shipped on the wire. That said, it has been useful practice
for many IANA registries to assign numbers starting from 1 with 0
being reserved for a future use. But note that reserved means that the
number remains simply unassigned. Following that practice, we could
indeed start numbering with 1 and leave 0 unassigned. However, it
might not give the requestor what he is looking for and I agree that
if the timezone is not configured, it is not configured.

If the goal is to support something outside of the standard, then
the proposer of this change should note that the timezone in
draft-ietf-netmod-system-mgmt-02 is defined as a choice - it is
possible to augment that choice.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>