Subject: [netmod] circular chains - imports vs includes

From: "Martin Ciglan -X (mciglan - PANTHEON TECHNOLOGIES at Cisco)" <[email-masked]>
Date: Tue, 14 Feb 2017 13:30:36 +0000

Hi all

RFC says:

There MUST NOT be any circular chains of imports.  For example, if module "a" imports module "b", "b" cannot import "a".

Does same apply to includes too?

   Thanks

        Martin

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 14 Feb 2017 14:35:36 +0100

> On 14 Feb 2017, at 14:30, Martin Ciglan -X (mciglan - PANTHEON TECHNOLOGIES at Cisco) <[email-masked]> wrote:
> 
> Hi all
> 
> RFC says:
> 

Not in YANG 1.1 because "include" in a submodule is essentially a no-op - it is syntactically permitted only for compatibility with YANG 1.0.

Lada

>  
> 
>    Thanks
> 
>         Martin
> 
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67