Subject: [netmod] YANG - valid enumeration names

From: "Martin Ciglan -X (mciglan - PANTHEON TECHNOLOGIES at Cisco)" <[email-masked]>
Date: Tue, 14 Feb 2017 12:26:15 +0000

Hi all

RFC says:

All assigned names in an enumeration MUST be unique.?

We're wondering here, if something like this is valid YANG snippet:

...
leaf foo {
type enumeration {
enum Foo;
enum foo;
}
}
...

  Thanks for help

       Martin

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 14 Feb 2017 13:32:44 +0100 (CET)

> We're wondering here, if something like this is valid YANG snippet:

Yes this is valid.

/martin