Subject: [netmod] WG adoption poll draft-bjorklund-netmod-yang-tree-diagrams

From: Kent Watsen <[email-masked]>
Date: Fri, 7 Apr 2017 23:22:51 +0000

All,

This is start of a two-week poll on making the following draft a 
NETMOD working group document:

  draft-bjorklund-netmod-yang-tree-diagrams

Please send email to the list indicating "yes/support" or "no/do not
support".  If indicating no, please state your reservations with the
document.  If yes, please also feel free to provide comments you'd like
to see addressed once the document is a WG document.

Thank you,
NETMOD WG Chairs

---

From: Alexander Clemm <[email-masked]>
Date: Sat, 8 Apr 2017 01:16:43 +0000

I do have a question re: the rationale that is given in the document: " Today's Common practice is include the definition of the syntax used   to represent a YANG module in every document that provides a tree diagram.  This practice has several disadvantages and the purpose of   the document is to provide a single location for this definition. "

I am not sure how much simplification this will really bring - is the boilerplate paragraph we find in drafts with YANG tree diagrams today really that a big problem, specifically while the snippet is still small enough (and could arguably even be generated by pyang itself, if extended accordingly, for easy pasting into drafts)?  While having a common and consistent definition in a central location is appreciated, one implication as the tree notation evolves will be that documents may now have to be specific as to which notation revision is used (as the notation might be updated, revisions might need to be maintained, although it is understood that churn will be kept to a minimum).  

--- Alex

-----Original Message-----
From: netmod [mailto:[email-masked]] On Behalf Of Kent Watsen
Sent: Friday, April 07, 2017 4:23 PM
To: [email-masked]
Cc: [email-masked]
Subject: [netmod] WG adoption poll draft-bjorklund-netmod-yang-tree-diagrams

All,

This is start of a two-week poll on making the following draft a NETMOD working group document:

Please send email to the list indicating "yes/support" or "no/do not support".  If indicating no, please state your reservations with the document.  If yes, please also feel free to provide comments you'd like to see addressed once the document is a WG document.

Thank you,
NETMOD WG Chairs

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Andy Bierman <[email-masked]>
Date: Sat, 8 Apr 2017 12:25:40 -0700

On Fri, Apr 7, 2017 at 6:16 PM, Alexander Clemm <[email-masked]>
wrote:

> I do have a question re: the rationale that is given in the document: "
> Today's Common practice is include the definition of the syntax used   to
> represent a YANG module in every document that provides a tree diagram.
> This practice has several disadvantages and the purpose of   the document
> is to provide a single location for this definition. "
>
> I am not sure how much simplification this will really bring - is the
> boilerplate paragraph we find in drafts with YANG tree diagrams today
> really that a big problem, specifically while the snippet is still small
> enough (and could arguably even be generated by pyang itself, if extended
> accordingly, for easy pasting into drafts)?  While having a common and
> consistent definition in a central location is appreciated, one implication
> as the tree notation evolves will be that documents may now have to be
> specific as to which notation revision is used (as the notation might be
> updated, revisions might need to be maintained, although it is understood
> that churn will be kept to a minimum).
>
>

I think the idea is that the current practice of including a terminology
section for
YANG tree diagrams would stop.  Instead, there will be an Informative
reference
to the YANG tree diagram RFC. Then YANG tree diagrams can appear in the
document
matching the syntax in the tree diagrams RFC.

I support the new RFC and also the idea that these diagrams need to be
consistent to have value for YANG readers.  I do not like the current
ad-hoc practice or reinventing the syntax in each RFC that uses a tree
diagram.

> --- Alex

Andy

> document.  If yes, please also feel free to provide comments you'd like to
> see addressed once the document is a WG document.
>
>
> Thank you,
> NETMOD WG Chairs
>
>

---

From: Robert Wilton <[email-masked]>
Date: Mon, 10 Apr 2017 09:50:40 +0100

Yes/support.

On 08/04/2017 00:22, Kent Watsen wrote:
> .

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 10 Apr 2017 10:54:44 +0200

> On 10 Apr 2017, at 10:50, Robert Wilton <[email-masked]> wrote:
> 
> Yes/support.

Support. Lada

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: wangzitao <[email-masked]>
Date: Mon, 10 Apr 2017 09:05:45 +0000

Support.
-Michael

-----邮件原件-----
发件人: Kent Watsen [mailto:[email-masked]] 
发送时间: 2017年4月8日 7:23
收件人: [email-masked]
抄送: [email-masked]
主题: WG adoption poll draft-bjorklund-netmod-yang-tree-diagrams

All,

Thank you,
NETMOD WG Chairs

---

From: Lou Berger <[email-masked]>
Date: Thu, 13 Apr 2017 16:32:52 -0400

Hi,

As contributor:

I don't know of any IPR on this document, and support its adoption.

Lou

---

From: "Xufeng Liu" <[email-masked]>
Date: Fri, 14 Apr 2017 13:56:02 -0400

yes/support.

Regards,
- Xufeng

> Sent: Friday, April 7, 2017 7:23 PM
> To: [email-masked]
support".  If
> indicating no, please state your reservations with the document.  If yes,
please
> also feel free to provide comments you'd like to see addressed once the
> document is a WG document.
> 
> 
> Thank you,
> NETMOD WG Chairs
> 
>

---

From: Christian Hopps <[email-masked]>
Date: Fri, 14 Apr 2017 22:57:35 -0400

yes/support.

Thanks,
Chris.