Subject: [netmod] Query on Announcing Conformance Information in the <hello> Message

From: Dhirendra Trivedi <[email-masked]>
Date: Thu, 20 Apr 2017 19:06:59 +0530

Hi All,

We had requirement of implementing ietf-netconf-monitoring YANG model

and we did it but partially. Now we need to advertise the deviation module

in the netconf server capability.

I tried doing it like

<capability>

urn:ietf:params:xml:ns:yang:ietf-netconf-monitoring?module=ietf-netconf-monitoring&amp;deviations=jnx-ietf-netocnf-monitoring-dev

</capability>

but it seems OpenDaylight controller is not taking it as valid capability.
Not sure

if the capability is syntactically incorrect or OpenDaylight controller is
having bug.

Is there way to validate the syntax of above capability?

Regards,

Dhirendra

---

From: Kent Watsen <[email-masked]>
Date: Thu, 20 Apr 2017 16:26:00 +0000

Is there a typo in your capability line?  s/netocnf/netconf/
Is your server also advertising jnx-ietf-netocnf-monitoring-dev in its hello message?

BTW, be aware that servers supporting RFC7950 no longer have "deviations=" in the
capability string, as the server is now expected to use YANG Library to announce
conformance.

K.

On 4/20/17, 9:36 AM, "netmod on behalf of Dhirendra Trivedi" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi All,

but it seems OpenDaylight controller is not taking it as valid capability. Not sure
if the capability is syntactically incorrect or OpenDaylight controller is having bug.

Regards,
Dhirendra

---

From: Andy Bierman <[email-masked]>
Date: Thu, 20 Apr 2017 09:35:11 -0700

On Thu, Apr 20, 2017 at 6:36 AM, Dhirendra Trivedi <[email-masked]>
wrote:

>      urn:ietf:params:xml:ns:yang:ietf-netconf-monitoring?
> module=ietf-netconf-monitoring&amp;deviations=jnx-
> ietf-netocnf-monitoring-dev
>
> </capability>
>
>
>

Yes -- it looks correct.
The structure is defined in RFC 6020:
https://tools.ietf.org/html/rfc6020#section-5.6.4

Regards,
> Dhirendra
Andy

>
>
>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>
>

---

From: Andy Bierman <[email-masked]>
Date: Thu, 20 Apr 2017 09:42:16 -0700

> capability string, as the server is now expected to use YANG Library to

Not quite.
YANG 1.0 modules are still advertised according to RFC 6020.
YANG 1.1 module capability URIs are left out of the <hello>.

We ignore that rule and put them in the server <hello> because most client
tools don't follow
the RFC 7950 rules correctly. In our client, if the server advertises
"module-set-id"
then we read the /modules-state subtree (unless our cached data matches the
module-set-id).
We read /netconf-state/schemas if needed as well.

Andy

>
>
> On 4/20/17, 9:36 AM, "netmod on behalf of Dhirendra Trivedi" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>
>
> Hi All,
>
>
>

---

From: Robert Varga <[email-masked]>
Date: Fri, 28 Apr 2017 18:26:53 +0200

> https://tools.ietf.org/html/rfc6020#section-5.6.4

Hello Andy,

One thing that is not quite clear in RFC6020 due to not being clear what
'supported module' means.

Should deviations be applied in case a module is advertised, but is not
mentioned in a deviations parameter like this:

   <hello xmlns="urn:ietf:params:xml:ns:netconf:base:1.0">
       <capability>
         http://example.com/syslog?module=syslog
       </capability>
       <capability>
         http://example.com/my-deviations?module=my-devs
       </capability>
     </hello>

If not, does this imply that any deviation statement targeting an
external module, which does not have a matching deviations parameter
should silently be ignored?

Thanks,
Robert