Subject: [netmod] Important: Guidelines for YANG module authors

From: Benoit Claise <[email-masked]>
Date: Fri, 9 Jun 2017 15:56:39 +0200

Dear all,

Now that the new NETMOD and NETCONF charters have been approved, it's 
time to think about the guidelines for YANG module authors.

The Network Management Datastore Architecture (NMDA) addresses the 
so-called "OpState problem" that has been the subject of much discussion 
in the IETF. NMDA is still in development, and there will be a 
transition period before NMDA solutions are universally available.

The NETMOD Datastore Design Team and the Routing Yang Architecture 
Design Team have worked with Alia and Benoit to create initial 
guidelines for how the NMDA, as defined in 
draft-ietf-netmod-revised-datastores 
<https://datatracker.ietf.org/doc/draft-ietf-netmod-revised-datastores/>, 
impacts Yang models. The draft-dsdt-nmda-guidelines 
<https://datatracker.ietf.org/doc/draft-dsdt-nmda-guidelines/> 
individual draft was foundational in helping creating those guidelines.

If you have questions or concerns on how these guidelines should apply 
to work of interest, please contact your WG Chairs or ADs.

It is our strong recommendation, as ADs with agreement from the NETMOD 
WG Chairs, that models SHOULD move as quickly as possible to the NMDA. 
The specific approach to be taken for models being developed now and 
during the NMDA transition period should be based on both the expected 
usage and the maturity of the data model.

1. New models and models that are not concerned with the operational 
state of configuration information SHOULD immediately be structured to 
be NMDA-compatible.

2. Models that require immediate support for "in use" and "system 
created" information SHOULD be structured for NMDA. Then derived 
versions of these models SHOULD be created, either by hand or with 
suitable tools, that follow the current modeling strategies. In some 
cases, the non-NMDA model may be an existing model and not derived from 
the NMDA model. In all cases, the NMDA and non-NMDA modules SHOULD be 
published in the same document, with NMDA modules in the document main 
body and the non-NMDA modules in an Appendix. The use of the non-NMDA 
model will allow temporary bridging of the time period until NMDA 
implementations are available. The non-NMDA module names should include 
’-state’ appended.

We would like to thank Kent Watsen, Lou Berger, Rob Wilton, Martin 
Bjorklund, Phil Shafer, Acee Lindem, Chris Hopps, Juergen Schoenwaelder, 
and all others who helped develop these guidelines.

Regards,
Alia Atlas, Routing AD
Deborah Brungard, Routing AD
Alvaro Retana, Routing AD
Warren Kumari, Operations & Management AD
Benoit Claise, Operations & Management AD

---

From: Lou Berger <[email-masked]>
Date: Fri, 9 Jun 2017 10:12:10 -0400

Benoit,

    Thanks for this!

WG,

    Now would be a good time to take a look at, and comment on,
draft-dsdt-nmda-guidelines
<https://datatracker.ietf.org/doc/draft-dsdt-nmda-guidelines/> also
consider how this document impacts draft-ietf-netmod-rfc6087bis
(particularly section 5.23).  Optimally we could have a proposed
revision to draft-ietf-netmod-rfc6087bis discussed on the list prior to
Prague, but I know I'm being optimistic.

Lou and Kent

On 6/9/2017 9:56 AM, Benoit Claise wrote:
> so-called "OpState problem" that has been the subject of much
> discussion in the IETF. NMDA is still in development, and there will
> be a transition period before NMDA solutions are universally available.
>
> cases, the non-NMDA model may be an existing model and not derived
> from the NMDA model. In all cases, the NMDA and non-NMDA modules
> SHOULD be published in the same document, with NMDA modules in the
> document main body and the non-NMDA modules in an Appendix. The use of
> the non-NMDA model will allow temporary bridging of the time period
> until NMDA implementations are available. The non-NMDA module names
> should include ’-state’ appended.
>
> Bjorklund, Phil Shafer, Acee Lindem, Chris Hopps, Juergen
> Schoenwaelder, and all others who helped develop these guidelines.
>
> Regards,
> Alia Atlas, Routing AD
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Andy Bierman <[email-masked]>
Date: Fri, 9 Jun 2017 10:06:24 -0700

Hi,

I am trying to complete rfc6087bis.
It has been held up waiting for this draft.
It is not clear to me how sec. 6.23 (Operational Data) needs to change.
Should the whole section be replaced by an informative reference to this
new draft?

Andy

On Fri, Jun 9, 2017 at 6:56 AM, Benoit Claise <[email-masked]> wrote:

> Dear all,
>
> Now that the new NETMOD and NETCONF charters have been approved, it's time
> to think about the guidelines for YANG module authors.
>
> so-called "OpState problem" that has been the subject of much discussion in
> the IETF. NMDA is still in development, and there will be a transition
> period before NMDA solutions are universally available.
>
> The NETMOD Datastore Design Team and the Routing Yang Architecture Design
> Team have worked with Alia and Benoit to create initial guidelines for how
> the NMDA, as defined in draft-ietf-netmod-revised-datastores
> <https://datatracker.ietf.org/doc/draft-dsdt-nmda-guidelines/> individual
> draft was foundational in helping creating those guidelines.
>
> If you have questions or concerns on how these guidelines should apply to
> work of interest, please contact your WG Chairs or ADs.
>
> It is our strong recommendation, as ADs with agreement from the NETMOD WG
> Chairs, that models SHOULD move as quickly as possible to the NMDA. The
> specific approach to be taken for models being developed now and during the
> NMDA transition period should be based on both the expected usage and the
> maturity of the data model.
>
> 1. New models and models that are not concerned with the operational state
> of configuration information SHOULD immediately be structured to be
> NMDA-compatible.
>
> 2. Models that require immediate support for "in use" and "system created"
> information SHOULD be structured for NMDA. Then derived versions of these
> models SHOULD be created, either by hand or with suitable tools, that
> follow the current modeling strategies. In some cases, the non-NMDA model
> may be an existing model and not derived from the NMDA model. In all cases,
> the NMDA and non-NMDA modules SHOULD be published in the same document,
> with NMDA modules in the document main body and the non-NMDA modules in an
> Appendix. The use of the non-NMDA model will allow temporary bridging of
> the time period until NMDA implementations are available. The non-NMDA
> module names should include ’-state’ appended.
>

---

From: Kent Watsen <[email-masked]>
Date: Sat, 10 Jun 2017 03:42:41 +0000

Yes, let's rewrite 6.23 completely to state more helpfully what's in the guidelines draft.

I don't expect the guidelines doc is going to progress independently.

Kent. // shepherd

On Jun 9, 2017, at 1:06 PM, Andy Bierman <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

I am trying to complete rfc6087bis.
It has been held up waiting for this draft.
It is not clear to me how sec. 6.23 (Operational Data) needs to change.
Should the whole section be replaced by an informative reference to this new draft?

Andy

On Fri, Jun 9, 2017 at 6:56 AM, Benoit Claise <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

Now that the new NETMOD and NETCONF charters have been approved, it's time to think about the guidelines for YANG module authors.

The Network Management Datastore Architecture (NMDA) addresses the so-called "OpState problem" that has been the subject of much discussion in the IETF. NMDA is still in development, and there will be a transition period before NMDA solutions are universally available.

The NETMOD Datastore Design Team and the Routing Yang Architecture Design Team have worked with Alia and Benoit to create initial guidelines for how the NMDA, as defined in draft-ietf-netmod-revised-datastores<https://datatracker.ietf.org/doc/draft-ietf-netmod-revised-datastores/>, impacts Yang models. The draft-dsdt-nmda-guidelines<https://datatracker.ietf.org/doc/draft-dsdt-nmda-guidelines/> individual draft was foundational in helping creating those guidelines.

If you have questions or concerns on how these guidelines should apply to work of interest, please contact your WG Chairs or ADs.

It is our strong recommendation, as ADs with agreement from the NETMOD WG Chairs, that models SHOULD move as quickly as possible to the NMDA. The specific approach to be taken for models being developed now and during the NMDA transition period should be based on both the expected usage and the maturity of the data model.

1. New models and models that are not concerned with the operational state of configuration information SHOULD immediately be structured to be NMDA-compatible.

2. Models that require immediate support for "in use" and "system created" information SHOULD be structured for NMDA. Then derived versions of these models SHOULD be created, either by hand or with suitable tools, that follow the current modeling strategies. In some cases, the non-NMDA model may be an existing model and not derived from the NMDA model. In all cases, the NMDA and non-NMDA modules SHOULD be published in the same document, with NMDA modules in the document main body and the non-NMDA modules in an Appendix. The use of the non-NMDA model will allow temporary bridging of the time period until NMDA implementations are available. The non-NMDA module names should include ’-state’ appended.

We would like to thank Kent Watsen, Lou Berger, Rob Wilton, Martin Bjorklund, Phil Shafer, Acee Lindem, Chris Hopps, Juergen Schoenwaelder, and all others who helped develop these guidelines.

Regards,
Alia Atlas, Routing AD

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod

---

From: Benoit Claise <[email-masked]>
Date: Sat, 10 Jun 2017 08:49:19 +0200

> I don't expect the guidelines doc is going to progress independently.
Agreed.

Regards, B.
>>     Now that the new NETMOD and NETCONF charters have been approved,
>>     it's time to think about the guidelines for YANG module authors.
>>
>>     The Network Management Datastore Architecture (NMDA) addresses
>>     the so-called "OpState problem" that has been the subject of much
>>     discussion in the IETF. NMDA is still in development, and there
>>     will be a transition period before NMDA solutions are universally
>>     available.
>>
>>     The NETMOD Datastore Design Team and the Routing Yang
>>     Architecture Design Team have worked with Alia and Benoit to
>>     create initial guidelines for how the NMDA, as defined in
>>     If you have questions or concerns on how these guidelines should
>>     apply to work of interest, please contact your WG Chairs or ADs.
>>
>>     It is our strong recommendation, as ADs with agreement from the
>>     NETMOD WG Chairs, that models SHOULD move as quickly as possible
>>     to the NMDA. The specific approach to be taken for models being
>>     developed now and during the NMDA transition period should be
>>     based on both the expected usage and the maturity of the data model.
>>
>>     1. New models and models that are not concerned with the
>>     operational state of configuration information SHOULD immediately
>>     be structured to be NMDA-compatible.
>>
>>     versions of these models SHOULD be created, either by hand or
>>     with suitable tools, that follow the current modeling strategies.
>>     In some cases, the non-NMDA model may be an existing model and
>>     not derived from the NMDA model. In all cases, the NMDA and
>>     non-NMDA modules SHOULD be published in the same document, with
>>     NMDA modules in the document main body and the non-NMDA modules
>>     in an Appendix. The use of the non-NMDA model will allow
>>     temporary bridging of the time period until NMDA implementations
>>     are available. The non-NMDA module names should include ’-state’
>>     appended.
>>
>>     We would like to thank Kent Watsen, Lou Berger, Rob Wilton,
>>     Martin Bjorklund, Phil Shafer, Acee Lindem, Chris Hopps, Juergen
>>     [email-masked] <mailto:[email-masked]>
>>     <https://www.ietf.org/mailman/listinfo/netmod>
>>
>>
>> [email-masked] <mailto:[email-masked]>