Subject: Re: [netmod] Some comments on yang tree diagrams

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 19 Jun 2017 15:16:45 +0000

Hi Michael, 

On 6/19/17, 3:20 AM, "netmod on behalf of wangzitao"
<[email-masked] on behalf of [email-masked]> wrote:

>Hi Authors,
>
>I have read this draft and think it is very useful. However, IMHO, there
>are also something need to improved. For example:
># In section2 Tree Diagram Syntax, it describes " !  for a presence
>container", but in some draft/ RFC the container not be marked by "!",
>for example "ietf-interface" [RFC7223].
># And I suggest to highlight the symbol "-w",

How do you highlight a symbol in plain ASCII text?

Thanks,
Acee 

>it usually appears in "input" of RPC, for example "ietf-yang-push"
>[draft-ietf-netconf-yang-push]
>
>Please consider my suggestion.
>
>Best Regards!
>-Michael
>
>-----邮件原件-----
>发件人: netmod [mailto:[email-masked]] 代表 [email-masked]
>发送时间: 2017年6月13日 20:34
>收件人: [email-masked]
>抄送: [email-masked]
>主题: [netmod] I-D Action: draft-ietf-netmod-yang-tree-diagrams-00.txt
>
>
>A New Internet-Draft is available from the on-line Internet-Drafts
>directories.
>This draft is a work item of the NETCONF Data Modeling Language of the
>IETF.
>
>        Title           : YANG Tree Diagrams
>        Authors         : Martin Bjorklund
>                          Lou Berger
>	Filename        : draft-ietf-netmod-yang-tree-diagrams-00.txt
>	Pages           : 4
>	Date            : 2017-06-13
>
>Abstract:
>   This document captures the current syntax used in YANG module Tree
>   Diagrams.  The purpose of the document is to provide a single
>   location for this definition.  This syntax may be updated from time
>   to time based on the evolution of the YANG language.
>
>
>The IETF datatracker status page for this draft is:
>https://datatracker.ietf.org/doc/draft-ietf-netmod-yang-tree-diagrams/
>
>There are also htmlized versions available at:
>https://tools.ietf.org/html/draft-ietf-netmod-yang-tree-diagrams-00
>https://datatracker.ietf.org/doc/html/draft-ietf-netmod-yang-tree-diagrams
>-00
>
>
>Please note that it may take a couple of minutes from the time of
>submission until the htmlized version and diff are available at
>tools.ietf.org.
>
>Internet-Drafts are also available by anonymous FTP at:
>ftp://ftp.ietf.org/internet-drafts/
>
>_______________________________________________
>netmod mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/netmod
>_______________________________________________
>netmod mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/netmod

---

From: wangzitao <[email-masked]>
Date: Tue, 20 Jun 2017 08:28:36 +0000

Hi Acee,

-----邮件原件-----
发件人: Acee Lindem (acee) [mailto:[email-masked]] 
发送时间: 2017年6月19日 23:17
收件人: wangzitao; Martin Bjorklund; Lou Berger
抄送: [email-masked]
主题: Re: [netmod] Some comments on yang tree diagrams

Hi Michael, 

On 6/19/17, 3:20 AM, "netmod on behalf of wangzitao"
<[email-masked] on behalf of [email-masked]> wrote:

>Hi Authors,
>
>I have read this draft and think it is very useful. However, IMHO, 
>there are also something need to improved. For example:

[Michael]: I don't know, maybe just mark it as "-writable"...

Thanks,
Acee