Subject: [netmod] Some questions about "draft-ietf-netmod-syslog-model-13"

From: "Zhengguangying (Walker)" <[email-masked]>
Date: Wed, 28 Jun 2017 06:25:21 +0000

Hi all,

I have read the "draft-ietf-netmod-syslog-model-13",  we have some comments want to discuss with you all,

https://tools.ietf.org/html/draft-ietf-netmod-syslog-model-13

1.      Because the destination may be in VRF, in the definition of list destination, there should add the vrf attribute

2.      Whether "DNS " should be one case of transport?

3.      The tls case should be concerned

Please help to confirm these comments, thanks

Regards
Zhangjun, Walker

---

From: "Clyde Wildes (cwildes)" <[email-masked]>
Date: Wed, 28 Jun 2017 19:42:08 +0000

Hi Zhangjun, Walker,

Please note that the most recent version of the draft is revision 15.

We have strived to provide a model that meets the minimum requirements for successful implementation by multiple vendors with the caveat that a feature that is only implemented by a single vendor can best be handled through model augmentation by that vendor. Destination VRF is an example that could be added through model augmentation.

Regarding your question about DNS: are you asking if the address leaf which is defined as “type inet:host” be a hostname that can be translated through DNS to an IP address? If so, the answer is yes.

TLS was added as a destination transport choice in revision 14 of the draft.

Regards,

Clyde

From: "Zhengguangying (Walker)" <[email-masked]>
Date: Tuesday, June 27, 2017 at 11:25 PM
To: "Clyde Wildes (cwildes)" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "Zhangjun (Echo, CSD)" <[email-masked]>
Subject: Some questions about "draft-ietf-netmod-syslog-model-13"

Hi all,

I have read the “draft-ietf-netmod-syslog-model-13”,  we have some comments want to discuss with you all,

  1.  Because the destination may be in VRF, in the definition of list destination, there should add the vrf attribute
  2.  Whether “DNS “ should be one case of transport?
  3.  The tls case should be concerned

Regards
Zhangjun, Walker