Subject: [netmod] I-D Action: draft-ietf-netmod-yang-tree-diagrams-00.txt

From: [email-masked]
Date: Tue, 13 Jun 2017 05:34:12 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the NETCONF Data Modeling Language of the IETF.

        Title           : YANG Tree Diagrams
        Authors         : Martin Bjorklund
                          Lou Berger
	Filename        : draft-ietf-netmod-yang-tree-diagrams-00.txt
	Pages           : 4
	Date            : 2017-06-13

Abstract:
   This document captures the current syntax used in YANG module Tree
   Diagrams.  The purpose of the document is to provide a single
   location for this definition.  This syntax may be updated from time
   to time based on the evolution of the YANG language.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netmod-yang-tree-diagrams/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-netmod-yang-tree-diagrams-00
https://datatracker.ietf.org/doc/html/draft-ietf-netmod-yang-tree-diagrams-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: wangzitao <[email-masked]>
Date: Mon, 19 Jun 2017 07:20:17 +0000

Hi Authors,

I have read this draft and think it is very useful. However, IMHO, there are also something need to improved. For example:
# In section2 Tree Diagram Syntax, it describes " !  for a presence container", but in some draft/ RFC the container not be marked by "!", for example "ietf-interface" [RFC7223].
# And I suggest to highlight the symbol "-w", it usually appears in "input" of RPC, for example "ietf-yang-push" [draft-ietf-netconf-yang-push]

Please consider my suggestion.

Best Regards!
-Michael

-----邮件原件-----
发件人: netmod [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2017年6月13日 20:34
收件人: [email-masked]
抄送: [email-masked]
主题: [netmod] I-D Action: draft-ietf-netmod-yang-tree-diagrams-00.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 26 Jun 2017 21:06:49 +0200 (CEST)

Hi,

wangzitao <[email-masked]> wrote:
> Hi Authors,
> 
> I have read this draft and think it is very useful. However, IMHO,
> there are also something need to improved. For example:
> # In section2 Tree Diagram Syntax, it describes " !  for a presence
> container", but in some draft/ RFC the container not be marked by
> "!", for example "ietf-interface" [RFC7223]. 

There are no presence containers in RFC 7223, which is why "!" is not
used in that tree diagram.

/martin

> # And I suggest to highlight the symbol "-w", it usually appears in
> "input" of RPC, for example "ietf-yang-push"
> [draft-ietf-netconf-yang-push] 
>