Subject: [netmod] nmda-guidelines-01: value space for config vs state

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Mon, 17 Jul 2017 10:22:30 +0000

Hi all,

A note in Rob Wilton's presentation today in rtgwg mentioned something about consistency in the value space for config vs state leafs.  The NMDA approach results in the same leaf for both config & state in many cases (at least for the cases where the separate config & state leafs were only there to represent intended vs applied config).

But aren't there some cases where the value space for state will be different than the value space for config ?  I'm thinking of the basic admin/oper state for interfaces for example where config may allow enable/disable but state may have additional values like 'testing'.  If the config & state value spaces aren't 100% the same, are module designers recommended to create a separate state leaf ?

Rgds,
Jason

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 18 Jul 2017 09:20:03 +0200

Jason,

Following on the example I gave on the other thread here is what I see for the admin/oper leafs.

> On Jul 17, 2017, at 12:22 PM, Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]> wrote:
> 
> Hi all,
>  
> A note in Rob Wilton’s presentation today in rtgwg mentioned something about consistency in the value space for config vs state leafs.  The NMDA approach results in the same leaf for both config & state in many cases (at least for the cases where the separate config & state leafs were only there to represent intended vs applied config).
>  
> But aren’t there some cases where the value space for state will be different than the value space for config ?  I’m thinking of the basic admin/oper state for interfaces for example where config may allow enable/disable but state may have additional values like ‘testing’.  If the config & state value spaces aren’t 100% the same, are module designers recommended to create a separate state leaf ?

leaf administrative-state {
  type boolean {
    description
      “When set to true, the interface is set to be
        administratively up. The actual state of the
        interface is reflected in the corresponding
        operational-state leaf.”;
  }
}

leaf operational-state {
  config false;
  type enumeration {
    enum up;
    enum down;
    enum testing;
    enum negotiating;
  }
}

>  
> Rgds,
> Jason
> _______________________________________________
> netmod mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netmod <https://www.ietf.org/mailman/listinfo/netmod>
Mahesh Jethanandani
[email-masked]