Subject: Re: [netmod] I-D Action: draft-ietf-netmod-rfc6087bis-13.txt

From: Kent Watsen <[email-masked]>
Date: Tue, 11 Jul 2017 20:31:37 +0000

Hi Andy,

I confirmed with Lou and Benoit that we want 6.23 to have the normative text within it,
as we're both unsure about if the nmda-guidelines draft will progress and also believe
that the text could be written more helpfully for the 6087bis audience.

Would it help if one of the nmda-guidelines authors wrote the section for you?

Thanks,
Kent   // co-chair

On 6/20/17, 11:27 AM, "Andy Bierman" <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

I rewrote 6.23 and it points at the NMDA guidelines.
The drafts will get published together so the references will
be to RFCs, not I-Ds.  That is usually what is meant by the comment below I think

> I don't expect the guidelines doc is going to progress independently.

Agreed.

Andy

On Tue, Jun 20, 2017 at 8:20 AM, Kent Watsen <[email-masked]<mailto:[email-masked]>> wrote:

Regarding the suggestion to add this text:

> Guidelines for
>  moving existing data modules to the NMDA are defined in
>  [I-D.dsdt-nmda-guidelines].

I'm hoping that we do not progress the guidelines doc.  Ideally 6087bis can just state what people should do, without providing a formula for transitioning.

I thought 6087bis is supposed to point people to the NMDA guidelines.
That is why 6087bis has been held back for so long, even though it was
supposed to be published with YANG 1.1.

We waste a lot of time refactoring drafts and re-reviewing them.
IMO the RD guidelines should be in the RD draft.

<KENT> I thought that this was settled before (maybe not): https://mailarchive.ietf.org/arch/msg/netmod/pDLDm8gdIBwwyGyfa_acVKHtu_Q

---

From: Andy Bierman <[email-masked]>
Date: Tue, 11 Jul 2017 13:44:29 -0700

Hi,

Do you have text from your that that should be pasted into section 6.23?

I think there were other issues, such as changing the terminology to
reference RD.
There were comments opposing that idea because the definition for
'configuration'
including everything that could possibly change the behavior of the device.

Andy

On Tue, Jul 11, 2017 at 1:31 PM, Kent Watsen <[email-masked]> wrote:

> On 6/20/17, 11:27 AM, "Andy Bierman" <[email-masked]> wrote:
>
>
>
> Hi,
>
>
>
> On Tue, Jun 20, 2017 at 8:20 AM, Kent Watsen <[email-masked]> wrote:
>
>
>
>
>
> I'm hoping that we do not progress the guidelines doc.  Ideally 6087bis
> can just state what people should do, without providing a formula for
> transitioning.
>
>
>
> <KENT> I thought that this was settled before (maybe not):
> https://mailarchive.ietf.org/arch/msg/netmod/pDLDm8gdIBwwyGyfa_acVKHtu_Q
>
>
>
>
>
>
>
>
>
>
>

---

From: Kent Watsen <[email-masked]>
Date: Tue, 11 Jul 2017 21:07:27 +0000

I think that there might be a paragraph or two in the nmda-guidelines draft that could be
used as source material, but by and large, I'm imagine new text being needed.  If none of
my co-authors step forward, I'll pen up some proposal text for Section 6.23 myself, but it
may be awhile, with IETF-week coming on strong now (I'm sure you relate).

Don't worry about timing. The urgency to get 6087bis out with 7950 has subsided.  But
we do need to ensure that 6087bis dovetails nicely with the NMDA.

Kent  // shepherd

On 7/11/17, 4:44 PM, "Andy Bierman" <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

I think there were other issues, such as changing the terminology to reference RD.
There were comments opposing that idea because the definition for 'configuration'
including everything that could possibly change the behavior of the device.

Andy

On Tue, Jul 11, 2017 at 1:31 PM, Kent Watsen <[email-masked]<mailto:[email-masked]>> wrote:
Hi Andy,

Thanks,
Kent   // co-chair

Hi,

Agreed.

Andy