Subject: Re: [netmod] [netmod-wg/acl-model] TCP flags values not defined and only single flag allowed (#5)

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 10 Jul 2017 10:31:21 +0200

Hi,

is it necessary to post these GitHub issues one by one to the WG mailing list?

Thanks, Lada

> On 8 Jul 2017, at 00:28, sonal1204 <[email-masked]> wrote:
> 
> The TCP flags container is a leaf. This allows only 1 TCP value to be specified per ACE.
> 
> leaf flags {
>   type uint16;
>   description
>     "Also known as Control Bits. Contains 9 1-bit flags.";
> }
> 
> Further, the TCP flags are not defined in the model.
> 
> The improvements to this would be:
> 
> 	• The data structure to store the TCP flags should be a leaf list.
> 	• The values could be defined to be something like:
> identity ETHERTYPE {
> description
> "Base identity for commonly used Ethertype values used
> in packet header matches on Ethernet frames. The Ethertype
> indicates which protocol is encapsulated in the Ethernet
> payload.";
> reference
> "IEEE 802.3";
> }
> 
> identity ETHERTYPE_IPV4 {
> base ETHERTYPE;
> description
> "IPv4 protocol (0x0800)";
> }
> 
> ...
> ...
> 
> and so on.
> 
> —
> You are receiving this because you are subscribed to this thread.
> Reply to this email directly, view it on GitHub, or mute the thread.
> 

--
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: Eliot Lear <[email-masked]>
Date: Mon, 10 Jul 2017 10:53:20 +0200

What would you prefer?  That way they can be knocked down one by one,
without the bunch getting intertwined.

On 7/10/17 10:31 AM, Ladislav Lhotka wrote:
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 10 Jul 2017 13:21:52 +0200

> On 10 Jul 2017, at 10:53, Eliot Lear <[email-masked]> wrote:
> 

Sure, but the WG should deal with issues of published revisions of Internet Drafts whereas GitHub issues should (in my view at least) be dealt with by the authors and other interested folks who can easily subscribe at GitHub.

If everybody does this, the traffic in the mailing list would grow considerably. I know, one can filter it, but the list archives would get cluttered, too.

Lada

---

From: Lou Berger <[email-masked]>
Date: Mon, 10 Jul 2017 08:36:36 -0400

Hi,

>From the wg chair perspective:

The working group has not decided how Github should be used, and at this 
point we defer to the authors / editors on their preferred method. But in 
all cases, issue resolution must be reviewed  with the working group. 
Editors / authors  have a lot of latitude on how they conduct this review 
and ensure that their document captures working group consensus.

Lou

On July 10, 2017 7:22:37 AM Ladislav Lhotka <[email-masked]> wrote:

> Sure, but the WG should deal with issues of published revisions of Internet 
> Drafts whereas GitHub issues should (in my view at least) be dealt with by 
> the authors and other interested folks who can easily subscribe at GitHub.
>
> If everybody does this, the traffic in the mailing list would grow 
> considerably. I know, one can filter it, but the list archives would get 
> cluttered, too.
>
> Lada
>
>>
>>
> ----------

---

From: Kent Watsen <[email-masked]>
Date: Mon, 10 Jul 2017 18:23:13 +0000

I have done it both ways, and it seems that folks prefer it more when
the discussion appears to be less formalized.  My current/personal
thoughts are, use github internally, only as an author's aid.  That
is, don't mention the GitHub issue to the WG list at all.

I have no issue with there being a thread per issue.  My only complaint,
if you can call it that, is that the email "Subject" lines should try
to detail the issue within the first 20 characters or so.  As it stands,
it looks like I have 11 distinct threads that all begin: 

  ACL: draft-ietf-netmod-acl-model-11...

So, it's hard to see which thread it is at a glance, without clicking into
the thread to see...

Kent

-- 

Hi,

Lou

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 10 Jul 2017 15:27:28 -0700

> On Jul 10, 2017, at 4:21 AM, Ladislav Lhotka <[email-masked]> wrote:
> 
>> 
>> On 10 Jul 2017, at 10:53, Eliot Lear <[email-masked] <mailto:[email-masked]>> wrote:
>> 

I think if the issue needs feedback/comment from the WG, we should post it to the mailing list. Otherwise, if issue has a well known solution it should be tracked in github only.

> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netmod <https://www.ietf.org/mailman/listinfo/netmod>
Mahesh Jethanandani
[email-masked]