Subject: Re: [netmod] draft netmod agenda posted

From: Kent Watsen <[email-masked]>
Date: Tue, 11 Jul 2017 21:48:30 +0000

Could all the presenters please have a slide on their module's NMDA
compatibility status?  Things to consider:

 - is the operational state of configured values important?
 - is there is a need to support system generated entries?
 - note: if yes to either, the module SHOULD be NMDA-compatible.
         is it? - is there a "-state" tree in the Appendix?

Thanks,
Kent // co-chair

--

The draft agenda for the NETMOD sessions at IETF 99 has been posted:

  https://datatracker.ietf.org/meeting/99/agenda/netmod/

Please let us know if any adjustments are needed.

Thanks,
NETMOD WG Chairs

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 12 Jul 2017 08:02:56 +0200

>          is it? - is there a "-state" tree in the Appendix?

I find this confusing. I think modules should be default be
NMDA-compatible. I also think -state trees should be avoided
as much as possible. So the questions should be something like
this:

 - Is the module NMDA-compatible? If not, why not?
 - Does the appendix include a -state tree? If so, why is
   it necessary and how to transition away from it?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Kent Watsen <[email-masked]>
Date: Thu, 13 Jul 2017 14:28:03 +0000

>   it necessary and how to transition away from it?

Yes, by all means, this is even more to the point.

Thanks,
Kent

---

From: Andy Bierman <[email-masked]>
Date: Thu, 13 Jul 2017 14:42:34 -0700

> >as much as possible. So the questions should be something like

If the module contains any config=false top-level subtrees (like the
/foo-state container
and nested config=false nodes) then the foo-state tree is needed.  If all
the config=false
nodes are child nodes of a config node, then the foo-state stree should not
be needed.

It would be nice if the term "NMDA-compatible" was widely understood.
There should be simple tests to determine if /foo-state is needed.

> Yes, by all means, this is even more to the point.
I thought the foo-state modules were supposed to be generated by tools, not
defined in RFCs.
Isn't the migration strategy the same for everybody? Remove the foo-state
module and stop
advertising it to the client (which is expected to use the operational
datastore).
Isn't it up to vendors and operators, not the IETF, when the foo-state
module should
be removed from a server implementation?

Thanks,
> Kent
Andy

>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>