Subject: [netmod] WG Last Call for draft-ietf-netmod-syslog-model-15

From: Kent Watsen <[email-masked]>
Date: Fri, 7 Jul 2017 18:34:33 +0000

This is a notice to start a three week NETMOD WG last call for the
document:

    A YANG Data Model for Syslog Configuration
    https://tools.ietf.org/html/draft-ietf-netmod-syslog-model-15

Note: Three weeks is more than needed, especially given this 
      draft has been through Last Call before, but we understand
      folks are busy these days.

Please indicate your support or concerns by Friday, July 28, 2017.

We are particularly interested in statements of the form:
  * I have reviewed this draft and found no issues.
  * I have reviewed this draft and found the following issues: ...

As well as:
  * I have implemented the data model in this draft.
  * I am implementing the data model in this draft.
  * I am considering to implement the data model in this draft.
  * I am not considering to implement the data model in this draft.

Thank you,
NETMOD WG Chairs

---

From: Alex Campbell <[email-masked]>
Date: Mon, 17 Jul 2017 23:20:40 +0000

I am considering to implement the data model in this draft. (dependent on business priorities of course)
I have reviewed this draft and found the following issues.

* I see pattern-match is specified to use POSIX 1003.2 regular expressions. This is presumably for compatibility with existing implementations; however it is inconsistent with most of YANG (which is specified to use XPath regular expressions) - unless these are the same.
* pattern-match is inside the facility-filter container; common sense says this is wrong as pattern-match has nothing to do with facilities.
* The advanced-compare container groups together two nodes that share a common "when" and "if-feature" statement, but don't seem to have any semantic relation to each other. Are there general guidelines on when to use a container?
* The advanced-compare container has a description starting with "This leaf ..." even though it is not a leaf.
* The examples are missing <facility-filter> nodes.
* Perhaps there should be more consistent terminology for receivers of syslog messages; both "collectors" and "actions" are used in the draft. RFC 5424 uses "collector" for the ultimate recipient of a log message - which might not be applicable, because the sending system has no idea whether the receiving system is a collector or a relay.

________________________________________
From: netmod <[email-masked]> on behalf of Kent Watsen <[email-masked]>
Sent: Saturday, 8 July 2017 6:34 a.m.
To: [email-masked]
Subject: [netmod] WG Last Call for draft-ietf-netmod-syslog-model-15

As well as:

Thank you,
NETMOD WG Chairs

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 18 Jul 2017 10:26:35 +0200

> * I see pattern-match is specified to use POSIX 1003.2 regular expressions. This is presumably for compatibility with existing implementations; however it is inconsistent with most of YANG (which i…

The fact that the schema language uses a different regular expression
language than the data model is by itself not a problem I think. What
is potentially a problem is that RFC 5424 syslog messages are UTF-8
and hence the regular expression language adopted should be able to
match on unicode characters. Does POSIX 1003.2 do that? (There also
needs to be a normative reference to POSIX 1003.2 or whatever is
finally adopted.)

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Clyde Wildes (cwildes)" <[email-masked]>
Date: Tue, 18 Jul 2017 18:20:59 +0000

Juergen and Alex,

The choice of Posix 1003.2 regular expressions was because of multiple vendors who supported same and asked for model support:
http://www.juniper.net/documentation/en_US/junos12.3/topics/reference/configuration-statement/syslog-edit-system.html
http://www.rsyslog.com/doc/v8-stable/configuration/filters.html
http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/esm/command/esm-cr-book/esm-cr-a1.html#wp1888787448
https://infoproducts.alcatel-lucent.com/html/0_add-h-f/93-0071-10-01/7750_SR_OS_System_Management_Guide/Logcli.html#1030840

Posix 1003.2 regular expressions support Unicode characters using the notation: \uFFFF or \x{FFFF}.

I will insert a normative reference to POSIX 1003.2 in the next revision of the draft.

Thanks,

Clyde

On 7/18/17, 1:26 AM, "netmod on behalf of Juergen Schoenwaelder" <[email-masked] on behalf of [email-masked]> wrote:

    
    /js