Subject: Re: [netmod] WG Last Call for draft-ietf-netmod-syslog-model-15

From: "t.petch" <[email-masked]>
Date: Wed, 9 Aug 2017 12:32:03 +0100

Clyde

You use xxxx as a placeholder for three different RFC and two of these
do not appear AFAICT in the list of References.

This might be a challenge for the RFC Editor.

Tom Petch

----- Original Message -----
From: "Clyde Wildes (cwildes)" <[email-masked]>
Sent: Wednesday, July 19, 2017 6:48 PM

> Hi Alex,
>
> Answers inline as [clyde]…
>
> On 7/17/17, 4:20 PM, "netmod on behalf of Alex Campbell"
<[email-masked] on behalf of [email-masked]> wrote:
>
>     I am considering to implement the data model in this draft.
(dependent on business priorities of course)
>     I have reviewed this draft and found the following issues.
>
>     * I see pattern-match is specified to use POSIX 1003.2 regular
expressions. This is presumably for compatibility with existing
implementations; however it is inconsistent with most of YANG (which is
specified to use XPath regular expressions) - unless these are the same.
>
> [clyde] I believe that my answer in the other thread explains why we
used Posix 1003.2 – it is commonly used.
>
>     * pattern-match is inside the facility-filter container; common
sense says this is wrong as pattern-match has nothing to do with
facilities.
>
> [clyde] I will move pattern-match up one level in the next version of
the draft. Thanks for catching this!
>
>     * The advanced-compare container groups together two nodes that
share a common "when" and "if-feature" statement, but don't seem to have
any semantic relation to each other. Are there general guidelines on
when to use a container?
>
> [clyde] The confusion may come as a result of the when clause
appearing before the if-feature clause which is set by the IETF
statement order recommendation.
>
> The when construct was suggested by Martin Björklund as a way of
solving the case that advanced-compare does not apply for the ‘all’ and
‘none’ case.
>
> The if-feature applies to the entire container – it is either
supported or not.
>
>     * The advanced-compare container has a description starting with
"This leaf ..." even though it is not a leaf.
>
> [clyde] This will be fixed in the next draft.
>
>     * The examples are missing <facility-filter> nodes.
>
> [clyde] This will be fixed in the next draft.
>
>     * Perhaps there should be more consistent terminology for
receivers of syslog messages; both "collectors" and "actions" are used
in the draft. RFC 5424 uses "collector" for the ultimate recipient of a
log message - which might not be applicable, because the sending system
has no idea whether the receiving system is a collector or a relay.
>
> [clyde] The definition of “collector” in RFC 5424 is: A "collector"
gathers syslog content for further analysis.
>
> actions relate to the “further analysis” taken by the “collector”.
>
> “Collectors” appears in the model under the remote action and I
believe the usage is correct:
>       container remote {
>         if-feature remote-action;
>         description
>           "This container describes the configuration parameters for
>            forwarding syslog messages to remote relays or
collectors.";
>
> I will revise the description of these terms in the next draft.
>
> Thanks,
>
> Clyde
>
>     ________________________________________
>     From: netmod <[email-masked]> on behalf of Kent Watsen
<[email-masked]>
>     Sent: Saturday, 8 July 2017 6:34 a.m.

---

From: "Clyde Wildes (cwildes)" <[email-masked]>
Date: Wed, 9 Aug 2017 16:53:49 +0000

Tom,

The agreement was that I should use “xxxx” until the two unapproved RFCs that the model depends on are assigned numbers.

     RFC xxxx: Keystore Management
     RFC xxxx: Transport Layer Security (TLS) Client";

Imported are:

  import ietf-tls-client {
    prefix tlsc;
  }

  import ietf-keystore {
    prefix ks;
  }

Have numbers been assigned?

Thanks,

Clyde

On 8/9/17, 4:32 AM, "t.petch" <[email-masked]> wrote:

    Clyde

    
    Tom Petch

    ----- Original Message -----
    From: "Clyde Wildes (cwildes)" <[email-masked]>
    Sent: Wednesday, July 19, 2017 6:48 PM

    supported or not.
    collectors.";
    <[email-masked]>

---

From: Kent Watsen <[email-masked]>
Date: Wed, 9 Aug 2017 17:38:02 +0000

Hi Clyde,

In my drafts that depend on more than one work in progress, I typically assign each of them a value (e.g., XXXX, YYYY, ZZZZ) and then have RFC Editor instructions mapping each to a specific value.

Kent // contributor

--

Tom,

Imported are:

  import ietf-tls-client {
    prefix tlsc;
  }

  import ietf-keystore {
    prefix ks;
  }

Thanks,

Clyde

    Clyde

    
    Tom Petch

    ----- Original Message -----
    From: "Clyde Wildes (cwildes)" <[email-masked]>
    Sent: Wednesday, July 19, 2017 6:48 PM

    supported or not.
    collectors.";
    <[email-masked]>

---

From: "t.petch" <[email-masked]>
Date: Fri, 11 Aug 2017 16:21:47 +0100

Clyde

As Kent says, I would prefer to see only one XXXX with others being YYYY
or some such.

Further, I think that this RFC xxxx to be should be in the list of
References.

Adding it there would then solve my additional problem of which I-D you
have in mind.  There are two relating to key management and neither are
titled Keystore Management:-(  I can guess which you mean but I do not
think that I should be guessing!

Tom Petch

----- Original Message -----
From: "Clyde Wildes (cwildes)" <[email-masked]>
To: "t.petch" <[email-masked]>; "Kent Watsen"
<[email-masked]>; <[email-masked]>
Sent: Wednesday, August 09, 2017 5:53 PM
Subject: Re: [netmod] WG Last Call for draft-ietf-netmod-syslog-model-15

> Tom,
>
> The agreement was that I should use “xxxx” until the two unapproved
RFCs that the model depends on are assigned numbers.

---

From: "t.petch" <[email-masked]>
Date: Tue, 15 Aug 2017 09:32:31 +0100

Clyde

What  concerns me most is that AFAICT anything that is referenced in a
YANG module is a Normative Reference in the RFC that defines it and you
do not have those two I-D in the list of references.

Since they have not been published, then they would appear as I-Ds in
the references and the RFC Editor knows to on the one hand, hold up the
publication of the referring I-D until until the references become RFC,
and on the other hand insert the RFC number when they do.

I note that in other modules, I see no RFC for an import.  Strictly one
is not needed since the name should be unique and can be derefenced but
it is nice to have (SNMP usually has it).

But as I say, it is the lack of Normative Reference that worries me
most.

Tom Petch