Subject: [nmrg] Updating draft-irtf-nmrg-autonomic-network-definitions-00

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Tue, 24 Jun 2014 13:55:25 +0000

NMRG, Anima, 

Having gone through feedback, and re-reading the document myself, here is a list of changes I'm proposing to make to 
http://tools.ietf.org/html/draft-irtf-nmrg-autonomic-network-definitions-00:

High level, I think the "meat" of the document, sections 3, 4 and 6 are pretty complete and correct. If anyone thinks we're missing an important design goal or a non-design goal, please speak up! 

Some details: 

1. Section 3.1. always refers to "nodes". We should rephrase this to "functions". The primary goal here is not to produce a fully autonomic node or network, but autonomic functions. For the foreseeable future fully autonomic nodes/networks will remain the exception. 
Therefore: s/node/function/ in this section. 
Actually, also later on in the doc the doc references sometimes "nodes" or "the network". I suggest to change that to "function". 

2. Common infrastructure. 
In my mail http://www.ietf.org/mail-archive/web/nmrg/current/msg01512.html I suggested to add to the design goals: 

<section title="Common Autonomic Networking Infrastructure">
	<t><xref target="I-D.irtf-nmrg-an-gap-analysis"/> points out that there are already a number of fully or partially autonomic functions available today. However, they are largely independent, and each has its own methods and protocols to communicate, discover, define and distribute policy, etc. </t>
	<t>The goal of the work on autonomic networking in the IETF is therefore not just to create autonomic functions, but to define a common infrastructure that autonomic functions can use. This autonomic networking infrastructure may contain common control and management functions such as messaging, service discovery, negotiation, intent distribution, etc. A common approach to define and manage intent is also required. </t>
	<t>Refer to the reference model below: All the components around the "autonomic service agents" should be common components, such that the autonomic service agents do not have to replicate common tasks individually. </t>
      </section>

Unless I missed it, I haven't seen any negative comments on that section, so I'll add it to the new version. 

3. Use case section. 
In the same email (link above) I proposed some text for the use case section. But frankly, I think this is overtaken by the discussion we had on the list, and out of date. 
We also want to drive this document to publication soon, so procedural issues such as how to report use cases should really not be there any more. 
I suggest we just remove this section completely, since IMO it is not required for the document to be useful and complete. Thoughts? 

Am I missing any feedback, or points we discussed? If so, please let me know! 

I'm finalising version -01 of the document now. I'll circulate first amongst the authors, then post the result. 

Michael

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 25 Jun 2014 08:05:46 +1200

Michael,

I think that's all reasonable; I will re-read the whole draft when you
circulate it to the co-authors.

...
> I suggest we just remove this section completely, since IMO it is not required for the document to be useful and complete. Thoughts? 

I agree. I think the use cases will be very valuable in confirming solution
requirements, but this topic doesn't really belong with the definitions.

    Brian

---

From: Sheng Jiang <[email-masked]>
Date: Wed, 25 Jun 2014 08:34:30 +0000

Hi, Michael,

Your suggestions looks good. 

One comments: the current definition of autonomic network looks vague. May I propose to modify it: a network which employs autonomic functions network-wide.

Best regards,

Sheng

>-----Original Message-----
>From: Anima [mailto:[email-masked]] On Behalf Of Michael
>Behringer (mbehring)
>Sent: Tuesday, June 24, 2014 9:55 PM
>To: [email-masked]; [email-masked]
>Subject: [Anima] Updating draft-irtf-nmrg-autonomic-network-definitions-00
>
>NMRG, Anima,
>
>High level, I think the "meat" of the document, sections 3, 4 and 6 are pretty
>complete and correct. If anyone thinks we're missing an important design
>goal or a non-design goal, please speak up!
>
>Some details:
>
>1. Section 3.1. always refers to "nodes". We should rephrase this to
>"functions". The primary goal here is not to produce a fully autonomic node
>or network, but autonomic functions. For the foreseeable future fully
>autonomic nodes/networks will remain the exception.
>Actually, also later on in the doc the doc references sometimes "nodes" or
>"the network". I suggest to change that to "function".
>
>In my mail
>http://www.ietf.org/mail-archive/web/nmrg/current/msg01512.html I
>suggested to add to the design goals:
>
>	<t><xref target="I-D.irtf-nmrg-an-gap-analysis"/> points out that there
>are already a number of fully or partially autonomic functions available today.
>However, they are largely independent, and each has its own methods and
>protocols to communicate, discover, define and distribute policy, etc. </t>
>	<t>The goal of the work on autonomic networking in the IETF is
>therefore not just to create autonomic functions, but to define a common
>infrastructure that autonomic functions can use. This autonomic networking
>infrastructure may contain common control and management functions such
>as messaging, service discovery, negotiation, intent distribution, etc. A
>common approach to define and manage intent is also required. </t>
>	<t>Refer to the reference model below: All the components around the
>"autonomic service agents" should be common components, such that the
>autonomic service agents do not have to replicate common tasks individually.
></t>
>      </section>
>
>In the same email (link above) I proposed some text for the use case section.
>But frankly, I think this is overtaken by the discussion we had on the list, and
>out of date.
>We also want to drive this document to publication soon, so procedural issues
>such as how to report use cases should really not be there any more.
>I suggest we just remove this section completely, since IMO it is not required
>for the document to be useful and complete. Thoughts?
>
>_______________________________________________
>Anima mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/anima

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Thu, 26 Jun 2014 10:23:36 +0000

> From: Sheng Jiang [mailto:[email-masked]]
> Sent: 25 June 2014 10:35
> To: Michael Behringer (mbehring); [email-masked]; [email-masked]
> Subject: RE: Updating draft-irtf-nmrg-autonomic-network-definitions-00
> 
> Hi, Michael,
> 
> One comments: the current definition of autonomic network looks vague.
> May I propose to modify it: a network which employs autonomic functions
> network-wide.

Thanks for the suggestion Sheng. Well, I think the definition is recursive, and actually DOES reflect what you're suggesting, because it says: 

      <t>Autonomic Network: A network containing autonomic nodes.</t>
and 
      <t>Autonomic Node: A node which employs autonomic functions. It may
      operate on any layer of the networking stack. Examples are routers,
      switches, personal computers, call managers, etc.</t>

The only thing that's not covered is the "network wide". But that's also not necessarily true, because an autonomic function could well span only a few devices. 

We could change the Autonomic Function definition to (last sentence added): 

      <t>Autonomic Function: A function which requires no configuration, and
      can derive all required information either through self-knowledge, discovery    
      or through intent. Typically an autonomic function spans several nodes.</t>

What do you think? I'm a bit in between "yes, this is more precise", and "this doesn't add much value and complicates things". Slight tendency to agree to add it. 

Thoughts? 

Michael

---

From: Sheng Jiang <[email-masked]>
Date: Fri, 27 Jun 2014 01:33:25 +0000

>Thanks for the suggestion Sheng. Well, I think the definition is recursive, and
>actually DOES reflect what you're suggesting, because it says:
>
>The only thing that's not covered is the "network wide". But that's also not
>necessarily true, because an autonomic function could well span only a few
>devices.

Hi, Michael,

The point is how much scale of autonomic function can be called an autonomic network. Say, if there is a network with hundreds devices, two of these devices has been deployed some autonomic functions. Can the network be claimed as an autonomic network? "Network wide" does not mean every devices. It means a large portion of the network have autonomic functions.

>What do you think? I'm a bit in between "yes, this is more precise", and "this
>doesn't add much value and complicates things". Slight tendency to agree to
>add it.

This is helpful. But it does not address my concern regarding to the autonomic network definition.

Regards,

Sheng

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Fri, 27 Jun 2014 07:00:17 +0000

Sheng, 

> Sent: 27 June 2014 03:33
> >> May I propose to modify it: a network which employs autonomic
> >> functions network-wide.
> >
> >Thanks for the suggestion Sheng. Well, I think the definition is
> >recursive, and actually DOES reflect what you're suggesting, because it
> says:
> >
> >The only thing that's not covered is the "network wide". But that's
> >also not necessarily true, because an autonomic function could well
> >span only a few devices.
> 
> Hi, Michael,
> 
> The point is how much scale of autonomic function can be called an
> autonomic network. Say, if there is a network with hundreds devices, two of
> these devices has been deployed some autonomic functions. Can the
> network be claimed as an autonomic network? "Network wide" does not
> mean every devices. It means a large portion of the network have
> autonomic functions.

The fundamental question is whether we want to include autonomic functions that for example just involve two devices. And I would strongly suggest YES, for example I can see improvements on VRRP in the future as an autonomic function (you could already claim some limited autonomy, in fact). We want to cover that, right? 

Michael

> >What do you think? I'm a bit in between "yes, this is more precise",
> >and "this doesn't add much value and complicates things". Slight
> >tendency to agree to add it.
>

---

From: Sheng Jiang <[email-masked]>
Date: Fri, 27 Jun 2014 07:38:58 +0000

>The fundamental question is whether we want to include autonomic functions
>that for example just involve two devices. And I would strongly suggest YES,
>for example I can see improvements on VRRP in the future as an autonomic
>function (you could already claim some limited autonomy, in fact). We want
>to cover that, right?

That's a valid use case for autonomic function deployment. But, with these two devices autonomic hot standby or backup each other, should the whole network be called an autonomic network? If you think "network-wide" is a too high threshold for autonomic network, we can work out some lower description.

Sheng

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Fri, 27 Jun 2014 09:46:24 +0000

> From: Anima [mailto:[email-masked]] On Behalf Of Sheng Jiang
> Sent: 27 June 2014 09:39
> Subject: Re: [Anima] Updating draft-irtf-nmrg-autonomic-network-
> definitions-00
> 
> >> autonomic network. Say, if there is a network with hundreds devices,
> >> two of these devices has been deployed some autonomic functions. Can
> >> the network be claimed as an autonomic network? "Network wide" does
> >> not mean every devices. It means a large portion of the network have
> >> autonomic functions.
> >
> >The fundamental question is whether we want to include autonomic
> >functions that for example just involve two devices. And I would
> >strongly suggest YES, for example I can see improvements on VRRP in the
> >future as an autonomic function (you could already claim some limited
> >autonomy, in fact). We want to cover that, right?
> 
> That's a valid use case for autonomic function deployment. But, with these
> two devices autonomic hot standby or backup each other, should the whole
> network be called an autonomic network? If you think "network-wide" is a
> too high threshold for autonomic network, we can work out some lower
> description.

Indeed, many people will probably imply that what we call an "autonomic network" is actually what we define as a "fully autonomic network". 
Maybe the better phrase would be "partially autonomic network". 

But, no doubt we'll have more discussions around this at the IETF. I suggest to leave it for now, discuss at NMRG how people feel we should call it. OK? 
 
Michael

---

From: Sheng Jiang <[email-masked]>
Date: Fri, 27 Jun 2014 09:55:20 +0000

>Indeed, many people will probably imply that what we call an "autonomic
>network" is actually what we define as a "fully autonomic network".

This sounds better for me.

>But, no doubt we'll have more discussions around this at the IETF. I suggest to
>leave it for now, discuss at NMRG how people feel we should call it. OK?

That's ok, for sure. :)

Sheng