Subject: Re: [nmrg] IETF BOF proposal on autonomic networking use cases (better link)

From: Benoit Claise <[email-masked]>
Date: Fri, 06 Jun 2014 12:07:36 +0200

On 15/05/2014 22:05, Brian E Carpenter wrote:
> On 15/05/2014 23:25, Michael Behringer (mbehring) wrote:
>> Brian, Jefferson,
>>
>> I really think we should get as many use cases as possible. The more we have, the easier it will be to see patterns in communication, policy and other requirements.
> I completely agree. If you look at the RTCweb use cases draft,
> it contains 15 distinct use cases, from which they extracted 36
> separate requirements. If we have too many use cases to fit into
> one BOF, that would be an excellent result!
One of the issues with many use cases is: where do you draw the line 
between what is an AN use cases and what is not?
There is so many features that have an AN aspect.
Should all AN use cases follow the design goals in 
http://tools.ietf.org/html/draft-irtf-nmrg-autonomic-network-definitions-00?
If yes, then you guys should really spend some time finishing up this 
work. This draft has not been updated for 6 months.

Regards, Benoit

>
>     Brian
>
>> Potential use case authors: Make sure you highlight why distribution of intelligence is preferred over a centralised solution. We will have to answer many questions on "why not just centralise this functionality?", "Why do we need this functionality?". So it is important to bring out the advantages of an autonomic approach.
>>
>> Who else is thinking of contributing a use case?
>>
>> Michael
>>
>>
>>> -----Original Message-----
>>> From: nmrg [mailto:[email-masked]] On Behalf Of Brian E Carpenter
>>> Sent: 15 May 2014 02:49
>>> To: Jéferson Campos Nobre
>>> Cc: [email-masked]
>>> Subject: Re: [nmrg] IETF BOF proposal on autonomic networking use cases
>>> (better link)
>>>
>>> Hi,
>>>
>>> Well, firstly, the BOF is not approved yet and we will not get a decision until
>>> about June 13.
>>>
>>> But of course it would be great to have more use cases published.
>>> At the moment we've timed the proposed agenda for a total of 4 cases, and
>>> if we get too many we may have to limit the time.
>>>
>>> Personally I think that a measurement use case would be very interesting,
>>> because it's a bit different from traditional network management actions.
>>>
>>> Regards
>>>     Brian
>>>
>>> On 15/05/2014 12:01, Jéferson Campos Nobre wrote:
>>>> Hi Brian.
>>>> Is it still possible to add use cases for presentation at the BOF?
>>>> Lisandro and I are working in an draft about autonomic control of
>>>> measurement probes which is based on the material presented at the
>>>> 31st and 32nd NMRG meetings. The draft should be finished in a couple
>>>> of weeks.
>>>> Thank you.
>>>> Best.
>>>>
>>>> Jéferson Campos Nobre
>>>> PhD Student
>>>> Computer Networks Group -  Institute of Informatics Federal University
>>>> of Rio Grande do Sul http://www.inf.ufrgs.br/~jcnobre
>>>>
>>>> On Tue, May 13, 2014 at 1:08 PM, Brian E Carpenter
>>>> <[email-masked]> wrote:
>>>>> http://trac.tools.ietf.org/bof/trac/wiki/WikiStart#UCANproposal
>>>>>
>>>>> Discussion here, and further use case documents, both very welcome.
>>>>>
>>>>>     Brian
>>>>>
>>>>> _______________________________________________
>>>>> nmrg mailing list
>>>>> [email-masked]
>>>>> https://www.irtf.org/mailman/listinfo/nmrg
>>> _______________________________________________
>>> nmrg mailing list
>>> [email-masked]
>>> https://www.irtf.org/mailman/listinfo/nmrg
> _______________________________________________
> nmrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmrg

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Fri, 6 Jun 2014 15:24:16 +0000

Benoit, 

We will have another version out of the definitions draft before the IETF. You are right, this is the cornerstone of the work and needs to be updated with recent discussions and thoughts. This will also be on the agenda for the NMRG. 

Michael

> From: Benoit Claise (bclaise)
> Sent: 06 June 2014 12:08
> To: Brian E Carpenter; Michael Behringer (mbehring)
> Cc: [email-masked]
> >> I really think we should get as many use cases as possible. The more we
> have, the easier it will be to see patterns in communication, policy and
> other requirements.
> > I completely agree. If you look at the RTCweb use cases draft, it
> > contains 15 distinct use cases, from which they extracted 36 separate
> > requirements. If we have too many use cases to fit into one BOF, that
> > would be an excellent result!
> If yes, then you guys should really spend some time finishing up this work.
> This draft has not been updated for 6 months.
> 
> Regards, Benoit
> 
> >
> >     Brian
> >
> >> Potential use case authors: Make sure you highlight why distribution of
> intelligence is preferred over a centralised solution. We will have to answer
> many questions on "why not just centralise this functionality?", "Why do we
> need this functionality?". So it is important to bring out the advantages of
> an autonomic approach.
> >>
> >>> Subject: Re: [nmrg] IETF BOF proposal on autonomic networking use
> >>> cases (better link)
> >>>
> >>> Hi,
> >>>
> >>> Well, firstly, the BOF is not approved yet and we will not get a
> >>> decision until about June 13.
> >>>
> >>> At the moment we've timed the proposed agenda for a total of 4
> >>> cases, and if we get too many we may have to limit the time.
> >>>
> >>> Personally I think that a measurement use case would be very
> >>> interesting, because it's a bit different from traditional network
> management actions.
> >>>
> >>> Regards
> >>>     Brian
> >>>
> >>>> 31st and 32nd NMRG meetings. The draft should be finished in a
> >>>> couple of weeks.
> >>>> Thank you.
> >>>> Best.
> >>>>
> >>>> Jéferson Campos Nobre
> >>>> PhD Student
> >>>> Computer Networks Group -  Institute of Informatics Federal
> >>>> University of Rio Grande do Sul http://www.inf.ufrgs.br/~jcnobre
> >>>>

---

From: Benoit Claise <[email-masked]>
Date: Fri, 06 Jun 2014 17:31:40 +0200

> We will have another version out of the definitions draft before the IETF. You are right, this is the cornerstone of the work and needs to be updated with recent discussions and thoughts. This will…
Then make sure NMRG is at the beginning of the week,  basically before 
the BoF.

Regards, Benoit

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Fri, 6 Jun 2014 15:35:52 +0000

> Sent: 06 June 2014 17:32
> To: Michael Behringer (mbehring); Brian E Carpenter
> Cc: [email-masked]
> > We will have another version out of the definitions draft before the IETF.
> You are right, this is the cornerstone of the work and needs to be updated
> with recent discussions and thoughts. This will also be on the agenda for the
> NMRG.
> Then make sure NMRG is at the beginning of the week,  basically before the
> BoF.

Absolutely! I've already expressed that wish to Lisandro, who has passed it on to the agenda folks. 

Michael
 
> >> have, the easier it will be to see patterns in communication, policy
> >> and other requirements.
> >>> contains 15 distinct use cases, from which they extracted 36
> >>> separate requirements. If we have too many use cases to fit into one
> >>> BOF, that would be an excellent result!
> >> http://tools.ietf.org/html/draft-irtf-nmrg-autonomic-network-definiti
> >> ons-
> >> 00?
> work.
> >> intelligence is preferred over a centralised solution. We will have
> >> to answer many questions on "why not just centralise this
> >> functionality?", "Why do we need this functionality?". So it is
> >> important to bring out the advantages of an autonomic approach.
> >>>>>> measurement probes which is based on the material presented at
> >>>>>> the 31st and 32nd NMRG meetings. The draft should be finished in
> >>>>>> a couple of weeks.
> >>>>>> Thank you.
> >>>>>> Best.
> >>>>>>
> >>>>>> Jéferson Campos Nobre
> >>>>>> PhD Student

---

From: Lisandro Zambenedetti Granville <[email-masked]>
Date: Fri, 6 Jun 2014 14:10:36 -0300

> Absolutely! I've already expressed that wish to Lisandro, who has passed it on to the agenda folks. 

Which I confirm: the request has been posted in the agenda request.

Lisandro