Subject: Re: [nmrg] draft-irtf-nmrg-autonomic-network-definitions-01 feedback

From: Benoit Claise <[email-masked]>
Date: Mon, 08 Sep 2014 14:51:05 +0200

Dear all,

Thanks for addressing my concerns in the version 3 of the 
draft-irtf-nmrg-autonomic-network-definitions.
Minor point, as mentioned below: I would have put the automatic 
definition directly in draft-irtf-nmrg-autonomic-network-definitions.

   o  Automatic: A process that occurs without human intervention, with
       step-by-step execution of rules.  However it relies on humans
       defining the sequence of rules, so is not Autonomic in the full
       sense.  For example, a start-up script is automatic but not
       autonomic.

Regards, Benoit
> Dear all,
>
> - Make it clear that the definition means a logical OR
>     Autonomic: Self-managing (self-configuring, self-protecting, self-
>     healing and self-optimizing); however, allowing high-level guidance
>     by a central entity, through intent.
> -
>     Intent: An abstract, high level policy used to operate the network
>     autonomically.  Its scope is an autonomic domain, such as an
>     enterprise network._It does not contain configuration or information
>     for a specific node._  It may contain information pertaining to nodes
>     with a specific role.
>
> Well in the end, configuration or information for a specific node will be involved.
> I guess you want to rephrase that the intent is a general policy above configuration or information for a specific node, dealing with the intent you want to have from the network.
>
> -  When I read "It requires no configuration" in ...
>
>     Autonomic Function: A feature or function which requires no
>     configuration, and can derive all required information either through
>     self-knowledge, discovery or through intent.
>
>     OR
>
>     Fully Autonomic Node: A node which employs exclusively autonomic
>     functions.  It requires no configuration.
>
> ... I wondered about an initial configuration before a device is shipped. Autonomic or not?
> Coincidently, this was just discussed at the time of typing these lines, by Brian, presenting in NMRG.
> I understand that this is automatic, right?
> And I see a extra definition in draft-irtf-nmrg-an-gap-analysis-00
>
>    o  Automatic: A process that occurs without human intervention, with
>        step-by-step execution of rules.  However it relies on humans
>        defining the sequence of rules, so is not Autonomic in the full
>        sense.  For example, a start-up script is automatic but not
>        autonomic.
>
> draft-irtf-nmrg-autonomic-network-definitions would benefit from this definition in my opinion, and a few words on the difference between autonomic and automatic
>
> -
> Northbound interface. These days, with the SDN/controller story, this is a confusing term.
> I would rephrase the section and the text inside
> OLD:
> 3.4.  Simplification of the Northbound Interfaces
> OLD:
> 3.4.  Simplification of the Autonomic Node Northbound Interfaces
>
> -
> 3.7 Modularity
> Section 3 intro says:
>
>     This section explains the high level goals of Autonomic Networking,
>     independent of any specific solutions.
>
> Is this an Autonomic Networking design goal to be modular? Not really
> I see this more like a good deployment practice, i.e. if you think about an autonomic protocol, please think of deployment, i.e. modularity
>
> Regards, Benoit
>
>
>
> _______________________________________________
> nmrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmrg

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Mon, 8 Sep 2014 14:05:40 +0000

Must have slipped through. I'll include it in the next version.

Michael

From: nmrg [mailto:[email-masked]] On Behalf Of Benoit Claise (bclaise)
Sent: 08 September 2014 14:51
To: [email-masked]
Subject: Re: [nmrg] draft-irtf-nmrg-autonomic-network-definitions-01 feedback

Dear all,

Thanks for addressing my concerns in the version 3 of the draft-irtf-nmrg-autonomic-network-definitions.
Minor point, as mentioned below: I would have put the automatic definition directly in draft-irtf-nmrg-autonomic-network-definitions.

      autonomic.

Regards, Benoit
Dear all,

   enterprise network.  It does not contain configuration or information

   for a specific node.  It may contain information pertaining to nodes

   with a specific role.

   OR

      autonomic.

-

OLD:

OLD:

-

3.7 Modularity

Section 3 intro says:

Regards, Benoit

nmrg mailing list

[email-masked]<mailto:[email-masked]>